#openstack-meeting-alt: zuul

Meeting started by jeblair at 22:02:46 UTC (full logs).

Meeting summary

    1. agenda https://wiki.openstack.org/wiki/Meetings/Zuul (jeblair, 22:03:07)
    2. previous meating http://eavesdrop.openstack.org/meetings/zuul/2017/zuul.2017-06-26-22.02.html (jeblair, 22:03:18)

  1. Actions from last meeting (jeblair, 22:03:34)
  2. Status update: standard job library (jeblair, 22:05:12)
    1. config shadowing https://review.openstack.org/479084 (jeblair, 22:07:01)
    2. tox-py35-on-zuul job runs the zuul py35 job on changes to zuul-jobs to better exercise unittest jobs on changes to zuul-jobs (jeblair, 22:08:52)
    3. after config shadowing change lands, non-openstack users should try using zuul-jobs (jeblair, 22:12:15)

  3. Status updates: Documentation (jeblair, 22:13:03)
    1. big documentation refactor landed (jeblair, 22:13:13)
    2. zuul v3 docs https://docs.openstack.org/infra/zuul/feature/zuulv3/ (jeblair, 22:13:31)
    3. now that the new doc structure has merged, new changes should once again be accompanied with documentation updates (jeblair, 22:18:46)
    4. ACTION: jlk add meat to github docs re app setup and depends-on (jeblair, 22:19:31)
    5. ACTION: jeblair make anchors for keywords (jeblair, 22:19:40)
    6. ACTION: mordred add v3 doc link to readme (jeblair, 22:20:00)

  4. Status update: GitHub parity (jeblair, 22:21:20)
  5. Status updates: (web) console streaming (jeblair, 22:23:48)
    1. ACTION: mordred make infra init script for zuul-web in puppet-zuul (jeblair, 22:27:25)
    2. http://git.openstack.org/cgit/openstack-infra/storyboard-webclient/tree/package.json storyboard webui packaging metadata (fungi, 22:33:01)

  6. Status update: Zuul test enablement (jeblair, 22:38:07)
  7. Progress summary (jeblair, 22:39:36)
    1. https://storyboard.openstack.org/#!/board/41 (jeblair, 22:39:43)

  8. Open Discussion (jeblair, 22:45:45)


Meeting ended at 23:00:14 UTC (full logs).

Action items

  1. jlk add meat to github docs re app setup and depends-on
  2. jeblair make anchors for keywords
  3. mordred add v3 doc link to readme
  4. mordred make infra init script for zuul-web in puppet-zuul


Action items, by person

  1. jeblair
    1. jeblair make anchors for keywords
  2. jlk
    1. jlk add meat to github docs re app setup and depends-on
  3. mordred
    1. mordred add v3 doc link to readme
    2. mordred make infra init script for zuul-web in puppet-zuul


People present (lines said)

  1. jeblair (83)
  2. mordred (43)
  3. fungi (23)
  4. jlk (17)
  5. rbergeron (10)
  6. Shrews (8)
  7. SpamapS (6)
  8. jamielennox (4)
  9. openstack (3)


Generated by MeetBot 0.1.4.