22:02:46 <jeblair> #startmeeting zuul
22:02:47 <openstack> Meeting started Mon Jul 10 22:02:46 2017 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:02:50 <openstack> The meeting name has been set to 'zuul'
22:02:54 * fungi needs to start drinking asap in that case
22:03:00 <rbergeron> it's whateever your favorite meat is. veggiemeat or beef-meat or fish-meat or ... popsicle-meat. your call :)
22:03:07 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/Zuul
22:03:18 <jeblair> #link previous meating http://eavesdrop.openstack.org/meetings/zuul/2017/zuul.2017-06-26-22.02.html
22:03:34 <jeblair> #topic Actions from last meeting
22:03:39 <jeblair> jlk look into moving depends-on to pull-request summary to see if it is both workable and a solution to the needed-by problem
22:03:51 <jlk> Done and done.
22:03:56 <mordred> wow. last meeting was a long time ago it feels
22:04:10 <jeblair> mordred: it was 2 weeks ago, which is ages in zuul time!
22:04:17 <jlk> Turns out it was easier all around to use the pull request summary.
22:04:26 <fungi> that's at least 6mos in zuul years
22:04:30 <jlk> so, thanks to those of you that pushed in that direction.
22:04:39 <jeblair> jlk: and i belive that merged, right?
22:04:48 <jlk> correct
22:05:12 <jeblair> #topic Status update: standard job library
22:05:29 <jeblair> mordred: this thing is starting to be a thing, eh?
22:05:38 <mordred> yah!
22:05:51 <mordred> we have jobs in zuul-jobs, and they're running tests on zuul
22:06:05 <fungi> it's true, i saw one
22:06:10 <mordred> and the speculative job stuff totally works - AND - they're parameterized and not openstack specific :)
22:06:36 <jeblair> i have an outstanding change related to this...
22:06:48 <mordred> I'm cranking currently on getting all of the standard tox jobs done, as well as the copied-in-shell-scripts ansible-ified
22:07:01 <jeblair> #link config shadowing https://review.openstack.org/479084
22:07:09 <mordred> but we're self-aware enough that hacking on the jobs using zuul to test that the jobs work is neat
22:07:23 <jlk> mordred: do you want some help with that? Divide and conquer mode, or just fast follow reviews?
22:07:27 <jeblair> once that change merges, we'll be able to move the base job into zuul-jobs and have a local override version of it in project-config
22:07:34 <Shrews> mordred: that's so meta
22:07:57 <mordred> btw - I added a job o the zuul-jobs repo called tox-py35-on-zuul - which grabs the zuul repo and runs the tox py35 job content on it - on changes to the zuul-jobs repo
22:08:24 <mordred> jlk: Id' love some! let's sync up after the meeting to divy up the list
22:08:36 <jlk> ack
22:08:52 <jeblair> #info tox-py35-on-zuul job runs the zuul py35 job on changes to zuul-jobs to better exercise unittest jobs on changes to zuul-jobs
22:09:02 <mordred> jeblair: you enjoyed writing that didn't you? :)
22:09:20 <jeblair> mordred: i like saying the words "zuul" and "jobs"
22:09:22 <jeblair> so yes
22:09:59 <jeblair> after the config-shadowing change merges, i'd like to ask other folks (bonnyci, tobiash, tristanC) to try using zuul-jobs locally as well
22:10:27 <mordred> ++
22:10:32 <mordred> won't THAT be exciting?
22:10:33 <jlk> ack
22:10:57 <jeblair> it should be reasonable to do so once that lands, and it will be really good to have a wide corpus of reviewers on that repo -- it's the future zuul commons.  :)
22:11:27 <mordred> next we'll need to figure out how to write  ajob that validates that changes to zuul-jobs don't break something in bonnyci
22:11:30 <jeblair> (the config shadowing gives folks an escape hatch so that zuul-jobs doesn't take over anything you don't want it to)
22:12:15 <jeblair> #info after config shadowing change lands, non-openstack users should try using zuul-jobs
22:12:25 <jeblair> anything else in this topic?
22:13:03 <jeblair> #topic Status updates: Documentation
22:13:13 <jeblair> #info big documentation refactor landed
22:13:31 <jeblair> #link zuul v3 docs https://docs.openstack.org/infra/zuul/feature/zuulv3/
22:13:45 <jeblair> there is *a lot* more we can do there
22:14:06 <jlk> it's really nice to have docs to point to again though
22:14:32 <jeblair> in particular, there's lots of room for examples (both in-line, and longer examples in the form of appendixes)
22:14:46 <jeblair> but yeah, it's a thing.  :)
22:15:08 <mordred> oh - did we update the README to link to that?
22:15:08 <jeblair> also, i need to do something to get us anchors on all the job keywords, etc, so we can deep link to them
22:15:20 <jeblair> mordred: no that's a good idea though
22:16:31 <jeblair> a while back we suspended the "changes should have docs" rule to facilitate faster iteration.  i think that's no longer required, so i think we should reinstate that rule now.
22:16:53 <jlk> I owe an action to add more meat to the github docs, particularly app vs API key and depends-on
22:17:21 <jeblair> i think we should make allowances for changes which have been in development for a while -- we can add documentation for those in followup patches
22:17:38 <fungi> that seems like a reasonable compromise
22:17:49 <jlk> +1 on the rule + compromise
22:18:03 <jeblair> but let's at least remind ourselves that we should do that, and start leaving -1s on patches which need doc updates and don't have them
22:18:20 <jeblair> leaving -1s on *new* patches...
22:18:46 <jeblair> #info now that the new doc structure has merged, new changes should once again be accompanied with documentation updates
22:19:31 <jeblair> #action jlk add meat to github docs re app setup and depends-on
22:19:40 <jeblair> #action jeblair make anchors for keywords
22:20:00 <jeblair> #action mordred add v3 doc link to readme
22:20:29 <jeblair> other than that, i think we can drop this section from the standing agenda.
22:20:39 <jeblair> any objections to that or anything else on this topic?
22:21:13 <fungi> sounds fine to me
22:21:20 <jeblair> #topic Status update: GitHub parity
22:21:31 <jeblair> jlk: are we at parity? :)
22:21:46 <jlk> I think it's time for a parity party!
22:21:57 <rbergeron> can we do parodies at the parity party?
22:22:05 <jlk> Depends-on was the last bit to land I think.
22:22:06 <jeblair> i'm going to dress up as a stop bit
22:22:16 <rbergeron> while wearing parrot-tees?
22:22:42 <jlk> I'm going to wear a pair of Ts
22:22:44 <jeblair> jlk: woot!
22:22:46 <rbergeron> OMG
22:22:47 * fungi wants to be flow control
22:22:48 <rbergeron> you are in my head
22:23:00 <rbergeron> sorry, i interrupted the flow of actual things
22:23:15 <jeblair> rbergeron: just for that, i'm dropping this topic from the agenda too!
22:23:23 <mordred> \o/
22:23:23 <jlk> +1
22:23:28 <fungi> error correction will just add it back you know
22:23:48 <jeblair> #topic Status updates: (web) console streaming
22:23:50 <mordred> jlk, jeblair: we still need cross-source depends-on right? but that's not a parity thing - that's a whole new thing both drivers need
22:23:55 <jeblair> mordred: ya
22:23:58 <jlk> yup
22:24:22 <jeblair> Shrews: your websocket server has merged!
22:24:26 <Shrews> Let us all rejoice and hail our new websocket overlord!
22:24:46 <Shrews> the new thing is zuul-web, which conjures up images of the spider from LoTR in my head
22:24:55 <mordred> \o/
22:24:59 <jeblair> Shrews: shelob?
22:25:05 <SpamapS> can we rejoice all at once or are we single threaded but async rejoicing?
22:25:13 <rbergeron> yes.
22:25:13 <mordred> SpamapS: YES
22:25:18 <Shrews> SpamapS: you are so terrible
22:25:32 <jeblair> we need to do some puppet work in infra in order to run it  (any volunteers?)
22:25:39 * rbergeron hides
22:25:43 * SpamapS poll()'d the channel
22:26:16 <mordred> jeblair: I'll do it if nobody else does - I'm kinda getting annoyed at our current init script situation anyway
22:26:19 <jeblair> tobiash handed us some html we can run, and i think Shrews is going to work on incorporating that into zuul + status page so we can actually have links and stuff
22:26:25 <jlk> ಠ_ಠ
22:26:36 <Shrews> yes
22:26:43 <Shrews> to the status page stuff
22:26:47 <jeblair> mordred: ack -- though i think some of the problems are actually zuul problems
22:27:25 <jeblair> #action mordred make infra init script for zuul-web in puppet-zuul
22:27:30 <mordred> jeblair: some of them may be zuul problems for sure - but before we go live they need to stop being problems wheever they are
22:27:58 <jeblair> mordred: yes.  just chat with me about them before you go change everything.  :)
22:28:08 <mordred> jeblair: too late. already done in production ;)
22:28:30 <jamielennox> having zuul-web be it's own repo with some proper deployment tools would actually be kind of useful
22:28:45 <jamielennox> ansible downloading jquery and copying files into apache is pretty ugly
22:29:42 <jamielennox> but not super important
22:29:55 <jeblair> i don't think zuul-web has any jquery yet, but the old webapp does, so i guess you mean when we port that over to zuul-web
22:30:17 <mordred> we poked a long time ago at using bower, etc for the javascript thigns, but there were so few of them it didn't seem worth it
22:30:26 <fungi> so looknig for some sort of (hopefully ecosystem-standard) javascript dependency management solution?
22:30:32 <jamielennox> oh, sorry confusing bits, but yes preferably before making it any more complicated
22:30:47 <mordred> it may be getting to be time to think about the strategy for managing those
22:30:49 <mordred> fungi: yah - that
22:31:21 <fungi> could always borrow the design storyboard is using for teh webclient i suppose
22:32:24 <mordred> one of the interesting outcomes of that is the ability to point test-patch versions of html/js at the live storyboard api endpoint - which is a thing we could certainly also do here as well
22:32:24 <fungi> seems to use bower/grunt
22:33:01 <fungi> #link http://git.openstack.org/cgit/openstack-infra/storyboard-webclient/tree/package.json storyboard webui packaging metadata
22:33:03 <fungi> for reference
22:33:09 <jeblair> mordred: that may be useful for the dashboard functionality
22:33:29 <jeblair> whatever we come up with needs to be comprehensible by everyone.  i do not want to end up in a situation where no one on the team understands the tooling.  i'd rather have crappy shell scripts than something that no one knows how to use.
22:33:30 <fungi> up side is we already have (granted jjb) job definitions for dealing with that stuff
22:34:02 <mordred> jeblair: agree
22:34:55 <jeblair> (and i'm not saying that's not bower/grunt, it may well be.  i'm just saying let's be realistic about the number of folks on the team that are interested in working on fashionable js technlogies.  otherwise we will dig a hole for ourselves.)
22:35:45 <jeblair> anyway, i think we at least have the next few steps of this laid out.
22:36:00 <jeblair> and i'm very excited about seeing our first websocket log streamed :)
22:36:02 <fungi> yep, my suggestion was more around common tooling and community building vs some bespoke tooling that only the zuul reviewers understand ;)
22:37:19 <jeblair> anything else?
22:37:31 <fungi> i'm also not opposed to what we did in v2 and just provided instructions for setting up the status page (plus a convenience script for downloading javascript deps)
22:37:47 <fungi> nothing else on my end
22:37:50 <Shrews> await mordred.install_zuul_web()
22:38:05 <jeblair> Shrews has the lingo
22:38:07 <jeblair> #topic Status update: Zuul test enablement
22:38:46 <jeblair> i think this topic took a vacation
22:39:31 <jeblair> maybe next week
22:39:36 <jeblair> #topic Progress summary
22:39:43 <jeblair> #link https://storyboard.openstack.org/#!/board/41
22:40:04 <jeblair> i think we've actually been doing a reasonable job keeping the board up to date
22:40:28 <jeblair> i've been putting a bunch of my punchlist items in there, and jlk added some stuff from our meeting with ansible folks
22:41:27 <jeblair> anyway, there's still stuff out there if folks want to pick things up
22:41:54 <SpamapS> sorry I looked away at the wrong moment
22:42:06 <SpamapS> I did a sweep through and updated a few stale bits last week
22:42:21 <jeblair> SpamapS: you were looking into a new tag... any news on that?
22:43:02 <SpamapS> jeblair: I think we should still do it, but I don't have a definitive plan written up yet. Basically we need to combine mordred's roadmap idea with my zuulv3.0 tag or something like that.
22:43:19 <SpamapS> and then we can start kicking a few things off zuulv3 onto zuulv30
22:44:25 <jeblair> SpamapS: ok, let's bat some ideas around later.
22:44:28 <mordred> ++
22:44:57 <jeblair> anything else?
22:45:45 <jeblair> #topic Open Discussion
22:47:44 <jeblair> mordred: want to talk about openstack rollout?
22:47:48 <mordred> I do!
22:47:50 <mordred> SO .....
22:47:53 <mordred> *drum roll*
22:47:57 <mordred> we're getting close everybody
22:48:13 <mordred> so close that I started writing up thoughts on openstack rollout process and timetable
22:48:20 <fungi> ooh!
22:48:28 <mordred> I was hoping to have them ready by today's meeting - but I didn't quite get there
22:49:11 <mordred> but - the tl;dr is that I believe we're in a position to actually start making plans and projecting completion times
22:49:29 <mordred> I'll try to have the first draft of the proposal done by tomorrow
22:49:36 <rbergeron> "speculative future state of zuul"
22:49:50 <jeblair> mordred, fungi: let's add that to the infra meeting agenda maybe?
22:49:51 <mordred> fungi: do you think it should be in the form of an infra-spec? a mailing list email? or both?
22:49:55 <fungi> wfm
22:49:57 <mordred> jeblair: that's a great idea
22:50:16 <jeblair> (i'll edit the wiki)
22:50:19 <rbergeron> iguess it's not speculative but just when it will land :) also, me with the words today is bad at this moment
22:50:40 <fungi> we can touch on it in the priority efforts section of the meeting tomorrow and see where we want to go with specs, mailing list threads, what have you
22:50:44 <mordred> it's also worth noting that with that, we're also getting to the point where folks may wantto start paying attention to patches to zuul-jobs
22:50:49 <mordred> fungi: cool
22:51:19 <Shrews> rbergeron: is good. hard is the words when end day of is near
22:51:54 <mordred> words
22:53:03 * jlk has to sneak out. Cheers.
22:54:07 <jeblair> mordred: would it be useful to take your plan in progress and have it in an etherpad for tommorow's infra meeting?
22:54:19 <mordred> jeblair: that's a great idea. yes
22:54:48 <fungi> excellent. feel free to link it on the agenda if you get a moment
22:55:21 <jeblair> cool, seems like that might be a good place to start, then we can decide whether that's ready to just go to the list, or bake in a spec or become a wiki page, or an entry in system-config or what... :)
22:55:31 <jeblair> (or maybe even remain an etherpad :)
22:56:31 <fungi> awesome
22:57:54 <jeblair> i'm excited.  i think we're really close to getting this rolling.  :)
22:58:32 <jeblair> if that's all, let's use the remaining 2 minutes to pass out.
22:58:36 <mordred> ++
22:58:45 <fungi> i'd like to start pondering what we might be able to do with zuul jobs at the ptg in denver
22:58:46 <mordred> writing jobs for v3 has actually been quite pleasant
22:59:02 <mordred> fungi: I think you'll like my document then
22:59:13 <fungi> i'm sure i'd like it anyway
22:59:45 <jeblair> oh good.  let's make a decision about how much zuuling we're going to do at the ptg soon so we make sure folks who want to come have time to plan.
23:00:11 <jeblair> thanks everyone!
23:00:14 <jeblair> #endmeeting