#openstack-meeting-alt: zuul

Meeting started by jeblair at 22:02:45 UTC (full logs).

Meeting summary

    1. agenda https://wiki.openstack.org/wiki/Meetings/Zuul (jeblair, 22:02:56)
    2. previous meeting http://eavesdrop.openstack.org/meetings/zuul/2017/zuul.2017-03-06-22.03.html (jeblair, 22:03:04)

  1. Actions from last meeting (jeblair, 22:03:13)
    1. ACTION: clarkb review https://review.openstack.org/#/c/435933/ (jeblair, 22:04:13)
    2. remaining skipped tests in zuul https://etherpad.openstack.org/p/zuulv3skips (jeblair, 22:06:16)

  2. Status updates: Nodepool (jeblair, 22:06:55)
  3. Status updates: Devstack-gate roles refactoring (jeblair, 22:20:53)
    1. http://www.roadtrafficsigns.com/close-the-gate-behind-you-goat-symbol-sign/sku-k2-1508?engine=googlebase&keyword=&skuid=K2-1508-AL-12x18&gclid=CMu7iPbB1NICFZKGfgodpOkDKA (rbergeron, 22:20:57)

  4. Status updates: Zuul test enablement (jeblair, 22:22:09)
    1. https://etherpad.openstack.org/p/zuulv3skips (rbergeron, 22:26:08)
    2. list of remaining tests that need enabling, along with an annotation as to complexity (rbergeron, 22:26:21)
    3. 28 left :) (rbergeron, 22:26:55)

  5. Status updates: Zuul sample jobs (jeblair, 22:27:06)
    1. pabelanger making headway on https://review.openstack.org/438281 (needs review), zuul sample jobs (rbergeron, 22:37:47)
    2. ACTION: jhesketh review https://review.openstack.org/438281 (jeblair, 22:38:05)

  6. Progress summary (jeblair, 22:38:07)
    1. then review, ask/answer questions about how they serve as foundational jobs / examples. (rbergeron, 22:38:22)
    2. https://storyboard.openstack.org/#!/board/41 (SpamapS, 22:38:37)

  7. Renaming zuul-launcher? (pabelanger) (jeblair, 22:42:16)
    1. AGREED: rename zuul-launcher zuul-executor to disambiguate from nodepool (jeblair, 22:47:19)

  8. Spec update: update job trees to graphs (jeblair) (jeblair, 22:48:27)
    1. Spec update: update job trees to graphs https://review.openstack.org/443985 (jeblair, 22:48:41)
    2. also https://review.openstack.org/445022 (jeblair, 22:49:23)
    3. https://review.openstack.org/443973 (jeblair, 22:49:37)

  9. New spec: Zuulv3 Launcher Security Enhancement (SpamapS) (jeblair, 22:53:29)
    1. New spec: Zuulv3 Launcher Security Enhancement https://review.openstack.org/444495 (jeblair, 22:53:40)

  10. New spec: An interface for Zuul Job Reporting (dmsimard) (jeblair, 22:58:49)
    1. New spec: An interface for Zuul Job Reporting https://review.openstack.org/#/c/444088/ (jeblair, 22:59:03)


Meeting ended at 23:00:11 UTC (full logs).

Action items

  1. clarkb review https://review.openstack.org/#/c/435933/
  2. jhesketh review https://review.openstack.org/438281


Action items, by person

  1. clarkb
    1. clarkb review https://review.openstack.org/#/c/435933/
  2. jhesketh
    1. jhesketh review https://review.openstack.org/438281
  3. openstack
    1. clarkb review https://review.openstack.org/#/c/435933/
    2. jhesketh review https://review.openstack.org/438281


People present (lines said)

  1. jeblair (123)
  2. SpamapS (57)
  3. rbergeron (29)
  4. pabelanger (23)
  5. fungi (18)
  6. Shrews (13)
  7. clarkb (6)
  8. jlk (5)
  9. jamielennox (4)
  10. openstack (4)
  11. jhesketh (4)


Generated by MeetBot 0.1.4.