22:02:45 <jeblair> #startmeeting zuul
22:02:46 <openstack> Meeting started Mon Mar 13 22:02:45 2017 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:02:50 <openstack> The meeting name has been set to 'zuul'
22:02:56 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/Zuul
22:03:04 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/zuul/2017/zuul.2017-03-06-22.03.html
22:03:13 <jeblair> #topic Actions from last meeting
22:03:21 <jeblair> Shrews restart nodepoolv3 launcher to pick up quota fix
22:03:25 <jeblair> that happened
22:03:32 <Shrews> it so happened
22:03:37 <jeblair> and then pabelanger made it happen again :)
22:03:50 <jeblair> clarkb review https://review.openstack.org/#/c/435933/
22:04:00 <rbergeron> hi! :)
22:04:05 <jeblair> that didn't happen
22:04:13 <jeblair> #action clarkb review https://review.openstack.org/#/c/435933/
22:04:47 <jeblair> jeblair consider removing layoutvalidator and tests
22:04:50 <jeblair> jeblair remove swift and layoutvalidator as appropriate
22:04:54 <jeblair> those things happened
22:05:01 <jeblair> jeblair triage remaining skipped tests
22:05:05 <jeblair> that happened as well
22:05:10 <jeblair> we should link the etherpad for that
22:05:23 <jeblair> SpamapS: do you still have that handy?
22:05:41 <SpamapS> eh?
22:05:49 <SpamapS> sorry I got twisted around for a second
22:06:16 <jeblair> #link remaining skipped tests in zuul https://etherpad.openstack.org/p/zuulv3skips
22:06:17 <jeblair> there it is
22:06:19 <SpamapS> thanks
22:06:30 <SpamapS> sorry.. I lost it in my pile of slacks and ircs and emails
22:06:55 <jeblair> #topic Status updates: Nodepool
22:07:32 <jeblair> Shrews: how goes it?
22:07:40 <Shrews> oh, not much interesting to report...
22:07:51 <Shrews> except that ZUULv3 NODEPOOL IS DONE
22:07:58 <Shrews> !!!!!!1111!!1eleven!!
22:07:59 <openstack> Shrews: Error: "!!!!!1111!!1eleven!!" is not a valid command.
22:08:05 <pabelanger> oh ya
22:08:07 <jeblair> nice :)
22:08:09 <fungi> you know, nothing _interesting_ though ;)
22:08:20 <jhesketh> woo :-)
22:08:22 <rbergeron> WOO
22:08:30 <fungi> good going!
22:08:32 <Shrews> there will be bugs to squash, but all outstanding things and requests are done
22:08:36 <SpamapS> whuuutttt
22:08:39 * SpamapS loses his mind
22:08:47 <jlk> o/
22:09:20 <SpamapS> Shrews be like http://imgur.com/xgz9nkR
22:09:49 <Shrews> i will hereafter be doing only LHF because i need some easy stuff for a while
22:09:51 <Shrews> :)
22:10:12 <jeblair> Shrews: there is certainly some of that in zuul :)
22:10:39 <jeblair> we should probably implement https://storyboard.openstack.org/#!/story/2000895 before we get to actual release time
22:10:41 * rbergeron actually fully pays attention now that phone is done, whew
22:10:59 <jeblair> but that's not so much of a change to functionality
22:11:38 <jeblair> other than that, i'm not seeing a whole bunch of nodepool on the storyboard
22:11:39 <SpamapS> Shrews: can I suggest documentation updates?
22:11:47 <SpamapS> Like, not to bring the party down
22:11:49 <SpamapS> but...
22:11:58 <SpamapS> nice when things work like the docs say they work. :)
22:12:09 <jeblair> (it might be good to stack doc updates behind the config syntax change)
22:12:09 <Shrews> SpamapS: to which docs? i think we updated as we went
22:12:53 <jeblair> i'm sure the whole nodepool docs need a once over anyway
22:13:01 <SpamapS> Right
22:13:05 * rbergeron notes she is here for giving the halp with the docs and finding all the corners of darkness and light
22:13:17 <jeblair> the narrative structure is mostly geared toward openstack-infra 3 years ago
22:13:26 <rbergeron> ...if some part of that is ready to be poked at or scoured for loose ends, yay? :)
22:13:29 <SpamapS> I'm sure it's generally correct but right after completed milestones are a good quiet period to land doc cleanups.
22:13:50 <pabelanger> Shrews: did you by chance look at nl01.o.o today? We seem to be still paused on ready nodes. Grouping this under potential bugs to squash
22:14:19 <rbergeron> jeblair: right
22:14:25 <Shrews> rbergeron and I can give the docs a once over
22:14:33 <rbergeron> shrews: that would be awesome :)
22:14:51 <pabelanger> should we also merge master to feature/zuulv3?
22:15:12 <SpamapS> That would certainly make merging feature/zuulv3 to master later much simpler. :)
22:15:21 <jeblair> yeah, we'll need to keep merging into v3 for a while yet
22:15:29 <Shrews> pabelanger: i looked quickly, but the exceptions looked to have stopped. i thought you and jeblair were looking deeper
22:15:31 <jeblair> also, try not to add too many things to master :)
22:15:51 <pabelanger> Shrews: okay, lets push it until tomorrow
22:15:59 <rbergeron> shrews: iwill beep you to figure out a time to do this in the next few days, if that's kosher? (docs pokin')
22:16:06 <jeblair> mordred: are you around to talk about the shim?
22:16:10 <Shrews> rbergeron: beep away
22:16:49 <fungi> i want to say mmmpork/auggy did a pass through a bunch of the nodepool docs more recently than three years ago, but this is a great opportunity to go through them again
22:17:02 <jhesketh> I can look at merging master -> v3
22:17:57 <rbergeron> shrews: i am settling up my "going to disneyland plans" for one day this week so as soon as i know that later today i'll know what days i'm not at disneyland and when we can theoretically go ... doc-toring
22:18:00 <jeblair> also, we need to drop ready scripts
22:18:26 <pabelanger> indeed, I have playbooks already setup for that
22:19:05 <Shrews> rbergeron: okie dokie
22:19:11 <jeblair> is anyone around to talk about devstack-gote roles refactoring?
22:19:34 <rbergeron> mmm. goats
22:19:36 <jeblair> i named it.  i'm allowed to call it that.
22:19:48 <SpamapS> I wonder if we could get a goat to eat a devstack
22:19:50 <rbergeron> oh wait, is that the actual word and not a typo?
22:19:59 <jeblair> heh, no it's devstack-gate
22:20:08 <jeblair> is a dvorak typo
22:20:12 * clarkb returns from dentist
22:20:18 <fungi> dvorak-gate
22:20:48 <jeblair> #topc Status updates: Devstack-gate roles refactoring
22:20:53 <jeblair> #topic Status updates: Devstack-gate roles refactoring
22:20:57 <rbergeron> http://www.roadtrafficsigns.com/close-the-gate-behind-you-goat-symbol-sign/sku-k2-1508?engine=googlebase&keyword=&skuid=K2-1508-AL-12x18&gclid=CMu7iPbB1NICFZKGfgodpOkDKA
22:21:26 <rbergeron> there you go. okay, i will stop being silly now :)
22:21:30 <jeblair> clarkb: apparently it would be helpful for you to review https://review.openstack.org/#/c/435933/ when you have a moment
22:21:39 <clarkb> jeblair: ok will add to todo list
22:21:58 <jeblair> i think that's probably the only thing for this topic
22:22:09 <jeblair> #topic Status updates: Zuul test enablement
22:22:40 <SpamapS> I got 0 done the last week. Been focused on security spec and deploying v3 in BonnyCI
22:22:47 <jeblair> as mentioned earlier, https://etherpad.openstack.org/p/zuulv3skips has the list of remaining tests that need enabling, along with an annotation as to complexity
22:23:08 <jeblair> SpamapS: is the "grab a test in storyboard" process still in effect, or do we need to adopt a different procedure?
22:23:40 <SpamapS> jeblair: It's still in effect, but I like your etherpad as the selection helper because most of the ones left are a bit scary for noobs
22:24:05 <jeblair> cool
22:24:20 <SpamapS> 28 left to re-enable
22:24:44 <SpamapS> with 4 of those added to test_connection with the merge from master
22:25:00 <jeblair> and yeah, as mentioned, i pulled a few out for being irrelevant, so that brought the number down a bit
22:25:10 <jeblair> anything else on this?
22:25:26 <SpamapS> I'm hoping we'll get v3 up and then can get our upstream dev contributions cranking again.
22:25:35 <jeblair> SpamapS: ++
22:25:39 <SpamapS> jeblair: oh yeah I forgot about the irrelevant ones.
22:26:08 <rbergeron> #link https://etherpad.openstack.org/p/zuulv3skips
22:26:08 <jeblair> SpamapS: soon afterwords, we should probably talk seriously about finding a long-term home for our stdlib playbooks/roles
22:26:21 <rbergeron> #info list of remaining tests that need enabling, along with an annotation as to complexity
22:26:34 <jeblair> whether that's in-zuul-repo, or in-sister-repo or what...
22:26:55 <rbergeron> #info 28 left :)
22:26:56 * fungi can imagine some of both
22:27:04 <jeblair> and, heh, i guess i just jumped topics accidentally
22:27:06 <jeblair> #topic Status updates: Zuul sample jobs
22:27:14 <jeblair> that's better
22:27:36 <jeblair> pabelanger: are you un-blocked on proceeding with setting up our sample jobs?
22:27:49 <SpamapS> jeblair: If BonnyCI gets a broad audience, we'll likely have a lot of tox-like jobs to contribute.
22:28:16 <jeblair> SpamapS: ++
22:28:18 <pabelanger> jeblair: I don't think we have merged it yet. Checking
22:28:33 <pabelanger> ya, we still need +3 on 438281
22:28:36 <jeblair> we got good feedback on that over the course of the week
22:28:40 <pabelanger> then we can iterate forward
22:28:50 <SpamapS> And there's also a big looming question that I keep getting asked which is "can you just run my tests in a container?" which I have to say I probably want to start making plans to answer with more than "sure once we get v3 production ready.."
22:28:53 <pabelanger> but everybody seems on the same page as 438281, which is good
22:28:54 <rbergeron> jeblair: in this case is job == test? or job == ?? (sorry, my dumb question of the day :D)
22:29:32 <jeblair> rbergeron: job meaning "unit of ansible execution in zuul"
22:30:11 <fungi> SpamapS: single-use containers on reusable nodes... without root access i guess?
22:30:15 <jeblair> rbergeron: usually we use "test" in the context of unit tests, to mean exercising a single bit of code
22:30:52 <jeblair> rbergeron: roughly equivalent to "project" in jenkins and "check" in travis
22:30:53 <fungi> SpamapS: or just with appropriate "you know this is a security foot-cannon" disclaimers?
22:31:08 <rbergeron> jeblair: ack, gotcha
22:31:42 <jeblair> SpamapS: i would too, but we're already quite a bit over-extended
22:32:01 <SpamapS> Yeah I can't even get into it
22:32:07 <SpamapS> but I'm having to start thinking about it
22:32:14 <jeblair> that's not okay
22:32:42 <jeblair> we're not even remotely ready to run for real in our friendliest environment yet
22:32:57 <jeblair> let's make some more actual progress before we take on any more design work for major new features
22:33:00 <SpamapS> Yeah, #1 priority is getting that up. :)
22:33:30 <SpamapS> (while maintaining management-feel-goods about trajectory and value)
22:33:43 <jeblair> anything else about the zuul sample jobs?
22:33:50 <rbergeron> jeblair: is there a list of wished for sample jobs
22:33:51 <rbergeron> ?
22:33:59 <SpamapS> great question
22:34:01 <rbergeron> it wounds like pabelanger has some ideas in mind
22:34:02 <rbergeron> err
22:34:03 <jeblair> rbergeron: no, pabelanger is making good headway on that
22:34:03 <rbergeron> sounds.
22:34:09 <jeblair> he has *lots* ready to go actually
22:34:17 <jeblair> and just needs someone to +3 https://review.openstack.org/438281
22:34:26 <jeblair> there's a stack of like 8 changes
22:34:40 <pabelanger> indeed
22:35:02 <jeblair> we paused waiting on resolution of 438281
22:35:37 <jeblair> but now someone needs to +3 that, and then the rest shoud be rebased and we should review them and ask/answer questions about how they serve as foundational jobs or examples
22:36:28 <jeblair> any volunteers for that, or should i just single-core approve it?
22:36:28 <rbergeron> that ask/answer should happen... where? future meeting? in the review?
22:36:34 <jeblair> in reviews
22:36:40 <jhesketh> jeblair: I can review it
22:36:50 <jeblair> until it gets too complicated, then we'll take it to ml/meetings, like we did for 438281
22:36:52 <rbergeron> okay. i thought so but wasn't sure if it was more meta-level head scratching
22:37:18 <jeblair> rbergeron: yeah, we might uncover more questions like that
22:37:30 <jeblair> rbergeron: but until then...
22:37:46 <jeblair> jhesketh: thanks!
22:37:47 <rbergeron> #info pabelanger making headway on https://review.openstack.org/438281 (needs review), zuul sample jobs
22:38:05 <jeblair> #action jhesketh review https://review.openstack.org/438281
22:38:07 <jeblair> #topic Progress summary
22:38:22 <rbergeron> #info then review, ask/answer questions about how they serve as foundational jobs / examples.
22:38:32 * SpamapS digging out link
22:38:37 <SpamapS> #link https://storyboard.openstack.org/#!/board/41
22:39:05 <SpamapS> Nothing untriaged yet there
22:39:05 <jeblair> i chatted with rcarrillocruz about the secrets work.  he's a bit swamped with other work right now, so i'm going to take that over from him for a bit
22:39:38 <SpamapS> jeblair: oh that's good to hear, I think we might butt up against it soon for artifact storage.
22:39:54 <jeblair> i updated sb to reflect that, and will start pushing patches soon.  fortunately rcarrillocruz did quite a bit of the hard stuff already.  :)
22:40:08 <SpamapS> so I may throw jamielennox at it if there's room for two cooks
22:40:10 <jeblair> SpamapS: yeah, it's going to be a blocker for real use for sure.
22:40:13 <SpamapS> assuming I can lift jamielennox
22:40:17 <jamielennox> :|
22:40:29 <SpamapS> jamielennox: it's auth. You love auth.
22:40:46 <jeblair> SpamapS, jamielennox: cool, let me know when you're ready and i'll see if we can split off some tasks.
22:41:07 <jeblair> at any rate, i'll take point on it to make sure it gets done
22:41:42 <SpamapS> I think the board accurately reflects things from where I stand
22:41:52 <SpamapS> which is to say.. there's a ton to do, and please everyone keep your assigned items moving :)
22:41:57 <jeblair> ++
22:42:04 <jamielennox> jeblair: ok, let's chat about it after
22:42:16 <jeblair> #topic Renaming zuul-launcher? (pabelanger)
22:42:30 <pabelanger> ohai
22:42:36 <SpamapS> to zuul-make-go-things-er?
22:42:39 <jeblair> let's paint that bikeshed
22:42:46 <rbergeron> zoo-lander i guess would be bad
22:42:50 <pabelanger> we talked a little about this at PTG, but wanted bikeshed more about it
22:42:54 <SpamapS> zuul-apult?
22:43:01 <pabelanger> do we want to have 2 launchers or just 1?
22:43:17 <SpamapS> I missed that discussion. The 2 are what?
22:43:20 <pabelanger> reason for 1, so we don't keep asking, which launcher
22:43:25 <jeblair> nodepool-launcher and zuul-launcher
22:43:28 <pabelanger> thanks
22:43:54 <pabelanger> I think we generally agreed about renaming zuul-launcher to something else, but didn't pick the something else
22:43:59 <SpamapS> AH
22:44:07 <pabelanger> figure now is the time to do it
22:44:08 <jlk> zuul-jobber
22:44:18 <SpamapS> so the problem is people say "on the launcher" and confusion happens?
22:44:21 <jeblair> i think zuul-executor is probably the best non-funny name i've seen so far.  it is annother borrowed-jenkins-word, but it's a good one.
22:44:25 <jeblair> SpamapS: yep
22:44:39 <jeblair> especially when we're wearing our sysadmin hats
22:44:42 <jeblair> "reboot the launcher"
22:44:44 <jlk> that makes sense
22:44:51 <jeblair> "er.  the other launcher."
22:44:53 <fungi> zuul-executioner would be funner
22:44:53 <SpamapS> well it runs playbooks, so the fun name is zuul-quarterback ... but executor is probably more geek-friendly
22:45:14 <pabelanger> I didn't mind zuul-runner, but think we had other plans for it
22:45:30 <pabelanger> otherwise , zuul-executor wfm
22:45:33 <jeblair> fungi: this is true
22:45:39 <jhesketh> +1 to pabelanger
22:45:42 <SpamapS> or just
22:45:44 <SpamapS> the zuuler
22:46:00 <fungi> but yeah, the pragmatist in me ultimately doesn't care what people pick as long as it's suitable disambiguated
22:46:03 <SpamapS> zuul-ansibler?
22:46:07 <fungi> er, suitably
22:46:13 <SpamapS> no I like executor and I'll stop saying ridiculous things
22:46:19 <jeblair> "zuuler?  zuueler?  zueller?  bueller?"
22:46:42 <Shrews> zuul-executor ftw
22:46:50 <pabelanger> okay, I'll propose a name change to zuul-executor and see how that goes
22:46:56 <fungi> or even just zuul-exec for teh shortnez
22:46:57 <jeblair> pabelanger: ++
22:47:08 <pabelanger> thanks, that is all
22:47:19 <jeblair> #agreed rename zuul-launcher zuul-executor to disambiguate from nodepool
22:47:26 <SpamapS> fwiw, I wouldn't shorten it to zuul-exec
22:47:33 <SpamapS> that sounds like a verb rather than a noun
22:47:40 <fungi> cool, then i won't either ;)
22:47:40 <jeblair> we're going to need new hosts zl01 -> ze01
22:47:48 <pabelanger> yes!
22:48:02 <fungi> then we can say "run it from ze server!"
22:48:03 <jeblair> but, i figured we'd get new hosts for v3 anyway, so that's probably convenient :)
22:48:16 <jeblair> omg where's the agenda
22:48:21 <rbergeron> zuulecutor
22:48:27 <jeblair> #topic Spec update: update job trees to graphs (jeblair)
22:48:41 <jeblair> #link Spec update: update job trees to graphs https://review.openstack.org/443985
22:48:55 <fungi> this one lgtm, happy to put forward for council vote tomorrow if you like
22:48:58 <jeblair> i proposed this spec update to do a thing we've been saying we would do in v3, which is have actual job graphs
22:49:00 <clarkb> jeblair: there is a follow up too
22:49:06 <clarkb> 445022?
22:49:17 <clarkb> yup
22:49:23 <jeblair> #link also https://review.openstack.org/445022
22:49:35 <jeblair> there's even an implementation
22:49:37 <jeblair> #link https://review.openstack.org/443973
22:49:51 <jeblair> which is a port to v3 of the original patch offered for v2
22:50:03 <jeblair> (which is why that's happening in the opposite order than we normall do with specs)
22:50:44 <jeblair> do folks think we'll be ready to put it to a formal vote at tomorrows infra meeting?
22:51:14 <pabelanger> no objection here
22:51:47 <fungi> fine with me to move forward there
22:52:18 <clarkb> they are straightforward
22:53:12 <jeblair> okay, let's go with putting it on the agenda tomorrow, but if anyone wants more time, that's fine.  that is, in fact, *why* we put it on the agenda so that we have an opportunity for people to request more time.  :)
22:53:25 <fungi> yup
22:53:29 <jeblair> #topic New spec: Zuulv3 Launcher Security Enhancement (SpamapS)
22:53:40 <jeblair> #link New spec: Zuulv3 Launcher Security Enhancement https://review.openstack.org/444495
22:53:50 <jlk> I keep meaning to read this
22:53:58 <jeblair> SpamapS has started working on this based on discussions we had at the ptg
22:54:05 <fungi> this is one i haven't had a chance to read yet, but i like some of the words in the title ;)
22:54:07 <SpamapS> 7 minutes, we should at least be able to narrow down the shed color a little :)
22:54:44 <jeblair> it has several solutions, and i'd say it's at a point where we want to flesh out each of them a bit, yeah?
22:55:04 <jeblair> clarkb and SpamapS has already started diving into this
22:55:04 <SpamapS> The tl;dr is that we want to wrap ansible-playbook in host-enforced security so that we're not totally reliant on ansible plugins.
22:55:33 <SpamapS> I just pushed a rev up as the meeting started that tries to address clarkb's initial comments and some nits
22:55:55 <jeblair> some of the options will definitely have deployment considerations
22:56:00 <jeblair> so wide input would be really good on this
22:56:04 <SpamapS> It's a little bit overwhelming, because there doesn't seem to be a clear winner.
22:57:05 <fungi> this could be said of information security in general
22:57:09 <jamielennox> is it something that needs an upstream decision vs launch this in your own env?
22:57:35 <SpamapS> jamielennox: I'm leaning toward an abstraction with a clear and simple initial implementation of all the options that don't require heavy deployment config.
22:57:37 <jamielennox> like gut instinct here is docker+selinux, but that's never going to fly as a general purpose requirement
22:57:47 <SpamapS> Which basically means chroot.
22:58:28 <SpamapS> Anyway, reviews are definitely helpful here.
22:58:38 <jeblair> SpamapS: thanks!
22:58:40 <SpamapS> I'm sure there are containment techs that I haven't considered.. feel free to add them.
22:58:49 <jeblair> #topic New spec: An interface for Zuul Job Reporting (dmsimard)
22:59:03 <jeblair> #link New spec: An interface for Zuul Job Reporting https://review.openstack.org/#/c/444088/
22:59:14 <jeblair> in the 1 minute remaining, i just wanted to point people at this spec
22:59:25 <jeblair> which i believe will change a bit before it's finalized
22:59:52 <jlk> ah, yes
23:00:09 <jeblair> thanks everyone!
23:00:11 <jeblair> #endmeeting