#openstack-meeting: openstack_salt

Meeting started by jasondotstar at 16:02:12 UTC (full logs).

Meeting summary

  1. roll call (jasondotstar, 16:02:23)
  2. Introduction (jasondotstar, 16:03:26)
    1. http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting (jasondotstar, 16:04:09)
    2. https://wiki.openstack.org/wiki/Meetings/openstack-salt (jasondotstar, 16:04:22)

  3. Review past action items (jasondotstar, 16:04:46)
    1. ACTION: genunix to continue openstack packaging research (jasondotstar, 16:07:50)
    2. ACTION: jasondotstar to look at the integration of launchpad with our repos (bug triage, tracking, etc.) *important* (jasondotstar, 16:09:04)
    3. AGREED: functional testing like beaker is required to achieve gating beyond linting (jasondotstar, 16:15:19)
    4. ACTION: cznewt to look at beaker gates and how to fold into the salt workflow (jasondotstar, 16:16:11)
    5. ACTION: cznewt to look at beaker gates and how to fold a similar process into the salt workflow (jasondotstar, 16:16:45)
    6. ACTION: consider testing deployments to windows-based clients (jasondotstar, 16:27:51)
    7. ACTION: cznewt get the first cloud based labs for openstack-salt testing fully operational (cznewt, 16:29:33)

  4. Today's Agenda (jasondotstar, 16:30:00)
    1. ACTION: continue to engage the salt community regarding our standardizing dependencies, packaging, versioning, and testing (jasondotstar, 16:35:23)
    2. ACTION: jasondotstar to complete local dev testing setup (jasondotstar, 16:36:37)
    3. ACTION: jasondotstar to work on pruning the salt formula projects underneath the stackforge/ namespace (jasondotstar, 16:43:16)

  5. Open Discussion (jasondotstar, 16:48:18)


Meeting ended at 16:53:03 UTC (full logs).

Action items

  1. genunix to continue openstack packaging research
  2. jasondotstar to look at the integration of launchpad with our repos (bug triage, tracking, etc.) *important*
  3. cznewt to look at beaker gates and how to fold into the salt workflow
  4. cznewt to look at beaker gates and how to fold a similar process into the salt workflow
  5. consider testing deployments to windows-based clients
  6. cznewt get the first cloud based labs for openstack-salt testing fully operational
  7. continue to engage the salt community regarding our standardizing dependencies, packaging, versioning, and testing
  8. jasondotstar to complete local dev testing setup
  9. jasondotstar to work on pruning the salt formula projects underneath the stackforge/ namespace


Action items, by person

  1. cznewt
    1. cznewt to look at beaker gates and how to fold into the salt workflow
    2. cznewt to look at beaker gates and how to fold a similar process into the salt workflow
    3. cznewt get the first cloud based labs for openstack-salt testing fully operational
  2. genunix
    1. genunix to continue openstack packaging research
  3. jasondotstar
    1. jasondotstar to look at the integration of launchpad with our repos (bug triage, tracking, etc.) *important*
    2. jasondotstar to complete local dev testing setup
    3. jasondotstar to work on pruning the salt formula projects underneath the stackforge/ namespace
  4. openstack
    1. genunix to continue openstack packaging research
    2. cznewt get the first cloud based labs for openstack-salt testing fully operational
  5. UNASSIGNED
    1. consider testing deployments to windows-based clients
    2. continue to engage the salt community regarding our standardizing dependencies, packaging, versioning, and testing


People present (lines said)

  1. jasondotstar (117)
  2. cznewt (57)
  3. genunix (5)
  4. openstack (3)
  5. clarkb (1)


Generated by MeetBot 0.1.4.