#openstack-cyborg: openstack-cyborg

Meeting started by zhipeng at 15:00:57 UTC (full logs).

Meeting summary

  1. Roll Call (zhipeng, 15:01:08)
    1. Howard (zhipeng, 15:01:15)
    2. Rushil (crushil, 15:09:07)

  2. Sydney Summit slide review (zhipeng, 15:11:27)
  3. Placement-Cyborg Interaction Discussion (zhipeng, 15:19:02)
    1. https://github.com/jaypipes/articles/blob/master/openstack/placement-queens-update.md (zhipeng, 15:20:18)
    2. Jay Pipe's writeup on Placement (zhipeng, 15:20:46)
    3. http://specs.openstack.org/openstack/nova-specs/specs/queens/approved/ironic-driver-traits.html (zhipeng, 15:21:23)
    4. https://review.openstack.org/#/c/504531/ (zhipeng, 15:21:40)
    5. first one is about Ironic report/accept trait with Nova, second one is about trait config in Ironic (zhipeng, 15:22:17)
    6. http://specs.openstack.org/openstack/nova-specs/specs/queens/approved/virt-add-support-for-vgpu.html (zhipeng, 15:23:00)
    7. https://github.com/kubernetes/community/pull/782 (zhipeng, 15:23:35)
    8. k8s discussion on resource class for accelerators (zhipeng, 15:23:48)
    9. 1. We need to define CUSTOM_ traits for sure, but also some additions to os-trait lib on FPGA if there are any (zhipeng, 15:25:43)
    10. 2. other than the reporting from cyborg-agent to the Placement API, we need (a) the driver also support trait api and (b) cyborg-api support trait (zhipeng, 15:26:41)
    11. 3. There is a caveat for Cyborg on resource provider modeling for accelerators which is we need to find a way to model different types of accelerators in a unified way (zhipeng, 15:27:44)
    12. 3a. Traits and resource class are used to define qualitive and quantative side of resource, however we might need a third kind to descirbe accelerators, because only using traits and ResourceClass means we will have a lot them for different accelerators (zhipeng, 15:29:17)
    13. 3b. We might need to consider using something like capability to describe the accelerator resource. For example FPGA and GPU both could be used for ML, a user might just want a VM to run a ML workload with the help of an attached accelerator (zhipeng, 15:30:35)
    14. 3c. This means we need to enable user to be able to select one capable resource instead of identifing very specifically which resource they want (zhipeng, 15:31:29)
    15. ACTION: crushil to work on a new spec on cyborg driver trait support, and zhipeng will work on a new spec on api trait extention (zhipeng, 15:46:37)

  4. Generic Driver progress update (zhipeng, 15:54:14)
    1. ACTION: shaohe_feng_ and crushil collaborate on the driver development for backend support (zhipeng, 15:58:09)
    2. ACTION: zhipeng to send meeting invites for monthly deep dive (zhipeng, 16:03:39)

  5. patch discussion (zhipeng, 16:03:46)
    1. https://review.openstack.org/#/q/project:openstack/cyborg+status:open (zhipeng, 16:04:05)

  6. AoB (zhipeng, 16:05:38)


Meeting ended at 16:09:54 UTC (full logs).

Action items

  1. crushil to work on a new spec on cyborg driver trait support, and zhipeng will work on a new spec on api trait extention
  2. shaohe_feng_ and crushil collaborate on the driver development for backend support
  3. zhipeng to send meeting invites for monthly deep dive


Action items, by person

  1. crushil
    1. crushil to work on a new spec on cyborg driver trait support, and zhipeng will work on a new spec on api trait extention
    2. shaohe_feng_ and crushil collaborate on the driver development for backend support
  2. shaohe_feng_
    1. shaohe_feng_ and crushil collaborate on the driver development for backend support
  3. zhipeng
    1. crushil to work on a new spec on cyborg driver trait support, and zhipeng will work on a new spec on api trait extention
    2. zhipeng to send meeting invites for monthly deep dive


People present (lines said)

  1. zhipeng (103)
  2. crushil (39)
  3. shaohe_feng_ (17)
  4. openstack (3)
  5. zhuli (1)


Generated by MeetBot 0.1.4.