15:00:57 <zhipeng> #startmeeting openstack-cyborg
15:00:58 <openstack> Meeting started Wed Nov  1 15:00:57 2017 UTC and is due to finish in 60 minutes.  The chair is zhipeng. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:01 <openstack> The meeting name has been set to 'openstack_cyborg'
15:01:08 <zhipeng> #topic Roll Call
15:01:15 <zhipeng> #info Howard
15:03:27 <shaohe_feng_> hi zhipeng
15:03:50 <zhipeng> hi shaohe
15:03:51 <shaohe_feng_> good evening
15:04:22 <shaohe_feng_> what does Howard mean?
15:05:42 <zhipeng> my alias lol
15:06:19 <shaohe_feng_> got it
15:07:05 <shaohe_feng_> Any info?
15:07:19 <shaohe_feng_> are we waiting for others?
15:07:49 <zhipeng> that is the cmd that will record your name in the minutes
15:08:03 <zhipeng> we are waiting for justin and crushil
15:08:22 <crushil> zhipeng, I am here
15:08:28 <crushil> Just in another meeting
15:09:07 <crushil> #info Rushil
15:09:16 <zhipeng> no problem :)
15:09:19 <crushil> zhipeng, Justin is on vacation till this friday
15:09:28 <zhipeng> ah okey
15:09:34 <zhipeng> then we can just start
15:09:45 <zhipeng> he could catch up later with the minutes
15:11:27 <shaohe_feng_> any introduce for each?
15:11:27 <zhipeng> #topic Sydney Summit slide review
15:11:45 <zhipeng> crushil is our core reviewer from Lenovo :)
15:11:55 <zhipeng> shaohe_feng_ is from Intel
15:12:13 <shaohe_feng_> crushil: hello, I'm shaohe feng
15:12:29 <zhuli> Sorry guys, it’s been a long time since we meet last time, unfortunately ,because I work very late today and I am driving home now, couldn’t pay attention to this meeting, so I will read the log history later and send some emails if needed
15:13:02 <zhipeng> zhuli safe driving !
15:13:03 <shaohe_feng_> crushil: from intel. focus on intel's accelerator
15:13:30 <zhipeng> hope you are using audio to text ML converter zhuli :P
15:13:40 <zhipeng> anyways back to the topic
15:13:49 <zhipeng> we have one lightening talk at Sydney Summit
15:14:23 <zhipeng> I have sent a simple slide I prepared to ttk[m] and crushil based upon our report to TC back in Denver
15:14:49 <zhipeng> so I might add a few today or tmr, but I think it should be ok now content wise for the lightening talk
15:15:19 <crushil> I made some changes
15:15:45 <crushil> And I am talking about it to my coworker who will present for us at Sydney
15:16:32 <zhipeng> ok gr8t
15:16:41 <zhipeng> i think we should have few problem with the slide
15:17:03 <zhipeng> and we could make the slide publicly available after the summit session
15:17:08 <crushil> Ya
15:18:49 <zhipeng> okey let's move onto the important topic today
15:19:02 <zhipeng> #topic Placement-Cyborg Interaction Discussion
15:19:34 <zhipeng> So I have been studying the Placement/Resource Provider/Trait stuff last week
15:19:45 <zhipeng> and attended the nova-ironic trait meeting yesterday
15:19:57 <zhipeng> so let me first send out some useful links here
15:20:18 <zhipeng> #link https://github.com/jaypipes/articles/blob/master/openstack/placement-queens-update.md
15:20:46 <zhipeng> #info Jay Pipe's writeup on Placement
15:20:52 <zhipeng> this is as the best as you could get
15:21:12 <zhipeng> and there are two specs that will be very useful to us, from Ironic
15:21:23 <zhipeng> #link http://specs.openstack.org/openstack/nova-specs/specs/queens/approved/ironic-driver-traits.html
15:21:40 <zhipeng> #link https://review.openstack.org/#/c/504531/
15:22:17 <zhipeng> #info first one is about Ironic report/accept trait with Nova, second one is about trait config in Ironic
15:22:45 <zhipeng> ok there is another spec that will help our modeling, is the vGPU spec from jianghua
15:23:00 <zhipeng> #link http://specs.openstack.org/openstack/nova-specs/specs/queens/approved/virt-add-support-for-vgpu.html
15:23:21 <zhipeng> and even more interestingly
15:23:32 <zhipeng> we could also learn something from the kubernetes discussion
15:23:35 <zhipeng> #link https://github.com/kubernetes/community/pull/782
15:23:48 <zhipeng> #info k8s discussion on resource class for accelerators
15:24:36 <zhipeng> well based upon all the readings i did via the above mentioned links
15:25:06 <zhipeng> I think there several points we need to consider when we modeling cyborg maneged resources
15:25:43 <zhipeng> #info 1. We need to define CUSTOM_ traits for sure, but also some additions to os-trait lib on FPGA if there are any
15:26:41 <zhipeng> #info 2. other than the reporting from cyborg-agent to the Placement API, we need (a) the driver also support trait api and (b) cyborg-api support trait
15:27:09 <crushil> zhipeng, Ya, I have been following the traits discussion on the Ironic end too. So, I might have some inputs once there is a spec up on our end
15:27:44 <zhipeng> #info 3. There is a caveat for Cyborg on resource provider modeling for accelerators which is we need to find a way to model different types of accelerators in a unified way
15:29:17 <zhipeng> #info 3a. Traits and resource class are used to define qualitive and quantative side of resource, however we might need a third kind to descirbe accelerators, because only using traits and ResourceClass means we will have a lot them for different accelerators
15:30:35 <zhipeng> #info 3b. We might need to consider using something like capability to describe the accelerator resource. For example FPGA and GPU both could be used for ML, a user might just want a VM to run a ML workload with the help of an attached accelerator
15:31:29 <zhipeng> #info 3c. This means we need to enable user to be able to select one capable resource instead of identifing very specifically which resource they want
15:31:43 <zhipeng> ok that is the end of my monologue lol
15:31:49 <zhipeng> any thoughts ?
15:37:32 <shaohe_feng_> need time to reading the link, too many  info.
15:38:11 <zhipeng> ya , any thoughts on my comments above ? besides the links :P
15:43:05 <crushil> I will chime in once we have specs in our backlog
15:43:36 <crushil> I have some thoughts about the way we should be implementing traits on our end and handing them over to Nova
15:44:22 <zhipeng> crushil that brings mine proposals actually
15:44:23 <crushil> And that will alter the implementation of the generic driver as well which I am working on currently
15:44:36 <zhipeng> i think besides justin's general spec
15:44:46 <zhipeng> we will need one on the driver side and one on the api side
15:45:06 <zhipeng> would you like to lead on the driver trait spec ?
15:45:11 <crushil> Sure
15:45:37 <crushil> When is the stable Queens release date?
15:45:40 <zhipeng> zhuli and I will work on the api side
15:45:54 <zhipeng> crushil I need to double check on that
15:46:21 <crushil> I think we need to be reasonable with the amount of work we promise
15:46:30 <crushil> I would hate to overpromise and underdeliver
15:46:37 <zhipeng> #action crushil to work on a new spec on cyborg driver trait support, and zhipeng will work on a new spec on api trait extention
15:46:43 <zhipeng> crushil that is for sure
15:48:15 <zhipeng> and on that note, let's also start simple
15:48:32 <zhipeng> we could cover very basic trait descriptions for Queens
15:48:57 <zhipeng> meaning for example not necessarily model FPGA resources in a Tree structure in full
15:49:11 <zhipeng> let's deliver something basic in Queens
15:49:42 <crushil> zhipeng, Exactly with at least a shim that vendors can build upon
15:49:56 <zhipeng> crushil +1
15:50:13 <zhipeng> okey any more comments on this topic ?
15:50:38 <zhipeng> folks you are more than welcomed to provide further feedback on mailing list later on
15:50:53 <crushil> zhipeng, We need to have something like a midcycle to go over things that need work on
15:51:10 <zhipeng> that is what I think
15:51:20 <zhipeng> maybe a video conf meeting for like 2-3 hours ?
15:51:24 <crushil> Ya
15:51:27 <zhipeng> maybe the week of Sydney Summit ?
15:51:34 <zhipeng> since all of us will not be there lol
15:51:38 <crushil> lol
15:51:48 <zhipeng> let's do something useful instead
15:51:48 <crushil> Or we can do that monthly
15:51:58 <zhipeng> of cource that'd be great
15:52:10 <crushil> Justin and I can be in the same room
15:52:59 <zhipeng> lol don't eat ice cream in front of me
15:53:41 <crushil> We'll join from Coldstone
15:53:50 <zhipeng> lol
15:54:00 <zhipeng> okey moving onto next topic
15:54:14 <zhipeng> #topic Generic Driver progress update
15:54:32 <zhipeng> crushil any thoughts on what or how much work needed there ?
15:54:45 <zhipeng> i think shaohe could also lend a hand here
15:55:29 <crushil> So, I am working on creating interfaces between Cyborg APIs and generic driver. After that is done, I will work on creating a shim for the vendors
15:55:44 <crushil> That can be helpful if shaohe can help
15:55:54 <crushil> Does shaohe work with you?
15:56:42 <zhipeng> no but we are in the same country, so it'll be easy for us to communicate
15:56:53 <zhipeng> shaohe_feng_ interested ?
15:56:53 <shaohe_feng_> I'm planning to support inte
15:57:01 <shaohe_feng_> yes.
15:57:07 <zhipeng> gr8t !
15:58:02 <shaohe_feng_> we are planning to support intel's accelerator in cyborg
15:58:09 <zhipeng> #action shaohe_feng_ and crushil collaborate on the driver development for backend support
15:58:23 <shaohe_feng_> such as intel's GPU and FPGA
15:58:32 <crushil> shaohe_feng_, That's awesome
15:59:04 <crushil> I have reached out to other vendors. Intel was one of the vendors that I hadn't talked ot
15:59:05 <crushil> *to
15:59:15 <zhipeng> nice :)
15:59:40 <zhipeng> okey moving on to next topic
15:59:43 <crushil> shaohe_feng_, Are you specifically supporting Intel products or Altera products?
16:00:43 <crushil> sorry zhipeng We can talk about this offline. I don't mean to start another tangent
16:00:56 <shaohe_feng_> crushil: I can help on some general work
16:01:01 <zhipeng> no worries
16:01:13 <zhipeng> no important items left :P
16:02:45 <shaohe_feng_> we know better Intel's and Altera specifically products
16:02:58 <shaohe_feng_> ^ crushil
16:03:01 <crushil> zhipeng, Please send a recurring calendar invite for every month where we analyze where we are
16:03:15 <crushil> shaohe_feng_, Cool
16:03:39 <zhipeng> #action zhipeng to send meeting invites for monthly deep dive
16:03:46 <zhipeng> #topic patch discussion
16:04:05 <zhipeng> #link https://review.openstack.org/#/q/project:openstack/cyborg+status:open
16:04:12 <zhipeng> any outstanding issue there ?
16:04:48 <crushil> We need more patches
16:04:51 <crushil> :)
16:05:08 <zhipeng> haha yep
16:05:34 <zhipeng> okey then
16:05:38 <zhipeng> #topic AoB
16:05:48 <zhipeng> any other business
16:06:13 <crushil> Nothing from me
16:07:04 <zhipeng> anyone else ?
16:07:42 <crushil> I got an email from NXCA technologies
16:07:50 <crushil> They want to know more about Cyborg
16:07:53 <zhipeng> me and justin as well
16:08:01 <zhipeng> not sure if Amol is at the meeting now
16:08:06 <crushil> I will schedule a call with them next week
16:08:10 <crushil> I don't think so
16:08:10 <zhipeng> probably not
16:08:15 <zhipeng> okey great
16:09:33 <zhipeng> if nothing else, then I will conclude the meeting
16:09:44 <zhipeng> we have an awesome one today, thx everyone
16:09:54 <zhipeng> #endmeeting