#openstack-meeting-alt: marconi

Meeting started by kgriffs at 15:00:27 UTC (full logs).

Meeting summary

  1. roll call (kgriffs, 15:00:30)
    1. https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda (kgriffs, 15:01:53)

  2. Marconi SqlAlchemy (alcabrera) (kgriffs, 15:02:17)
    1. https://etherpad.openstack.org/p/marconi-sqlalchemy (kgriffs, 15:02:43)
    2. https://etherpad.openstack.org/p/marconi-sqlalchemy (alcabrera, 15:09:08)
    3. ACTION: alcabrera to implement shards controller (sqlalchemy) (alcabrera, 15:10:26)
    4. ACTION: alcabrera to implement catalogue controller (sqlalchemy) (alcabrera, 15:10:33)
    5. ACTION: flaper87, alcabrera, and malini to save the world by implementing the SQL driver in record time (kgriffs, 15:11:51)
    6. sqlalchemy effort prioritized - targeting Feb. 20th (alcabrera, 15:12:19)

  3. pending patches (kgriffs, 15:12:55)
    1. https://review.openstack.org/#/q/status:open+project:openstack/marconi,n,z (kgriffs, 15:13:22)
    2. https://review.openstack.org/#/c/70202/ (sqlalchemy config ++) (alcabrera, 15:13:43)
    3. https://review.openstack.org/#/c/68267/ (lots of bug fixes) (alcabrera, 15:13:53)

  4. i-3 (kgriffs, 15:18:18)
    1. https://launchpad.net/marconi/+milestone/icehouse-3 (kgriffs, 15:18:50)
    2. balajiiyer making good progress on docs initiative (alcabrera, 15:21:18)
    3. balajiiyer aiming to support enough pecan in marconi to benchmark by end of week (alcabrera, 15:25:19)
    4. ACTION: flaper87 to sanity-check heat template, see if we are all done there (kgriffs, 15:29:15)
    5. next week - reviewing v1.1 spec (alcabrera, 15:34:29)
    6. https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1 (kgriffs, 15:34:33)
    7. ACTION: kgriffs to invite sdk devs to v1.1 api review (kgriffs, 15:36:28)
    8. cpallares reports slow progress on cross transport API spec (alcabrera, 15:38:06)
    9. https://github.com/fog/fog (alcabrera, 15:38:49)
    10. https://github.com/fog/fog (alcabrera, 15:38:54)
    11. security testing effort re-targetted for Juno (alcabrera, 15:42:53)
    12. ACTION: kgriffs to break out bps for v1.1 work (alcabrera, 15:46:34)
    13. https://blueprints.launchpad.net/marconi/+spec/detailed-health (kgriffs, 15:46:34)
    14. https://blueprints.launchpad.net/marconi/+spec/benchmark (kgriffs, 15:51:07)
    15. flwang to continue work on more detailed health info/KPIs (alcabrera, 15:52:09)
    16. benchmark effort retargetted for Juno (alcabrera, 15:52:18)
    17. https://review.openstack.org/#/c/70202/ (alcabrera, 15:53:02)
    18. alcabrera started shards controller for sql driver (alcabrera, 15:53:51)

  5. bugs (kgriffs, 15:55:05)
    1. https://blueprints.launchpad.net/marconi/+spec/marconi-horizon-integration (kgriffs, 15:56:15)
    2. jay-atl launching horizon effort for marconi - progress: started (alcabrera, 15:56:15)

  6. open discussion (kgriffs, 15:59:57)


Meeting ended at 16:00:38 UTC (full logs).

Action items

  1. alcabrera to implement shards controller (sqlalchemy)
  2. alcabrera to implement catalogue controller (sqlalchemy)
  3. flaper87, alcabrera, and malini to save the world by implementing the SQL driver in record time
  4. flaper87 to sanity-check heat template, see if we are all done there
  5. kgriffs to invite sdk devs to v1.1 api review
  6. kgriffs to break out bps for v1.1 work


Action items, by person

  1. alcabrera
    1. alcabrera to implement shards controller (sqlalchemy)
    2. alcabrera to implement catalogue controller (sqlalchemy)
    3. flaper87, alcabrera, and malini to save the world by implementing the SQL driver in record time
  2. flaper87
    1. flaper87, alcabrera, and malini to save the world by implementing the SQL driver in record time
    2. flaper87 to sanity-check heat template, see if we are all done there
  3. kgriffs
    1. kgriffs to invite sdk devs to v1.1 api review
    2. kgriffs to break out bps for v1.1 work
  4. malini
    1. flaper87, alcabrera, and malini to save the world by implementing the SQL driver in record time


People present (lines said)

  1. kgriffs (188)
  2. alcabrera (105)
  3. flaper87 (65)
  4. malini (31)
  5. balajiiyer (17)
  6. flwang (8)
  7. amitgandhi (7)
  8. cpallares (7)
  9. ametts (4)
  10. jay-atl (4)
  11. openstack (3)
  12. mpanetta (2)
  13. jaypipes (2)
  14. oz_akan_ (1)


Generated by MeetBot 0.1.4.