15:00:27 <kgriffs> #startmeeting marconi
15:00:28 <openstack> Meeting started Tue Feb  4 15:00:27 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:30 <kgriffs> #topic roll call
15:00:32 <openstack> The meeting name has been set to 'marconi'
15:00:35 <flwang> o/
15:00:37 <alcabrera> o/
15:00:50 <flaper87> o/
15:00:50 <kgriffs> anyone else here for marconi awesomeness
15:01:02 <balajiiyer> o/
15:01:05 <alcabrera> w00t
15:01:09 <mpanetta> o/
15:01:19 <cpallares> o/
15:01:28 <kgriffs> excellent
15:01:29 <alcabrera> hurray - looking lively!
15:01:36 * kgriffs hands out teh pop-tartz
15:01:51 * flaper87 eats his and steals cpallares's
15:01:53 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:01:55 <balajiiyer> good thing, havent had breakfast yet
15:01:56 <cpallares> :o
15:02:04 <alcabrera> lol
15:02:15 * cpallares pouts
15:02:15 * alcabrera clones his poptarts, stashes for later
15:02:17 <kgriffs> #topic Marconi SqlAlchemy (alcabrera)
15:02:33 <ametts> \o/
15:02:40 <kgriffs> :)
15:02:42 <alcabrera> Cool - I'm surprised we're launching with the sqlalchemy topic. :P
15:02:43 <kgriffs> #link https://etherpad.openstack.org/p/marconi-sqlalchemy
15:02:44 <flaper87> go alcabrera, go alcabrera, go alcabrera
15:03:03 <alcabrera> yes, that link. :D
15:03:04 <alcabrera> Anyway
15:03:34 <alcabrera> Here's the situation - I'm hoping to drive our effort to get us sqlalchemy support by the end of this month (really, Feb. 20ish)
15:03:47 <alcabrera> That link above describes a proposed strategy to meet that
15:03:48 * kgriffs wants that
15:04:14 <kgriffs> alcabrera: is there anything specific you wanted feedback on?
15:04:19 <alcabrera> It's a tight schedule, a bit aggressive, but yes - sqlalchemy support is *really* desirable for ice house.
15:04:21 <alcabrera> hmmm
15:04:27 <oz_akan_> hi
15:04:32 <malini> o/
15:04:38 <alcabrera> two things I can think of off the top of my head -
15:04:45 <alcabrera> 1) general thoughts on timeline
15:04:49 <alcabrera> 2) testing strategy
15:04:51 * kgriffs hands teh oz_akan_ and teh malini teh pot-tarts
15:04:53 <flaper87> /
15:04:55 <flaper87> o/
15:04:58 <malini> yayy
15:04:58 <flaper87> o/
15:05:23 <malini> alcabrera: do u want to discuss test strategy now  or after the meeting?
15:05:24 <ametts> Hey, why didn't I get a pop-tart when I showed up?
15:05:30 <flaper87> I got some feedback fro Yeela, the queue controller is almost done, she sent it to me. I'll ask here to push it to gerrit and mark it as WIP
15:05:36 <flaper87> so we can all provide feedback
15:05:39 <malini> alcabrera: I have been thinking abt how to test it
15:05:43 <cpallares> ammets, flaper87 probably ate it
15:05:44 * kgriffs passes the box to ametts
15:05:44 <alcabrera> flaper87: thanks!
15:05:49 * alcabrera listens to malini
15:06:01 <flaper87> the issue is that the tests for the queue controller depend on the message controller to
15:06:09 <flaper87> I *think*
15:06:20 <flaper87> so, some work on the message controller is needed too
15:06:39 <malini> I am thinking of adding a gate/check job that will be functional-tests-devstack-mongodb
15:06:40 * flaper87 STFU
15:06:42 <alcabrera> hmmm, flaper87 - I think that's right. The implementation order might need to be swapped so that the msg ctrl comes before the queue ctrl - or something like that
15:06:58 <flaper87> I can work on that asap
15:07:10 <flaper87> and we can isolate the queue_controller tests from the message controller
15:07:16 <alcabrera> +1
15:07:18 <flaper87> that will help with getting the queues patch in
15:07:22 <malini> Once we have that in place , we can use the same template to do a  functional-tests-devstack-postgres, functional-tests-devstack-mysql or whatever backend we need to
15:07:27 <flaper87> and then work on the message controller
15:07:46 <flaper87> I think the due date for the queue controller should be next monday!
15:07:52 <alcabrera> malini: +1 - could you add notes in that regard to the etherpad?
15:07:59 <malini> alcabrera: sure
15:08:11 <malini> This will be in addition & separate from the tempest tests
15:08:13 <kgriffs> alcabrera: so you and flaper87 have worked out which parts you are implementing?
15:08:24 <alcabrera> not yet, kgriffs. :)
15:08:36 <alcabrera> so, now is a good a time as any
15:08:49 <alcabrera> flaper87: I'll be tackling the catalogue and shards controller this week
15:08:52 <flaper87> I think it would be nice if alcabrera could thake the shard part
15:08:55 <flaper87> LOL
15:08:57 <alcabrera> :D
15:09:01 <malini> alcabrera: Can you post the link again, plz?
15:09:06 <alcabrera> sure thing, malini
15:09:08 <alcabrera> https://etherpad.openstack.org/p/marconi-sqlalchemy
15:09:10 <flaper87> alcabrera: yeah, I'll make sure the rest of the work is complete and lands
15:09:15 <flaper87> malini: +1 for the gate thing
15:09:18 <kgriffs> ok, let's rock this out
15:09:18 <alcabrera> sweet
15:09:24 <alcabrera> so, let's distribute #actions
15:09:26 <kgriffs> we need everyone to keep a close eye on the review queue
15:09:33 <kgriffs> (to keep things truckin' along)
15:09:51 <kgriffs> anything else on that topic?
15:10:02 <flaper87> I'll be tracking the work there, I'm kind of burried in stuff this week
15:10:04 <alcabrera> I'm pretty satisfied for now. I think we're on track.
15:10:20 <flaper87> if there are reviews to do, feel free to ping me. I'm not monitoring gerrit much this week
15:10:26 <alcabrera> #action alcabrera to implement shards controller (sqlalchemy)
15:10:33 <alcabrera> #action alcabrera to implement catalogue controller (sqlalchemy)
15:10:33 <flaper87> I will try to, though!
15:10:36 <kgriffs> flaper87: will you be able to work on the SQL driver this week?
15:10:41 <flaper87> and sorry about that!
15:10:51 <flaper87> kgriffs: Yeela is working on the queue controller
15:10:55 <alcabrera> flaper87: no worries. :)
15:11:08 <flaper87> kgriffs: I'll start working on the message controller asap
15:11:09 <kgriffs> ok, it's just that I am getting *really* nervous
15:11:20 <kgriffs> we are down to the wire
15:11:28 <alcabrera> 16 days to go
15:11:51 <kgriffs> #action flaper87, alcabrera, and malini to save the world by implementing the SQL driver in record time
15:11:54 <flaper87> yeah, I'll make that happen
15:11:56 <alcabrera> hurray
15:11:59 <alcabrera> :D
15:12:02 <kgriffs> ;)
15:12:06 <malini> me too...
15:12:12 <kgriffs> of course!
15:12:19 <alcabrera> #info sqlalchemy effort prioritized - targeting Feb. 20th
15:12:21 <malini> I will really really focus on graduation starting now
15:12:25 <kgriffs> our code would totally suck without you keeping us honest. srsly.
15:12:55 <kgriffs> #topic pending patches
15:13:19 <kgriffs> just wanted to take a moment to give people an opportunity to highlight any of these
15:13:22 <kgriffs> https://review.openstack.org/#/q/status:open+project:openstack/marconi,n,z
15:13:23 <alcabrera> there's several close patches in the queue
15:13:39 <kgriffs> yep
15:13:43 <alcabrera> #link https://review.openstack.org/#/c/70202/ (sqlalchemy config ++)
15:13:53 <alcabrera> #link https://review.openstack.org/#/c/68267/ (lots of bug fixes)
15:14:00 <kgriffs> so, last week I bloodied myself kicking against the wsgiref stuff
15:14:09 <alcabrera> oh yes - the evils of wsgiref
15:14:26 <kgriffs> after the team bandaged my wounds, we came up with the idea for that first patch there
15:14:53 <kgriffs> there are a couple housekeeping patches with a -1
15:14:57 <kgriffs> minor stuff
15:14:59 <alcabrera> I'm very +2 for the idea.
15:15:05 <kgriffs> let's get those updated and merged ASAP
15:15:06 <alcabrera> re: wsgiref changes
15:15:13 * kgriffs gives alcabrera a big hug
15:15:20 <alcabrera> :D
15:15:23 * kgriffs wipes a tear from his eye
15:15:23 * alcabrera returns hug
15:15:38 * ametts is getting nauseated
15:15:44 * kgriffs was traumatized
15:16:01 <kgriffs> ametts: LOL
15:16:10 <alcabrera> lol
15:16:13 <kgriffs> flaper87: can you take a look at my patch there?
15:16:24 <alcabrera> so, quick question:
15:16:25 <flaper87> kgriffs: I'm doing that as we speak
15:16:27 <flaper87> :D
15:16:28 <alcabrera> "The style guideline says if there's no code the file shouldn’t contain any license header nor comments. I double checked."
15:16:29 <kgriffs> it will make everyone's lives soooo much better. I promise.
15:16:43 <kgriffs> oic
15:16:44 <malini> tht is just a crazy guideline
15:16:48 <kgriffs> that is kinda silly
15:16:50 <kgriffs> but whatever
15:16:56 <kgriffs> I can remove my -1
15:16:59 <kgriffs> not a big deal
15:17:02 <alcabrera> cool
15:17:08 <alcabrera> that's two patches we can merge now
15:17:10 <kgriffs> ok, anything else on the topic?
15:17:18 <alcabrera> hmmm
15:17:37 <alcabrera> nah, I'm good. We can get back to this in #marconi later
15:18:18 <kgriffs> #topic i-3
15:18:40 <alcabrera> bps and bugs~
15:18:49 <kgriffs> this is pretty much graduation stuff, so I am going to combine those agenda items
15:18:50 <kgriffs> #link https://launchpad.net/marconi/+milestone/icehouse-3
15:19:18 <kgriffs> so, I deprioritized a few things there
15:19:26 <kgriffs> and made sure all bps are assigned
15:19:37 <kgriffs> let's go down these in order
15:19:40 <kgriffs> balajiiyer: docs
15:20:06 <balajiiyer> Im working with Catherine on docs. she is going to start with user docs this week.
15:20:16 <kgriffs> excellent
15:20:20 <alcabrera> sweet
15:20:32 <kgriffs> did you end up deciding to put those in the marconi repo then?
15:20:44 <balajiiyer> I have to talk to oz_akan_ mpanetta and get a draft installation guide, and give it to Catherine to make it pretty
15:20:54 <balajiiyer> yes, it will go to marconi repo
15:21:04 <kgriffs> balajiiyer: cool. Let them do a very rough draft and let Catherine work her magic
15:21:08 <kgriffs> balajiiyer: kk
15:21:18 <alcabrera> #info balajiiyer making good progress on docs initiative
15:21:31 <kgriffs> flaper87: we are going to try to mirror the manuals repo so it will be easy to move over once we are integrated
15:21:43 <balajiiyer> there are a few things Catherine & I will have to figure out, but I will post those questions once we cross the bridge
15:21:46 <flaper87> that sounds good to me
15:21:48 <kgriffs> balajiiyer: thanks!
15:21:56 <flaper87> balajiiyer: +1 for the effort there!
15:21:56 <kgriffs> balajiiyer: pecan
15:21:59 <flaper87> we really need that
15:22:32 <balajiiyer> Been working on pecan the last couple of days, bloodied (going to borrow your word, Kurt)
15:22:56 * kgriffs hands balajiiyer some bandages and salve
15:23:05 * amitgandhi the walls in our office are red with the bloodied work of balajiiyer
15:23:06 <malini> pecan shud be called macadamia - hard to crack
15:23:15 <kgriffs> balajiiyer: do you think we will have a POC by the end of the week?
15:23:16 <alcabrera> haha
15:23:17 <balajiiyer> alcabrera been helping me out, so will be successful. Lots of architectural changes reqd to get marconi going with pecan
15:23:41 <kgriffs> sounds like pecan doesn't like to play nice with others
15:23:45 <alcabrera> global request/response objects are a bit strange
15:23:48 <mpanetta> malini: ++
15:23:49 <kgriffs> i knew a kid like that once
15:23:52 <malini> :D
15:23:57 <alcabrera> 'from pecan import request, response'
15:24:00 <alcabrera> e.g.
15:24:21 <kgriffs> ok, how soon before we can run a significant benchmark?
15:24:25 <balajiiyer> kgriffs:  I have been updating the notes page, so take a look at that
15:24:31 <kgriffs> balajiiyer: kewl
15:24:34 <kgriffs> which reminds me
15:24:44 <balajiiyer> Im targetting EOW, lets see
15:24:50 <kgriffs> I need to go write some marconi docs so we have something to show on that line item. :p
15:25:19 <alcabrera> #info balajiiyer aiming to support enough pecan in marconi to benchmark by end of week
15:25:28 <kgriffs> tbh, lots of people say when they use falcon the README is almost good enough, since Falcon is so easy to learn
15:25:37 <kgriffs> </shameless-plug>
15:25:39 <alcabrera> :P
15:25:51 <kgriffs> balajiiyer: thanks man, I REAAAAALLLLLYYYYY appreciate this!
15:26:00 <alcabrera> :D
15:26:03 <alcabrera> yeah, thanks balajiiyer!
15:26:04 <balajiiyer> kgriffs:  yw
15:26:12 * kgriffs gives balajiiyer a high-five
15:26:16 <kgriffs> ok
15:26:17 <kgriffs> next
15:26:24 <kgriffs> SQL storage driver
15:26:30 <alcabrera> haha
15:26:32 <alcabrera> yes, that
15:26:46 <kgriffs> we already talke about that
15:26:46 <kgriffs> next
15:26:46 <kgriffs> malini: tempest
15:26:59 <malini> I got one patch merged y'day
15:27:15 <malini> have another one I am working on now https://review.openstack.org/#/c/65140/
15:27:24 <alcabrera> sweet
15:27:33 <malini> I have been neglecting these patches the last couple of weeks
15:27:41 <malini> HAve been crazy busy with other stuff
15:27:44 <kgriffs> kk
15:27:58 <malini> But I will get back on track & get the outstanding patches merged this week
15:28:00 <kgriffs> malini: is that other stuff winding down?
15:28:07 <malini> kgriffs: yes
15:28:10 <kgriffs> gtk
15:28:13 <alcabrera> very yes
15:28:27 * alcabrera gives a sigh of relief
15:28:31 <kgriffs> heat template merged
15:28:38 <kgriffs> flaper87: can you sanity-check that template?
15:28:53 <flaper87> kgriffs: will do. I just clicked on it :D
15:28:57 <kgriffs> kk
15:29:15 <kgriffs> #action flaper87 to sanity-check heat template, see if we are all done there
15:29:32 <kgriffs> alcabrera: Make Basic Marconi Docs Available
15:29:37 <kgriffs> is this superseded?
15:29:48 <alcabrera> yes, balajiiyer is tackling the proper effort
15:30:09 <kgriffs> kk
15:30:13 <kgriffs> status updated
15:30:26 <alcabrera> thanks
15:30:27 <kgriffs> kgriffs: api v1.1
15:30:40 <kgriffs> i am going to start working on that today
15:31:08 <kgriffs> first step is to create a v1.0 clone i guess, since we wanted to make the schema work run in parallel
15:31:29 <kgriffs> flaper87: did you have any thoughts on that?
15:31:40 <flaper87> kgriffs: I actually wanted to talk about that
15:31:51 * kgriffs picks up the floor and hands it to flaper87
15:32:05 <flaper87> I guess our best shot now is to move the wsgi contents under a v1 package
15:32:20 <flaper87> and copy that one to a v11 or something like that
15:32:24 <flaper87> well, 11 is a major
15:32:27 <flaper87> :P
15:32:32 <kgriffs> ok. Let's do the silly copy-paste for now
15:32:49 <alcabrera> CP works for me
15:32:53 <kgriffs> we will clean up later assuming the fancy API abstraction works out
15:32:55 <alcabrera> v1_1, I suppose
15:33:01 <alcabrera> re: naming
15:33:23 <flaper87> not sure what the best thing to do there is, TBH. But yeah, I'd go with v1_1 for now
15:33:40 <kgriffs> I know other projects do copy-paste, but that doesn't always mean it's right (just because another project is doing it) -- more like, we can get away with it if we need to
15:33:42 <flaper87> ugly but sounds like it'll work
15:33:45 <kgriffs> kk
15:34:08 <kgriffs> so next week I'd like to review the 1.1 spec
15:34:19 <kgriffs> please everyone do their homework and come prepared to discuss the finer points
15:34:29 <alcabrera> #info next week - reviewing v1.1 spec
15:34:33 <kgriffs> #link https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1
15:35:19 <kgriffs> fwiw, pretty much the entire delta between 1.0 and 1.1 was driven by user/sdk developer feedback
15:35:36 <kgriffs> so if you don't like it, TOUGH
15:35:41 * kgriffs is kidding
15:35:52 <kgriffs> cpallares: Cross Transport API Spec
15:35:54 <amitgandhi> maybe worth having a few of those folks in that meeting too
15:36:01 <kgriffs> amitgandhi: good idea!
15:36:28 <kgriffs> #action kgriffs to invite sdk devs to v1.1 api review
15:36:52 <kgriffs> cpallares: status on that bp?
15:36:58 <balajiiyer> kgriffs:  speaking of sdk, did you need a note about fog being broken due to a change lower case headers?
15:37:09 <balajiiyer> need /see
15:37:10 <cpallares> yeah, working on tests for the api/storage communication
15:37:30 <kgriffs> is it still "slow progress" or "good progress"?
15:37:32 <cpallares> ...Still. I got a little stuck on the testing but flaper87 helped me out
15:37:37 <cpallares> slow progress
15:37:39 <kgriffs> kk
15:38:06 <alcabrera> #info cpallares reports slow progress on cross transport API spec
15:38:10 <kgriffs> thanks for working on that. glad to see it making some progress
15:38:23 <alcabrera> thanks, cpallares! :)
15:38:24 <kgriffs> balajiiyer: mmm. Parson my ignorance, but what is "fog"?
15:38:29 <kgriffs> s/parson/pardon
15:38:43 <alcabrera> Ruby cloud sdk, kinda like libcloud, kgriffs
15:38:47 <kgriffs> oic
15:38:49 <alcabrera> https://github.com/fog/fog
15:38:51 <alcabrera> errr
15:38:54 <alcabrera> #link https://github.com/fog/fog
15:39:24 <kgriffs> um, so, clients are supposed to not care about header case
15:39:38 * kgriffs hides behind HTTPbis
15:39:39 <balajiiyer> kgriffs: http://stackoverflow.com/questions/21489139/exception-claiming-messages-from-cloud-queues-in-fog/21489263#21489263
15:39:43 <alcabrera> +1
15:40:07 <kgriffs> oh, glad to know they fixed it
15:40:09 <kgriffs> hmm
15:40:17 <alcabrera> after discussing with the fog sdk devs, they traced the case-sense issue back to one of their deps - excon, which is kind of like the requests module of ruby
15:40:20 <kgriffs> I didn't realize that change went out in Cloud Queues
15:40:23 <ametts> Cool... people are asking about us on Stack Overflow...
15:40:32 <malini> we are famous!!
15:40:36 <kgriffs> w00t
15:40:42 <kgriffs> alcabrera: gtk
15:40:42 <balajiiyer> There is a tag for 'Rackspace'  in SO
15:41:23 <kgriffs> malini: Basic Security Tests
15:41:34 <kgriffs> as much as I hate to say this, I think this will have to slip into juno
15:41:36 <malini> havent started yet
15:41:42 <malini> I think so too
15:41:49 <kgriffs> but don't forget about it!
15:41:51 <kgriffs> :)
15:42:02 <malini> I will be focussing on tempest +sqlalchemy till feb 20
15:42:07 <alcabrera> agreed - we're too full to do more than what we're doing now
15:42:12 <malini> Will get to it after tht
15:42:16 <malini> wont forget :)
15:42:53 <alcabrera> #info security testing effort re-targetted for Juno
15:42:57 <kgriffs> flaper87: Make TTL optional
15:43:07 <kgriffs> so, I think that is basically part of the v1.1 API
15:43:18 <flaper87> I haven't started working on that but I think it's important
15:43:21 <flaper87> kgriffs: yeah
15:43:23 <flaper87> agreed
15:43:31 <kgriffs> "The ttl field is no longer required when posting messages and creating claims; if omitted, it will default to the max TTL allowed by your cloud operator."
15:43:42 <kgriffs> so, maybe I can just nuke this extra bp?
15:43:48 <alcabrera> +1 for nuking
15:43:58 <flaper87> well, I wouldn't
15:44:06 <flaper87> I mean, it's part of v1.1 but it's a different thing
15:44:18 <flaper87> ah wait
15:44:24 <flaper87> I understood what you mean, mmh
15:44:34 <flaper87> so your thinking about making all those changes in a single bp?
15:44:34 <kgriffs> well, is it really big enough to be it's own bp?
15:44:40 <kgriffs> flaper87: mmm
15:44:44 <kgriffs> good point
15:44:49 <flaper87> I'd prefer breaking those down into several bps
15:44:53 <kgriffs> we can break it down and make them dep
15:44:59 <flaper87> and with that we can split the job
15:45:04 <kgriffs> kk
15:45:47 <kgriffs> I'll break out the other things too
15:45:54 <alcabrera> +1 for breaking down v1.1 into bps - parallel development is good
15:46:03 <kgriffs> #kgriffs to break out bps for v1.1 work
15:46:33 <flaper87> LOL
15:46:33 <kgriffs> here's another v1.1 thing
15:46:34 <alcabrera> #action kgriffs to break out bps for v1.1 work
15:46:34 <kgriffs> https://blueprints.launchpad.net/marconi/+spec/detailed-health
15:46:40 <flaper87> #kgriffs is not a thing
15:46:42 <kgriffs> lol
15:46:43 <alcabrera> lol
15:46:43 <flaper87> you're cheating
15:46:46 <flaper87> :D
15:46:46 * kgriffs facepalm
15:47:33 <kgriffs> flwang: &&
15:47:36 <kgriffs> flwang: ^^
15:47:37 <kgriffs> I mean
15:47:42 <flwang> kgriffs: I have collected the KPI, 1) CPU utilization  2) # of active shards  3) # of queues/shard   4) response time / reqs/sec
15:47:45 * kgriffs wonders what is wrong with his keyboard
15:47:59 <flwang> does that make sense for you for the first stage?
15:48:16 <flwang> kgriffs: I'm not sure if all of them can be collected easily though
15:48:43 <kgriffs> flwang: sure. So let me create a v1_1 transport and then you can start plugging it in.
15:48:50 <kgriffs> mmm
15:48:53 <flwang> kgriffs: great
15:48:55 <alcabrera> flwang: let's talk about it in #openstack-marconi. I'll be glad to discuss the difficulty of each of those KPIs
15:49:02 <kgriffs> flwang: start with just one metric that is easy to collect
15:49:15 <kgriffs> that way you get all the plumbing done
15:49:17 <flwang> kgriffs: sure, that's what I want to do
15:49:23 <kgriffs> kk
15:49:36 <kgriffs> then we can add others and see how many we get in before i-3 closes.
15:49:42 <alcabrera> +1
15:49:46 <kgriffs> rock on
15:49:51 <kgriffs> flwang: thanks!
15:49:53 <flwang> kgriffs: yep
15:50:03 <flwang> kgriffs: sure, glad to contribute
15:50:21 <kgriffs> malini: benchmark
15:50:48 <kgriffs> malini: this would be helpful to add to the operator manual so people can make an educated decision
15:50:48 <kgriffs> but
15:50:54 <kgriffs> I'm thinking Juno
15:51:03 <malini> +1 for juno :)
15:51:07 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/benchmark
15:51:22 <malini> I also want to try out the stress test framework in tempest for this
15:51:40 <malini> Adding tsung configs is really easy & has worked out well for RAX implementation
15:51:50 <kgriffs> cool
15:52:04 <malini> But doing it in for gate/jenkins will require the infra team to add tsung etc
15:52:09 <alcabrera> #info flwang to continue work on more detailed health info/KPIs
15:52:12 <malini> which will raise a lot of questions
15:52:18 <alcabrera> #info benchmark effort retargetted for Juno
15:52:21 <kgriffs> alcabrera: Implement Sharding Controllers for sqlalchemy
15:52:30 <kgriffs> I can make that dep on SQL Storage Drive, nicht?
15:52:33 <alcabrera> started
15:52:35 <alcabrera> and yes. :)
15:52:51 <alcabrera> I have one patch in that is important for getting the rest going
15:53:01 <kgriffs> done
15:53:02 <alcabrera> #link https://review.openstack.org/#/c/70202/
15:53:18 <kgriffs> ah yes, thanks for the reminder
15:53:26 <kgriffs> I started reviewing that a few days ago and got sidetracked
15:53:31 <kgriffs> flaper87: ^^^
15:53:34 <alcabrera> no worries.
15:53:36 <kgriffs> let's get that reviewed ASAP
15:53:50 * flaper87 clicks
15:53:51 <alcabrera> #info alcabrera started shards controller for sql driver
15:53:59 <flaper87> oh yeah, that one!
15:54:21 <flaper87> sorry for not having reviewed it yet! I'll get to it asap!
15:54:26 <alcabrera> thanks!
15:55:02 <kgriffs> ok
15:55:05 <kgriffs> #topic bugs
15:55:11 <amitgandhi> holdup
15:55:15 <amitgandhi> horizon update?
15:55:25 <amitgandhi> jay-atl: has been making progress
15:55:33 <kgriffs> oh
15:55:36 <flaper87> wat?
15:55:38 <flaper87> ohhh
15:55:45 <kgriffs> I didn't realize that was being worked on
15:55:50 <kgriffs> bonus points!
15:55:51 * flaper87 neither
15:55:53 <jay-atl> yeah yesterday I got devstack with Marconi up... and pointed my horizon server to that.
15:55:56 <flaper87> thanks
15:56:00 <alcabrera> sweet
15:56:03 <alcabrera> :D
15:56:05 <flaper87> jay-atl:++
15:56:14 <kgriffs> this guy?
15:56:15 <kgriffs> https://blueprints.launchpad.net/marconi/+spec/marconi-horizon-integration
15:56:15 <alcabrera> #info jay-atl launching horizon effort for marconi - progress: started
15:56:24 <jay-atl> It's slow going, but today I hope to actually be populating it with data...
15:56:26 * amitgandhi to those that dont know jay he is one of our UX devs in ATL
15:56:40 <balajiiyer> kgriffs: yes, thats the bp Jay's been working on
15:56:50 <kgriffs> ah, cool
15:56:54 * jaypipes really must remove "jay" as an IRC notification pinger...
15:56:55 <kgriffs> let me move that into i-3 then
15:57:07 <alcabrera> lol
15:57:10 <jaypipes> :P
15:57:16 <balajiiyer> jay jay jay
15:57:21 <flaper87> LOL
15:58:03 <kgriffs> jay-atl do you have a launchpad account?
15:58:10 <kgriffs> I can assign the bp to you if you do
15:58:15 * alcabrera issues 2 minute warning
15:58:17 <jay-atl> Nope...
15:58:20 <kgriffs> kk
15:58:31 <kgriffs> balajiiyer can get you set up
15:58:40 <jay-atl> Ok
15:58:40 <kgriffs> for now, I'll leave it assigned to balajiiyer
15:58:55 <amitgandhi> jay-atl: https://wiki.openstack.org/wiki/Getting_Started
15:58:56 <kgriffs> thanks man!
15:59:25 <kgriffs> ok, re bugs, if we can get that wsgiref thing sorted, I will be unblocked from working on more bugs
15:59:43 <alcabrera> cool
15:59:44 <kgriffs> fwiw, I have the autoreconnect almost done - I imagine it will need a few review cycles
15:59:51 <kgriffs> (stay tuned)
15:59:57 <kgriffs> #topic open discussion
15:59:59 <kgriffs> 30 seconds
16:00:00 <kgriffs> ....go!
16:00:16 <alcabrera> I'm happy about the increasing help. :)
16:00:35 <kgriffs> w00t
16:00:38 <flaper87> I'm happy about Marconi and our team
16:00:38 <kgriffs> #endmeeting