#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:00:10 UTC (full logs).

Meeting summary

  1. kuryr-lib (apuimedo, 14:02:27)
    1. https://review.openstack.org/500420 (apuimedo, 14:03:10)
    2. https://review.openstack.org/508778 (apuimedo, 14:03:19)
    3. We are merging a dependencies update: https://review.openstack.org/#/c/496048/94 (apuimedo, 14:04:18)
    4. merging https://review.openstack.org/#/c/500420/14 (apuimedo, 14:05:15)
    5. kuryr-lib test coverage fix got merged on https://review.openstack.org/506985 (apuimedo, 14:06:49)

  2. kuryr-libnetwork (apuimedo, 14:07:05)
    1. kuryr-lib test coverage fix got merged on https://review.openstack.org/506985 (apuimedo, 14:07:12)
    2. ACTION: hongbin to find out what's wrong with the zuul gating of https://review.openstack.org/#/c/509655/ (apuimedo, 14:07:48)
    3. https://etherpad.openstack.org/p/zuulv3-issues (dmellado, 14:11:39)
    4. https://etherpad.openstack.org/p/zuulv3-issues (apuimedo, 14:11:50)

  3. kuryr-kubernetes (apuimedo, 14:12:01)
    1. ACTION: irenab apuimedo to review the base cni split patch (apuimedo, 14:15:55)
    2. https://docs.google.com/document/d/1eVPOgzkOm_y05gbmo3Dhs0W0iq0kowuyjDNmvvJyuDs/edit?ts=59d5046a (apuimedo, 14:17:05)
    3. https://docs.google.com/document/d/1jFC8SWHu_r3Q5OlR1YHk8v2Q_wR1tIaFxq5mh4FNAvs/edit?usp=sharing (apuimedo, 14:20:00)
    4. https://usercontent.irccloud-cdn.com/file/Pgso12tf/2.PNG https://usercontent.irccloud-cdn.com/file/oWT0I6vB/1.PNG (janonymous, 14:20:24)
    5. ACTION: apuimedo irenab ltomasbo to review https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support (apuimedo, 14:24:05)
    6. devstack switched to the previous behavior of managing the pod ports in debug mode, i.e., changing the port name into the name of the pod it services (apuimedo, 14:25:43)
    7. ACTION: review https://review.openstack.org/#/c/510157/2 (apuimedo, 14:28:11)
    8. Irenab_ stumbled upon a service fip issue (apuimedo, 14:30:43)
    9. https://bugs.launchpad.net/kuryr-kubernetes/+bug/1723938 (Irenab_, 14:30:47)
    10. https://bugs.launchpad.net/kuryr-kubernetes/+bug/1723938 (apuimedo, 14:30:58)
    11. ACTION: yboaron to take a good look at https://bugs.launchpad.net/kuryr-kubernetes/+bug/1723938 (apuimedo, 14:31:20)

  4. general (apuimedo, 14:32:57)
    1. queens cycle trello cards were updated last week https://trello.com/b/1Ij919E8/networking (apuimedo, 14:33:53)


Meeting ended at 14:35:58 UTC (full logs).

Action items

  1. hongbin to find out what's wrong with the zuul gating of https://review.openstack.org/#/c/509655/
  2. irenab apuimedo to review the base cni split patch
  3. apuimedo irenab ltomasbo to review https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support
  4. review https://review.openstack.org/#/c/510157/2
  5. yboaron to take a good look at https://bugs.launchpad.net/kuryr-kubernetes/+bug/1723938


Action items, by person

  1. apuimedo
    1. irenab apuimedo to review the base cni split patch
    2. apuimedo irenab ltomasbo to review https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support
  2. hongbin
    1. hongbin to find out what's wrong with the zuul gating of https://review.openstack.org/#/c/509655/
  3. irenab
    1. irenab apuimedo to review the base cni split patch
    2. apuimedo irenab ltomasbo to review https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support
  4. ltomasbo
    1. apuimedo irenab ltomasbo to review https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support
  5. openstack
    1. hongbin to find out what's wrong with the zuul gating of https://review.openstack.org/#/c/509655/
    2. apuimedo irenab ltomasbo to review https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support
    3. review https://review.openstack.org/#/c/510157/2


People present (lines said)

  1. apuimedo (86)
  2. dulek (22)
  3. dmellado (16)
  4. ltomasbo (8)
  5. Irenab_ (6)
  6. janonymous (6)
  7. hongbin (4)
  8. openstack (4)
  9. irenab (3)
  10. leyal (1)


Generated by MeetBot 0.1.4.