14:00:10 <apuimedo> #startmeeting kuryr
14:00:11 <openstack> Meeting started Mon Oct 16 14:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'kuryr'
14:00:27 <apuimedo> Welcome everybody to the weekly kuryr IRC meeting
14:00:27 <dulek> o/
14:00:32 <apuimedo> who's here today?
14:00:40 <irenab> hi
14:01:18 <ltomasbo> o/
14:01:24 <apuimedo> ltomasbo: janonymous: ?
14:01:37 <leyal> o/
14:01:37 <apuimedo> dmellado said he would not make it
14:01:40 <apuimedo> due to meetings
14:01:45 <janonymous> o/
14:01:59 <dmellado> I'm in read-only mode
14:02:15 <ltomasbo> :D
14:02:18 <apuimedo> dmellado: not to grease the keyboard with lunch, eh?
14:02:21 <apuimedo> xD
14:02:27 <apuimedo> #topic kuryr-lib
14:02:32 <dmellado> I'm over the phone xD
14:02:59 <apuimedo> We've got a few patches that require attention in the lib as requirements for kuryr-libnetwork
14:03:10 <apuimedo> #link https://review.openstack.org/500420
14:03:19 <apuimedo> #link https://review.openstack.org/508778
14:04:12 <apuimedo> We are merging a dependencies update: https://review.openstack.org/#/c/496048/94
14:04:17 <irenab> apuimedo: first seems to be ready, second requires small fix
14:04:18 <apuimedo> #info We are merging a dependencies update: https://review.openstack.org/#/c/496048/94
14:04:30 * apuimedo looking
14:05:15 <apuimedo> #info merging https://review.openstack.org/#/c/500420/14
14:05:40 <apuimedo> anybody's got anything else on kuryr-lib?
14:06:49 <apuimedo> #info kuryr-lib test coverage fix got merged on https://review.openstack.org/506985
14:06:57 <apuimedo> arggg
14:07:00 <apuimedo> that's for the next topic
14:07:02 <apuimedo> xD
14:07:05 <apuimedo> #topic kuryr-libnetwork
14:07:12 <apuimedo> #info kuryr-lib test coverage fix got merged on https://review.openstack.org/506985
14:07:48 <apuimedo> #action hongbin to find out what's wrong with the zuul gating of https://review.openstack.org/#/c/509655/
14:07:58 <hongbin> o/
14:08:21 <hongbin> zuul gate is non-voting for now
14:08:21 <apuimedo> ltomasbo: could you check hongbin's answer to your comments on https://review.openstack.org/#/c/505443/ ?
14:08:30 <ltomasbo> sure
14:08:34 <apuimedo> thanks
14:09:34 <apuimedo> hongbin: I guess once the kuryr-lib patch gets merged, we'll cut a release of it and you'll refresh https://review.openstack.org/#/c/500436/ , right?
14:09:48 <hongbin> apuimedo: yes, i will do that
14:10:30 <dmellado> folks, in any case regarding zuul gates
14:10:46 <dmellado> even if there's only zuul, please do note that there are a couple of still opened issues
14:10:48 <apuimedo> thanks hongbin
14:10:58 <apuimedo> ok
14:11:07 <apuimedo> hongbin: anything else on kuryr-libnetwork?
14:11:17 <hongbin> apuimedo: nothing else from me
14:11:39 <dmellado> https://etherpad.openstack.org/p/zuulv3-issues
14:11:41 <apuimedo> very well
14:11:43 <dmellado> just in case
14:11:50 <apuimedo> #link https://etherpad.openstack.org/p/zuulv3-issues
14:12:01 <apuimedo> #topic kuryr-kubernetes
14:12:07 <dmellado> so before debugging or spending time, check that, pls
14:12:30 <apuimedo> we've got a big queue of patches in kuryr-kubernetes
14:12:41 <apuimedo> let's start with the deployment/cni-split
14:12:56 <apuimedo> dulek: can you summarize the state and call attention to the patches that need it?
14:13:04 <dulek> Sure!
14:13:40 <dulek> So to see the patches just follow https://review.openstack.org/#/c/480028/
14:13:52 <dulek> On the right hand side you have all the related changes listed.
14:14:34 <dulek> I believe the base patch is done, then unit tests, docs, changes that enable logging.
14:14:43 * apuimedo wishes jenkins would stop voting
14:14:49 <dulek> Yup. :(
14:14:51 <apuimedo> seeing so much red is painful
14:15:16 <dulek> I think Jenkins is off and this is only result from previous patch. I guess I'll get rid of that through rebasing.
14:15:26 <dulek> s/previous patch/previous run
14:15:38 <dmellado> apuimedo: jenkins votes aren't worth a penny now
14:15:47 <irenab> need to drop for about 10 mins
14:15:54 <dmellado> so you should be able to merge it even with the jenkins -1
14:15:55 <apuimedo> #action irenab apuimedo to review the base cni split patch
14:16:00 <dulek> I'm currently working on pooling Watcher threads in CNI daemon. Have a bit of troubles, but I should have the commit ready by tomorrow.
14:16:20 <dulek> Then containerized version of cni-daemon and we should have the split functional.
14:16:21 <apuimedo> dulek: no need to rebase for that
14:16:42 <apuimedo> dulek: did you see irenab's link about cni gRPC?
14:16:57 <apuimedo> they are thinking of optionally having kubelet call a cni daemon via gRPC
14:16:58 <dulek> apuimedo: Whoops, I must have missed it.
14:17:05 <apuimedo> #link https://docs.google.com/document/d/1eVPOgzkOm_y05gbmo3Dhs0W0iq0kowuyjDNmvvJyuDs/edit?ts=59d5046a
14:17:20 <dulek> apuimedo: Ah, right, I don't have access to that.
14:17:25 <apuimedo> really?!
14:17:53 <apuimedo> that's odd
14:17:55 <dulek> apuimedo: Yup, not sure why. I've already asked for access, so I guess someone will approve me?
14:18:00 <apuimedo> I think it should be publicly acessible
14:18:01 <ltomasbo> can I get access to that?
14:18:06 <apuimedo> ltomasbo: you don't either?
14:18:29 <apuimedo> mm
14:18:31 <ltomasbo> nop, I cannot access it
14:18:36 <apuimedo> maybe with a @gmail.com address it would work
14:18:46 <dulek> apuimedo: I've already tried.
14:18:56 <janonymous> seems i am the prviledged one :P
14:19:00 <apuimedo> so am I
14:19:20 <dulek> Maybe it has to do something e.g. with email configured in K8s Slack, or something.
14:19:56 <apuimedo> maybe
14:19:58 <apuimedo> in any case
14:20:00 <apuimedo> https://docs.google.com/document/d/1jFC8SWHu_r3Q5OlR1YHk8v2Q_wR1tIaFxq5mh4FNAvs/edit?usp=sharing
14:20:05 <apuimedo> this is a copy I just made of the current state
14:20:11 <apuimedo> just so you can read
14:20:12 <dulek> apuimedo: Thanks!
14:20:24 <janonymous> https://usercontent.irccloud-cdn.com/file/Pgso12tf/2.PNG https://usercontent.irccloud-cdn.com/file/oWT0I6vB/1.PNG
14:20:44 <janonymous> apuimedo: sry! u already shared :D
14:20:59 <dulek> One more note on cni-daemon - I have had an idea to make it oslo.service+oslo.service.wsgi, but with apuimedo we've decided to stick to what we have now and explore that in case cni-daemon won't meet our performance expectations.
14:21:38 <apuimedo> thanks anyway janonymous ;-)
14:22:16 <janonymous> :)
14:22:34 <apuimedo> dulek: One of my concerns of oslo service and its eventlet usage is that eventlet has been historically troublesome and a cause of issues when interacting with netlink via pyroute2
14:23:12 <dulek> apuimedo: Sure, it's nice to be aware of that before coding it. ;)
14:23:42 <apuimedo> :-)
14:24:05 <apuimedo> #action apuimedo irenab ltomasbo to review https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support
14:24:21 <dulek> So I guess that's it. CNI daemon patches are out there, please take a look and review. They are splitted into smaller patches for your convenience. :)
14:24:30 <apuimedo> I think we should get to merging the multpiple vif support in cni
14:24:40 <apuimedo> (after proper review, of course)
14:24:52 <apuimedo> others are more than welcome to review it too
14:25:01 <apuimedo> thanks a lot dulek
14:25:21 <janonymous> thanks dulek :)
14:25:30 <dulek> :)
14:25:43 <apuimedo> #info devstack switched to the previous behavior of managing the pod ports in debug mode, i.e., changing the port name into the name of the pod it services
14:26:32 <apuimedo> irenab: I wonder why zuul -1s https://review.openstack.org/#/c/512232/ when all the voting gates passed
14:26:37 <apuimedo> it's a mistery
14:27:00 <dulek> apuimedo: openstack-tox-py35 openstack-tox-py35 : MERGER_FAILURE
14:27:14 <dulek> apuimedo: That's why, but no logs attached, so I don't know how to debug that.
14:27:21 <apuimedo> :/
14:28:11 <apuimedo> #action review https://review.openstack.org/#/c/510157/2
14:28:19 <apuimedo> anything else on kuryr-kubernetes?
14:28:44 <dmellado> dulek: that's one of the issues, I'd recheck
14:28:56 <Irenab_> There is the FIP issue, we can discuss it offline
14:29:00 <ltomasbo> yep
14:29:06 <ltomasbo> I was about to write the same
14:29:49 <Irenab_> I report bug on this issue
14:30:24 <apuimedo> Irenab_: please report it!
14:30:43 <apuimedo> #info Irenab_ stumbled upon a service fip issue
14:30:47 <Irenab_> https://bugs.launchpad.net/kuryr-kubernetes/+bug/1723938
14:30:48 <openstack> Launchpad bug 1723938 in kuryr-kubernetes "Cannot access service of LoadBalancer type " [High,New]
14:30:58 <apuimedo> #link https://bugs.launchpad.net/kuryr-kubernetes/+bug/1723938
14:31:20 <apuimedo> #action yboaron to take a good look at https://bugs.launchpad.net/kuryr-kubernetes/+bug/1723938
14:31:24 <apuimedo> thanks Irenab_
14:31:29 <apuimedo> anything else?
14:31:35 <Irenab_> Somehow it works with reference implementation, but does not work for dragonflow or old
14:32:17 <ltomasbo> Irenab_, I tested with OVN, not with ODL (yet)
14:32:20 <Irenab_> Nothing from me
14:32:45 <apuimedo> alright
14:32:57 <apuimedo> #topic general
14:32:58 <Irenab_> I suspect it will be the same for Odl
14:33:11 <apuimedo> I don't have anything more
14:33:20 <apuimedo> any other topic that was not covered?
14:33:24 <apuimedo> oh yes
14:33:53 <apuimedo> #info queens cycle trello cards were updated last week https://trello.com/b/1Ij919E8/networking
14:34:04 <apuimedo> anything else?
14:34:21 <dmellado> apuimedo: zuulv3, I stated it a few times
14:34:26 <dmellado> but please, please
14:34:34 <dmellado> if you see random errors
14:34:36 <dmellado> please do report them
14:34:42 <apuimedo> to that etherpad, right?
14:34:47 <dmellado> exactly
14:35:06 <dmellado> feel free pinging me but only *after* you check the etherpad first
14:35:48 <apuimedo> dmellado: will do!
14:35:54 <apuimedo> Thank you all for joining!
14:35:58 <apuimedo> #endmeeting