#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:03:00 UTC (full logs).

Meeting summary

  1. kuryr-libnetwork (apuimedo, 14:05:37)
    1. https://docs.google.com/document/d/1GNZbmVxE2n5j07YRlkx4zP-XbFSPI9UEcVifX1MRXyY/edit (kzaitsev_ws, 14:06:54)
    2. https://docs.openstack.org/kuryr-libnetwork/latest/ (kzaitsev_ws, 14:07:28)

  2. kuryr-kubernetes (apuimedo, 14:09:32)
    1. From 12-13h utc today we held a videoconference meeting about multiple networks. In it the community worked towards converging in the approach we adopt based on Network TPR/CRD and Pod network annotations and OIR for SRIOV (and possibly DPDK) bookkeeping (apuimedo, 14:11:14)
    2. kzaitsev_ started a document for the SR-IOV Network object usage pros/cons https://docs.google.com/document/d/1GNZbmVxE2n5j07YRlkx4zP-XbFSPI9UEcVifX1MRXyY/ (apuimedo, 14:11:58)
    3. ACTION: apuimedo to try again to deploy the network addon (apuimedo, 14:16:10)
    4. https://docs.google.com/presentation/d/1-2UVtWSsiMdzO1xUpsPsKjXcX3mOHb5zHI-xEPHi7v4/edit?usp=sharing (apuimedo, 14:17:32)
    5. janonymous has been advancing his work on the CNI Daemon split (apuimedo, 14:22:48)
    6. https://review.openstack.org/#/c/480028/ (apuimedo, 14:22:53)
    7. ACTION: apuimedo irenab ltomasbo kural to review SRIOV patches (apuimedo, 14:25:35)
    8. https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support (apuimedo, 14:25:48)
    9. ACTION: janonymous to address comments from kzaitsev_ in https://review.openstack.org/#/c/454555/ (apuimedo, 14:27:01)
    10. ACTION: review https://blueprints.launchpad.net/kuryr-kubernetes/+spec/nested-dpdk-support (apuimedo, 14:28:39)

  3. fuxi (apuimedo, 14:34:26)
  4. general (apuimedo, 14:38:49)


Meeting ended at 14:49:26 UTC (full logs).

Action items

  1. apuimedo to try again to deploy the network addon
  2. apuimedo irenab ltomasbo kural to review SRIOV patches
  3. janonymous to address comments from kzaitsev_ in https://review.openstack.org/#/c/454555/
  4. review https://blueprints.launchpad.net/kuryr-kubernetes/+spec/nested-dpdk-support


Action items, by person

  1. apuimedo
    1. apuimedo to try again to deploy the network addon
    2. apuimedo irenab ltomasbo kural to review SRIOV patches
  2. irenab
    1. apuimedo irenab ltomasbo kural to review SRIOV patches
  3. kural
    1. apuimedo irenab ltomasbo kural to review SRIOV patches
  4. kzaitsev_
    1. janonymous to address comments from kzaitsev_ in https://review.openstack.org/#/c/454555/
  5. ltomasbo
    1. apuimedo irenab ltomasbo kural to review SRIOV patches
  6. openstack
    1. janonymous to address comments from kzaitsev_ in https://review.openstack.org/#/c/454555/


People present (lines said)

  1. apuimedo (103)
  2. irenab (15)
  3. ltomasbo (14)
  4. kzaitsev_ (14)
  5. kural (14)
  6. mchiappero (9)
  7. hongbin (7)
  8. kzaitsev_ws (7)
  9. zengchen1 (6)
  10. garyloug (4)
  11. openstack (4)


Generated by MeetBot 0.1.4.