14:03:00 <apuimedo> #startmeeting kuryr
14:03:01 <openstack> Meeting started Mon Jul 10 14:03:00 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:06 <openstack> The meeting name has been set to 'kuryr'
14:03:21 <apuimedo> Hello and welcome to the weekly Kuryr IRC meeting
14:03:27 <apuimedo> who's here for the show?
14:03:27 <ltomasbo> o/
14:03:31 <kzaitsev_ws> o/
14:03:35 <garyloug> o/
14:03:55 <irenab> hi
14:03:55 <kzaitsev_ws> will be connecting from my phone shortly as I need to go
14:04:10 <mchiappero> o/
14:04:37 <apuimedo> kzaitsev_ws: I did the whole meeting last week in the car while my wife was driving
14:04:39 <kural> o/
14:04:42 <apuimedo> I got so darned dizzy
14:04:54 <apuimedo> do not ride and read
14:05:00 <ltomasbo> :D
14:05:37 <apuimedo> #topic kuryr-libnetwork
14:06:35 <apuimedo> kzaitsev_ws: do we have the doc fixed?
14:06:46 <apuimedo> I saw your oslosphinx patches merged
14:06:54 <kzaitsev_ws> #link https://docs.google.com/document/d/1GNZbmVxE2n5j07YRlkx4zP-XbFSPI9UEcVifX1MRXyY/edit
14:07:02 <kzaitsev_ws> oh not that doc
14:07:03 <kzaitsev_ws> =)
14:07:05 <kzaitsev_ws> yeah
14:07:28 <kzaitsev_ws> #link https://docs.openstack.org/kuryr-libnetwork/latest/
14:07:46 <apuimedo> perfect
14:07:49 <apuimedo> thanks
14:08:00 <apuimedo> So that was all that happened this week in kuryr-libnetwork land
14:08:12 <apuimedo> Anybody's got anything else on that?
14:09:26 <apuimedo> alright
14:09:28 <apuimedo> moving on
14:09:32 <apuimedo> #topic kuryr-kubernetes
14:11:14 <apuimedo> #info From 12-13h utc today we held a videoconference meeting about multiple networks. In it the community worked towards converging in the approach we adopt based on Network TPR/CRD and Pod network annotations and OIR for SRIOV (and possibly DPDK) bookkeeping
14:11:58 <apuimedo> #info kzaitsev_ started a document for the SR-IOV Network object usage pros/cons https://docs.google.com/document/d/1GNZbmVxE2n5j07YRlkx4zP-XbFSPI9UEcVifX1MRXyY/
14:12:12 <ltomasbo> nice
14:12:40 <ltomasbo> I got some questions/request at my meetings last week for being able to specify the networks where the pods are to be plugged
14:12:43 <kural> +1
14:12:52 <apuimedo> ltomasbo: dmellado: I'll send you the link to the recording later
14:12:56 <apuimedo> If I forget, ping me
14:13:02 <ltomasbo> apuimedo, great! thanks!
14:13:07 <apuimedo> if anybody else wants it, ping me as well ;-)
14:13:19 <apuimedo> ltomasbo: cool
14:13:28 <apuimedo> so the recording should help with that
14:13:33 <irenab> apuimedo: maybe you can put a link on kuryr wiki?
14:13:41 <apuimedo> we'll add the agreements to vikasc' patch
14:13:52 <apuimedo> irenab: you know I prefer to edit it first
14:13:55 <apuimedo> :-)
14:14:00 <irenab> apuimedo: sure
14:14:06 <apuimedo> otherwise it's full of silences
14:14:23 <ltomasbo> so, the idea is to polish vikasc spec?
14:14:29 <apuimedo> I have pto tomorrow, wednesday and Friday
14:14:40 <apuimedo> so I'll probably put the link on Thursday or Monday
14:14:55 <ltomasbo> and then make the modifications (considering the current SRIOV efforts)
14:15:01 <apuimedo> ltomasbo: yes, it will veer towards something more similar to what the community is doing
14:15:01 <kzaitsev_> there is a short analysis of what can be moved to network objs. and only focuses on my sriov stuff. feel free to suggest/edit
14:15:28 <apuimedo> and provide a way for the SRIOV to do it (probably as kzaitsev_'s current patches, we can make it simpler afterwards)
14:15:30 <kzaitsev_> yeah. probably network objs is the way k8s will handle things
14:15:46 <kzaitsev_> so no reason not to adopt it ahead of time
14:15:56 <hongbin> o/
14:16:06 <ltomasbo> sure, I like the idea and happy to collaborate!
14:16:10 <apuimedo> #action apuimedo to try again to deploy the network addon
14:16:32 <apuimedo> hongbin: hi!
14:16:48 <kural> Currently k8s network objs agreed to have only plugin in network spec, rest of args will be part of annotation..
14:17:32 <apuimedo> #link https://docs.google.com/presentation/d/1-2UVtWSsiMdzO1xUpsPsKjXcX3mOHb5zHI-xEPHi7v4/edit?usp=sharing
14:17:37 <irenab> I think we should try to be aligned with what is agreed at k8s-net-sig
14:17:41 <apuimedo> ltomasbo: this are the slides I showed
14:17:47 <apuimedo> kural: righr
14:17:49 <apuimedo> *right
14:17:52 <kural> Once k8s community agreed on proposal, we can change the args from annotation.. Will provide more information in the doc
14:18:10 <apuimedo> and I think it's a good thing that the rest be annotation tbf
14:18:16 <ltomasbo> ok, thanks!
14:18:23 <apuimedo> it will prevent people wanting to put spec for CIDR in network objects
14:18:30 <apuimedo> which IMHO is a good thing
14:18:35 <kzaitsev_> so where does the networkid go then?
14:18:48 <apuimedo> kzaitsev_: annotation
14:18:53 <kural> annotation
14:18:55 <kzaitsev_> pod annotation?
14:18:57 <apuimedo> either annotation or label
14:19:02 <kural> network annotation
14:19:11 <kzaitsev_> oh. ok makes sense
14:19:12 <kural> pod annotation is only for network obj name
14:19:12 <apuimedo> kzaitsev_: if you mean the subnetid, on the network annotation
14:19:20 <apuimedo> right
14:19:31 <apuimedo> kural: and it is namespace specific!)
14:19:47 <kural> CR or TPR don't support namespace
14:19:55 <irenab> network is namespace specific?
14:19:57 <kural> it support only default namespace
14:19:59 <apuimedo> oh true
14:20:04 <apuimedo> I'm dumb
14:20:06 <apuimedo> xD
14:20:25 * apuimedo scratches the bruise on top of his head
14:20:26 <kzaitsev_> we'll have to work with that then :/
14:20:28 <kural> original K8s Multi-net PoC, puts them out of scope
14:20:43 <apuimedo> kural: no, no. It makes sense
14:20:53 <kural> but it open new windows of complexity
14:21:01 <apuimedo> indeed
14:21:22 <apuimedo> kural: it basically means networks are operational things
14:21:28 <apuimedo> possibly not to be created by users :P
14:21:38 <apuimedo> but we'll see how it plays out
14:21:52 <kural> network obj is created by operator, pod spec network is by users
14:21:56 <apuimedo> right
14:22:43 <kzaitsev_> I'll be working on a multi-network poc this week. will see if i can incorporate discussion results there
14:22:48 <kural> user can only select the network, operator has privilege to update/create network obj
14:22:48 <apuimedo> #info janonymous has been advancing his work on the CNI Daemon split
14:22:53 <apuimedo> #link https://review.openstack.org/#/c/480028/
14:23:46 <apuimedo> kzaitsev_: irenab: ltomasbo: please review ^^
14:24:04 <apuimedo> It is tight for Pike, but it would be nice to have it asap
14:24:07 <irenab> its still WIP
14:24:17 <apuimedo> irenab: right, just to check the direction
14:24:20 <kzaitsev_> would be grateful if you add me manually to the review :)
14:24:25 <ltomasbo> apuimedo, ok
14:24:28 <irenab> apuimedo: cool, will check it asap
14:24:28 <apuimedo> kzaitsev_: I will!
14:24:34 <kzaitsev_> hard to do on the go :)
14:24:49 <apuimedo> kzaitsev_: done
14:25:35 <apuimedo> #action apuimedo irenab ltomasbo kural to review SRIOV patches
14:25:48 <apuimedo> #link https://review.openstack.org/#/q/status:open+project:openstack/kuryr-kubernetes+branch:master+topic:bp/kuryr-kubernetes-sriov-support
14:26:03 <apuimedo> I've already looked into them
14:26:10 <apuimedo> but we should add some comments ;-)
14:26:30 <kural> Gary and me will work..
14:26:30 <irenab> apuimedo: I did partially, will follow-up
14:27:01 <apuimedo> #action janonymous to address comments from kzaitsev_ in https://review.openstack.org/#/c/454555/
14:27:04 <apuimedo> perfect
14:27:52 <apuimedo> alright. Anybody's got anything else on kuryr-k8s?
14:27:57 <garyloug> yes
14:28:10 <garyloug> I've added a BP for DPDK: https://blueprints.launchpad.net/kuryr-kubernetes/+spec/nested-dpdk-support
14:28:15 <apuimedo> on my side, I'm struggling moving to the separate devstack-container-plugin
14:28:21 <apuimedo> garyloug: OH! Didn't see it
14:28:25 <apuimedo> sorry
14:28:27 <mchiappero> how will the daemon split deal with the config file?
14:28:31 <garyloug> I just uploaded :)
14:28:39 <apuimedo> #action review https://blueprints.launchpad.net/kuryr-kubernetes/+spec/nested-dpdk-support
14:28:46 <apuimedo> ah
14:28:58 <apuimedo> mchiappero: well, the conf file will be for the daemon
14:29:27 <mchiappero> so will it keep the default network information?
14:29:37 <apuimedo> the small kubelet called executable will only know which unix domain socket to talk to
14:30:06 <apuimedo> mchiappero: I hadn't thought it like htat. I expected that to be known by the controller only
14:30:29 <mchiappero> ok :)
14:31:04 <irenab> I think we try to preserve the asumption that the only info CNI gets is the VIF related stuff driven by controller
14:31:15 <apuimedo> garyloug: alright. I'll get back to you on Thursday about the blueprint
14:31:22 <apuimedo> right
14:31:44 <apuimedo> irenab: just as you said. As much as possible without getting to stubborn about it
14:32:31 <mchiappero> sounds good :) I was just curious
14:32:40 <apuimedo> :-)
14:32:53 <apuimedo> Anything else before we move on to fuxi
14:34:23 <apuimedo> alright, moving on
14:34:26 <apuimedo> #topic fuxi
14:34:35 <hongbin> hi all
14:34:36 <apuimedo> #chair hongbin
14:34:37 <openstack> Current chairs: apuimedo hongbin
14:34:57 <hongbin> in last week, the major things are the patches proposed by zengchen1
14:35:07 <hongbin> zengchen1: could you give an update about that
14:35:13 <zengchen1> yes
14:35:53 <zengchen1> for the past week, I finished the flexvolume driver of cinder and have tested it on the real environment
14:36:18 <zengchen1> that is all.
14:37:01 <hongbin> i believe a few patches were merged last week, thanks for the kuryr team for reviewing them
14:37:20 <hongbin> there are a few patches that is under active reviews
14:37:23 <zengchen1> yes, they gave many valume comments.
14:37:36 <zengchen1> s/valume/valuable
14:37:38 <apuimedo> cool
14:37:47 <apuimedo> zengchen1: ping us any time we slow down
14:37:52 <apuimedo> sometimes it happens :/
14:37:54 <zengchen1> ok
14:38:42 <hongbin> apuimedo: that is all from my side :)
14:38:46 <apuimedo> very well
14:38:49 <apuimedo> #topic general
14:39:44 <apuimedo> I wanted to propose dates for the VTG
14:39:58 <apuimedo> September 19th, 20th and 21st
14:40:14 <apuimedo> I will not be attending the PTG this time, btw
14:40:32 <irenab> apuimedo: I think it may be the holidays for me
14:40:53 <kzaitsev_> Are we doing it virtually or do we plan to pursue that Brno idea? :)
14:41:06 <apuimedo> we could maybe do it the week before the ptg instead, this time
14:41:19 <apuimedo> kzaitsev_: it would depend on how easy it is for all the folks to attend
14:41:20 <irenab> a week before is better
14:41:38 <ltomasbo> before PTG? that is the first week of September?
14:41:47 <kzaitsev_> I'll try my best to not attend the PTG too :)
14:41:54 <ltomasbo> xD
14:42:37 <apuimedo> ltomasbo: 6, 7 and 8th is before I think
14:42:46 <irenab> apuimedo: just checked September 20-22 are holidays over here
14:43:08 <kzaitsev_> a doodle might help
14:43:18 <irenab> apuimedo: 5,6, 7 ?
14:43:39 <irenab> no Sundays and Fridays :-)
14:43:58 <apuimedo> irenab: that's right
14:45:23 <apuimedo> alright. That was all from me. Does anybody have anything else?
14:46:35 <mchiappero> this is likely my last kuryr-meeting, I just wanted to say it's been nice working with you
14:46:54 <mchiappero> you're great people :)
14:47:24 <irenab> mchiappero: good luck with your next projects. It was a pleasure working with you
14:47:26 <ltomasbo> ohh, bad to hear it!
14:47:28 <kzaitsev_> oh that's sad :(. please come by to say hello :)
14:47:36 <ltomasbo> good luck in the next challenge!
14:47:41 <mchiappero> I will still be around somehow :)
14:48:10 <mchiappero> best of luck to you guys
14:48:49 <apuimedo> thanks a lot mchiappero!
14:48:58 <apuimedo> and good luck
14:49:18 <apuimedo> Thanks to you all for joining today, specially after the long bluejeans meeting we had just before
14:49:23 <apuimedo> I really appreciate it
14:49:26 <apuimedo> #endmeeting