#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:02:20 UTC (full logs).

Meeting summary

  1. kuryr-libnetwork (apuimedo, 14:04:19)
    1. This week there continued to be improvements on the kuryr-libnetwork front and I think that we could release after the tagging situation is solved (apuimedo, 14:06:13)
    2. https://review.openstack.org/#/c/425772 (ltomasbo, 14:06:35)
    3. https://review.openstack.org/#/c/431091/ (ltomasbo, 14:12:01)
    4. kuryr-libnetwork 1.0.0 freeze active Wednesday 20:00utc (apuimedo, 14:20:57)
    5. ACTION: apuimedo to fix https://hub.docker.com/r/kuryr/libnetwork for the release (apuimedo, 14:26:41)

  2. fuxi (apuimedo, 14:29:03)
    1. ACTION: hongbin review https://review.openstack.org/#/c/430658/1 (hongbin__, 14:31:23)

  3. kuryr-kubernetes (apuimedo, 14:32:40)
    1. ivc_'s patch that improves the handling of resourceVersion conflicts was taken in (apuimedo, 14:35:08)
    2. A videoconf meeting about resource management took place last thursday: https://www.youtube.com/watch?v=3698DBV-Ng4 (apuimedo, 14:35:42)
    3. In the resource management meeting it was agreed to work on feature parity between baremetal (by reusing both ports and veths) and nested (reusing just ports) (apuimedo, 14:37:02)
    4. vikasc has demonstrated ivc's service patches to work with pods-in-VMs. A demo will be shared by the end of the week on the mailing list (apuimedo, 14:38:29)
    5. ACTION: apuimedo to submit the blueprint for resource management (apuimedo, 14:41:22)

  4. general (apuimedo, 14:48:44)
    1. I updated the VTG schedule and sessions https://etherpad.openstack.org/p/kuryr_virtual_gathering_2017h1 (apuimedo, 14:49:12)
    2. ACTION: apuimedo to move it to the wiki (apuimedo, 14:49:37)
    3. There will be a PTG meeting in Atlanta about Kolla/Tripleo + kuryr http://lists.openstack.org/pipermail/openstack-dev/2017-February/111950.html (apuimedo, 14:53:14)
    4. https://ethercalc.openstack.org/Pike-PTG-Discussion-Rooms (apuimedo, 14:53:25)
    5. https://review.openstack.org/#/c/429329/ (yedongcan, 14:55:10)
    6. https://review.openstack.org/#/c/431844/ (yedongcan, 14:55:18)
    7. https://review.openstack.org/#/c/431312/ (yedongcan, 14:55:31)
    8. ACTION: apuimedo to review https://review.openstack.org/#/c/429432/ https://review.openstack.org/#/c/429329/ https://review.openstack.org/#/c/431844/ https://review.openstack.org/#/c/431312/ (apuimedo, 14:55:48)


Meeting ended at 14:56:33 UTC (full logs).

Action items

  1. apuimedo to fix https://hub.docker.com/r/kuryr/libnetwork for the release
  2. hongbin review https://review.openstack.org/#/c/430658/1
  3. apuimedo to submit the blueprint for resource management
  4. apuimedo to move it to the wiki
  5. apuimedo to review https://review.openstack.org/#/c/429432/ https://review.openstack.org/#/c/429329/ https://review.openstack.org/#/c/431844/ https://review.openstack.org/#/c/431312/


Action items, by person

  1. apuimedo
    1. apuimedo to fix https://hub.docker.com/r/kuryr/libnetwork for the release
    2. apuimedo to submit the blueprint for resource management
    3. apuimedo to move it to the wiki
    4. apuimedo to review https://review.openstack.org/#/c/429432/ https://review.openstack.org/#/c/429329/ https://review.openstack.org/#/c/431844/ https://review.openstack.org/#/c/431312/
  2. hongbin
    1. hongbin review https://review.openstack.org/#/c/430658/1
  3. openstack
    1. hongbin review https://review.openstack.org/#/c/430658/1
    2. apuimedo to review https://review.openstack.org/#/c/429432/ https://review.openstack.org/#/c/429329/ https://review.openstack.org/#/c/431844/ https://review.openstack.org/#/c/431312/


People present (lines said)

  1. apuimedo (102)
  2. ltomasbo (29)
  3. irenab (20)
  4. limao (9)
  5. yedongcan (8)
  6. hongbin__ (8)
  7. alraddarla (4)
  8. openstack (4)
  9. hongbin_ (3)
  10. janonymous (2)
  11. garyloug (1)
  12. mchiappero (1)
  13. hongbin (0)


Generated by MeetBot 0.1.4.