14:02:20 <apuimedo> #startmeeting kuryr
14:02:20 <openstack> Meeting started Mon Feb 13 14:02:20 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:24 <openstack> The meeting name has been set to 'kuryr'
14:02:36 <apuimedo> Hello everybody and welcome to the weekly IRC kuryr meeting
14:02:59 <irenab> hi
14:03:03 <apuimedo> Who's here?
14:03:08 <mchiappero> o/
14:03:11 <alraddarla> o/
14:03:15 <yedongcan> o/
14:03:22 <ltomasbo> o/
14:03:25 <garyloug> o/
14:03:26 <limao> 0/
14:04:12 <apuimedo> Welcome :-)
14:04:19 <apuimedo> #topic kuryr-libnetwork
14:06:13 <apuimedo> #info This week there continued to be improvements on the kuryr-libnetwork front and I think that we could release after the tagging situation is solved
14:06:35 <ltomasbo> https://review.openstack.org/#/c/425772
14:06:47 <ltomasbo> this already have the +2s, missing W
14:07:17 <irenab> apuimedo: want to take a look to approve?
14:07:27 <apuimedo> ah, good
14:07:34 * apuimedo taking a fast look
14:08:01 <ltomasbo> :D
14:10:05 <apuimedo> ltomasbo: irenab: so this patch gets rid of DEVICE_OWNER tag for kuryr-libnetwork altogether
14:10:07 <apuimedo> ?
14:10:35 <ltomasbo> actually, it leaves it
14:10:41 <ltomasbo> but it does not use it later one
14:10:49 <irenab> it keeps the owner, but uses tag to for filtering
14:10:55 <ltomasbo> just use tagging to find the nsubnets to be deleted after pod deletion
14:11:06 <apuimedo> it keeps it or does it still set it as well
14:11:13 <apuimedo> ?
14:11:22 <ltomasbo> sets it
14:11:25 <apuimedo> ok
14:11:29 <irenab> set to compute:kuryr to be aligned with convention
14:11:29 <ltomasbo> as it was before this patch
14:11:30 <apuimedo> then I think we can take this
14:11:47 <apuimedo> merging
14:11:52 <apuimedo> alright
14:11:54 <ltomasbo> the compute:kuryr is in the kuryr-lib part
14:12:01 <ltomasbo> https://review.openstack.org/#/c/431091/
14:12:31 <apuimedo> ltomasbo: that means that we should also cut a new kuryr-lib release
14:13:17 <irenab> and bump the requirements on kuryr-libnetworks
14:13:21 <apuimedo> right
14:13:34 <ltomasbo> if you agree on changing the device_owner value...
14:13:44 <apuimedo> I do
14:13:53 <apuimedo> the problem is
14:13:58 <ltomasbo> it will work on kuryr-libnetworks regardless of the change anyway
14:14:19 <irenab> right, its just alignment with naming convention
14:14:23 <apuimedo> for people that upgrade, the filtering will be broken for already 'device_owner' marked resources
14:14:51 <apuimedo> since we were before 1.0, I think we can live with this
14:14:55 <apuimedo> but it's the last time
14:15:08 <apuimedo> next times we'll have to do legacy checks
14:15:11 <irenab> since there is nothing that counts on the device owner name any more,it should not be a problem\
14:15:25 <irenab> apuimedo: even more important to fix it now
14:15:28 <ltomasbo> right
14:15:30 <apuimedo> alright. Let's set wednesday as freeze day for kuryr-lib and kuryr-libnework
14:15:40 <apuimedo> and then we cut the release
14:15:51 <apuimedo> agreed?
14:15:54 <irenab> +1
14:16:13 <apuimedo> limao: yedongcan: hongbin ^^
14:16:17 <limao> (if neutron do not support tag-ext, we still use device owner for filter port)
14:16:19 <apuimedo> I'll request a 1.0.0
14:16:22 <limao> +1
14:16:41 <yedongcan> +1
14:16:46 <apuimedo> so that means that it's the first supported release
14:16:48 <ltomasbo> the tag-ext patch was merged last week
14:17:00 <apuimedo> ltomasbo: also the backport?
14:17:08 <ltomasbo> that I don't know
14:17:13 <irenab> limao: maybe we need to check for ‘kuryr’ presence in OWNER field
14:17:28 <yedongcan> backport in neutron stable branch
14:17:29 <apuimedo> if there are patches that you feel should be in. Please, bother the cores about getting them in by Wednesday 20:00utc
14:17:41 <apuimedo> irenab: that's a very good point
14:17:46 <apuimedo> ltomasbo: can you patch that?
14:17:47 <limao> ltomasbo: yes, I mean if user use kuryr in an openstack environment not support tag-ext
14:18:43 <ltomasbo> limao, it should work the same way, there is an extra check in those cases
14:19:19 <irenab> ltomasbo: lets just make sure there is a test that covers the case
14:19:27 <apuimedo> limao: please, check if you think https://review.openstack.org/#/c/432777/ should get into the release
14:19:37 <hongbin_> o/
14:19:51 <ltomasbo> irenab, I've included unit test with and without tag-ext support
14:20:08 <irenab> ltomasbo: I mean the case limao raised
14:20:18 <apuimedo> hi hongbin_
14:20:27 <ltomasbo> irenab, https://review.openstack.org/#/c/425772/8/kuryr_libnetwork/tests/unit/test_kuryr_ipam.py
14:20:33 <apuimedo> we were saying that we'll cut a 1.0.0 release of kuryr-libnetwork
14:20:34 <irenab> ltomasbo: great
14:20:37 <limao> apuimedo: ok, I will check
14:20:56 <ltomasbo> irenab, let me know if you were thinking about some extra tests
14:20:57 <apuimedo> #info kuryr-libnetwork 1.0.0 freeze active Wednesday 20:00utc
14:21:06 <apuimedo> hongbin_: ^^
14:21:06 <irenab> ltomasbo: sure
14:21:16 <hongbin_> apuimedo: ack
14:22:01 <apuimedo> hongbin_: I know you have some patches, so please work with the cores to try and get those that should make the release in
14:22:15 <hongbin_> apuimedo: i will try that
14:23:28 <apuimedo> @all: remember that we are release independent, so we are flexible. But we should patch for critical issues at least the previous released version
14:23:36 <apuimedo> so we can't get too crazy with the amount of releases
14:23:45 <apuimedo> Anything else on kuryr-libnetwork?
14:24:14 <limao> apuimedo: https://hub.docker.com/r/kuryr/libnetwork/
14:25:28 <limao> your Source Repository has not updated for some time, will we plan to maintain this docker image?
14:26:13 <irenab> limao: apuimedo : maybe we should consider hosting the image in some more ‘official’ repo?
14:26:23 <apuimedo> limao: we need to for the 1.0.0 release. yes
14:26:41 <apuimedo> #action apuimedo to fix https://hub.docker.com/r/kuryr/libnetwork for the release
14:26:58 <apuimedo> irenab: not possible yet. Infra does not have its own repository
14:27:09 <limao> apuimedo: irenab: I think toni want to use the auto build on hub.docker
14:27:11 <apuimedo> but I would love it
14:27:47 <irenab> ok, the docker hub seems a good option for now
14:27:52 <apuimedo> limao: yes. I like the auto build. It makes it immediate for people to see how things were built
14:28:29 <limao> apuimedo: agree, nothing more about kuryr-libnetwork from me now
14:28:51 <apuimedo> very well
14:28:59 <apuimedo> thanks a lot for bringing it up limao!
14:29:03 <apuimedo> #topic fuxi
14:29:09 <hongbin__> o/
14:29:13 <apuimedo> #chair hongbin
14:29:14 <openstack> Current chairs: apuimedo hongbin
14:29:16 <apuimedo> go ahead
14:29:17 <apuimedo> ;-)
14:29:23 <hongbin__> i don't have too much to update this week
14:29:32 <hongbin__> if you have any topic to discuss, please feel free to bring it up
14:30:55 <apuimedo> hongbin__: please review https://review.openstack.org/#/c/430658/1
14:31:12 <hongbin__> apuimedo: ack
14:31:23 <hongbin__> #action hongbin review https://review.openstack.org/#/c/430658/1
14:31:26 <apuimedo> and https://review.openstack.org/#/c/431085/
14:31:49 <hongbin__> done
14:31:52 <apuimedo> thanks hongbin__
14:32:15 <apuimedo> hongbin__: I would also like to ask you to lead the VTG session on Fuxi
14:32:26 <hongbin__> apuimedo: sure, i can do that
14:32:30 <apuimedo> it will be about fuxi, fuxi-kubernetes and plans for release
14:32:34 <apuimedo> thanks hongbin
14:32:40 <apuimedo> #topic kuryr-kubernetes
14:32:42 <hongbin__> my pleasure
14:33:54 * apuimedo updating document
14:35:08 <apuimedo> #info ivc_'s patch that improves the handling of resourceVersion conflicts was taken in
14:35:42 <apuimedo> #info A videoconf meeting about resource management took place last thursday: https://www.youtube.com/watch?v=3698DBV-Ng4
14:37:02 <apuimedo> #info In the resource management meeting it was agreed to work on feature parity between baremetal (by reusing both ports and veths) and nested (reusing just ports)
14:37:12 <apuimedo> ltomasbo is leading the way
14:37:23 <apuimedo> ltomasbo: did you get around to trying it with nested?
14:37:41 <ltomasbo> I committed a newer version last friday
14:37:52 <ltomasbo> with the min and max number of ports at the pool
14:37:56 <ltomasbo> as we were discussing
14:38:13 <ltomasbo> as well as reusing created ports, by reseting the security-group and the name to the default one
14:38:29 <apuimedo> #info vikasc has demonstrated ivc's service patches to work with pods-in-VMs. A demo will be shared by the end of the week on the mailing list
14:38:50 <ltomasbo> I also updated the nested version, but I still need a decent server to test it and measure the performance for the nested case
14:39:22 <apuimedo> more info: the max number of ports is about limiting the amount of ports that are kept in the pool. So if you have the pool full, you delete the resource instead of pooling it
14:39:34 <apuimedo> ltomasbo: very well
14:39:43 <ltomasbo> yes, you define a max number of ports
14:39:45 <ltomasbo> per pool
14:40:07 <ltomasbo> and then, if the pool is already full, then the port gets deleted instead of returned to the pool
14:40:31 <irenab> ltomasbo: apuimedo what about the spec we discussed?
14:40:39 <ltomasbo> also, there is a batch variable, to create ports/subports in batches, as it is more efficient
14:40:53 <irenab> to capture the oevrall plan and steps
14:41:00 <apuimedo> irenab: you mean the spec about the pool namespace?
14:41:09 <apuimedo> sorry
14:41:11 <apuimedo> bp
14:41:19 <irenab> yes, bp
14:41:22 <apuimedo> #action apuimedo to submit the blueprint for resource management
14:41:54 <irenab> it will be helpful to see the overal plan and various steps to achive performance goals
14:42:23 <apuimedo> indeed
14:44:25 <apuimedo> good
14:45:07 <apuimedo> anything else on kuryr-kubernetes?
14:45:32 <apuimedo> alraddarla: you are on the devref moving, right?
14:45:49 <alraddarla> apuimedo, yes.
14:46:08 <alraddarla> sorry for the delay...my laptop got messed up and had to wipe it and put a new OS on it. I can get that push up today
14:46:17 <apuimedo> no worries
14:46:43 <apuimedo> just following-up in case you had any further doubts on the parts that needed to be ported and merged
14:46:47 <janonymous> o/
14:46:50 <apuimedo> and those that had to be dropped
14:46:54 * janonymous got a bit late
14:47:10 <alraddarla> I will let you knwo if I have more questions once I actually move everything around
14:48:32 <apuimedo> janonymous: you can ask after going over the logs in the channel if you have questions ;-)
14:48:37 <apuimedo> perfect alraddarla
14:48:44 <apuimedo> #topic general
14:49:12 <apuimedo> #info I updated the VTG schedule and sessions https://etherpad.openstack.org/p/kuryr_virtual_gathering_2017h1
14:49:37 <apuimedo> #action apuimedo to move it to the wiki
14:50:03 <apuimedo> There's still some orphan sessions
14:50:22 <apuimedo> but I'll be contacting some of you to ask for session steering
14:50:24 <apuimedo> ;-)
14:50:46 <apuimedo> please, let me know about important time conflicts
14:51:12 <apuimedo> Is anybody going to atlanta?
14:51:28 <apuimedo> there will be a session about tripleo/kolla integration on Wednesday
14:51:31 <apuimedo> let me hunt for the time
14:53:14 <apuimedo> #info There will be a PTG meeting in Atlanta about Kolla/Tripleo + kuryr http://lists.openstack.org/pipermail/openstack-dev/2017-February/111950.html
14:53:25 <apuimedo> #link https://ethercalc.openstack.org/Pike-PTG-Discussion-Rooms
14:54:33 <apuimedo> anything else anybody?
14:54:58 <yedongcan> apuimedo: please see these patch: https://review.openstack.org/#/c/429432/
14:55:10 <yedongcan> https://review.openstack.org/#/c/429329/
14:55:18 <yedongcan> https://review.openstack.org/#/c/431844/
14:55:31 <yedongcan> https://review.openstack.org/#/c/431312/
14:55:48 <apuimedo> #action apuimedo to review https://review.openstack.org/#/c/429432/ https://review.openstack.org/#/c/429329/ https://review.openstack.org/#/c/431844/ https://review.openstack.org/#/c/431312/
14:55:53 <yedongcan> I just sort these, and think it can merged before we released.
14:56:05 <apuimedo> thanks yedongcan. I will!
14:56:20 <apuimedo> alright
14:56:26 <apuimedo> closing the meeting!
14:56:30 <apuimedo> THank you all for joining
14:56:33 <apuimedo> #endmeeting