#openstack-meeting-4: kuryr

Meeting started by tfukushima at 03:01:22 UTC (full logs).

Meeting summary

    1. fawadkhaliq, mspreitz and tfukushima are present. (tfukushima, 03:03:36)

  1. Kubernetes Integration (tfukushima, 03:05:18)
    1. ACTION: baohua gives us more details about the linux bridge stuff and the policy agent. (tfukushima, 03:11:27)
    2. ACTION: Everyone reviews mspreitz's spec, which introduces the CNM-CNI translation. (tfukushima, 03:12:05)
    3. ACTION: Everyone reviews irenab's spec, which introduces the direct translation with the agent and the CNI plugin. (tfukushima, 03:12:35)
    4. ACTION: irenab thinks about to split her spec into a few pieces, like kube-proxy part and multi-tenancy part. (tfukushima, 03:15:38)
    5. mspreitz 's CNM-CNI spec: https://review.openstack.org/#/c/290172/ (tfukushima, 03:18:37)
    6. irenab's direct translation spec: https://review.openstack.org/#/c/281132/ (tfukushima, 03:18:57)
    7. ACTION: K8s guys check the thread "[openstack-dev] [neutron] BGP Dynamic Routing Development Going Forward" on ML (tfukushima, 03:23:48)
    8. ACTION: tfukushima write the devref of the API watcher agent (tfukushima, 03:25:38)

  2. Nested Containers and Magnum Integration (tfukushima, 03:27:48)
    1. ACTION: fawadkhaliq takes the next step to give the details of the kuryr agent and the implementation with the help from oanson (tfukushima, 03:31:36)

  3. Existing Networks (tfukushima, 03:32:26)
    1. banix's patch with Neuron tag https://review.openstack.org/#/c/288737/ (tfukushima, 03:33:14)
    2. banix's patch for "-o neutron.net.uuid=d98d1259-03d1-4b45-9b86-b039cba1d90d" capability https://review.openstack.org/#/c/280948/ (tfukushima, 03:35:31)

  4. Fullstack and Rally integration (tfukushima, 03:35:52)
    1. baohua's patches https://review.openstack.org/#/q/owner:baohua%2540linux.vnet.ibm.com+status:open (tfukushima, 03:37:06)

  5. open discussion (tfukushima, 03:38:13)


Meeting ended at 03:39:47 UTC (full logs).

Action items

  1. baohua gives us more details about the linux bridge stuff and the policy agent.
  2. Everyone reviews mspreitz's spec, which introduces the CNM-CNI translation.
  3. Everyone reviews irenab's spec, which introduces the direct translation with the agent and the CNI plugin.
  4. irenab thinks about to split her spec into a few pieces, like kube-proxy part and multi-tenancy part.
  5. K8s guys check the thread "[openstack-dev] [neutron] BGP Dynamic Routing Development Going Forward" on ML
  6. tfukushima write the devref of the API watcher agent
  7. fawadkhaliq takes the next step to give the details of the kuryr agent and the implementation with the help from oanson


Action items, by person

  1. fawadkhaliq
    1. fawadkhaliq takes the next step to give the details of the kuryr agent and the implementation with the help from oanson
  2. mspreitz
    1. Everyone reviews mspreitz's spec, which introduces the CNM-CNI translation.
  3. openstack
    1. K8s guys check the thread "[openstack-dev] [neutron] BGP Dynamic Routing Development Going Forward" on ML
  4. tfukushima
    1. tfukushima write the devref of the API watcher agent
  5. UNASSIGNED
    1. baohua gives us more details about the linux bridge stuff and the policy agent.
    2. Everyone reviews irenab's spec, which introduces the direct translation with the agent and the CNI plugin.
    3. irenab thinks about to split her spec into a few pieces, like kube-proxy part and multi-tenancy part.


People present (lines said)

  1. tfukushima (55)
  2. mspreitz (24)
  3. fawadkhaliq (8)
  4. openstack (3)


Generated by MeetBot 0.1.4.