#openstack-meeting-4: kuryr

Meeting started by apuimedo at 15:02:06 UTC (full logs).

Meeting summary

    1. vikasc banix fawadkhaliq and apuimedo are present (apuimedo, 15:03:49)

  1. ipam (apuimedo, 15:04:59)
    1. ACTION: vikasc to send an email to the ml about the remaining patches to get ipam into a working state (apuimedo, 15:07:36)
    2. https://review.openstack.org/#/q/owner:choudharyvikas16%2540gmail.com+status:open (apuimedo, 15:07:48)
    3. ACTION: : apuimedo irenab banix to review and get those merged (apuimedo, 15:08:59)

  2. COE integration (apuimedo, 15:09:46)
    1. banix did a very nice blog post about swarm integration (apuimedo, 15:10:03)
    2. ACTION: banix to submit a bit of a quickstart for using kuryr with swarm in the documentation (apuimedo, 15:11:25)
    3. http://mbanikazemi.com (banix, 15:11:26)
    4. http://mbanikazemi.com/2016/01/07/docker-swarm-and-kuryr/ (apuimedo, 15:12:00)
    5. http://blog.kubernetes.io/2016/01/why-Kubernetes-doesnt-use-libnetwork.html (fawadkhaliq, 15:15:20)
    6. https://etherpad.openstack.org/p/kuryr_k8s (apuimedo, 15:16:39)
    7. https://github.com/projectcalico/calico-cni/blob/master/calico_cni/calico_cni.py (vikasc, 15:26:57)
    8. : seems like there is consensus in having a kuryr python package with common bits and directories for different drivers (apuimedo, 15:29:17)
    9. ACTION: apuimedo to submit refactoring proposal (apuimedo, 15:29:39)

  3. openfloor (apuimedo, 15:32:22)
    1. https://review.openstack.org/#/c/269039/ (fawadkhaliq, 15:33:33)
    2. ACTION: all to review the proposal (apuimedo, 15:33:57)
    3. ACTION: all to review https://review.openstack.org/#/c/269039/ (apuimedo, 15:34:10)


Meeting ended at 15:40:15 UTC (full logs).

Action items

  1. vikasc to send an email to the ml about the remaining patches to get ipam into a working state
  2. : apuimedo irenab banix to review and get those merged
  3. banix to submit a bit of a quickstart for using kuryr with swarm in the documentation
  4. apuimedo to submit refactoring proposal
  5. all to review the proposal
  6. all to review https://review.openstack.org/#/c/269039/


Action items, by person

  1. apuimedo
    1. : apuimedo irenab banix to review and get those merged
    2. apuimedo to submit refactoring proposal
  2. banix
    1. : apuimedo irenab banix to review and get those merged
    2. banix to submit a bit of a quickstart for using kuryr with swarm in the documentation
  3. irenab
    1. : apuimedo irenab banix to review and get those merged
  4. openstack
    1. all to review https://review.openstack.org/#/c/269039/
  5. vikasc
    1. vikasc to send an email to the ml about the remaining patches to get ipam into a working state


People present (lines said)

  1. apuimedo (116)
  2. banix (27)
  3. fawadkhaliq (21)
  4. vikasc (18)
  5. irenab (15)
  6. openstack (3)


Generated by MeetBot 0.1.4.