15:02:06 <apuimedo> #startmeeting kuryr
15:02:06 <openstack> Meeting started Mon Jan 18 15:02:06 2016 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:09 <openstack> The meeting name has been set to 'kuryr'
15:02:26 <apuimedo> Welcome everybody to another kuryr meeting!
15:02:33 <apuimedo> who's here for the show?
15:02:37 <vikasc> o/
15:02:39 <banix> o/
15:02:45 <fawadkhaliq> o/
15:03:49 <apuimedo> #info vikasc banix fawadkhaliq and apuimedo are present
15:03:59 <apuimedo> Thank you for joining the meeting
15:04:46 <apuimedo> We don't have an agenda so this is going to be a bit fast
15:04:59 <apuimedo> #topic ipam
15:05:17 <apuimedo> vikasc: is everything you had on the backlog merged?
15:05:32 <banix> may i suggest we get the ipam patches reviewed and merged as soon as possib;e
15:05:34 <vikasc> few small small fixes are waiting for review
15:05:49 <banix> small fixes are necessary to make the code functional
15:05:51 <apuimedo> banix: you definitely may
15:06:02 <apuimedo> yes, I wanted to say that we currently have it a bit broken
15:06:04 <apuimedo> :P
15:06:17 <banix> otherwise the code as is is not functiona
15:06:19 <banix> yes
15:06:20 <irenab> vikasc: banix : can you please post the list of the patches urgent to review?
15:06:26 <apuimedo> vikasc: please link the patches that are necessary for the fixes
15:06:36 <apuimedo> and let's get them tested and merged by Wednesday the latest
15:06:55 <vikasc> i will drop a mail
15:07:13 <apuimedo> very well
15:07:36 <apuimedo> #action vikasc to send an email to the ml about the remaining patches to get ipam into a working state
15:07:38 <banix> here are all patches by vikas: https://review.openstack.org/#/q/owner:choudharyvikas16%2540gmail.com+status:open
15:07:48 <apuimedo> #link https://review.openstack.org/#/q/owner:choudharyvikas16%2540gmail.com+status:open
15:08:07 <apuimedo> banix: vikasc: have you tried if with all of those it is completely functional
15:08:24 <vikasc> apuimedo, yes, i have tried
15:08:33 <apuimedo> good :-)
15:08:59 <apuimedo> #action: apuimedo irenab banix to review and get those merged
15:09:01 <banix> the ones i have +2’ed are  working
15:09:09 <apuimedo> good
15:09:09 <banix> will lokk at the rest and try them
15:09:15 <irenab> same here
15:09:20 <apuimedo> I'll get through them between today and tomorrow
15:09:38 <vikasc> thanx banix apuimedo irenab
15:09:46 <apuimedo> #topic COE integration
15:10:03 <apuimedo> #info banix did a very nice blog post about swarm integration
15:10:22 <apuimedo> banix: could you maybe put some documentation in the repository about using swarm?
15:10:32 <fawadkhaliq> +1
15:10:45 <banix> apuimedo: yes sure
15:10:50 <apuimedo> thanks :-)
15:11:08 <vikasc> banix, Can you please share link of blog post
15:11:25 <apuimedo> #action banix to submit a bit of a quickstart for using kuryr with swarm in the documentation
15:11:26 <banix> #link http://mbanikazemi.com
15:12:00 <apuimedo> #link http://mbanikazemi.com/2016/01/07/docker-swarm-and-kuryr/
15:12:02 <apuimedo> :-)
15:12:15 <apuimedo> for when you have a new blog post to keep having the correct link :P
15:12:33 <apuimedo> About Kubernetes
15:12:36 <banix> i have been planning to add more to it and make it better but haven’t got the chance yet.
15:12:37 <vikasc> apuimedo, :D thanks
15:14:10 <apuimedo> banix: I saw that you and Mike Spreitzer are looking at running Kubernetes and make it consume the libnetwork kuryr daemon for binding
15:14:41 <banix> apuimedo: yes, still looking into how/if this is possible
15:14:47 <apuimedo> same here :P
15:15:16 <fawadkhaliq> apuimedo: banix..talking about Kubernetes and libnetwork, ran into this over the weekend
15:15:17 <apuimedo> irenab: can you refresh us with the kuryr etherpad for kubernetes integration?
15:15:20 <fawadkhaliq> #link http://blog.kubernetes.io/2016/01/why-Kubernetes-doesnt-use-libnetwork.html
15:15:25 <fawadkhaliq> :-)
15:15:39 <apuimedo> fawadkhaliq: yes. We were discussing with Tim on Friday on the sig meeting
15:15:46 <apuimedo> there was Mike and I on the call
15:16:20 <irenab> apuimedo: https://etherpad.openstack.org/p/kuryr_k8s
15:16:24 <apuimedo> while they want to keep Kubernetes able to pass the necessary "flags" to docker for it to connect to libnetwork
15:16:27 <banix> yes, have been trying to watch the recording but the play back doesb’t work for me
15:16:27 <apuimedo> thanks irenab
15:16:39 <apuimedo> #link https://etherpad.openstack.org/p/kuryr_k8s
15:17:00 <irenab> apuimedo: can you give some brief summary?
15:17:00 <apuimedo> I feel like we need to also follow the CNI discussion
15:17:09 <fawadkhaliq> apuimedo: cool cool.
15:17:14 <fawadkhaliq> apuimedo: agree
15:17:30 <banix> apuimedo: yes
15:17:52 <banix> and participate as it is still early on
15:18:05 <fawadkhaliq> banix: absolutely
15:18:10 <apuimedo> what I take from the meeting is that we need to make sure that the current state of things gets unbroken (IIRC nowadays we can't pass the flags to plug to libnetwork networks, they proposed to put net as default but that does not work)
15:18:16 <apuimedo> but more importantly
15:18:19 <apuimedo> for the future
15:18:24 <apuimedo> we need to participate in the discussion
15:18:29 <apuimedo> and work on a cni plugin
15:18:49 <irenab> cni plugin supporting kuryr networkm type?
15:19:04 <apuimedo> networkm?
15:19:08 <fawadkhaliq> apuimedo: agree. let's have some representation from kuryr team there as well
15:19:13 <irenab> sorry :-) network
15:19:25 <apuimedo> irenab: oh, I thought you meant network model :P
15:19:41 <apuimedo> well, there's two ways that are immediately apparent
15:19:42 <apuimedo> one is
15:19:48 <apuimedo> cni plugin that calls to kuryr
15:20:06 <apuimedo> another is cni plugin in python that reuses parts of kuryr code (with a bit of healthy refactoring)
15:20:17 <apuimedo> I have to say that I prefer the latter
15:20:44 <banix> apuimedo: why is that?
15:21:06 <irenab> apuimedo: so kuryr is more conceptual thing, link to neutron api?
15:21:16 <fawadkhaliq> apuimedo: with cni model, kuryr southbound interface would be interesting to define
15:21:20 <apuimedo> irenab: bring neutron networking to containers
15:21:21 <banix> irenab: i see
15:21:38 <apuimedo> CNI works for rkt
15:21:42 <apuimedo> for example
15:22:04 <apuimedo> fawadkhaliq: indeed
15:22:46 <apuimedo> how I see it, it may necessitate kuryr to have a core library and different "frontends"
15:22:56 <apuimedo> since the models differ a bit
15:22:57 <irenab> for me there are alot of questions regarding how kuryr fits into kube ecosystem
15:23:08 <apuimedo> irenab: agreed
15:23:18 <fawadkhaliq> yup
15:23:22 <apuimedo> we need more brains into the k8s meetings :P
15:23:32 <irenab> apuimedo: I think you may be correct about core and different frontends
15:23:33 <apuimedo> and after that in mesos
15:23:33 <vikasc> cni passes just two args "ADD" and "DEL". how we are goint to map it existing kuryr? i guess will not be able to reuse much of existing code.
15:23:40 <fawadkhaliq> apuimedo: +1
15:23:59 <apuimedo> vikasc: if you look at libnetwork now
15:24:09 <apuimedo> we already have two drivers (thanks to you for the second one)
15:24:17 <apuimedo> one that does binding
15:24:20 <apuimedo> one that does ipam
15:24:29 <apuimedo> in kubernetes
15:24:37 <apuimedo> I suspect that we need a similar approach
15:24:51 <apuimedo> one that will get the connectivity information and prepare the ports
15:24:55 <irenab> apuimedo: its not only binding, it is neutron logical topology creation as well. I think its the third part
15:24:56 <apuimedo> and the cni plugin that will bind
15:25:56 <vikasc> apuimedo,  how about having k8s plugin totally seperate from existing controllers.py
15:26:08 <vikasc> for example, like Calico k8s plugin
15:26:31 <apuimedo> banix: you probably heard that in k8s they have the gap of passing the "allowfrom" down the cni plugin or getting it to the networking layer somehow
15:26:32 <vikasc> they are maintaing it totally seperate from lbnetwork driver
15:26:56 <irenab> vikasc: I think there should be low level controller driver that calls neutron, this can/sould be reused
15:26:57 <apuimedo> vikasc: it's not a libnetwork driver, is it, for Calico?
15:26:57 <vikasc> https://github.com/projectcalico/calico-cni/blob/master/calico_cni/calico_cni.py
15:27:27 <apuimedo> vikasc: but yes, I'm not saying to reuse almost all
15:27:46 <apuimedo> I'm thinking of refactoring the bits that we find useful into libraries
15:27:59 <apuimedo> and then have the libnetwork driver in a directory
15:28:02 <banix> apuimedo: dont know that issue
15:28:06 <fawadkhaliq> apuimedo: +1
15:28:07 <apuimedo> the cni one in another, etc
15:28:13 <vikasc> apuimedo,  +1 for refactoring into modular libraries
15:28:22 <apuimedo> and have they consume the kuryr python package
15:28:33 <vikasc> apuimedo, +1
15:28:41 <apuimedo> it will enforce better modularity anyway
15:28:42 <vikasc> apuimedo, making sense
15:29:10 <irenab> apuimedo: do you mind to put up some proposal for refactoring kuryr?
15:29:17 <apuimedo> #info: seems like there is consensus in having a kuryr python package with common bits and directories for different drivers
15:29:26 <apuimedo> irenab: I shall have to
15:29:39 <apuimedo> #action apuimedo to submit refactoring proposal
15:30:32 <apuimedo> the good thing is that the swarm directory will just be documentation for now :P
15:30:41 <banix> sounds good
15:30:45 <apuimedo> on using the libnetwork driver
15:31:02 <banix> yes nothing to do specifically for swarm
15:31:05 <fawadkhaliq> apuimedo: lol
15:31:18 <vikasc> i want to write a poc k8s driver. Will it be helpful. I have understood current flow of cni in k8s
15:31:21 <banix> then there is mesos and all
15:31:28 <apuimedo> banix: indeed
15:32:00 <apuimedo> for mesos I suspect we may start with just giving some directions about connecting to the network passing flags to the docker containerizer
15:32:15 <apuimedo> and then we can grow it as people join work in making the integration better
15:32:22 <banix> with significant gap as of now; seems they are not caught up with network cli
15:32:22 <apuimedo> #topic openfloor
15:32:50 <apuimedo> banix: yeah... last time I checked it seemed like you had to hack a bit the c++ containerizer
15:33:03 <apuimedo> anybody else wants to raise more things?
15:33:20 <fawadkhaliq> apuimedo: banix. I had added the initial draft of nested containers proposal
15:33:24 <apuimedo> I saw fawadkhaliq submitted an early version of the spec for vm nested containers
15:33:33 <fawadkhaliq> #link https://review.openstack.org/#/c/269039/
15:33:34 <apuimedo> fawadkhaliq: you were faster to type than me :P
15:33:41 <fawadkhaliq> reviews welcome :)
15:33:45 <apuimedo> thanks a lot for the submission
15:33:48 <fawadkhaliq> lol
15:33:53 <banix> fawadkhaliq: yes thank you
15:33:57 <apuimedo> #action all to review the proposal
15:33:59 <vikasc> fawadkhaliq, thanks
15:34:04 <fawadkhaliq> I will be adding more details. Jugging several balls at the same time.
15:34:09 <fawadkhaliq> thanks guys
15:34:10 <apuimedo> #action all to review https://review.openstack.org/#/c/269039/
15:34:31 <fawadkhaliq> This capture the high level design. We can all collaborate to improve it.
15:34:59 <apuimedo> devvesa has created a bug for the rdo team to review the inclusion of a kuryr libnetwork driver package
15:35:08 <apuimedo> fawadkhaliq: cool :-)
15:35:30 <apuimedo> I can't tell when devvesa will have time to work on the deb package yet though :P
15:36:08 <apuimedo> anybody else has more topics?
15:36:40 <banix> we need to also have a list of things what we definitely want to do for M
15:36:52 <apuimedo> banix: perfectly right
15:36:53 <vikasc> banix, +1
15:37:01 <irenab> any update on the testing?
15:37:09 <apuimedo> actually, for me, the list of "absolute must do was:"
15:37:13 <apuimedo> *IPAM
15:37:16 <apuimedo> *testing
15:37:18 <apuimedo> *swarm
15:37:20 <apuimedo> *packaging
15:37:31 <apuimedo> in terms of implementation
15:37:42 <apuimedo> and in terms of spec/design:
15:37:46 <apuimedo> *k8s
15:37:49 <apuimedo> *vm-nested
15:37:50 <banix> bahoa and gal are working on that fron; have to check with them. will do that.
15:38:07 <banix> i meant testing
15:38:08 <apuimedo> I have some patches to review from them
15:38:12 <apuimedo> yeah ;-)
15:38:24 <irenab> banix: thanks
15:39:42 <apuimedo> alright, if nobody else has further things to add
15:39:45 <apuimedo> going 3
15:39:47 <apuimedo> goind 2
15:39:51 <apuimedo> going 1
15:39:59 <apuimedo> gone!
15:40:05 <apuimedo> thank you all for joining
15:40:06 <banix> thanks!
15:40:11 <apuimedo> and for all the work in the past week
15:40:12 <irenab> thanks :-)
15:40:15 <apuimedo> #endmeeting