#openstack-meeting-4: Kuryr

Meeting started by banix at 15:09:12 UTC (full logs).

Meeting summary

  1. libnetwork updates (banix, 15:11:15)
    1. new remot plugin APIs https://github.com/docker/libnetwork/blob/master/docs/remote.md#discovernew-notification (tfukushima, 15:13:21)
    2. label patch got merged https://github.com/docker/libnetwork/pull/222 (tfukushima, 15:13:44)
    3. ACTION: banix to open bug with info on multi node setup (banix, 15:25:43)
    4. ACTION: tfukushima: update the wiki with the outstanding patches and the assumptions (banix, 15:27:45)
    5. https://trello.com/b/cbIAXrQ2/project-kuryr (irenab, 15:29:58)
    6. ACTION: all review outstanding patches and merge if in reasonable shape (banix, 15:32:49)
    7. devref https://github.com/openstack/kuryr/blob/master/doc/source/devref/libnetwork_remote_driver_design.rst (tfukushima, 15:34:59)
    8. https://review.openstack.org/#/c/232472/ (irenab, 15:37:20)
    9. ACTION: VikasC___ to update the devref (banix, 15:40:59)
    10. Docker Network UX & remote API changes https://github.com/docker/docker/pull/16645 (tfukushima, 15:43:32)

  2. libnetwork API validation (tfukushima, 15:49:02)
    1. https://blueprints.launchpad.net/kuryr/+spec/validate-libnetwork-api-calls (VikasC___, 15:52:19)
    2. JSON schemata https://github.com/openstack/kuryr/tree/master/kuryr/schemata (tfukushima, 15:54:33)
    3. ACTION: tfukushima to update the validation blueprint ttps://blueprints.launchpad.net/kuryr/+spec/validate-libnetwork-api-calls (banix, 15:55:38)

  3. demo (tfukushima, 15:57:13)
    1. quick demo https://drive.google.com/file/d/0BwURaz1ic-5tcnFxSndEVVh3dXc/view?usp=sharing (tfukushima, 15:58:42)


Meeting ended at 15:59:19 UTC (full logs).

Action items

  1. banix to open bug with info on multi node setup
  2. tfukushima: update the wiki with the outstanding patches and the assumptions
  3. all review outstanding patches and merge if in reasonable shape
  4. VikasC___ to update the devref
  5. tfukushima to update the validation blueprint ttps://blueprints.launchpad.net/kuryr/+spec/validate-libnetwork-api-calls


Action items, by person

  1. banix
    1. banix to open bug with info on multi node setup
  2. tfukushima
    1. tfukushima: update the wiki with the outstanding patches and the assumptions
    2. tfukushima to update the validation blueprint ttps://blueprints.launchpad.net/kuryr/+spec/validate-libnetwork-api-calls
  3. VikasC___
    1. VikasC___ to update the devref


People present (lines said)

  1. banix (64)
  2. tfukushima (41)
  3. VikasC___ (32)
  4. irenab (24)
  5. openstack (5)
  6. salv-orlando (1)


Generated by MeetBot 0.1.4.