15:09:12 <banix> #startmeeting Kuryr
15:09:13 <openstack> Meeting started Mon Oct 12 15:09:12 2015 UTC and is due to finish in 60 minutes.  The chair is banix. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:09:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:09:16 <openstack> The meeting name has been set to 'kuryr'
15:09:53 <tfukushima> Thanks, banix. I need to learn how to use the IRC bot.
15:10:17 <banix> Sall we discuss latest development in libnetwork/docker and the progress of the demo?
15:10:28 <irenab> banix: +1
15:10:40 <banix> libnetwork has been going through a lot of churns past couple of weeks
15:10:51 <tfukushima> #topic libnetwork updates
15:11:15 <banix> #topic libnetwork updates
15:11:24 <banix> #chair tfukushima
15:11:25 <openstack> Current chairs: banix tfukushima
15:11:30 <banix> #chair irenab
15:11:31 <openstack> Current chairs: banix irenab tfukushima
15:11:38 <banix> So the API between remote driver and network plugis changed
15:11:49 <banix> The User facing API changes as well
15:12:22 <banix> The API for using kvstore has changes as well
15:12:41 <tfukushima> Yes, it got changed so much and we need to catch up with it quickly.
15:12:58 <banix> The gateway functionality for those plugins that do not provide it is also added
15:13:18 <banix> the labels patch got merged this weekend!
15:13:21 <tfukushima> #link new remot plugin APIs https://github.com/docker/libnetwork/blob/master/docs/remote.md#discovernew-notification
15:13:44 <tfukushima> #link label patch got merged https://github.com/docker/libnetwork/pull/222
15:14:28 <banix> tfukushima: thanks for the link; havent had a chance to look at the latest support for labels, has anyone done that?
15:14:49 <salv-orlando> nope, sorry. I
15:15:07 <irenab> me neither
15:15:10 <tfukushima> I don't think so. No one is working on that as far as I know.
15:15:30 <banix> looks like the labels are limited to networks only which may be just fine but what was not clear for me is that if they get propagated to the remote driver. Need to verify.
15:16:21 <irenab> It looks like we need to go back to the devef and update it based on recent changes
15:16:46 <banix> irenab: yes, note that the docs may have not been updated completely
15:17:12 <tfukushima> I need the latest Docker installed in my env to do them.
15:17:33 <banix> also not the code from docker/docker may not be the same as that from docker/libnetwork as the changes are being picked up
15:18:14 <banix> tfukushima: so looks like the publish option is not there anymore
15:18:17 <irenab> The “pleasure” to work with experimenal feature :-)
15:18:34 <banix> tfukushima: had a question about the demo video you showed us last time
15:18:49 <banix> irenab: yeah has been very difficult last few days.
15:18:58 <tfukushima> banix: Please let me know.
15:19:07 <banix> tfukushima: your containers were hosted on the same node/VM. correct?
15:19:16 <tfukushima> Yes.
15:19:32 <banix> makes sense
15:20:03 <banix> I tried the kvstore stuff and looks like we need to adjust the plugin (Kuryr) a bit but generaly things seemed to be operational
15:20:51 <banix> I also added the binding for OVS on my local copy but I know diga or feisky are working on it; so will sync with them
15:21:10 <irenab> banix: Can you please submit a bug in the launchpad to track the multi-node required change?
15:21:20 <tfukushima> I haven't tested Kuryr on the multiple nodes yet. I have another env with Docker, so I'll test it this week.
15:22:03 <VikasC___> o/
15:22:17 <banix> irenab: sure, will do; it has to do with how you configure the kv store with docker
15:22:23 <tfukushima> VikasC___: It seems you finally succeeded to join.
15:22:30 <VikasC___> tfukushima:  :D yess
15:22:46 <banix> VikasC___: hi
15:22:57 <VikasC___> banix: Hi banix
15:23:14 <irenab> banix: diga updated tfukushima’s patchwith support for OVS vif binding
15:23:23 <irenab> VikasC___:  hi
15:23:33 <VikasC___> irenab: hi irenab
15:23:36 <banix> So we have a lot of patches and somewhat diverging local developments, we need to get beyond that and get to an operational version
15:23:48 <VikasC___> sorry, joined late
15:23:51 <banix> irenab: will visit and comment if need be based on my experience
15:24:20 <banix> It would be nice to have something working before the summit
15:24:48 <tfukushima> Yeah, my latest series of patches should work out of the box but they're not merged.
15:25:03 <banix> Do you think we should have a day or half day sprint  and get patches merged
15:25:43 <banix> #action banix to open bug with info on multi node setup
15:25:49 <irenab> tfukushima: Can you  please udate the kuryr wiki with the list of patches to be revied in order to merge working solution?
15:25:53 <tfukushima> That would be nice but I'm not sure you can allocate your time.
15:26:36 <irenab> At least this way was very usefuul with ML2 subteam, so everyone can se the urgent patches/bug
15:26:58 <tfukushima> irenab: Yes. I think current patches should have the good shape but there are still some assumptions such as the default subnetpools.
15:27:45 <banix> #action tfukushima: update the wiki with the outstanding patches and the assumptions
15:27:46 <irenab> tfukushima: As long as assumptions are reasonable and docuented, I thik this is good for now
15:28:08 <tfukushima> I submitted few patches for workarounds.
15:28:32 <banix> tfukushima: irenab yes. for subnetpool, as long as we put it as a config option rather than hardcode name i think that is just fine
15:28:48 <tfukushima> This tip of patches would work https://review.openstack.org/231405.
15:29:02 <VikasC___> This patch set is also there for a long time. https://review.openstack.org/#/c/230752/
15:29:10 <irenab> I wanted to mention that there is also Trello board with kuryr tasks for now
15:29:31 <VikasC___> yes.. Gal created
15:29:58 <irenab> #link https://trello.com/b/cbIAXrQ2/project-kuryr
15:30:31 <tfukushima> VikasC___: Oh, it was invisible from me. I added me to the reviewers.
15:30:42 <banix> tfI think we should get these patches merged even if there are missing pieces and revise with follow on patches
15:30:54 <irenab> eventually all tasks will be maintained in launchpad
15:31:20 <VikasC___> banix: +1
15:31:31 <VikasC___> tfukushima: thanks
15:32:03 <tfukushima> banix: I'd love to but they need to get approved by the reviewers.
15:32:08 <VikasC___> irenab banix : would appreciate if you could please review  https://review.openstack.org/#/c/230752/
15:32:33 <irenab> VikasC___: sure
15:32:49 <banix> #action all review outstanding patches and merge if in reasonable shape
15:33:30 <banix> Anything else to discuss?
15:33:42 <tfukushima> So who wants to update the devref?
15:33:54 <VikasC___> o/
15:34:05 <banix> tfukushima: can you provide the link please
15:34:33 <tfukushima> banix: Do you mean the link to the deverf?
15:34:39 <banix> yes pls
15:34:59 <tfukushima> #link devref https://github.com/openstack/kuryr/blob/master/doc/source/devref/libnetwork_remote_driver_design.rst
15:35:15 <banix> tfukushima: thanks
15:35:40 <banix> when you say update, you mean with respect to new changes in libnetwork?
15:36:03 <banix> tfukushima: ^
15:36:40 <irenab> I wanted to raise a question regarding visibility of Containers in Horizon
15:36:41 <tfukushima> Yes. It's written long time ago and the content is outdated so much.
15:36:55 <banix> VikasC___: are you familiar with the latest changes in libnetwork API?
15:37:15 <banix> irenab: yes saw the discussion on review
15:37:20 <irenab> https://review.openstack.org/#/c/232472/
15:37:33 <VikasC___> irenab:  tfukushima : i want to discuss activity "docker api validation tests"
15:38:08 <tfukushima> Ok, let's discuss things sequentially.
15:38:13 <VikasC___> sure
15:38:19 <banix> irenab: this requires changes in Horizon? I recall Ironic people were facing the same issue
15:38:48 <banix> yes 1- with respect to devref
15:39:13 <irenab> banix:  The proposed patch issetting nova:compute as device_owner of the containe port…
15:39:36 <banix> VikasC___: you said you want to updat it; you are familiar with the latest changes in the API?
15:39:45 <banix> irenab: one second please
15:40:19 <irenab> I disagree and do not think we should let hacking code to merge. It can be nice for demo, but we should not merge it.
15:40:44 <VikasC___> banix:  yes banix
15:40:59 <banix> #action VikasC___ to update the devref
15:41:08 <irenab> banix, VikasC___ , all: Please comment on the patch
15:41:45 <banix> irenab: I agree. I was thinking more about cases where we do not have test coverage. But even with those cases I see your point
15:41:51 <tfukushima> VikasC___: You can check the history of the spec. https://github.com/docker/libnetwork/blob/master/docs/remote.md
15:42:21 <irenab> With device_owber set to kuryr:container and device_id set to ContainerId, port is wel preented in the list of network ports in Horizon
15:42:51 <banix> It would be good to have a working version by the summit so people can try it (not to mention having a Kolla container for it)
15:43:19 <tfukushima> VikasC___: The following pull request would be helpful as well.
15:43:32 <tfukushima> #link Docker Network UX & remote API changes https://github.com/docker/docker/pull/16645
15:43:33 <banix> irenab: I see, so then there is no issue with using kuryr:container. Right?
15:44:16 <irenab> Container is not see in the Topology view, but I think it will require Horizon code change
15:44:46 <banix> I see
15:44:58 <VikasC___> irenab: dont have much idea about horizon code.
15:45:13 <irenab> Since Horizon suport is usually a Relase after the feature, I think it is OK
15:46:25 <irenab> For now, its possible to see neutron port belongs to container in the list of network ports (with kuryr:container)
15:46:54 * irenab : sorry, need to leave
15:46:58 <banix> irenab: you are suggesting to go with kuryr:container and have Horizon changes in next cycle?
15:47:04 <banix> irenab: sure
15:48:30 <banix> VikasC___: please go ahead with validation tests
15:48:31 <VikasC___> makes sense..will not be fully functional but that would be inline with future changes.
15:49:02 <tfukushima> #topic libnetwork API validation
15:49:04 <VikasC___> i think we are already validating docker apis
15:49:08 <VikasC___> https://review.openstack.org/#/c/230752/
15:49:37 <VikasC___> or this activity means something else?
15:50:47 <tfukushima> VikasC___: Sorry, I'm not following. I'm not familiar with "the libnetwork API validation" actually.
15:51:24 <tfukushima> Could you give us some contexts?
15:51:25 <VikasC___> tfukushima: give me a moment, will give share link of bp
15:52:19 <VikasC___> https://blueprints.launchpad.net/kuryr/+spec/validate-libnetwork-api-calls
15:52:36 <VikasC___> i think we are already validating these now
15:52:54 <tfukushima> Oh, I see. I thought I wrote the validation against the requests that libnetwork gives us.
15:53:28 <banix> is this wrt using schemas for valication?
15:53:31 <VikasC___> this validation task was in open tasks
15:53:48 <VikasC___> i guess yess
15:53:59 <VikasC___> or what else can be done in validation?
15:54:12 <banix> tfukushima: can you see if this is done and mark as completed?
15:54:25 <tfukushima> Yes, I mean the validations with JSON schema but do you mean others?
15:54:33 <tfukushima> #link JSON schemata https://github.com/openstack/kuryr/tree/master/kuryr/schemata
15:54:58 <banix> I think that is what the blueprint is referring to
15:55:12 <tfukushima> Sorry, I didn't know about the blueprint and actually I wrote few validations at the point this blue print was written.
15:55:38 <banix> #action tfukushima to update the validation blueprint ttps://blueprints.launchpad.net/kuryr/+spec/validate-libnetwork-api-calls
15:55:45 <VikasC___> so can we say this activity is done.
15:55:46 <VikasC___> ?
15:55:49 <banix> 5 minutes left
15:55:55 <banix> VikasC___: i think so. yes.
15:56:09 <VikasC___> agree
15:56:21 <VikasC___> next topic
15:56:24 <tfukushima> Ok, we're running our time.
15:56:30 <tfukushima> out
15:56:46 <banix> Anything else to discuss in the 3-4 minutes we have?
15:57:13 <tfukushima> #topic demo
15:57:13 <banix> Please be available on the neutron channel if possible
15:57:39 <tfukushima> So about the demo, I uploaded the video last time.
15:57:51 <VikasC___> can you share link pls?
15:57:54 <tfukushima> Do we need more such as one with audio?
15:58:09 <banix> tfukushima: no i think that was fine
15:58:42 <tfukushima> #link quick demo https://drive.google.com/file/d/0BwURaz1ic-5tcnFxSndEVVh3dXc/view?usp=sharing
15:58:51 <tfukushima> Ok. I'm done.
15:59:07 <tfukushima> I think we should finish our meeting.
15:59:10 <VikasC___> tfukushima: thanks mate
15:59:11 <banix> thanks all
15:59:16 <VikasC___> thanks all
15:59:19 <banix> #endmeeting