#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:00:32 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:00:38)
  2. review past meeting work items (d34dh0r53, 15:03:48)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-03-13-15.01.html (d34dh0r53, 15:04:01)
    2. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:04:16)
    3. ACTION: d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation (d34dh0r53, 15:04:27)

  3. liaison updates (d34dh0r53, 15:04:38)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:05:12)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:05:23)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:05:25)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (d34dh0r53, 15:05:29)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:05:33)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:05:37)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:05:39)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:09:04)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:09:17)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:09:25)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (Merged) (d34dh0r53, 15:09:27)
    4. ttps://review.opendev.org/c/openstack/tempest/+/912489 (d34dh0r53, 15:09:29)

  6. specification Improve federated users management (gtema) (d34dh0r53, 15:14:20)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/748748 - waiting for reviews (d34dh0r53, 15:14:27)

  7. specification OpenAPI support (gtema) (d34dh0r53, 15:14:47)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/910584 (d34dh0r53, 15:14:57)

  8. open discussion (d34dh0r53, 15:15:38)
    1. https://foss.heptapod.net/python-libs/passlib/-/issues/190 (d34dh0r53, 15:15:56)

  9. bug review (d34dh0r53, 15:22:03)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:22:05)
    2. https://bugs.launchpad.net/keystone/+bug/2026345 (d34dh0r53, 15:22:31)
    3. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:24:37)
    4. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:24:57)
    5. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:25:23)
    6. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:25:45)
    7. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:26:07)

  10. conclusion (d34dh0r53, 15:26:14)
    1. https://etherpad.opendev.org/p/dalmation-ptg-keystone (d34dh0r53, 15:31:23)


Meeting ended at 15:31:57 UTC (full logs).

Action items

  1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


People present (lines said)

  1. d34dh0r53 (74)
  2. dmendiza[m] (10)
  3. opendevmeet (3)
  4. Luzi (2)
  5. gtema (1)


Generated by MeetBot 0.1.4.