15:00:32 <d34dh0r53> #startmeeting keystone
15:00:32 <opendevmeet> Meeting started Wed Mar 20 15:00:32 2024 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <opendevmeet> The meeting name has been set to 'keystone'
15:00:38 <d34dh0r53> #topic roll call
15:00:45 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla[m], lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m], mharley, jph, gtema
15:00:48 <d34dh0r53> o/
15:01:29 <dmendiza[m]> 🙋
15:01:44 <Luzi> o/
15:03:09 <gtema> sorry, I am not available, skip my topics pls
15:03:32 <d34dh0r53> will do, thanks gtema
15:03:48 <d34dh0r53> #topic review past meeting work items
15:04:01 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-03-13-15.01.html
15:04:06 <d34dh0r53> no updates from me this week
15:04:16 <d34dh0r53> #action d34dh0r53 Look into adding/restoring a known issues section to our documentation
15:04:27 <d34dh0r53> #action d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
15:04:38 <d34dh0r53> #topic liaison updates
15:04:45 <d34dh0r53> nothing from me
15:05:12 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:05:23 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:05:25 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:05:27 <d34dh0r53> External OAuth 2.0 Specification
15:05:29 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554
15:05:31 <d34dh0r53> OAuth 2.0 Implementation
15:05:33 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls
15:05:35 <d34dh0r53> OAuth 2.0 Documentation
15:05:37 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/838108
15:05:39 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:08:52 <d34dh0r53> ok, moving on
15:09:04 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:09:17 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:09:19 <d34dh0r53> 2024.1 Release Timeline
15:09:21 <d34dh0r53> Update oslo.policy in keystone to enforce_new_defaults=True
15:09:23 <d34dh0r53> Update oslo.policy in keystone to enforce_scope=True
15:09:25 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/902730 (Merged)
15:09:27 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (Merged)
15:09:29 <d34dh0r53> #link ttps://review.opendev.org/c/openstack/tempest/+/912489
15:09:34 <dmendiza[m]> Still working on improving the  SRBAC testing
15:09:45 <d34dh0r53> ack
15:09:57 <dmendiza[m]> We have a test in keystone, but it only runs tests in keystone-tempest-plugin
15:10:18 <dmendiza[m]> And there's a few failures in the keystone tests in tempest proper
15:10:25 <dmendiza[m]> so, working on a patch for those.
15:10:46 <dmendiza[m]> It's looking like we missed some policies for  Phase 1, so I should have a patch up soon that we'll need to backport
15:10:56 <dmendiza[m]> Also looking into adding Keystone to the tempest SRBAC tests
15:11:15 <dmendiza[m]> for some reason the SRBAC job in Tempest is only turning on SRBAC in like 2 projects
15:11:24 <dmendiza[m]> and Keystone is not one of them
15:11:47 <dmendiza[m]> I should have some patches to get all that working hopefully later this week
15:12:07 <d34dh0r53> awesome, thank you dmendiza[m]
15:14:08 <d34dh0r53> moving on, gtema isn't able to update so I'll just put these here for the minutes
15:14:20 <d34dh0r53> #topic specification Improve federated users management (gtema)
15:14:27 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/748748 - waiting for reviews
15:14:36 <d34dh0r53> this is being reviewed and iterated on
15:14:39 <d34dh0r53> next up
15:14:47 <d34dh0r53> #topic specification OpenAPI support (gtema)
15:14:57 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/910584
15:15:38 <d34dh0r53> #topic open discussion
15:15:46 <d34dh0r53> passlib update
15:15:54 <d34dh0r53> The maintainer responded to the bug, and one of the top priorities is to fix the bcrypt version bug
15:15:56 <d34dh0r53> #link https://foss.heptapod.net/python-libs/passlib/-/issues/190
15:15:58 <d34dh0r53> Targeted to 1.7.5
15:16:08 <d34dh0r53> 1.7.5 should be released this week
15:16:16 <d34dh0r53> at which point I'll update our dependencies
15:16:29 <d34dh0r53> anything else for open discussion?
15:18:38 <Luzi> i added the spec for the domain-manager to the rbac ptg session list: https://review.opendev.org/c/openstack/keystone-specs/+/903172
15:19:11 <d34dh0r53> ack, thanks Luzi
15:20:18 <d34dh0r53> Speaking of, I've scheduled 4 sessions, 2 on Wednesday and 2 on Thursday.  I doubt we'll need all 4 but we have flexibility if there are conflicts
15:21:52 <d34dh0r53> moving on
15:22:03 <d34dh0r53> #topic bug review
15:22:05 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:22:15 <d34dh0r53> looks like there is one new bug for keystone
15:22:31 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2026345
15:23:53 <d34dh0r53> it's a Sphinx bug and is low-hanging-fruit if someone would like to grab it
15:24:31 <d34dh0r53> next up
15:24:37 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:24:43 <d34dh0r53> no new bugs there
15:24:57 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:25:16 <d34dh0r53> no new bugs in keystoneauth
15:25:23 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:25:38 <d34dh0r53> keystonemiddleware is good
15:25:45 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:25:58 <d34dh0r53> pycadf is also good
15:26:07 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:26:10 <d34dh0r53> as it ldappool
15:26:14 <d34dh0r53> #topic conclusion
15:26:36 <d34dh0r53> As I said, I've booked Keystone sessions for the PTG
15:30:12 <d34dh0r53> I've lost the link for the etherpad :/, switched to a new browser
15:31:23 <d34dh0r53> #link https://etherpad.opendev.org/p/dalmation-ptg-keystone
15:31:39 <d34dh0r53> please add any topics you'd like to discuss
15:31:52 <d34dh0r53> that does it for me, thanks all!
15:31:57 <d34dh0r53> #endmeeting