#openstack-meeting-3: api-wg

Meeting started by cdent at 16:00:14 UTC (full logs).

Meeting summary

    1. agenda: https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (cdent, 16:01:26)

  1. previous meeting action items (cdent, 16:01:37)
    1. previous meeting: http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-11-17-16.00.html (cdent, 16:01:51)

  2. open mic (cdent, 16:02:45)
  3. Clarifying use of 400 vs. 404 (cdent, 16:04:09)
    1. review with conflicting 400 vs 404: https://review.openstack.org/#/c/401941/ (cdent, 16:04:26)
    2. https://tools.ietf.org/html/rfc7231#section-6.5.1 (edleafe, 16:07:50)

  4. Let's discuss dropping APIImpact as a thing, not only do we not do it, but what it means in commit messages is not the same as how we intended to make use of it? (cdent, 16:14:32)
    1. ACTION: cdent to clean up persistent docs to indicate that APIImpact is no longer an api-wg bat signal, [api] ml tag and agenda are. (cdent, 16:25:22)
    2. AGREED: APIImpact is no longer the api-wg bat signal (cdent, 16:26:00)

  5. guidelines (cdent, 16:29:05)
    1. pending guidelines https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (cdent, 16:29:17)

  6. bug review (cdent, 16:34:45)
  7. weekly newsletter (cdent, 16:38:07)
    1. newsletter etherpad: https://etherpad.openstack.org/p/api-wg-newsletter (cdent, 16:39:09)


Meeting ended at 17:00:35 UTC (full logs).

Action items

  1. cdent to clean up persistent docs to indicate that APIImpact is no longer an api-wg bat signal, [api] ml tag and agenda are.


Action items, by person

  1. cdent
    1. cdent to clean up persistent docs to indicate that APIImpact is no longer an api-wg bat signal, [api] ml tag and agenda are.


People present (lines said)

  1. cdent (79)
  2. edleafe (34)
  3. elmiko (27)
  4. etoews (19)
  5. Dinesh_Bhor (4)
  6. openstack (4)
  7. mlavalle (2)
  8. gouthamr (1)


Generated by MeetBot 0.1.4.