16:00:14 <cdent> #startmeeting api-wg
16:00:15 <openstack> Meeting started Thu Dec  1 16:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:18 <openstack> The meeting name has been set to 'api_wg'
16:00:22 <mlavalle> cdent: LOL, you beat me to it
16:00:30 <cdent> #chair etoews elmiko
16:00:31 <openstack> Current chairs: cdent elmiko etoews
16:00:34 * mlavalle waves at cdent
16:00:36 <cdent> :)
16:00:41 <etoews> o/
16:00:57 <elmiko> hi
16:00:58 <cdent> has elmiko returned from
16:01:02 <cdent> well there ya go
16:01:05 <elmiko> i has =)
16:01:07 <gouthamr> hi o/
16:01:12 <cdent> edleafe: you about?
16:01:26 <cdent> #link agenda: https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:26 <edleafe> yup
16:01:37 <cdent> #topic previous meeting action items
16:01:51 <cdent> #link previous meeting: http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-11-17-16.00.html
16:02:15 <cdent> one agenda item was on edleafe, he did it, made it happen, guideline for nin now under review
16:02:29 <cdent> s/agenda/action/
16:02:45 <cdent> #topic open mic
16:02:58 <cdent> there's one listed there, but before we get to that anyone have anything?
16:03:12 <edleafe> there are two
16:03:22 <edleafe> I added one ~30 min ago
16:03:51 <cdent> ah, awesome
16:03:58 <cdent> well let's do your then:
16:04:09 <cdent> #topic Clarifying use of 400 vs. 404
16:04:26 <cdent> #link review with conflicting 400 vs 404: https://review.openstack.org/#/c/401941/
16:04:38 <edleafe> ok, the guideline at https://github.com/openstack/api-wg/blob/master/guidelines/http.rst#id7 is what I'm concerned with
16:05:21 <edleafe> It states that if a resource passed in the body of a request isn't found, to return 400, not 404, because 404 means just the URI
16:05:57 <edleafe> My concern is that 400 means that the request is malformed or otherwise has bad syntax
16:06:21 <cdent> 400 is also the "something is wrong and nothing else fits, but you might be able to fix it on your side"
16:06:38 <edleafe> I don't agree that a perfectly-formed request that references a resource that doesn't exist should be a 400
16:07:35 <cdent> I think I probably wrote the bit you are objecting to (I can't remember for sure). Can you point to the part of the rfc that makes you think otherwise?
16:07:50 <edleafe> https://tools.ietf.org/html/rfc7231#section-6.5.1
16:08:15 <edleafe> the only thing that suggests being a catch-all is "perceived to be"
16:08:39 <cdent> yeah, that's not the thing, the reason to use 404 is in 6.5.4: "that the origin server did not find a current representation for the target resource"
16:08:42 <cdent> so 404 is wrong
16:08:54 <cdent> 400 may also be wrong, but it definitely should not be 404
16:09:15 <elmiko> 409 stands out as a possible likely candidate with 400
16:09:23 <elmiko> although, also not perfect
16:09:54 <etoews> i don't think it's a 409
16:09:55 <cdent> no, 409 wouldn't be very good oeither
16:10:00 <cdent> which is why we fall back to 400...
16:10:04 <elmiko> right
16:10:09 <edleafe> yeah, 409 seems as poor a fit as 400
16:11:02 <edleafe> So are we stuck with 400, but with a honking good error message?
16:11:14 <etoews> i think 400 would be okay with a good error message
16:11:29 <cdent> yeah, pretty much
16:11:35 <edleafe> Dinesh_Bhor: how does that sound to you?
16:11:47 <Dinesh_Bhor> Agree
16:11:57 <etoews> has cinder adopted the error message guideline?
16:12:12 <edleafe> ok, I'll re-review with an eye on the error messages
16:12:15 <elmiko> i like honking good error messages, in general XD
16:12:23 <etoews> beep beep
16:12:26 <cdent> are honking and stonking the same?
16:12:43 <elmiko> doesn't seem like it, at the least there are 3 character different
16:12:59 * cdent thinks maybe we should send elmiko back
16:13:02 <edleafe> cdent: kindred spirits
16:13:12 <elmiko> oh please do, i fell in love with al Andaluz
16:13:19 <cdent> :)
16:13:39 <cdent> So, is that resolved then?
16:14:02 <edleafe> topol_: you and stevemar are one and the same??
16:14:11 <edleafe> :)
16:14:25 * cdent moves on
16:14:25 <edleafe> cdent: Yes, I don't see a better solution
16:14:32 <cdent> #topic Let's discuss dropping APIImpact as a thing, not only do we not do it, but what it means in commit messages is not the same as how we intended to make use of it?
16:14:44 <edleafe> cdent: I'll propose some extra wording to the guideline to clarify
16:14:53 <cdent> edleafe++
16:15:10 <Dinesh_Bhor> Could someone please comment on the patch so that it will be easy for me to convience cinder community to accept it?
16:15:29 <cdent> my reasoning on this is that having something we intend to do but never do and we have a more workable solution anyway just seems like bad form, so we may as well dump it, if we can
16:15:42 <cdent> The "if we can" is wondering if we have some kind or charter or otherwise that requires it?
16:15:46 <elmiko> cdent: that is sound reasoning
16:15:54 <edleafe> Dinesh_Bhor: yes, I'll do that
16:16:04 <elmiko> it's a great aspiration, but we have sadly fallen short
16:16:11 <Dinesh_Bhor> edleafe: ok, thank you
16:16:20 <etoews> cdent: do you mean dump it from our meeting or dump it from all of openstack everywhere?
16:16:21 <cdent> most of the time human interaction seems to work the best (as today)
16:16:39 <cdent> etoews: I mean dump it from our meeting, our newsletter, and any other documents we have
16:16:41 <edleafe> Dinesh_Bhor: the question is always "is it worth it", and that you'll have to work out amongst yourselves
16:17:09 <Dinesh_Bhor> edleafe: yes, I will
16:17:15 <cdent> as far as I can tell it operates as a signal within each project independent of whatever it means to us
16:17:27 <edleafe> cdent: would there be a way for a patch submitter to indicate that they would like it reviewed by the API WG?
16:17:41 <edleafe> cdent: or do they have to do that with this meeting, or the ML?
16:18:42 <cdent> right now it seems the ML is the defacto way, with followups here, and that seems to be working?
16:18:52 <etoews> afaik and as far as our docs are concerned, i think it's only in https://wiki.openstack.org/wiki/API_Working_Group
16:18:55 <cdent> the [api] tag is visible and meaningful
16:19:15 <cdent> If we choose to make the change I can take the action to cleanup wiki and anything else
16:19:40 <etoews> i agree that [api] on ml and bringing folks into this meeting seems to be working well enough
16:20:04 <edleafe> etoews: that's the doc I had in mind
16:20:23 <cdent> should we poll the world or is it okay to decide unilaterally?
16:20:43 <etoews> i don't think we need to poll the world
16:20:49 <cdent> (me neither)
16:21:03 * cdent looks at elmiko
16:21:05 <edleafe> but... what if we accidentally offend someone???
16:21:13 * cdent gives edleafe a cookie
16:21:15 <etoews> i don't think we should tell people to stop using it though
16:21:15 <cdent> well done
16:21:28 <cdent> oh yeah, I wasn't suggesting that
16:21:36 <etoews> kk
16:21:43 <elmiko> hmm
16:21:46 <edleafe> etoews: we should tell them that it is no longer a bat signal
16:22:06 <elmiko> maybe follow our normal proceedure, and signal that we will deprecate APIImpact and see if there is a huge backlash?
16:22:15 <edleafe> IOW, that we are largely ignoring it
16:22:34 <cdent> that's already obvious from several months of saying that in the newsletter (every single time)
16:22:42 <edleafe> APIImpact has other uses
16:23:03 <cdent> yes, which is why we're not telling people not to use it, just that it won't mean anything to the api-wg
16:23:11 <edleafe> we use it in Nova for indicating a need for microversions, release notes, etc.
16:23:32 <edleafe> cdent: exactly. Not the API WG bat signal
16:23:38 * cdent nods
16:24:12 <elmiko> cdent: +1
16:24:50 <cdent> cool, whoever gets the newsletter can say something about that, and also remove that chunk from the newsletter etherpad, I'll do the wiki etc
16:25:22 <cdent> #action cdent to clean up persistent docs to indicate that APIImpact is no longer an api-wg bat signal, [api] ml tag and agenda are.
16:26:00 <cdent> #agreed APIImpact is no longer the api-wg bat signal
16:26:06 <cdent> any other opens?
16:26:13 <etoews> i don't think we want to say "deprecate APIImpact"
16:26:25 <etoews> that will give the impression that people should stop using it
16:26:39 <cdent> yeah, good point etoews
16:27:06 <elmiko> fair
16:27:16 <cdent> I think "bat signal" is about right, but is too colloquial?
16:27:19 <etoews> simply say that we're not actively reviewing apiimpact anymore and to hit us up on the ml with [api]
16:27:31 <elmiko> should we change the language in the newsletter to direct folks towards making an email with [api]?
16:27:51 * cdent buys the jinxers a coke
16:27:56 <elmiko> lol
16:29:05 <cdent> #topic guidelines
16:29:17 <cdent> #link pending guidelines https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:29:42 <cdent> nin is freezable? https://review.openstack.org/#/c/399131/
16:30:12 <cdent> (other two not)
16:30:16 <edleafe> not a lot of controversy, eh?
16:30:21 <elmiko> seems like it is
16:30:48 <cdent> edleafe: politics fatigue :)
16:31:24 <cdent> "wanna fight about it?" "nah"
16:31:31 <elmiko> hehe
16:32:34 <cdent> etoews: you wanna freeze that one?
16:32:35 <edleafe> big whoop
16:32:41 <etoews> cdent: sure
16:34:36 <cdent> nothing is ready to merge
16:34:45 <cdent> #topic bug review
16:34:48 <cdent> there are no new bugs
16:35:16 <cdent> since elmiko has been away for a while that means he has to do 20 penalty bugs
16:35:49 <elmiko> wow
16:35:53 <elmiko> so harsh
16:36:01 <elmiko> =)
16:36:18 <edleafe> elmiko: yeah, cdent doesn't mess around
16:36:56 <elmiko> seriously
16:37:22 <cdent> Yeah, I'm all about amassing and abusing power.
16:37:45 <elmiko> hahaha
16:38:07 <edleafe> "You will all bow down before me!!!"
16:38:07 <cdent> #topic weekly newsletter
16:38:54 <cdent> is anyone aching to be the newletter editor this week? or shall we work on it together in the next 20 mins?
16:39:09 <cdent> #link newsletter etherpad: https://etherpad.openstack.org/p/api-wg-newsletter
16:39:50 <elmiko> i'm all for collaboration
16:40:22 <cdent> sweet, i mean suite
16:40:56 <elmiko> lol
16:47:31 <edleafe> Pushed the change for the 400v404 thing: https://review.openstack.org/#/c/405515/
16:56:06 <cdent> how's the etherpad seem?
16:56:15 <elmiko> looking tight on my end
16:56:52 <etoews> +1
16:58:24 <cdent> I'm having a spelling and grammar brainfart. Is this correct: " led to a proposed" ?
16:58:44 <elmiko> that seems correct to me
16:58:48 <etoews> sound fine
16:59:02 <cdent> etoews: did you do the cpl thingie on the frozen guideline?
16:59:11 <etoews> yep.
16:59:19 <cdent> \o/
16:59:22 <cdent> perfect timing
16:59:25 <cdent> thanks everyone
16:59:28 <etoews> before freezing so they see the frozen comment
17:00:35 <cdent> #endmeeting