22:03:24 <jeblair> #startmeeting zuul
22:03:25 <openstack> Meeting started Mon Oct 30 22:03:24 2017 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:03:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:03:28 <openstack> The meeting name has been set to 'zuul'
22:03:38 <jeblair> i guess we should start with....
22:03:42 <jeblair> let's not have a meeting next week
22:03:49 <fungi> let's not, no
22:03:59 <jeblair> on account of many of us will be in australia where the timezones are all weird anyway
22:04:07 <clarkb> it will be sunday too
22:04:18 <clarkb> er
22:04:22 <clarkb> I did that math wrong
22:04:26 <clarkb> tuesday!
22:04:27 <jeblair> see what i mean?
22:04:30 <jeblair> it's hopeless
22:04:36 <Shrews> will people be recovered enough for the following meeting?
22:04:53 <jeblair> i will be erm... bushwalking is i think the term.
22:05:00 <clarkb> I'll be back
22:05:16 <jeblair> (i'll be away the week after summit)
22:05:24 <jhesketh> 9am Tuesday to be exact ;-)
22:05:57 <jeblair> mordred is taking time off this week, but i think he will be back the week after
22:06:08 <jeblair> (the week after summit that is)
22:06:18 <jeblair> don't hold me to that
22:06:35 <jeblair> in fact, never hold me accountable for mordred's schedule.  just passing along what i think i know :)
22:07:24 <clarkb> ha
22:07:40 <jeblair> so yeah, sounds like we'll have most folks around after summit, with me being away and it sounds like Shrews may be planning on needing a long recovery.  :)
22:08:25 <Shrews> i will not need a recovery as i will not be traveling
22:08:38 <jeblair> Shrews: no one had to know that
22:08:47 <Shrews> well, not to sydney, at least
22:08:56 <jeblair> Shrews: summit's busy, you can totally fake being there
22:09:12 <jeblair> i really have had people say "i can't believe i didn't see you at ..."
22:09:23 <jeblair> despite my being present 12 hours a day in like every track
22:09:35 <jeblair> anyway
22:09:38 <fungi> i get home thursday night after the summit, so will hopefully be awake and at least as eloquent as usual by monday
22:09:49 <jeblair> let's say no meeting next week (summit) and yes meeting week after
22:09:59 <fungi> wfm
22:10:02 <clarkb> sounds good
22:10:02 <jeblair> and we can always send out an email canceling it if folks don't feel like it
22:10:13 <pabelanger> ++
22:10:30 <jeblair> #info no meeting next week (nov 6) due to openstack summit
22:11:27 <jeblair> okay, with that out of the way... the agenda's open -- anything we should discuss?  (SpamapS  wanted to discuss road to v3 release starting at ~22:30)
22:12:15 <jeblair> i think the 'zuul issues' section of the https://etherpad.openstack.org/p/zuulv3-issues is looking pretty good
22:12:16 <clarkb> are there any urgent fixes for things that need review? Seems like its been much more quiet today
22:12:48 <jeblair> there are still zuul issues, but i don't think any are urgent at this point
22:12:54 <jeblair> and even the job issues are looking tractable now
22:13:10 <jeblair> we're still mid-transition on the zuul.projects list -> dict transition
22:13:18 <jeblair> i had to revert the latest attempt at that over the weekend
22:13:57 <jeblair> i'm sure we'll figure out the right way to do that soon... though i'm starting to wonder if mordred's idea of a filter to handle that may not be a bad idea :)
22:14:21 <jeblair> over the weekend i pushed up 78 changes to add .yaml file extensions to playbook names
22:14:24 <clarkb> I'd like to make an 0.11.0 gear release today if possible to pick up that chagne to statsd reporting
22:14:40 <jeblair> clarkb: ++  i'm happy to release as soon as it merges
22:14:54 <clarkb> it has merged, do you want to tag or should I go ahead and do it?
22:15:25 <jeblair> clarkb: i say go for it
22:15:53 <clarkb> ok I'll work on that now
22:15:57 <jeblair> my plan for the playbook extension deprecation is basically to see if all those changes get merged by the time i get back from bushwalking
22:16:22 <jeblair> and if they are, consider that a reasonable deprecation period, and then drop support for not having extensions
22:16:31 <jeblair> i'll send an email to the infra list for other zuul users
22:16:54 <Shrews> jeblair: is there a reason we *must* deprecate that?
22:16:58 <pabelanger> Yup, we even did a puppet modules release this morning using native zuulv3 jobs :)
22:17:03 <clarkb> jeblair: it is possible for new changes to use the old format though right?
22:17:10 <clarkb> do we have to worry about new regressions showing up?
22:17:21 <jeblair> though my feeling is that between now and v3.0 release, we don't need a firm backwards compat commitment.  no one should be using this that isn't prepared to use under-development softwaer.
22:17:52 <jeblair> clarkb: yes.  i'll check again later and see if more changes are needed.
22:18:22 <jeblair> if the deprecation doesn't go smoothly, then we'll have to work out how to deal with it... drop projects?  force-merge changes?  i dunno.
22:18:43 <fungi> i'm cool with the latter in this circumstance
22:18:44 <jeblair> Shrews: i'd like our initial release of the job syntax to be as clear as possible
22:18:57 <Shrews> fair 'nuf
22:19:07 <jeblair> Shrews: after we release with an actual commitment, changes will have to be slower
22:19:20 <fungi> since we have a distributed configuration we're now responsible for, transitions like this can't wait for every single project-team to take their time reviewing
22:19:22 <jeblair> but i think we should grant ourselves a paper-bag period to fix things like this
22:20:06 <jeblair> fungi: ++ that's honestly the least disruptive thing.
22:20:14 <fungi> and yeah, we have administrative override for the code review system, and i feel like this is one of the few legitimate use cases
22:20:25 <pabelanger> I really like the .yaml change, and happy we did it.
22:20:52 <jeblair> we've already insta-deprecated the implied playbook (there were only 2 instances of that in the whole system).  i couldn't make that backwards compat, so i just fixed one instance before implementation.
22:21:11 <jeblair> and missed the second one.  i didn't realize my 'clone-all-repos' script aborted 2/3 of the way through.
22:21:14 <jeblair> but it's since been fixed.
22:21:36 <jeblair> the third deprecation thing is one i just pushed up: https://review.openstack.org/516451
22:21:43 <jeblair> changes 'override-branch' to 'override-checkout'
22:22:00 <jeblair> there was an email to the infra list about that one too, and that seemed to be the preferred approach
22:22:40 <jeblair> we can support backwards compat for a weeks-long deprecation period like the .yaml change with that one too
22:23:51 <pabelanger> do you have a general idea when you'd like to tag v3.0?
22:25:57 <jeblair> yes, but let's wait 5 more mins for SpamapS :)
22:27:17 <jeblair> anything else in the interim?
22:27:27 <fungi> i really like zuul v3
22:27:30 <fungi> that is all
22:27:32 <jeblair> \o/
22:27:58 <tristanC> o/ I'll be rebasing and resume work on zuul-web in the next few days
22:28:06 <jeblair> tristanC: welcome back!
22:28:30 <Shrews> halloween joke while waiting for SpamapS: Why is it that programmers always confuse Halloween with Christmas?
22:28:45 <Shrews> Because 31 OCT = 25 DEC
22:28:48 <fungi> octal conversion?
22:28:55 <fungi> yup
22:28:56 <jeblair> nice :)
22:29:15 <fungi> always liked that one
22:29:36 <jeblair> i think we're getting to the point where we can "unfreeze" the development work we paused during the infra rollout, so hopefully we can start landing fun things like the dashboard, etc, soon :)
22:30:06 <pabelanger> OOh, nice
22:30:37 <tristanC> sweet, seems like you have been busy polishing things :)
22:30:38 <fungi> that'll be swell
22:30:39 * SpamapS is here
22:30:51 <Shrews> "And there was much rejoicing."
22:30:55 <fungi> a stray SpamapS appears
22:30:56 <SpamapS> zomg no, because Halloween IS my christmas
22:31:09 <jeblair> #topic v3 roadmap
22:31:42 <jeblair> at the last ptg we brainstormed a roadmap
22:31:54 <jeblair> which i've held on to because it's just been "put out all the fires" since then
22:32:01 <jeblair> but i think now's the time to get back to that
22:32:07 <SpamapS> \o/
22:32:11 <jeblair> i've polished it up and will send out an email with it soon
22:32:43 <jeblair> but here's my previous draft: http://paste.openstack.org/show/625018/
22:32:58 <jeblair> i need to update it once more to catch it up with some changes
22:33:18 <jeblair> but i've laid out what i think we need for the v3 release
22:33:46 <jeblair> the first section, btw, is all stuff that i think we can land *very* quickly because it's already in progress or nearly complete
22:33:51 <clarkb> jeblair: based on earlier conversation with dmsimard and pabelanger about helping infra and where people can get involved it might be worth adding a zuulv3 entry to the help wanted specs entry? maybe use a meta spec that points at zuuls kanban board thing?
22:34:32 <jeblair> that leaves the second section for things that need development work between now and then
22:34:43 <jeblair> er 'significant' development work
22:34:50 <jeblair> clarkb: good idea
22:34:57 * SpamapS reading
22:35:05 <jeblair> and speaking of which -- after we discuss/revise this over email
22:35:11 <jeblair> what should we do with it?
22:35:20 <jeblair> translate into storyboard?  stick into zuul repo as rst?  ...other?
22:35:40 <SpamapS> git driver support for reading zuul-jobs and such without github/gerrit credentials ?
22:35:45 <SpamapS> What's this one about?
22:36:04 <clarkb> SpamapS: basically pointing at a "raw" git repo aiui
22:36:10 <jeblair> SpamapS: oh basically "make the git driver work"  so that your zuul can use openstack-infra/zuul-jobs without using gerrit or github
22:36:10 <clarkb> SpamapS: so no gerrit or github, could just be local on disk
22:36:14 <fungi> a lot of these look like they could spawn their own specs
22:36:19 <SpamapS> jeblair: Oh storyboard.. man.. I totally forgot to even go back to that and look at it once the bombs started dropping in the cutover. ;)
22:36:42 <jeblair> fungi: certainly the longterm/design ones yeah.  in fact, almost each one of those would make a good spec.
22:36:42 <pabelanger> I could give storyboard a try again, i didn't use it too much first time around. But if we are to make it a thing in openstack, I'm willing try harder
22:36:58 <SpamapS> jeblair: ah, and then other not-code-review based triggers?
22:36:59 <tristanC> SpamapS: jeblair: will this git driver implement periodic update to poll merged changes?
22:37:04 <clarkb> The board required extra special privs to edit right?
22:37:11 <clarkb> I think that was my biggest struggle any time I interacted with it
22:37:15 <jeblair> tristanC: that was what i was thinking, yes
22:37:19 <clarkb> I as user couldn't actually use it beyond reading descriptions
22:37:20 <SpamapS> clarkb: you just have to be added to the board.
22:37:37 <SpamapS> clarkb: but we had a bot that added and removed work that was in progress
22:37:49 <jeblair> still do have the bot in fact :)
22:38:05 <SpamapS> It was mostly just to give a high level view for coordinating new contributors.
22:38:41 <SpamapS> jeblair: hah yeah I suppose I think of that as "in a former life" because I haven't been able to keep up with overall dev since BonnyCI was wound down.
22:39:13 <SpamapS> anyway, the git driver sounds awesome, but I believe you could cut 3.0 without it.
22:39:15 <tristanC> jeblair: on the (probably) significant work, should we discuss workflow around nodepool building speculative image for container based project?
22:39:26 <SpamapS> Unless there's some submarine dependency chain I missed there.
22:39:49 <SpamapS> same for cross-source deps
22:40:02 <clarkb> SpamapS: I think the git driver thing is a simplicity in deployment eg good user experience thing
22:40:30 <jeblair> i agree using storyboard for this is theoretically a good idea, but it takes more work than editing a text file to manage, so if we do, i'd like for two things: other folks to help manage it and do all the typing and clicking and stuff, as well as people actually using it (not just theoretical in case a new contributor shows up and asks what do i do?)
22:41:09 <SpamapS> jeblair: I'd be on board with just closing everything that isn't a bug in storyboard, and moving to feature trackign in text files.
22:41:12 <jeblair> SpamapS: well, git driver is in there because we want a big part of the story to be "you can use this standard library of jobs super easy" and "hook up your zuul to zuul's gerrit" is not super easy :)
22:41:15 * Shrews reiterates his hate for storyboard
22:42:24 <jeblair> fortunately, the git driver will be easy
22:42:28 <jeblair> it's mostly written
22:43:32 <clarkb> I know I'm personally bad at storyboard, big hurdle for me is I can't tell it to send email to a different address, but I can work around that with forwards and stuff if i have to
22:43:32 <jeblair> SpamapS: similarly, i think cross-source deps is a crucial feature, and it may have implications for driver behavior that i think would be good to iron out before we have a release cut.
22:44:08 <clarkb> I'm also still somewhat confused about how the baord is supposed to work because iirc I couldn't edit anything on it like entry descriptions even
22:45:20 <jeblair> how about this:  i will volunteer to help maintain the board in storyboard if at least one other person is willing to split duties with me 50%.  otherwise, let's assume we'd all prefer stuff in text files and just add it to the repo in dev docs.
22:45:33 <SpamapS> So, let me just say that I think all of what you're saying is great. But I also think that what's in Zuul now is perfectly usable and fine without those features and a 3.0 that did not have them would be amazingly cool and useful to have ASAP.
22:45:50 <fungi> clarkb: the tasks belong to stories, so the tasklists and boards are just there for you to organize the tasks
22:46:42 <SpamapS> Truth be told, I think the only thing in that list that _must_ be done is documentation. And I'm signing up to write a "getting started guide" with leifmadsen as soon as I feel I have gotten through that phase (which actually is probably last Friday).
22:46:50 <clarkb> fungi: ya it was the actual baord entries iirc that you couldn't edit as they have their own attributes and descriptions/comments iirc
22:47:06 <fungi> ahh
22:47:10 <clarkb> jeblair: I feel like I've got to figure out the todo list generally for infra so I'd be willint to help with zuul specifically too
22:47:29 <clarkb> whether that is text files or storyboard
22:47:54 <SpamapS> To address the lack of git driver, I am just maintaining my own zuul-jobs mirror. I have only one source, so I don't need cross-source deps or anything.
22:48:03 <fungi> i will admit i've not used storyboard much beyond dealing with tasks in the story context, so am a little unfamiliar with the tasklist and board ui
22:48:36 <SpamapS> What I do need is a web page I can send my bosses to where they can see a real project that has other users that will provide a pool of engineering talent and general forward momentum to convince them to invest in Zuul.
22:48:48 <leifmadsen> SpamapS: nice, I mostly just need to finish my work on AWX and the Ansible tower_* modules. Once that is done, I want to automate the documentation I have in a quickstart guide so that it can set us up with a reproducible environment to start from.
22:49:12 <jeblair> SpamapS: yeah, we definitely should avoid featuritis.  i'm trying to hold the line, but for me it feels very incomplete to have multiple drivers but not have them interact.  the git driver, i'm not worried about.  i can finish it fast enough it's not worth arguing about :)
22:49:12 <SpamapS> leifmadsen: Sure. Can we just start with rst in zuul/doc/source ?
22:49:38 <leifmadsen> SpamapS: how about we start with getting something working with rough notes before we worry about dealing with syntax issues in RST
22:49:46 <SpamapS> Cause I've been taking copious rst-ish notes for the last 3 weeks. ;)
22:49:50 <leifmadsen> I have an etherpad started via mordred and jeblair
22:50:06 <leifmadsen> SpamapS: send them my way, and I'll work through them to test and find your bugs :)
22:50:11 <leifmadsen> I guarantee there are bugs :)
22:50:16 <SpamapS> leifmadsen: k
22:50:18 <leifmadsen> for, I am, THE BUG FINDER
22:50:29 <leifmadsen> https://etherpad.openstack.org/p/zuulv3-quickstart
22:50:34 <leifmadsen> this is the start of the docs (pre-zuul install)
22:50:46 <SpamapS> jeblair: yeah I don't want to be pushy. I want to be a cheer leader. Ra ra ra.. let's go RELEASE! Sis boom bah, git 'er done...
22:50:49 <leifmadsen> however, I'm probably just going to stop fighting CentOS 7 and assume you need to run Fedora for Zuul for now
22:50:58 * fungi thinks leifmadsen needs a catchy theme song to go along with his new television series title
22:51:09 <leifmadsen> fungi: you think I don't have one already?
22:51:13 <leifmadsen> pashaw
22:51:16 <fungi> ahh, you likely do yes ;)
22:51:29 <SpamapS> leifmadsen: cool, I may take that, submit it as a patch to feature/zuulv3, and then add my own on top, because I can't really stand etherpads for things like this (they're great for in-the-moment collab.. not somuch for async)
22:51:53 <leifmadsen> it sounds a lot like the Duck Tales theme song
22:52:14 <fungi> good enough
22:52:24 <leifmadsen> SpamapS: that still sounds terrible for async work :)
22:52:53 <jeblair> yeah, the etherpad was good for our interactive session (of which i hope to have another soon)
22:53:19 <leifmadsen> yea, I will probably mostly ignore other documentation work for now, for fear of it getting too distracting, or jumping too far ahead of what I was trying to accomplish
22:53:21 <pabelanger> leifmadsen: SpamapS: I'd recommend fedora or ubuntu, centos is going to need a fair bit more things to get into place
22:53:22 <jeblair> but i don't see why we can't dump that into the tree, then work on top of it (can always move it back to an etherpad for another interactive session)
22:53:30 <leifmadsen> docs are great, I encourage that, but you already know Zuul, so your approach will be different
22:53:41 <leifmadsen> pabelanger: welcome to 2 minutes ago :)
22:54:00 <leifmadsen> 18:50 <leifmadsen> however, I'm probably just going to stop fighting CentOS 7 and assume you need to run Fedora for Zuul for now
22:54:04 <pabelanger> indeed
22:54:36 <leifmadsen> my approach was to start with documentation from a "I don't know what the fuck I'm doing here!" approach. That approach found 2 bugs in a single 3 hour session :)
22:54:39 <jeblair> leifmadsen: i'm available wednesday and thursday, then i'm out for 2 weeks, but mordred should be back the week after next.
22:54:49 <leifmadsen> jeblair: Wednesday it is then
22:54:52 <leifmadsen> I have the whole day open
22:55:01 <leifmadsen> jeblair: pick any time on my calendar that works for you
22:55:10 <leifmadsen> I will spend time getting what we have automated tomorrow then
22:55:25 <leifmadsen> then we can reproduce the first set of this documentation with a single button
22:55:27 <jeblair> cool, anyone else want to hop on an interactive bootstrapping phone call?
22:55:41 <pabelanger> don't mind listening in
22:55:44 <leifmadsen> I have a Fedora image on RDO cloud, and I have the ansible stuff to spin up VMs there very easily
22:56:05 <leifmadsen> I don't expect the first half of this to take to long to automate
22:56:10 <leifmadsen> too long*
22:56:16 <clarkb> I won't be able to make wednesday but I've stumbled my way through zuulv3 bootstrapping to test gerrit 2.13 so I think I'll be ok
22:56:30 <leifmadsen> cool -- I won't be using gerrit in my docs :)
22:56:38 <leifmadsen> the less infra required to play around in a quickstart, the better
22:56:46 <jeblair> also, we should fix up https://review.openstack.org/498050 and merge it
22:56:55 <leifmadsen> jeblair: the royal we, right? :)
22:57:26 <leifmadsen> if there was any chance of having that cleaned up and merged before wednesday would make things simpler, but I can automate around it
22:57:59 <jeblair> the actual we.. mordred mentions stuff in that commit message i'm not sure about.
22:58:04 <jeblair> it takes a village.
22:58:07 <leifmadsen> +1
22:58:13 <leifmadsen> np, easy enough to cherry pick in likely
22:58:57 <jeblair> okay, i'll polish up the draft list i pasted and send out an email with it for further discussion
22:59:09 <jeblair> #action jeblair send out roadmap email
22:59:21 <jeblair> anything else in the 1m we have left?
22:59:23 <leifmadsen> cool, and I'll make sure I can spin up our phase 1 docs easily so we have somewhere to start from on Wednesday
22:59:34 <jeblair> leifmadsen: ++ thanks!
22:59:36 <leifmadsen> I gotta go actually
22:59:38 <leifmadsen> so no :)
22:59:46 <SpamapS> I have to buzz off to other meetings (already kind of did)
22:59:46 * leifmadsen goes to hang with kids before bed
22:59:51 <SpamapS> anyway, this all sounds great!
22:59:56 <jeblair> thanks everyone!
23:00:04 <fungi> thanks jeblair!
23:00:04 <SpamapS> looking forward to 3.0'ing with everyone :)
23:00:16 <jeblair> #endmeeting