22:03:33 <jeblair> #startmeeting zuul
22:03:33 <openstack> Meeting started Mon Jan  9 22:03:33 2017 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:03:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:03:37 <openstack> The meeting name has been set to 'zuul'
22:03:41 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/Zuul
22:03:51 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/zuul/2016/zuul.2016-12-19-22.02.html
22:04:25 <jeblair> no announcements or previous action items...
22:04:38 <jeblair> #topic Status updates: Nodepool Zookeeper work
22:05:07 <jeblair> Shrews: you've started on the next phase in nodepool!
22:05:23 <Shrews> i have? i mean... yeah! i have
22:06:03 <Shrews> i expect i'll be finished tomorrow
22:06:13 <Shrews> tomorrow is April, right?
22:06:37 <adam_g> o/
22:06:38 <SpamapS> o/
22:06:41 <jeblair> :)  fortunately, we worked out most of the zookeeper stuff already
22:06:43 <rattboi> o/
22:06:55 <jeblair> so we can jump right into the fun bits
22:07:05 <pabelanger> nice
22:07:05 <jamielennox> o/
22:07:49 <jeblair> related: i have a 17-patch series to zuul to implement the zuul side of this
22:08:22 * SpamapS isn't sure why but he imagined jeblair saying that as Gilderoy Lockhart
22:08:30 <SpamapS> ;)
22:08:52 <jeblair> the zuul side of course, is the easy bit.  it just asks for things and gets upset if it doesn't get them.
22:09:21 <Shrews> next time i get the easy part
22:09:23 <jeblair> SpamapS: 2 points from gryffindor
22:10:39 <jeblair> anyway, those patches are ready for review; the series is long enough that if folks do request changes, i might ask to implement them as follow-ups.  :)
22:10:46 <jeblair> starts at 413241
22:11:23 <jeblair> i'm also thinking of adding a zuul/nodepool integration job
22:11:50 <Shrews> that should totally be a thing
22:12:12 <jeblair> i figure we can run nodepool with its "fakes" configuration so we don't have to wait on devstack+image builds, and use the fake gerrit, etc, on the zuul side, but then have zuul and nodepool talk for real over zk
22:12:51 <jeblair> we can add it to 'check experimental' since it'll be a while until we're ready for it, but it'll take a while to set up, so i think it's good to go ahead and get the infrastructure in place
22:13:14 <pabelanger> I actually have that working today with some ansible things I have been working on.  Atleast the nodepool / zookeeper parts (with image builds too)
22:13:43 <clarkb> jeblair: compartmentalizing the integration testing makes sense to me
22:13:52 <clarkb> should make it easier to debug specific failures too
22:14:03 <jeblair> pabelanger: cool, maybe we can implement the job as an ansible playbook then... that may be forward thinking for zuulv3 :)
22:14:32 <jeblair> clarkb: ++
22:15:08 <pabelanger> jeblair: sure
22:15:09 <jeblair> last thing i have on this topic, is we said we would release nodepool master in early january
22:15:12 <jeblair> it's early january
22:15:47 <jeblair> are we ready?  do we want to land the '--no-builder' change we were discussing this morning, or push that into the next release?
22:16:12 <Shrews> land it. earlier the better
22:16:41 <Shrews> though it needs to be changed to the master branch first
22:16:56 <pabelanger> ya, working on that now
22:17:10 <jeblair> yeah, considering this is the release where we're saying "change your nodepool builder configuration" it's probably good to get it into this one
22:18:07 <jeblair> so maybe we can make the release tomorrow
22:18:23 <jeblair> anything else nodepool/zookeeper related?
22:18:56 <jeblair> #topic Status updates: Devstack-gate roles refactoring
22:18:57 <clarkb> yes I think earlier is better for that too
22:19:46 <jeblair> rcarillocruz isn't here
22:20:09 <jeblair> but it looks like there are 2 devstack-gate changes that could use reviews
22:20:16 <jeblair> 403732 404243
22:20:34 <clarkb> looks like my last comment was addressed so I need to rereview will put that on the list
22:20:58 <jeblair> clarkb: thanks
22:21:38 <jeblair> #topic Status updates: Zuul test enablement
22:22:57 <jeblair> there are some changes from SpamapS and adam_g from before the holidays that need dusting off, i think
22:23:11 <adam_g> ive got a few test enablement patches up collecting dust from before the holiday that i hope to get moving again now that im back from holiday
22:24:28 <jeblair> cool, anything else?
22:25:11 <jeblair> #topic Progress summary
22:25:50 <jeblair> SpamapS: how's it going?
22:26:00 <jhesketh> I've been snowed under with linux.conf.au and other responsibilities... after next week though I hope to have more time to return to actually writing code. In the mean time I'll try and catch up on reviews :-)
22:27:30 <jeblair> jhesketh: ++
22:29:17 <jhesketh> (also ya'll should come to https://linux.conf.au)
22:29:35 <pabelanger> :)
22:29:52 <jeblair> i wish i could, hopefully next year
22:30:04 <jeblair> looking at the board:
22:30:07 <fungi> does sound lovely
22:30:10 <jeblair> #link https://storyboard.openstack.org/#!/board/41
22:30:25 <jeblair> i'll move the zk nodepool stuff Shrews and i are working on to in-progress
22:31:11 <jeblair> anyone else see anything on there that should be changed?
22:32:15 <jeblair> #topic Open Discussion
22:32:30 <jeblair> mordred: any chance you're around?
22:34:52 <jeblair> was hoping we could discuss the plan for the zuulv2->nodepoolv3 shim... maybe a mailing list post
22:35:11 <jeblair> #action mordred describe plan for zuulv2->nodepoolv3 shim in mailing list post
22:35:50 <jeblair> speaking of mailing list posts, i followed up on the nodepool config file format discussion we were having from before the holidays
22:36:05 <pabelanger> I wouldn't mind some thoughts on https://review.openstack.org/#/c/412160/. Basically allowing nodepool-builder to just frontend to diskimage-builder (diskimage builds only).  Biggest reason, is the yaml support we have in nodepool-builder
22:36:31 <clarkb> jeblair: I haven't had a chance to resposne to that but I read it really quickly before the meeting and I like it
22:36:34 <pabelanger> pretty minimal change actually, adds a new 'format' setting into diskimages
22:36:40 <jeblair> we should probably finalize that so we can go ahead and update the config file format soonish
22:36:58 <jeblair> clarkb: yeah, sorry about the timing there :)  no rush
22:38:25 <jeblair> pabelanger: that seems like a fairly minimal change to enable a new set of use cases (one that i know folks have talked about previously)
22:39:07 <clarkb> pabelanger: that would run in foreground?
22:39:14 <clarkb> or does it still run as a service?
22:39:27 <pabelanger> clarkb: service
22:39:39 <pabelanger> but, -d would forground it
22:39:58 <clarkb> I guess by foreground I mean `build-me-one-image` sort of command
22:40:26 <pabelanger> Ya, that doesn't work
22:40:32 <jeblair> clarkb: that seems like it should be the purview of dib itself
22:40:37 <clarkb> jeblair: ya I agree
22:40:52 <clarkb> jeblair: its also what I think would be more useful :) (at least its what I end up doing often because I don't run my image build VM all the time)
22:41:03 <jeblair> this is more: i want to run a daemon that builds/updates an image everyday
22:41:20 <pabelanger> or container :)
22:41:23 <pabelanger> but yes
22:41:25 <clarkb> without worrying about tying it to a cloud
22:41:37 <pabelanger> exact;u
22:41:42 <pabelanger> exactly*
22:42:40 <clarkb> gotcha
22:44:38 <jeblair> shall we wrap this up then?
22:45:00 <Shrews> jeblair: that "Use Zookeeper for Workers" task on the storyboard... duplicate? either way, it's done
22:45:12 <Shrews> under New
22:45:24 <jeblair> Shrews: yeah, i think it's the one attached to the spec
22:46:11 <jeblair> i think i'll just mark it in progress until the spec is marked completed
22:47:02 <jeblair> thanks everyone!
22:47:04 <jeblair> #endmeeting