03:00:06 <mkrai> #startmeeting zun
03:00:07 <openstack> Meeting started Tue Dec 19 03:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is mkrai. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:08 <mkrai> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-12-19_0300_UTC Today's agenda
03:00:08 <mkrai> #topic Roll Call
03:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:10 <openstack> The meeting name has been set to 'zun'
03:00:32 <mkrai> #topic Roll Call
03:02:49 <kiennt26> o/
03:02:51 <kiennt26> hi
03:03:04 <mkrai> Hi kiennt26
03:03:09 <mkrai> Thank you for joining the meeting
03:03:21 <mkrai> It seems we are only two in the meeting
03:03:33 <mkrai> Let's have a short update from both of us
03:03:51 <mkrai> kiennt26: Would you like to go first?
03:04:01 <kiennt26> mkrai: yeah, ok.
03:04:12 <mkrai> Thank you
03:04:23 <kevinz> o/
03:04:24 <kiennt26> last week, i have worked on blueprint Use privsep
03:04:28 <kiennt26> hi kevinz
03:04:29 <mkrai> Hi kevinz
03:04:33 <kevinz> sorry I'm late
03:04:40 <mkrai> I am glad you're here today
03:04:46 <kevinz> Hi kiennt26 mkrai
03:04:46 <kiennt26> #link https://review.openstack.org/#/c/511430/
03:04:47 <mkrai> kiennt26: is giving an update now
03:04:51 <kevinz> OK
03:05:26 <kiennt26> mkrai, kevinz: I have proposed a patch to implement blueprint use-privsep
03:05:54 <kiennt26> the above link, could you test and review it? :)
03:05:56 <mkrai> kiennt26: Thank you for it
03:06:12 <mkrai> Yes sure I will review it
03:06:38 <kevinz> kiennt26: I will review too:-)
03:06:42 <mkrai> kiennt26: Anything else from your side?
03:06:49 <kiennt26> My 2nd work is publishing Zun-tempest-plugin's documentation. The patch was landed.
03:06:58 <kiennt26> #link https://review.openstack.org/#/c/527886/
03:07:25 <mkrai> Great. With that the migration is completed I assume?
03:07:49 <kiennt26> mkrai: yeah, i think :)
03:07:51 <kiennt26> That's all from me last weak.
03:08:05 <mkrai> kiennt26: Thank you
03:08:18 <mkrai> kevinz: Would you like to provide an update?
03:08:24 <kevinz> yeah sure
03:09:14 <kevinz> I'm working on volume attach for capsule. Now the function is finished. I will submit a patch after fix some UT error
03:09:39 <mkrai> kevinz: I saw that the multi-attach support is merged in Nova now
03:09:42 <mkrai> #link http://lists.openstack.org/pipermail/openstack-dev/2017-December/125356.html
03:10:04 <mkrai> That might help you
03:10:16 <kevinz> mkrai: Good news. I will follow this
03:10:25 <kevinz> mkrai: Now only support one attach
03:10:29 <kevinz> in zun
03:10:34 <mkrai> kevinz: Great
03:11:09 <kevinz> also I'm looking at virtual-kubelet
03:11:19 <kevinz> https://github.com/virtual-kubelet/virtual-kubelet
03:11:31 <kevinz> which we can use with kubernetes-connector
03:11:42 <mkrai> #link https://github.com/virtual-kubelet/virtual-kubelet
03:12:25 <mkrai> I don't know much about it
03:12:34 <mkrai> How is it used with k8s-connector?
03:12:45 <mkrai> And then zun?
03:13:03 <kevinz> This project will make ACI or AWS as the kubernetes backend
03:13:21 <kevinz> So the same with Zun. We can use this project to register a node in Kubernetes.
03:13:52 <mkrai> That node is an Openstack node?
03:14:05 <kevinz> in general, make zun cluster as a single node in Kubernetes
03:14:14 <mkrai> Ok got it
03:14:15 <kevinz> The node is K8s node.
03:14:49 <mkrai> kevinz: If possible, I would like to have a diagram for this support
03:14:59 <mkrai> That will make things easier to understand
03:15:17 <mkrai> How k8s, zun, k8s-connector all are connected sort of diagram
03:15:35 <kevinz> OK, I will compile one after meeting :-)
03:15:45 <kiennt26> mkrai: +1
03:15:52 <mkrai> Great. Thank you for this kevinz :)
03:16:00 <mkrai> I will mark an action for it
03:16:02 <kiennt26> kevinz: looking for it, thank you!
03:16:05 <mkrai> kevinz: Is it ok?
03:16:16 <kevinz> mkrai: kiennt26: my pleasure
03:16:24 <kevinz> That's all from my side
03:16:30 <mkrai> #action kevinz to create a diagram explaining the k8s-connector feature
03:16:42 <mkrai> kevinz: Thank you for all your hard work :)
03:16:54 <mkrai> Ok so my turn now!
03:16:58 <kevinz> mkrai: yw
03:17:42 <mkrai> So I have been working on the clear container support in ZUn
03:17:52 <mkrai> #link https://review.openstack.org/#/c/499534/
03:18:07 <mkrai> Now that there is new Kata containers, the patch is in question
03:18:29 <mkrai> I posted a comment saying that this can be merged for now and later replace with kata containers
03:18:36 <mkrai> Kata containers will take time to be ready
03:18:53 <mkrai> I also posted a patch to add a document on how to use CC with Zun
03:19:04 <mkrai> #link https://review.openstack.org/#/c/527611/
03:19:14 <mkrai> I will update this patch today
03:19:33 <mkrai> So that's all I did last week
03:19:37 <mkrai> Any questions on the same?
03:20:14 <kiennt26> mkrai, kevinz : Zun-tempest-plugin still 404.
03:20:25 <kiennt26> I have pushed a patch to fix it
03:20:29 <kiennt26> #link https://review.openstack.org/#/c/527851/
03:20:29 <kevinz> mkrai: Not yet. Maybe come up with some questions after review the patch
03:20:58 <mkrai> kiennt26: Ok I will review it
03:21:07 <mkrai> I guess this is critical patch
03:21:16 <mkrai> kevinz: Thank you!
03:21:32 <kevinz> kiennt26: me too
03:21:43 <kiennt26> mkrai, kevinz : thank you :) Hope this patch will fix our problem.
03:21:53 <kevinz> mkrai: yw
03:22:03 <mkrai> kiennt26: sure, Thank you!
03:22:06 <mkrai> Anything else to discuss?
03:22:19 <kiennt26> Nothing from me.
03:22:43 <kevinz> That's all from my side
03:22:56 <mkrai> Ok thank you all for joining the meeting :)
03:22:57 <mkrai> See you next week!
03:23:06 <mkrai> #endmeeting