03:00:06 <hongbin> #startmeeting zun
03:00:07 <openstack> Meeting started Tue Jul  4 03:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:11 <openstack> The meeting name has been set to 'zun'
03:00:13 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-07-04_0300_UTC Today's agenda
03:00:17 <hongbin> #topic Roll Call
03:00:26 <Shunli> shunli
03:00:27 <mkrai> o/
03:00:50 <kevinz> o/
03:01:25 <hongbin> thanks for joining the meting Shunli mkrai kevinz
03:01:42 <hongbin> there are not too much people today, so let's have a short meeting
03:01:51 <hongbin> #topic Announcements
03:01:57 <hongbin> 1. Heat integration is completed
03:02:03 <hongbin> #link https://review.openstack.org/#/c/437810/
03:02:13 <hongbin> thanks Namrata  for the great work
03:02:34 <Namrata> Hi
03:02:38 <mkrai> Thanks Namrata and Hongbin
03:02:52 <Namrata> yes hongbin with your help it got merged
03:02:54 <Shunli> Thanks Namrata and Hongbin
03:03:11 <hongbin> my pleasure
03:03:13 <hongbin> Any other announcement ?
03:03:35 <kevinz> I have a little
03:03:42 <hongbin> kevinz: go ahead
03:04:08 <kevinz> https://www.openstack.org/software/project-navigator
03:04:31 <kevinz> I find that zun is in compute service but our logo is missing,,,
03:04:54 <hongbin> not sure why it is missing
03:05:06 <mkrai> kevinz: good finding
03:05:34 <hongbin> kevinz: do you have any clue?
03:06:00 <kevinz> hongbin: I don't have
03:06:10 <mkrai> hongbin: kevinz I found that it is missing from our launchpad page also
03:06:12 <hongbin> ok, i will take an AI to figure it out
03:06:21 <mkrai> See https://bugs.launchpad.net/ironic
03:06:27 <mkrai> for reference
03:06:43 <hongbin> #action hongbin figure out why project logo is missing in https://www.openstack.org/software/project-navigator
03:06:46 <hongbin> mkrai: ack
03:06:49 <kevinz> mkrai: Aha  yes
03:07:22 <mkrai> Great. Thanks kevinz :)
03:07:31 <hongbin> #action hongbin figure out why project logo is missing in LB as well
03:07:48 <hongbin> thanks for the finding mkrai kevinz
03:07:56 <kevinz> yw :-)
03:08:03 <hongbin> ok, proceed to the next topic
03:08:09 <hongbin> #topic Cinder integration
03:08:30 <hongbin> for this one, i uploaded a new patch for modifying hte spec
03:08:42 <hongbin> #link https://review.openstack.org/#/c/468658/
03:09:07 <hongbin> the new patchset addressed the comments from pradeep about adding the workflow for deleting volume
03:09:19 <hongbin> it also clarifies lakerzhou's comment
03:09:35 <hongbin> i will work on a WIP patch for this feature soon
03:09:45 <hongbin> that is all from me
03:09:49 <mkrai> I review the spec
03:10:00 <hongbin> mkrai: ack
03:10:07 <hongbin> any question for this topic?
03:10:28 <mkrai> no :)
03:10:32 <hongbin> #topic Introduce container composition (kevinz)
03:10:41 <hongbin> kevinz: ^^
03:10:48 <kevinz> Hi all.
03:11:07 <kevinz> This week I'm working on capsule create and capsule list
03:11:22 <kevinz> will push a WIP patch today I hope
03:11:49 <hongbin> kevinz: that is great
03:12:00 <hongbin> kevinz: look forward to reviewing your wip patch
03:12:20 <kevinz> hongbin : thanks
03:12:43 <hongbin> kevinz: do you have any question that needs us to clarify?
03:13:09 <kevinz> hongbin: I find miaohb is working on make infra container option
03:13:50 <kevinz> I think capsule patch will modify after this bp is finished
03:14:02 <hongbin> #link https://review.openstack.org/#/c/471634/
03:14:35 <hongbin> kevinz: this one?
03:14:41 <kevinz> yes
03:14:58 <hongbin> i uploaded the latest patchset for him
03:15:20 <hongbin> i tried to make the native docker driver to support both sandbox and non-sandbox
03:15:28 <hongbin> so there are two modes
03:15:48 <hongbin> kevinz: the capsule feature will possibly leverage the sandbox mode
03:15:51 <kevinz> Wow that will be better
03:16:07 <kevinz> I will check the patch today
03:16:11 <kevinz> Thanks hongbin
03:16:13 <mkrai> hongbin: Do you think we need to keep the sandbox for docker driver?
03:16:39 <hongbin> mkrai: yes, because kevinz needs the sandbox to implement capsule
03:16:50 <mkrai> Oh ok.
03:16:54 <hongbin> mkrai: however, sandbox will be turned off by default
03:17:20 <kevinz> btw, I don't use zun-capsule-api now, all in zun-api since it is not decied
03:17:20 <mkrai> hongbin: ack
03:17:24 <kevinz> decided
03:17:36 <hongbin> kevinz: that is fine
03:17:46 <mkrai> kevinz: I think that's good to start with
03:18:11 <kevinz> OK
03:18:17 <kevinz> Thanks hongbin mkrai
03:18:24 <hongbin> thanks kevinz
03:18:36 <hongbin> ok, next topic
03:18:44 <hongbin> #topic Add user specify network to create container (Shunli)
03:18:56 <hongbin> Shunli: want to chair this topic?
03:19:02 <Shunli> sure
03:20:01 <Shunli> zun&kuryr integration now create or select a network in neutron for the first be selected one.
03:20:31 <Shunli> user specify network is try to add CLI options to let use specify a network pre-created.
03:21:07 <Shunli> such as zun create -it --nets network='test' nginx bash
03:21:33 <hongbin> that would be a very handy feature
03:21:49 <hongbin> i like it!
03:21:51 <mkrai> Yes useful feature
03:21:52 <Shunli> So that user can controll the container network create.
03:22:23 <Shunli> hongbin: i checked the nova implementation.
03:22:23 <kevinz> It's cool
03:22:53 <hongbin> In addition, i guess user can specify the --nets multiple times for specifying multiple networks
03:22:59 <Shunli> wrap all CLI parameter in network request seems done in nova-api and compute side.
03:23:11 <Shunli> not in the CLI side.
03:23:46 <mkrai> Shunli: Yes this should be done at the server side. For us, it should be zun-compute
03:24:44 <hongbin> Shunli: yes, that is my understanding of nova as well
03:24:47 <Shunli> also per your comments, seems add for each item the 'net-name' is not so convinient for user to create container.
03:25:08 <hongbin> Shunli: i see
03:25:34 <Shunli> for example, user specify each network, maybe port, maybe ip address.
03:25:59 <Shunli> in nova, they do not need to specify in which network.
03:26:38 <hongbin> Shunli: nova needs to specify a neutron network name/id? i remember
03:27:31 <hongbin> Shunli: perhaps, you have a suggestion for this?
03:28:17 <Shunli> if user specify a port, nova CLI will query the network from neutron, user no need explicitly specify the network.
03:28:45 <hongbin> that is true
03:29:11 <hongbin> if a neutron port is specified, it is enough information
03:29:20 <Shunli> I'm think if possible user only specify network or port-id or ip address, then compute side will query the full info from neutron.
03:30:07 <mkrai> Shunli: hongbin But the boot api takes the network name/id only. Right?
03:30:43 <Shunli> mkrai: boot api also accept just pass a port-id
03:30:54 <hongbin> Shunli: port-id and network should be fine, ip address will work if it is unified (no other part has the same ip addresses)
03:31:11 <mkrai> Shunli: I see
03:31:36 <Shunli> hongbin: i see, you are right. only ip address may not enough to create container network.
03:32:25 <hongbin> Shunli: however, zun can return 400 if it detect the ambigious
03:32:48 <hongbin> Shunli: therefore, your proposal sound good to me so far
03:32:57 <Shunli> hongbin: Seems i need to do more investaigation about the how to handle ip adrees case.
03:33:02 <Shunli> hongbin: ack
03:33:46 <Shunli> hongbin: i will try to may the CLI more simple for user.
03:33:58 <Shunli> may->make
03:34:03 <hongbin> ack
03:34:07 <hongbin> Shunli: i have a nit comment, which is what i commented in the patch
03:34:25 <hongbin> the "network" and "port-id" doesn't look consistency with each other
03:34:38 <hongbin> i would say, it is more consistency if
03:34:45 <hongbin> 1. "network" and "port"
03:34:52 <hongbin> 2. "network-id" and "port-id"
03:35:05 <hongbin> either #1 or #2
03:35:21 <Shunli> hongbin: ok, i get what you are saying.
03:35:29 <Shunli> will fix it later
03:35:38 <hongbin> Shunli: awesome
03:35:39 <mkrai> I vote for #1
03:35:48 <Shunli> mkrai: ack
03:36:21 <hongbin> Shunli: besides this nit, everything looks good to me
03:36:39 <Shunli> hongbin: ack, so that's all for me
03:36:54 <hongbin> mkrai: you have any comment about Shunli
03:37:02 <hongbin> Shunli's patch
03:37:29 <mkrai> hongbin: No
03:37:30 <mkrai> I will review the patch today
03:37:47 <hongbin> thanks Shunli mkrai
03:38:17 <Shunli> my pleasure.
03:38:18 <hongbin> #topic Open Discussion
03:38:37 <hongbin> we finished all the topics in the agenda now
03:39:02 <hongbin> if nobody else has a topic, we will end the meeting earlier tody
03:39:09 <Shunli> hongbin: after kuryr integration, zun-compute should run the ovs-agent, right?
03:39:37 <hongbin> Shunli: yes, kuryr integration is finished, so zun-compute should run with an ovs-agent
03:40:08 <Shunli> ack, thx.
03:40:28 <mkrai> hongbin: One thing
03:40:32 <hongbin> i am thinking to containerized ovs-agent and kuryr-libnetwork , and make them all managed by zun-compute, but that is a long-term idea
03:40:44 <hongbin> mkrai: go ahead
03:40:45 <mkrai> Are you going for the PTG?
03:41:10 <hongbin> mkrai: possibly i won't, but will possibly go to Sydney
03:41:52 <mkrai> Ok I am also not going
03:42:13 <hongbin> mkrai: how about sydney?
03:42:32 <mkrai> depends on Openstack Travel support :)
03:42:48 <hongbin> mkrai: go ahead to apply it as last time !
03:43:06 <mkrai> hongbin: yes will do that
03:43:37 <hongbin> mkrai: hope to see you in sydney
03:43:53 <hongbin> Shunli: will your employer support you to travel to ptg / summit ?
03:44:11 <zsli_> not sure now.
03:44:18 <hongbin> ok
03:44:36 <hongbin> zsli_: hope to see you in sydney as well
03:44:45 <hongbin> all, thanks for joining the meeting
03:44:50 <hongbin> have a good day
03:44:54 <zsli_> bye.
03:44:58 <hongbin> #endmeeting