03:00:05 <hongbin> #startmeeting zun
03:00:06 <openstack> Meeting started Tue Jun 20 03:00:05 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:09 <openstack> The meeting name has been set to 'zun'
03:00:10 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-06-20_0300_UTC Today's agenda
03:00:14 <hongbin> #topic Roll Call
03:00:18 <kevinz> kevinz
03:00:24 <mkrai> o/
03:00:38 <lakerzhou> lakerzhou
03:01:24 <Namrata> NAmrata
03:01:40 <hongbin> thanks for joining kevinz mkrai lakerzhou Namrata
03:02:00 <hongbin> ok, let's get started
03:02:17 <hongbin> #topic Announcements
03:02:32 <hongbin> i have an announcement
03:02:52 <hongbin> i and kevinz will present at openstack day china next month
03:03:08 <hongbin> both of us has an accepted presentation about zun
03:03:16 <mkrai> Great :)
03:03:21 <Namrata> great
03:03:30 <hongbin> that is all from my side
03:03:46 <hongbin> any announcement from you?
03:03:53 <mkrai> No
03:03:58 <lakerzhou> will you please share the slides?
03:04:19 <hongbin> lakerzhou: sure, i will share mine after the presentation
03:04:30 <kevinz> lakerzhou: me too
03:04:45 <lakerzhou> hongbin and kevin, thanks
03:04:50 <hongbin> ok
03:04:56 <hongbin> #topic Cinder integration
03:05:18 <hongbin> i am working on a WIP patch to introduce cinder integration
03:06:16 <hongbin> i don't think it is ready to be reviewed yet, but the idea is there
03:07:05 <hongbin> basically, the idea is to connect to the cinder volume and bind-mount it to the container
03:07:18 <hongbin> the high level idea has been outlined in a spec
03:07:29 <hongbin> #link https://review.openstack.org/#/c/468658/
03:07:47 <hongbin> a WIP patch will be ready to be reviewed soon
03:07:59 <hongbin> that is all from me for this topic
03:08:05 <hongbin> any question?
03:08:12 <mkrai> Thanks Hongbin. I will be happy to review
03:08:30 <hongbin> mkrai: thanks madhuri
03:08:43 <mkrai> I think I have one but that might be a vague question
03:08:57 <hongbin> mkrai: go ahead
03:09:23 <mkrai> After reeading the spec, why do we have to use os-brick? Cinder doesn't provide the same device info?
03:09:57 <hongbin> os-brick is the library to connect to different cinder backend
03:10:25 <hongbin> the connection code will be very different for each backend, and os-brick provides a abstracted layer for that
03:10:48 <mkrai> I see
03:11:02 <mkrai> os-brick is just a library?
03:11:15 <hongbin> yes, it is a library (not a service)
03:11:30 <mkrai> Ok thanks for the information
03:11:35 <hongbin> and it is maintained by the cinder team
03:11:58 <hongbin> ok, move on to the next topic
03:12:04 <hongbin> #topic Introduce container composition (kevinz)
03:12:09 <hongbin> #link https://review.openstack.org/#/c/437759/ The design spec
03:12:14 <hongbin> #link https://etherpad.openstack.org/p/zun-container-composition The etherpad
03:12:18 <hongbin> kevinz: ^^
03:12:38 <kevinz> I have several questions to discuss
03:13:15 <kevinz> First is about the Object and db models of Capsule
03:13:57 <hongbin> go ahead
03:14:09 <kevinz> Does caspule need to include the container uuid? Or   container object store a capsule uuid
03:15:05 <mkrai> Capsule should store the container uuid
03:15:37 <hongbin> kevinz: from my perspective, it is better to make container's data model independent, so agree with mkrai
03:16:07 <kevinz> OK, now I plan to use this: 'containers': fields.ListOfObjectsField('Container'),
03:16:31 <hongbin> sounds like a good option to try
03:16:33 <kevinz> Capsule store the container Object entry
03:16:58 <kevinz> Or just a List of container uuid
03:17:33 <mkrai> what is container object entry?
03:18:10 <kevinz> capsule.containers will point to the container
03:18:25 <mkrai> i mean is it a dictionary or something else?
03:19:19 <kevinz> mkrai: I think it is a Object List
03:20:23 <mkrai> If we have decided to keep the container and capsule object independent. It will be good to store the container object itself
03:21:30 <hongbin> mkrai: i think in db level, the capsule object will have a fields called "containers", which is a list of container objects
03:21:38 <hongbin> sorry, in object level
03:22:05 <kevinz> hongbin: that's what I mean. Thanks hongbin
03:22:15 <hongbin> i guess that is what kevinz mean as well :)
03:22:55 <hongbin> ListOfObjectsField is actually a list of "container" object per my understanding
03:24:06 <kevinz> yes it is
03:24:22 <hongbin> mkrai: still have doubt?
03:24:29 <mkrai> No
03:24:34 <mkrai> Got it. Thanks
03:24:55 <mkrai> So I suggest to store container object in capsule db
03:25:15 <hongbin> oh, in db level
03:25:44 <mkrai> yes
03:26:36 <hongbin> mkrai: just want to clarify, what is the goal for this proposal?
03:26:58 <mkrai> keep container and capsule db independent
03:27:17 <hongbin> i see
03:27:39 <mkrai> The same as you suggested :)
03:27:48 <hongbin> i think we can take this proposal as a homework, and eveyone give it more thoughts
03:28:16 <kevinz> OK
03:28:56 <hongbin> kevinz: mkrai i did have some thoughts about the capsule feature, i think it is better to make it as an add-on
03:29:34 <hongbin> kevinz: mkrai like a api extension
03:29:44 <mkrai> hongbin: Would you like to tell it now?
03:30:39 <hongbin> kevinz: mkrai i think this will make the end-users to tell the difference between "container" and "capsule", contianer-api is the core api, capsule is an add-on
03:31:25 <hongbin> kevinz: mkrai i guess that is how it works in neutron (core api, extension)
03:31:47 <mkrai> I am in favor of this idea
03:32:15 <mkrai> Otherwise mixing container and capsule might get complicated in future as well
03:32:25 <mkrai> So its better to keep them independent
03:33:04 <kevinz> I'm OK also, so that all tha API will be separated?
03:33:27 <mkrai> Yes I think so
03:33:31 <hongbin> kevinz: just an initial idea, there will be a zun-api and zun-capsule-api
03:34:13 <hongbin> kevinz: like a docker core api, and the swarm api
03:34:37 <hongbin> (swarm api is an add-on)
03:35:04 <mkrai> +1
03:35:06 <hongbin> (if swarm mode is disabled, there is just docker core api)
03:35:49 <kevinz> hongbin: I see. It's a good point. We can decide to separate it, I think much work need to do
03:36:16 <hongbin> kevinz: :) yes
03:36:22 <kevinz> hongbin: So that the in the db level, container and capsule will separated?
03:36:42 <kevinz> and capsule will maintain its own containers?
03:37:04 <hongbin> kevinz: from my point of view, separation in api level is important, the data model is optional
03:38:03 <kevinz> hongbin: got it. I think so. That will reduce the API cost as well
03:38:34 <hongbin> kevinz: ack
03:39:16 <hongbin> kevinz: btw, let's keep the disucssion open for this idea
03:39:47 <kevinz> hongbin: ack:-)
03:39:57 <hongbin> ok, anything else on this topic?
03:40:08 <kevinz> a small one
03:40:15 <hongbin> go ahead
03:40:17 <kevinz> I plan to place the yaml abstract functions in API server side.
03:40:48 <kevinz> Just mkrai referred in last meeting
03:40:49 <hongbin> ok
03:40:57 <kevinz> That's all from my side
03:41:13 <mkrai> Thanks kevinz for the consideration :)
03:41:20 <hongbin> thanks kevinz
03:41:47 <hongbin> Namrata: ready to talk about your htea integration work?
03:41:51 <kevinz> mkrai:hongbin: Thanks for your help
03:42:01 <Namrata> yeah sure hongbin
03:42:09 <hongbin> Namrata: go ahead
03:42:13 <hongbin> #topic Add Zun Resources to Heat
03:42:38 <Namrata> https://review.openstack.org/#/c/437810/
03:42:50 <Namrata> Add Container to Zun resources
03:42:53 <hongbin> lakerzhou: will talk about nfv as the next topic if you are still there :)
03:42:57 <Namrata> Hongbin update the patch
03:43:03 <Namrata> *updated
03:43:20 <Namrata> Thanks for that
03:43:26 <lakerzhou> I am still online
03:43:37 <Namrata> I think only comments need to be incorporated
03:43:45 <Namrata> So hope to get this merged this week
03:43:52 <diga> sorry I got very late in joining the meeting
03:44:04 <hongbin> Namrata: thanks Namrata
03:44:21 <hongbin> diga: hey, thanks for joinning
03:44:38 <hongbin> ok, next topic
03:44:40 <diga> hongbin: Hi
03:44:42 <hongbin> #topic NFV use cases
03:44:46 <hongbin> #link https://etherpad.openstack.org/p/zun-nfv-use-cases
03:44:55 <hongbin> lakerzhou: want to drive this topic?
03:45:13 <lakerzhou> I am try to tackle SR-IOV use case for container first because it is relatively simpler than DPDK. However it is still too complicated. I am breaking it down to three BPs.
03:45:55 <lakerzhou> 1. build PCI resource data model. I am almost done with the design spec. Should have it ready for review tomorrow.
03:46:23 <lakerzhou> 2. Support PciPassthroughFilter in zun scheduler
03:47:10 <lakerzhou> 3. Support SR-IOV usage. It has dependency on Kuryr.
03:47:38 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-pcipassthroughfilter
03:47:46 <diga> lakerzhou: Hi, what dependency we have on kuryr for SR-IOV
03:47:48 <lakerzhou> Once I have #1 reviewed. I will finalize #3.
03:48:17 <hongbin> lakerzhou: ack
03:48:34 <hongbin> lakerzhou: i couldn't find hte bp for #3, do you have the link?
03:48:50 <diga> lakerzhou: I can help you if you need help on NFV side as I am working closely with OpenStack NFV orchestration team
03:49:20 <lakerzhou> two major changes in Kuryr. 1. matching a SR-IOV port to endpoint; 2. Binding endpoint to container
03:49:39 <diga> okay
03:50:25 <lakerzhou> Hongbin, I don't have a BP for #3 yet
03:50:49 <hongbin> lakerzhou: ack, mind i assigning you an action item to create a bp for #3?
03:51:06 <lakerzhou> Hongbin: sure, please.
03:51:25 <hongbin> #action lakerzhou create a bp for supporting SR-IOV usage
03:51:46 <hongbin> lakerzhou: i will review the action item in the next team meeting
03:52:01 <hongbin> lakerzhou: just fyi
03:52:29 <lakerzhou> Also, with #1 and #2 completed, we should in better position to support GPU in ZUN.
03:52:52 <hongbin> sound good
03:53:18 <lakerzhou> I am working with a large cloud operator with some requirements for GPU work load.
03:53:55 <hongbin> i see, it looks containerized gpu is a trend
03:54:14 <lakerzhou> I will share the thoughts later. But some example in spec already use GPU as a example.
03:54:28 <diga> Yeah, so many consumers are asking about containerized GPUs
03:54:47 <hongbin> i see
03:54:59 <diga> mostly telcos
03:55:24 <lakerzhou> that is all from me. Will send the spec of #1 for review tomorrow.
03:55:43 <hongbin> lakerzhou: thanks lakerzhou
03:55:44 <diga> Good work lakerzhou
03:56:05 <hongbin> #topic Open Discussion
03:56:22 <hongbin> anyone has a topic to bring up?
03:56:50 <diga> hongbin: about cinder integration, yesterday I made the setup ready, will test the patch & push it today
03:57:05 <hongbin> diga: ack
03:57:20 <diga> hongbin: will talk to you later as I have some questions on it
03:57:37 <hongbin> diga: ok
03:58:11 <hongbin> anything else to discuss?
03:58:38 <hongbin> seems no
03:58:48 <hongbin> all, thanks for joining the meeting
03:58:51 <hongbin> #endmeeting