03:00:09 <hongbin> #startmeeting zun
03:00:10 <openstack> Meeting started Tue Apr 25 03:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:13 <openstack> The meeting name has been set to 'zun'
03:00:14 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-04-25_0300_UTC Today's agenda
03:00:18 <hongbin> #topic Roll Call
03:00:26 <mkrai> Madhuri Kumari
03:00:28 <pksingh> Hello, all
03:00:44 <kevinz> kevinz
03:01:08 <Namrata> Namrata
03:01:21 <hongbin> thanks for joining mkrai pksingh kevinz Namrata
03:01:22 <Shunli> shunli
03:01:29 <hongbin> thanks for joining Shunli
03:01:38 <hongbin> ok, let's get started
03:01:44 <hongbin> #topic Announcements
03:01:51 <hongbin> 1. We will have a "Boston Summit" release by the end of April
03:02:04 <hongbin> the python-zunclient already released
03:02:09 <hongbin> #link https://review.openstack.org/#/c/459160/
03:02:20 <hongbin> will release zun and zun-ui in this week
03:02:36 <mkrai> Great!!
03:02:55 <hongbin> just let me know if you have any patch wanted to be included in the release
03:03:10 <hongbin> or you saw any patch that should be included
03:03:19 <hongbin> 2. Review Zun's mascot
03:03:26 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/attachments/20170421/1db0d2fb/attachment.png
03:03:38 <hongbin> all, what do you think about this mascot?
03:03:39 <shubhams> hongbin: Will we have some release doc or some document that lists what we supports ?
03:03:40 <mkrai> I looked at it and it looks really good
03:03:44 <mkrai> +1 for it
03:04:09 <Shunli> cute, looks like docker's mascot
03:04:09 <pksingh> will mirror image be better?
03:04:16 <hongbin> shubhams: yes, there should be some release notes to explain the list of features of this release
03:04:24 <shubhams> hongbin: ack
03:04:36 <shubhams> hongbin: mascot looks cool +1
03:04:39 <hongbin> shubhams: will write the notes if i have a chance, otherwise, leave it to the pike release
03:04:45 <Shunli> +1
03:05:04 <shubhams> hongbin: got that
03:05:06 <hongbin> pksingh: what is mirrow image?
03:06:08 <hongbin> ok, it looks most people like the mascot, i will approve it
03:06:32 <hongbin> any other announcement from our team members?
03:07:10 <hongbin> seems no
03:07:12 <hongbin> #topic Review Action Items
03:07:20 <hongbin> 1. hongbin help diga to get the cinder integration patch passed the gate (IN PROGRESS)
03:07:26 <pksingh_> sorry i got disconnected
03:07:27 <hongbin> #link https://review.openstack.org/#/c/429943/
03:07:47 <hongbin> pksingh_: you said something about mirror image?
03:08:01 <hongbin> pksingh_: what do you mean by mirror image?
03:08:02 <pksingh_> face just opposite, means towards left
03:08:12 <hongbin> i see
03:09:32 <mkrai> pksingh_: Any reason ?
03:09:58 <pksingh_> mkrai: no specific reason, just i think it would look better
03:10:36 <pksingh_> just from myside, nothing strong about it
03:10:36 <mkrai> pksingh_: Ok
03:10:50 <mkrai> I am ok with the current one
03:11:06 <hongbin> :)
03:11:34 <hongbin> ok, let's get back to the action item
03:11:45 <hongbin> #link https://review.openstack.org/#/c/429943/
03:12:04 <hongbin> diga cannot join the meeting today
03:12:34 <hongbin> i left a message to the review, mentioning that it missed a db migration script so the gate broke
03:12:47 <hongbin> will ping him about that after the meeting
03:12:56 <hongbin> #topic Cinder integration (diga)
03:13:02 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/cinder-zun-integration The BP
03:13:18 <hongbin> ok, i just mentioned this bp
03:13:44 <hongbin> it looks the progress of this bp is slow, i am going to mark it as slow progress
03:14:04 <hongbin> any comment about this one?
03:14:56 <hongbin> seems no
03:15:04 <hongbin> #topic Kuryr integration (hongbin)
03:15:10 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/kuryr-integration The BP
03:15:41 <hongbin> #link https://review.openstack.org/#/c/453387/
03:15:48 <hongbin> the patch got merged last week
03:15:55 <hongbin> thanks everyone for the reviewing
03:16:22 <hongbin> this is a big patch, just let me know if you find anything that is breaking
03:16:56 <hongbin> it requires to run devstack with kuryr-libnetwork enabled, if not, you will got an error message on creating containers
03:17:08 <Shunli> Thanks hongbin.
03:17:28 <kevinz> Thx hongbin
03:17:34 <hongbin> my pleasure
03:18:00 <hongbin> mkrai: i think you will continue the work on defining the network api?
03:18:24 <mkrai> hongbin: Sure
03:18:55 <hongbin> mkrai: ok, i don't think the network api is urgent, (the Boston summit is the priority)
03:18:56 <mkrai> I will design the APIs and then share with team
03:19:06 <hongbin> mkrai: just take your time about that
03:19:14 <mkrai> hongbin: Ok thanks
03:19:16 <hongbin> mkrai: ok, thanks
03:19:30 <kevinz> a small question, the container can connect internet after launch? Do we need some to do in neutron side?
03:20:18 <hongbin> if the cloud provide has setup the neutron net, you don't need to do anything
03:20:39 <hongbin> which is similar to vm
03:20:40 <kevinz> OK
03:20:56 <Shunli> do we need something like floating ip?
03:21:26 <hongbin> yes, if you want to connect from outside to container, you will need the floating ip
03:21:58 <Shunli> so bind floating ip to container is on the to do list
03:22:05 <hongbin> the way to do that is to find the neutron port of the container, and associate a floating ip to the neutron port
03:22:50 <hongbin> i think yes, we might need an api to automatically associate floating ip
03:23:07 <hongbin> all, thoughts on this?
03:23:07 <Shunli> ok, i see. thx
03:23:31 <hongbin> ok, i will track this idea by a bp
03:23:32 <mkrai> I think we should have this API in zun
03:23:42 <hongbin> mkrai: ack
03:23:58 <hongbin> #action hongbin create a bp for floating ip association to containers
03:24:30 <hongbin> any other questions about this topic?
03:24:39 <Shunli> no
03:25:04 <hongbin> ok, advance topic
03:25:06 <hongbin> #topic Introduce container composition
03:25:11 <hongbin> #link https://review.openstack.org/#/c/437759/
03:25:14 <hongbin> kevinz: ^^
03:25:28 <kevinz> Hi all
03:25:42 <kevinz> Thanks everyone for review this spec
03:26:05 <kevinz> And there are two question need to discuss
03:26:21 <kevinz> 1. since zun also gives container life-cycle management facility then will the user be able to manage their containers that are running inside a capsule ?
03:26:41 <kevinz> 2.
03:26:41 <kevinz> We dont have mechanism to label the hosts yet, do we need to give the control of host selection to user?
03:27:02 <kevinz> The questions are just picked from comments :-)
03:27:46 <hongbin> all, thoughts on these?
03:27:53 <Shunli> +1 for label the host
03:28:38 <Shunli> whether user can controller the host selection not sure.
03:28:45 <kevinz> nova support label the host. user can choose host when launch vm
03:29:07 <hongbin> kevinz: could you elaborate?
03:29:08 <Shunli> controller->controll
03:29:11 <mkrai> For 1, I think we shouldn't allow this because it might bring some inconsistency across zun. For example, we delete a container from a capsule or etc
03:29:55 <kevinz> I think " give the control of host" is give user the authority to choose the host which launch the container
03:30:29 <kevinz> For 1,  +1 with mkrai
03:30:48 <hongbin> ok, let's discuss #1 first
03:30:52 <mkrai> kevinz: as per my knowledge, Nova doesn't allow host selection directly. It is done through host-aggregate. Right?
03:31:23 <mkrai> Ok #1 first
03:31:26 <hongbin> i am not sure what it means by "manage their containers that are running inside a capsure"
03:31:32 <shubhams> mkrai: kevinz : for #1, That will mean that zun can support individual container lifecyle management but when the container is created through capsule api then it wont allow to handle container operations
03:31:53 <shubhams> mkrai: kevinz : Am I right here in my understanding ?
03:32:18 <mkrai> shubhams: Yes
03:32:27 <hongbin> there are several apis: create, delete, update, logs, restart, rename, ...
03:32:44 <pksingh_> for #1 i think create/delete container in capsule should not be done, but other operations should be possible
03:32:54 <hongbin> how these operations will behave for a in-capsule container and a bare container
03:33:02 <shubhams> mkrai: then its wont be listed in zun list as well  (I suppose)
03:33:32 <mkrai> I agree with pksingh_ here, the rest of the actions apply to capsule as well
03:34:01 <mkrai> shubhams: I suppose so, it shouldn't be listed
03:34:34 <hongbin> mkrai: if it is not listable, users won't be able to find the container to operate on it?
03:34:36 <pksingh_> after seeing the list, i think exec and logs should be possible on containers in capsule
03:34:42 <kevinz> Here I find nova support specify host https://docs.openstack.org/admin-guide/cli-nova-specify-host.html
03:34:51 <pksingh_> i think other operations would change the state of the container
03:35:16 <hongbin> i see, state change operations are not allowed
03:35:18 <kevinz> sorry for late responding , my boss call me just now...
03:35:34 <mkrai> hongbin: I am not sure whether we can allow to perform actions on individual container in capsule
03:35:44 <hongbin> kevinz: ok, i will handle this topic, take your time
03:35:50 <mkrai> hongbin: Right, it might bring inconsistency
03:36:39 <mkrai> pksingh_: We can restart, stop, pause etc a capsule also
03:36:43 <mkrai> Right?
03:37:41 <mkrai> hongbin: Are we going to have another set of APIs for capsule or just reuse the same as containers?
03:37:46 <pksingh_> mkrai: i am not sure, if i want to stop or restart, simply delete and create would be enough?
03:38:17 <hongbin> mkrai: i think kevinz proposed a /capsule endpoint, so it is another set of apis
03:38:36 <mkrai> hongbin: Ok
03:39:20 <mkrai> I think we should then allow only read only container APIs to capsule for single containers
03:39:57 <shubhams> My take for supported apis for individual apis : exec and logs .. also restart and stop upto some extent
03:40:13 <kevinz> hongbin: ok, thanks hongbin. I'm back now
03:40:17 <shubhams> mkrai: +1 for read only container
03:40:34 <pksingh_> k8s support only attach/exec/logs, https://kubernetes.io/docs/user-guide/kubectl-overview/
03:40:37 <mkrai> Or to completely segregate this two resources, we can have similar capsule-* APIs also. But this APIs might me redudant
03:41:06 <hongbin> yes, since attach/exec/logs only make senses on single contianer
03:41:42 <pksingh_> yes i think the same
03:41:45 <shubhams> yeah .. internally capsule api can perform other operations as required
03:43:22 <hongbin> i think we can do this: list all the operaitons in the etherpad, then iterate each one to see which one should be allowed for a in-capsule container, and which one is not
03:43:54 <shubhams> hongbin:  great idea
03:44:12 <hongbin> kevinz: i think you have an etherpad for capsule in before?
03:44:14 <mkrai> +1
03:44:25 <Shunli> +1
03:44:26 <kevinz> yes here
03:44:31 <kevinz> https://etherpad.openstack.org/p/zun-container-composition
03:44:45 <hongbin> ok, let't do it in the etherpad
03:44:50 <kevinz> I will move item to etherpad
03:45:15 <hongbin> ok, then move to #2
03:45:33 <hongbin> We dont have mechanism to label the hosts yet, do we need to give the control of host selection to user?
03:45:55 <kevinz> In the 138-151 is the capsule api
03:46:30 <hongbin> #link https://docs.openstack.org/admin-guide/cli-nova-specify-host.html
03:46:41 <kevinz> That is user can select host to launch container
03:46:42 <hongbin> in nova, only admin can use "forced_host" to select a host
03:47:38 <hongbin> normal usrs can choose availability zone, but not a specific host
03:47:41 <kevinz> Yeah, that right
03:47:55 <hongbin> however, that is for nova
03:48:06 <hongbin> what about us? thoughts?
03:48:51 <kevinz> Does this operation induce some issue? If not, I thinks it's OK to have the function
03:49:06 <mkrai> I don't have a very strong take on it, if we allow this should be admin only
03:49:38 <hongbin> #link https://specs.openstack.org/openstack/nova-specs/specs/pike/approved/resource-provider-traits.html
03:49:50 <Shunli> +1 for label host. But give the control of host selection to user-not sure.
03:50:10 <hongbin> the placement api has a proposal about traits, which is a similar idea as lables
03:50:47 <Shunli> I lean to think host selection of a in-capsule container is some policy controll on the capsule.
03:51:21 <hongbin> Shunli: yes, i agree
03:51:50 <hongbin> i also think host labels would be a good idea
03:52:04 <kevinz> +1
03:52:27 <hongbin> for who has privileage to select host, i am open for ideas
03:52:58 <shubhams> hongbin: kevinz : This host labelling is for associating a capsule to a host , not a container to a host .. right?
03:53:15 <hongbin> in addition, i am thinking how to aglin host labeling with the traits api above
03:53:23 <Shunli> hongbin: i guess like nova. only admin can select host.
03:53:31 <mkrai> Shunli: Right
03:53:40 <mkrai> shubhams: Right
03:53:42 <hongbin> shubhams: not sure right now
03:53:47 <Shunli> normal user can not see the host in the datacenter.
03:54:25 <hongbin> Shunli: yes
03:54:46 <hongbin> hide hosts from users is basically the model
03:55:15 <hongbin> ok, we are running close to the end
03:55:27 <hongbin> let me record the discussion as bp
03:55:44 <hongbin> #action hongbin create a bp to track the idea of labeling hosts
03:55:55 <hongbin> #topic Open Discussion
03:56:16 <hongbin> Namrata: want to give the team a update about your heat work?
03:56:44 <Namrata> i am working on https://review.openstack.org/#/c/437810/
03:57:10 <Namrata> will update the patch today. working on inlien comments
03:57:18 <mkrai> I will work with Namrata on this as we might need it for summit
03:57:32 <hongbin> Namrata: great work Namrata
03:57:45 <Namrata> Hongbin mkrai:Thanks for the help
03:57:50 <hongbin> mkrai: thx
03:58:19 <hongbin> Namrata: np, do you have ideas how to address the comments?
03:58:41 <hongbin> Namrata: for example, is any comment that needs a clarification for you?
03:59:24 <Namrata> No i am okay with the explaination
03:59:26 <hongbin> Namrata: ok, ping me or others offline if you need helps to address those comments
03:59:32 <hongbin> Namrata: ack
03:59:34 <Namrata> thanks hongbin
03:59:41 <hongbin> Namrata: welcome
03:59:48 <hongbin> ok, all, thanks for joining the meeting
03:59:56 <hongbin> see you next time
04:00:00 <hongbin> #endmeeting