03:00:02 <mkrai> #startmeeting zun
03:00:03 <openstack> Meeting started Tue Jul 12 03:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is mkrai. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:06 <openstack> The meeting name has been set to 'zun'
03:00:10 <mkrai> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2016-07-12_0300_UTC Today's agenda
03:00:17 <mkrai> #topic Roll Call
03:00:26 <Wenzhi> Wenzhi Yu
03:00:27 <sudipto> o/
03:00:27 <yanyanhu> hello
03:00:32 <shubhams> shubham o/
03:00:36 <eliqiao> o/
03:01:02 <mkrai> Thanks Wenzhi  sudipto yanyanhu shubhams eliqiao for joining today
03:01:19 <mkrai> Let's wait for a minute for others to join
03:02:08 <mkrai> #topic Announcements
03:02:11 <Namrata_> O/
03:02:19 <mkrai> hongbin is on travel this week so I will chair this meeting.
03:02:35 <mkrai> Hey Namrata_
03:02:44 <mkrai> Any other announcement from team?
03:02:52 <yanyanhu> he is gonna join openstack day china I think :)
03:03:10 <mkrai> Yes I think he already have done it
03:03:16 <yanyanhu> yea
03:03:18 <flwang1> o/
03:03:25 <mkrai> Hey flwang1
03:03:31 <eliqiao> mkrai: not yet, it's the day after tomorrow.
03:03:32 <vivek___> o/
03:03:33 <flwang1> mkrai: hey there
03:03:38 <mkrai> Oh I see
03:03:43 <mkrai> Hi vivek___
03:03:57 <mkrai> #topic Review Action Items
03:04:07 <mkrai> hongbin create an etherpad for the COE API design (TBD)
03:04:18 <mkrai> This task is still to be done
03:04:31 <mkrai> We will discuss the status in next meeting
03:04:40 <mkrai> Anyone has something to add on this?
03:05:20 <mkrai> Ok let's advance topic
03:05:26 <mkrai> #topic Runtimes API design
03:05:33 <mkrai> #link https://blueprints.launchpad.net/zun/+spec/api-design The BP
03:05:41 <mkrai> #link https://etherpad.openstack.org/p/zun-containers-service-api Etherpad
03:06:04 <mkrai> Ok so I have written down all the basic APIs for containers
03:06:15 <mkrai> And also some advanced and miscellaneous
03:06:26 <mkrai> I will wait for few minutes for everyone to read
03:07:03 <mkrai> #link https://etherpad.openstack.org/p/zun-containers-service-api-spec
03:07:17 <mkrai> Please see above link
03:08:07 <mkrai> Please feel free to add or update any APIs
03:08:19 <mkrai> I plan to submit spec this week
03:08:36 <yanyanhu> quick question, for basic operations like CUDR, will COEs and runtime based implementation share the same API interface?
03:09:00 <mkrai> yanyanhu, As of now, no
03:09:21 <yanyanhu> I see
03:09:21 <mkrai> It is quite not possible to club both APIs
03:09:32 <yanyanhu> yes, feel so as well
03:09:48 <mkrai> We will create APIs for COEs this week or so
03:10:47 <mkrai> Ok I will leave etherpad offline, please add your ideas
03:11:23 <mkrai> Shall we advance or someone has to add anything?
03:11:56 <yanyanhu> will add comment offline
03:12:04 <mkrai> Ok thanks yanyanhu
03:12:20 <mkrai> #topic Nova integration
03:12:30 <mkrai> #link https://blueprints.launchpad.net/zun/+spec/nova-integration The BP
03:12:39 <mkrai> Is aditi here today?
03:13:05 <yanyanhu> guess not
03:13:11 <mkrai> Ok I think she has not attended quite few meetings
03:13:34 <mkrai> And as I feel this bp is important for us, so please feel free to take up this one
03:13:47 <mkrai> Anyone interested here to work on this?
03:14:00 <Namrata> Yes I am
03:14:09 <mkrai> Thanks Namrata
03:14:25 <mkrai> Please connect with aditi
03:14:29 <yanyanhu> And I guess we may need a spec or etherpad for this topic as well
03:14:38 <Namrata> Okay
03:14:40 <yanyanhu> for discussion and tracking
03:14:43 <mkrai> Agree yanyanhu
03:14:47 <Wenzhi> +1
03:15:05 <mkrai> Yes it will be bit complex as compared to ironic driver
03:15:30 <mkrai> #action mkrai to create an etherpad for nova-integration
03:15:33 <yanyanhu> yes, not that straightfoward I think
03:16:22 <sudipto> If i may - what does the nova-integration actually mean? Creating a compute driver for zun?
03:16:38 <mkrai> sudipto, yes
03:16:45 <Namrata> Yes
03:17:09 <sudipto> and ... how does it have similarity to ironic? In terms of a 2 layered scheduler?
03:17:50 <mkrai> sudipto, yes that's what I am trying to highlight that it would be complex as Zun will also have its own scheduler
03:17:50 <sudipto> also, how is it going to be different from the nova-docker driver?
03:18:18 <mkrai> nova-docker driver has very limited functionality I guess
03:18:25 <mkrai> And not even maintained well
03:18:36 <sudipto> but has an overlap to this...you probably know why it had issues...
03:18:57 <sudipto> that is w.r.t not integrating well with nova.
03:19:31 <mkrai> I agree to it to some extent as containers and vms are not same
03:19:51 <sudipto> yeah and i think the same debate is going to come up again with this?
03:20:11 <mkrai> But here we just aim to provide same set of nova APIs for containers
03:20:20 <mkrai> Yes certainly
03:20:40 <mkrai> Nova is good point to sell Zun IMO
03:20:50 <sudipto> Nova providing same set of APIs for containers was the problem with the nova-docker driver AFAIK.
03:21:14 <Wenzhi> I agree, limited by nova data model, I think nova-zun driver will also be difficult to design
03:21:28 <mkrai> sudipto, ack
03:22:40 <mkrai> It is quite difficult to take out common APIs between VMs and containers, but still we have few that satifies both
03:23:16 <sudipto> I tend to think that the Nova workflow could actually cater to something like an isolated/secure container workflow, that has overlaps with a VM lifecycle.
03:23:32 <mkrai> And IMO it's worth spending some effort to consider this
03:24:27 <mkrai> sudipto, Sorry I don't get it. Could you please explain?
03:25:43 <sudipto> mkrai, going with a container API that fits the VM APIs is fundamentally wrong and it would lead to the same fate as nova-dockers at least that's what i feel. However, if you imagine something like a container in a VM workflow - that probably fits the APIs of a Virtual Machine.
03:26:43 <sudipto> however with that said - we are free to try and still do whatever we think is the best :)
03:26:59 <mkrai> sudipto, What I understand here is the host where we are running our containers. Right?
03:27:18 <sudipto> mkrai, didn't understand your last statement?
03:27:59 <mkrai> Ok the point you stated is one where we are running containers inside vm or not inside vm
03:28:47 <sudipto> we have stated that we want to support hyper like workflows into openstack - i meant that use case could fit into a nova integration per say - but in general running containers with Nova APIs - sounds similar to nova-docker.
03:29:01 <sudipto> I would like to hear everyone's thought around it as well, who knows - i might be short sighted here :)
03:29:42 <mkrai> yes I agree that is similar to nova-docker but with more features
03:29:58 <mkrai> More container runtime tools and also COEs
03:30:06 <mkrai> Yes I want to ask team here
03:30:06 <shubhams> You are right sudipto , but anyway from an instance's perspective (baremetal/vm/container) , we need to use nova only, right?
03:30:21 <mkrai> Do they feel this work is worth spending some effort?
03:30:49 <sudipto> shubhams, you mean provision the instance via nova and then have containers run inside them via zun?
03:31:20 <shubhams> nope, I mean everything ( a vm/bm or container ) should be provisioned by nova
03:31:28 <mkrai> shubhams, Yes we aim to do so
03:31:39 <mkrai> But it is not hard and fast
03:31:44 <sudipto> shubhams, why?
03:31:57 <sudipto> are you referring to the host management being done by nova?
03:32:08 <shubhams> Yes sudipto
03:32:16 <mkrai> Ok let's take this discussion in Open discussion
03:32:23 <sudipto> alrite.
03:32:31 <shubhams> are we bound to use nova for all this ?
03:32:31 <mkrai> Thanks
03:32:44 <mkrai> #topic Re-consider RabbitMQ. How about using key/value store (i.e. etcd) for passing messages
03:33:00 <mkrai> In our last meeting, we discussed about managing state of containers in Zun
03:33:12 <mkrai> We talked about etcd which is distributed key-value store
03:33:24 <mkrai> However we also discussed few more options like rabbitmq and taskflow.
03:33:36 <mkrai> I want to know team's opinion on it.
03:33:48 <mkrai> I gues yuanying is not present today
03:33:57 <mkrai> s/gues/guess/
03:34:00 <Wenzhi> for passing messages, I prefer rabbitmq
03:34:06 <sudipto> I think we need a PoC for etcd
03:34:12 <mkrai> +1 sudipto
03:34:21 <Wenzhi> I think etcd is not designed for this(message exchange)
03:34:24 <mkrai> I strongly feel so
03:34:48 <mkrai> Yes it is meant to store distributed data
03:34:54 <Wenzhi> yes
03:35:11 <mkrai> Anyone is interested in doing this work?
03:36:22 <shubhams> ok .. I will take this up
03:36:33 <shubhams> althouugh its new for me .. but will see how to do that
03:36:33 <mkrai> Thanks shubhams
03:36:40 <mkrai> Appreciate it
03:36:56 <mkrai> I feel a bp is also needed for it
03:37:18 <mkrai> #action shubhams to create a bp for managing state of containers
03:37:28 <itzdilip> <mkrai> <shubhams> i like to join too in that
03:37:39 <mkrai> Thanks itzdilip
03:37:50 <mkrai> You can work together with shubhams
03:38:05 <mkrai> Please feel free to ping me or hongbin anytime on this
03:38:06 <shubhams> thanks itzdilip
03:38:37 <mkrai> Do anyone has something to add?
03:38:43 <itzdilip> <shubhams> <mkrai> sure I will
03:39:17 <mkrai> Also yuanying is good point of contact for same
03:39:53 <shubhams> mkrai, ok we will connect with yuanying
03:40:02 <mkrai> Thanks shubhams
03:40:16 <mkrai> Shall we advance topic?
03:40:26 <shubhams> yep
03:40:30 <mkrai> #topic Open Discussion
03:41:17 <mkrai> sudipto, We can continue the discussion
03:41:51 <sudipto> mkrai, well i guess i was trying to understand shubhams point on 'why nova is needed'
03:42:11 <mkrai> shubhams, Would you like to answer?
03:42:27 <shubhams> My point on nova integration was : Before going ahead , we should first note it down (may be on etherpad) that do we really want to work around "Nova" or we want a separate solution .
03:43:20 <shubhams> s/work around/work around with nova
03:43:22 <mkrai> shubhams, Separate solution for us is Zun itseld
03:43:42 <sudipto> Zun should be designed as independently as possible IMHO
03:43:59 <mkrai> Yes sudipto that we all agree
03:44:28 <sudipto> ok - i don't mean to derail the approach...please go ahead if you think it's needed :)
03:44:34 <sudipto> and it's something that can eventually fly.
03:44:44 <sudipto> I am sure there are probably strong reasons behind doing it.
03:44:47 <mkrai> This bp just aims to provision containers from nova as we provision baremetal
03:45:22 <mkrai> And that shouldn't impact Zun design at all
03:45:41 <sudipto> baremetal provisioning forms a pre-requisite to VM provisioning, i am not sure that's the case here.
03:46:25 <sudipto> if you ask me, i feel baremetal could be made as a pre-req for container provisioning - but that means an ironic integration to zun
03:47:08 <mkrai> That is the host where we run our container i.e host management
03:47:21 <mkrai> And we are not targeting host management in this bp
03:47:44 <mkrai> Exactly the same way nova-docker does
03:48:03 <shubhams> Yep .. so let host management be the responsibility of nova and container management is left for Zun , right?
03:48:39 <mkrai> shubhams, agree with later part
03:48:53 <mkrai> But host management is itself a huge topic in itself
03:49:03 <sudipto> think of it like this - if host management is done by nova or something else - why make zun worry about it?
03:49:21 <shubhams> Sudipto, agree
03:49:50 <mkrai> Host management can be independent of Zun. Operators can manage host or we might in future want to manage it ourself
03:50:46 <mkrai> It can be either we already have pool of host or we provision one at runtime
03:51:03 <mkrai> There are many options that we can think of
03:52:08 <mkrai> Team I want to record an action, whether we want to spend effort on this task?
03:52:13 <shubhams> I may be wrong but my whole point is : if we are creating something relevent to what already exists (ex: nova-docker) then we should we have clear boundaries and reasons that why we need the solution that we want to create.
03:52:31 <mkrai> +1 shubhams
03:52:35 <shubhams> and so far I am not sure why we need this
03:53:29 <mkrai> #action madhuri Add points why we want to integrate with nova on BP whiteboard
03:53:48 <mkrai> Team feel free to add any points that you have in mind
03:53:58 <shubhams> Yes sure
03:54:02 <mkrai> #link https://blueprints.launchpad.net/zun/+spec/nova-integration
03:55:01 <mkrai> Any more discussion do you want to have?
03:55:18 <mkrai> If not, I will end meeting early
03:55:36 <shubhams> seems ok to me
03:55:47 <mkrai> Thanks everyone for joining
03:55:58 <Wenzhi> thanks all
03:55:59 <Namrata_> Thanks
03:56:02 <mkrai> #endmeeting