15:02:07 <flwang1> #startmeeting Zaqar
15:02:08 <openstack> Meeting started Mon Oct  5 15:02:07 2015 UTC and is due to finish in 60 minutes.  The chair is flwang1. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:11 <openstack> The meeting name has been set to 'zaqar'
15:02:36 <ryansb> hello folks
15:02:40 <flaper87> o/
15:02:42 <flwang1> o/
15:03:08 <flwang1> #topic roll call
15:03:25 <flwang1> vkmc: ?
15:03:45 <vkmc> o/
15:03:46 <vkmc> HERE
15:03:49 <flwang1> #topic agenda
15:04:07 <flwang1> #link https://wiki.openstack.org/wiki/Meetings/Zaqar#Agenda
15:04:22 <flwang1> Pending important reviews
15:04:31 <flwang1> Tokyo summit sessions
15:05:03 <flwang1> those are the main topics today from me
15:05:16 <vkmc> sweeeet
15:05:24 * flaper87 thinks we should give some love to client reviews
15:05:31 * flaper87 has been bad with reviews lately
15:05:38 <flwang1> flaper87: i can't agree more
15:05:58 <flwang1> flaper87: i'm blaming myself as well
15:06:17 <flwang1> i should put client review on my first priority
15:06:44 <flaper87> lets do it!
15:07:07 <flwang1> sure thing
15:07:09 <flwang1> #link https://review.openstack.org/#/c/206080/  websocket notification
15:07:25 <flwang1> i have tested it manually on my local
15:07:35 <flwang1> and it works great
15:08:31 <flwang1> i'm going to +2 it after another round test since there is a new patch set to support given subscriber
15:08:44 <flaper87> ++
15:08:53 <flaper87> I'll take a better look at the latest patchset
15:09:07 <therve`> Hooray
15:09:18 <flwang1> therve`: hey
15:09:41 <flwang1> we're talking about your notification websocket patch
15:10:25 <flwang1> i saw there is a new patch set, seems it's adding the support for a given subscriber
15:10:42 <therve> Yep, I snicked that in :)
15:11:33 <flwang1> therve: that's awesome
15:12:21 <flwang1> guys, any other important review we should discuss?
15:13:05 <ryansb> yeah, there's https://review.openstack.org/230053
15:13:08 <jasondotstar> o/
15:13:15 <jasondotstar> sorry I'm tardy for the party
15:13:17 <ryansb> which fixes a stacktrace in logging decorator
15:13:44 <ryansb> (not a large review at all
15:13:46 <ryansb> )
15:14:23 <vkmc> jasondotstar, do you have an update for the puppet modules you want us to review?
15:14:27 <flwang1> clicking...
15:14:40 <flwang1> vkmc: that's my question :)
15:14:49 <vkmc> :D
15:14:59 <jasondotstar> yes....
15:15:20 <jasondotstar> so the latest involves working on the adding the debian install side
15:15:25 <flwang1> ryansb: i have +2 for that one https://review.openstack.org/230053   vkmc, flaper87 pls bless it
15:15:46 <vkmc> flwang1, sure, thankx
15:15:53 <jasondotstar> so far, the RPM installation works fairly well using CentOS
15:16:19 <jasondotstar> there are still a few more parameters to expose to the .conf file
15:16:35 <jasondotstar> and we need to begin writing tests as well
15:16:55 <jasondotstar> but things are moving along at a decent clip, I'd say.
15:17:00 <jasondotstar> questions for me?
15:17:25 <flwang1> jasondotstar: so generally, it's on track, right? :)
15:17:44 <jasondotstar> flwang1: yes, in a nutshell. :-)
15:18:05 <flwang1> jasondotstar: are you using pooling as default in the conf?
15:18:51 <flwang1> jasondotstar: i'm trying to figure out what's the reference conf for puppet deployment
15:19:10 <flwang1> flaper87: any comments?
15:19:54 <jasondotstar> flwang1: no, not using pooling by default
15:20:13 <flaper87> mmh, I think we should just go with pooling by default
15:20:24 <flaper87> at some point, I'd love to see that config option go away
15:20:27 <flaper87> and just use pooling
15:20:40 <jasondotstar> unreliable is true by default (that's probably unrelated, still...)
15:20:43 <flaper87> That's what we recommend as a deployment and it should probably be the default
15:20:55 <flaper87> jasondotstar: erm, mmh. I thought flwang1 changed that
15:20:56 <jasondotstar> flaper87: duly noted. I can add it
15:21:00 <flaper87> there was a patch for it
15:21:08 <flaper87> I mean, unreliable must be False now
15:21:13 <jasondotstar> flaper87: oh ok....
15:21:15 <flwang1> flaper87: yes
15:21:15 <flaper87> the deprecation path was respected
15:21:39 * jasondotstar will have to take a look at setting unreliable = false
15:22:10 <ryansb> that needs to be in the DEFAULT section, btw
15:22:28 <flwang1> my point is the default conf puppet is most like a referenced conf from the deployer's view
15:22:46 <jasondotstar> it is in the default section, but it set to true and not false
15:23:13 <flwang1> jasondotstar: i will revisit that to make sure
15:23:30 <jasondotstar> flwang1: ack.
15:24:18 <flwang1> #action flwang will check the unreliable conf to make sure False is the default value for puppet
15:24:45 <flwang1> jasondotstar: thanks for the updates,
15:25:00 <jasondotstar> flwang1: np.
15:25:14 <flwang1> anything else? should we move to next topic summit session?
15:25:34 <flwang1> we only have 3 weeks
15:25:41 <ryansb> I think that's it for reviews, so yeah onto summit
15:25:58 <flwang1> #topic summit sessions
15:26:17 <flwang1> #link https://etherpad.openstack.org/p/Mitaka-Zaqar
15:27:01 <flwang1> we have 1 fishbowl and 3 workrooms
15:27:48 <flwang1> we have 2 proposed sessions, both of them targeted for fishbowl
15:27:55 <flaper87> I think we should use 1 workroom session for Sahara
15:28:18 <flaper87> flwang1: what are those sessions?
15:28:19 <flwang1> flaper87: are u happy to host it? :)
15:28:23 * flaper87 can't find the link
15:28:26 <flaper87> flwang1: sure thing
15:28:30 <flaper87> I'm planning to
15:28:32 <vkmc> yeah, sahara and horizon if we are lucky
15:28:34 <vkmc> :D
15:28:37 <flwang1> flaper87: client  and horizon integration
15:29:01 <flwang1> Session: Client & Command Line Interface
15:29:10 <flwang1> Session: Realtime update for Horizon tables
15:29:27 <flwang1> i'm supporting vkmc on the horizon one
15:29:39 <flaper87> yeah, I'd go with horizon
15:29:49 <flaper87> it sounds like the client could use a workroom, TBH
15:30:00 <flaper87> We should make sure we have folks from Horizon in that session
15:30:16 <flwang1> flaper87: we have contacted them and got YES
15:30:37 <flwang1> vkmc: would you mind confirming with mrunge?
15:30:47 <vkmc> flwang1, sure thing
15:30:48 <mrunge> what?
15:31:01 <mrunge> confirm what?
15:31:16 <vkmc> mrunge, Zaqar + Horizon design session
15:31:19 <vkmc> hi mrunge!
15:31:22 <flwang1> mrunge: hah, join the session about horizon zaqar integration
15:31:31 <mrunge> hey o/
15:31:40 <mrunge> yes, I'm interested in that!
15:31:58 <vkmc> mrunge, if Horizon team could discuss about this topic, we would really like to have a working session with you guys
15:32:01 <vkmc> we are defining our slots
15:32:02 <vkmc> :)
15:32:15 <flwang1> flaper87: should we make the horizon session as workroom as well?
15:32:27 <flaper87> that'd work, yes!
15:32:33 <vkmc> workroom sounds good to me
15:32:34 <flwang1> flaper87: cool
15:32:48 <flaper87> fishbowl is great when we need to have a bigger crowd there
15:33:19 <mrunge> horizoners have a single fishbowl, as we found workrooms way more productive
15:33:30 <flaper87> mrunge: yeah, same does Zaqar
15:34:04 <mrunge> for reference, I added zaquar and async to https://etherpad.openstack.org/p/horizon-mitaka-summit
15:34:23 <flwang1> flaper87: so for now, we have 1 session for client, 1 for horizon, 1 for sahara, all of them are workrooms
15:34:34 <mrunge> but did not request a real cross project session
15:34:47 <mrunge> (they were intended for > 2 projects)
15:34:49 <flwang1> mrunge: thanks
15:35:14 <mrunge> I have to thank *you* folks!
15:37:05 <vkmc> :D
15:37:28 <flwang1> vkmc and i are going to get some comments from your guys as for the horizon demo, but we can discuss that offline, in zaqar channel
15:37:54 <flwang1> so do we have any topic for the fishbowl?
15:38:16 <flaper87> mmh, not yet!
15:38:23 <flaper87> we could throw a gummy-party
15:38:41 <flwang1> flaper87: lol, that's an option :)
15:39:05 <vkmc> can we have all working sessions?
15:39:15 <flaper87> if we don't have a topic for it, I'd rather just give it away than coming up with a random thing to talk about that could perfectly be discussed in a hallway-track
15:39:19 <vkmc> I always find them more productive
15:40:06 <flwang1> works for me
15:41:44 <flwang1> anything else for the summit session?
15:42:11 <vkmc> let's add the sessions in the etherpad
15:42:20 <vkmc> https://etherpad.openstack.org/p/Mitaka-Zaqar
15:43:56 <flwang1> vkmc: thanks for the remind, flaper87 will add the sahara session and i'm going to polish the format :)
15:44:43 <flwang1> #action flaper87 will host the sahara session
15:44:51 <vkmc> flaper87, I'm adding dynarro for the Client/CLI, let her know
15:44:53 <vkmc> :D
15:45:11 <flwang1> vkmc: awesome, thanks
15:46:03 <flwang1> anything else?
15:46:09 <flaper87> vkmc: I will
15:46:11 <flaper87> hahaha
15:46:40 <vkmc> flwang1, nothing else from my side
15:47:01 <flwang1> #topic open discussion
15:47:31 * flaper87 hadn't had this much sushi before in his life
15:47:41 <vkmc> flaper87, is it better than sushi elsewhere?
15:47:46 <flwang1> flaper87: r u kidding?
15:47:58 <flaper87> it actually is
15:48:06 <flwang1> sushi is always on my lunch list
15:48:13 <flaper87> flwang1: LOL
15:48:18 <vkmc> yummy
15:48:34 <flwang1> i would suggest a team lunch in summit
15:48:42 <flwang1> given we have some new members
15:48:43 <flaper87> that'd be great
15:48:50 <flaper87> nice nice nice nice nice!
15:49:05 <vkmc> now I want sushi
15:49:14 <vkmc> can we have a sushi lunch in the summit?
15:49:15 <vkmc> :D
15:49:19 <vkmc> haha
15:49:35 <flwang1> if the summit food is not OK, then we will go for sushi to make flaper87 happy
15:49:37 <flaper87> suuuuuuuuuuuuuuuuuuuuure
15:49:43 <vkmc> yeaaaaaah
15:49:55 <flwang1> and make vkmc happy either
15:50:37 <flwang1> should we still use wechat as the team communication tool?
15:50:51 <flaper87> it worked well last time, I think we can use it
15:50:56 <flaper87> and the group is still there
15:51:23 <vkmc> yeaaah
15:51:25 <flaper87> gotta go folks, thanks for the meeting and talk to you soon!
15:51:29 * vkmc is excited
15:51:34 <vkmc> bye flaper87
15:51:41 <vkmc> take care, eat tons of sushi for me
15:52:26 <flwang1> flaper87: ttyl
15:52:55 <flwang1> ok, anything else? otherwise we will be back to zaqar channel :)
15:53:10 <ryansb> not from me
15:53:39 <flwang1> #endmeeting