15:01:49 <flaper87> #startmeeting Zaqar
15:01:50 <openstack> Meeting started Mon Aug 24 15:01:49 2015 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:54 <openstack> The meeting name has been set to 'zaqar'
15:02:03 <flaper87> #topic Roll Call
15:02:09 <therve> o/
15:02:10 <ryansb> \o
15:02:12 <flaper87> I think we have "CHORUS" ;)
15:02:23 <flaper87> o/
15:02:30 <flaper87> vkmc flwang focus
15:02:35 <vkmc> o/
15:02:47 <flaper87> #topic Agenda
15:02:49 <flaper87> #link https://wiki.openstack.org/wiki/Meetings/Zaqar#Agenda
15:02:59 <jasondotstar> o/
15:03:17 <flaper87> that's our agenda for today. IT's not fixed, keep your topics handy and prepare to add them at runtime
15:03:20 <flaper87> jasondotstar: hey there :D
15:03:34 <jasondotstar> Hey
15:03:41 <flaper87> #topic Review Items from last week
15:03:42 <jasondotstar> need to put this meeting on my cal
15:03:45 <flaper87> #link http://eavesdrop.openstack.org/meetings/zaqar/2015/zaqar.2015-08-17-21.01.html
15:03:55 <flaper87> jasondotstar: I'll add you to the list of courtesy pings
15:04:01 <flaper87> vkmc sync with folks from horizon
15:04:01 <jasondotstar> gr8 thx
15:04:05 <flaper87> vkmc: ?
15:04:15 <ryansb> jasondotstar: you can get all the meetings from http://eavesdrop.openstack.org/
15:04:21 <ryansb> there's a nice iCal you can import
15:04:27 <jasondotstar> cool.
15:04:36 * ryansb gets back on topic
15:04:46 <flaper87> vkmc: 1
15:04:48 <flaper87> vkmc: 2
15:04:56 <flaper87> vkmc: 3
15:05:09 <flaper87> moving on
15:05:11 <flaper87> flwang1 to sync with folks from swift about a possible joint session for zaqar+swift (swift notification middleware)
15:05:13 <flaper87> flwang: ^
15:05:20 <flaper87> flwang: dude, you should really use 1 nick
15:05:21 <flaper87> :P
15:05:23 <flaper87> it's confusing
15:05:34 <flaper87> I can't figure out which one is your evil side
15:05:40 <flaper87> flwang: 1
15:05:40 <flwang> flaper87: i have two computes :D
15:05:42 <vkmc> sorry, all the lag
15:05:55 <flaper87> vkmc: no worries, lets wait for flwang to provide feedback
15:06:05 <flaper87> flwang: ZNC is the answer to all your problems
15:06:07 <flwang> i was trying to catch the guy, but not response
15:06:07 <flaper87> anyway
15:06:11 <flaper87> flwang: news on that?
15:06:12 <flaper87> ok
15:06:14 <flwang> i will send a mail to thim
15:06:41 <flaper87> #action flwang to chase down notmyname and the person behind zaqar+swift middleware
15:07:00 <flaper87> vkmc sync with folks from horizon about a possible joint session for zaqar+horizon ?
15:07:23 <flwang> the patch has been not activity more than 1 month, so i think he is busy
15:07:35 <flaper87> flwang: likely, and not high-prio
15:07:49 <flaper87> but lets keep up with it and help moving it forward
15:08:00 <flwang> flaper87: sure
15:08:04 * flaper87 waits for vkmc to get back from lag-land
15:08:07 <vkmc> couldn't do that this week, I couldn't find the etherpad we had with the Horizon use case
15:08:23 <flaper87> vkmc: ok, think you'll have time this week ?
15:08:32 <vkmc> flaper87, yeah, sorry about that
15:08:35 <flaper87> hard to tell but I'll action you
15:08:44 <flaper87> #action vkmc to sync with folks from horizon about a possible joint session for zaqar+horizon ?
15:08:48 <flaper87> #undo
15:08:49 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa7d4950>
15:08:52 <flaper87> #action vkmc to sync with folks from horizon about a possible joint session for zaqar+horizon
15:08:59 <flaper87> flaper87 to sync with folks from Sahara about their guest-agent use-case
15:09:07 <ryansb> lol. python default __repr__
15:09:23 <flaper87> I talked to SergeyLukjanov and he mentioned he was going to bring the topic up during last week's Sahara meeting
15:09:31 <flaper87> I've to check if that happened or not
15:09:41 <flaper87> I also promissed docs on signed url and I need to complete that
15:09:51 <flaper87> #action flaper87 to write docs for pre-signed urls
15:10:07 <therve> flaper87, Before you do that maybe https://review.openstack.org/215638 is worth a look
15:10:26 <flaper87> therve: awesome, thanks :D
15:10:50 <flaper87> #topic Pending important reviews
15:10:51 <therve> Not that I want to derail doc writing :)
15:11:03 <flaper87> therve: not at all, I'll take a look at that first
15:11:13 <flaper87> #link https://review.openstack.org/#/c/215638/
15:11:19 <ryansb> I'll add that to my review list
15:11:24 <ryansb> flaper87: speaking of reviews, when do I get the magic +2 power?
15:11:45 <flaper87> ryansb: right after the meeting when I was supposed to welcome you during the open discussion
15:11:50 <flaper87> but since you SPOILED it
15:11:55 <flaper87> I guess I could do it now
15:11:56 <flaper87> :P
15:12:08 * ryansb didn't see that as a topic
15:12:09 <jasondotstar> hey the initial puppet review is still pending
15:12:14 <flaper87> jokes apart, lemme finish this and I'll add you to the magic group
15:12:25 <flwang> flaper87: i just have a chat with cschwede the author of the notification middleware author
15:12:26 <flaper87> #link https://review.openstack.org/#/c/213744/ (ws auth)
15:12:33 <flaper87> that patch from last week is still pending
15:12:36 <flwang> who will submit a new patchset this week
15:12:38 <flaper87> anyone care looking at it?
15:12:41 <flwang> just FYI
15:12:47 <flaper87> flwang: AWESOME
15:12:51 <jasondotstar> https://review.openstack.org/#/c/204225/
15:12:56 <ryansb> #link https://review.openstack.org/#/c/204225/ (puppet review)
15:13:03 <jasondotstar> I've looked at it
15:13:21 * ryansb adds ws auth to queue
15:13:27 <flaper87> #link https://review.openstack.org/#/c/202374/ (email notification)
15:13:31 <flaper87> flwang: you need to update that one
15:13:34 <jasondotstar> it's got a couple unit test fails, but I'm thinking it might be b/c the class defs are empty
15:13:55 <jasondotstar> basically looks to import the puppet template code
15:14:13 <flaper87> #link https://review.openstack.org/#/c/212828/ (move get|inc_counter methods)
15:14:16 <flaper87> I'll update that one
15:14:20 <flwang> jasondotstar: you can you give it a hand, it would be awesome
15:14:22 <therve> jasondotstar, That's a lot of random crap
15:14:48 <jasondotstar> flwang: a hand with?
15:14:55 <flaper87> #link https://review.openstack.org/#/c/195010/ (ws claims)
15:14:57 <jasondotstar> therve: the puppet template stuff is crap, you mean?
15:14:59 <flwang> we are waiting it for adopting zaqar in our prod
15:15:12 <flwang> jasondotstar: https://review.openstack.org/#/c/204225/
15:15:15 <therve> jasondotstar, I guess I should verbose and possibly duplicated?
15:15:16 <flaper87> #link https://review.openstack.org/#/c/199824/ (make unreliable False by default)
15:15:25 * therve shut up he doesn't know anything about puppet
15:15:29 <flaper87> we basically didn't land any of the patches from last week
15:15:43 <flwang> flaper87: https://review.openstack.org/#/c/199824/ failed to build the doc
15:15:49 <flaper87> we gotta keep up with reviews, especially now that we're just a couple of weeks away from the freeze
15:15:57 <flaper87> flwang: will look at it
15:16:14 <flwang> since the reliable = false will always throw a runtime error
15:16:27 <flwang> though it works fine on my local, i haven't figured it out
15:16:28 <flaper87> jasondotstar: I'll look at the puppet one and see if I spot something
15:16:38 <jasondotstar> ack.
15:16:50 <flaper87> flwang: pls, make sure to upate both your patches so we can move them forward
15:16:58 <flwang> flaper87: if you can push the puppet one, it would be awesome
15:17:04 <flwang> you know, we really really need it
15:17:08 <flaper87> flwang: yup
15:17:20 <flaper87> ok, moving on (unless someone has other patches)
15:17:29 <flaper87> I think the ones linked are enough for a week :D
15:17:37 <flaper87> but pls, don't stop yourself from doing more
15:17:38 <flwang> flaper87: i will, my son is sick, so i can't work at daytime, that's why you can see my now
15:18:11 <flaper87> flwang: no worries, I'm happy to help if you need support on a patch
15:18:17 <flaper87> I can help with quick amends/fixes
15:18:25 <flaper87> (any of us can, actually)
15:18:42 <flwang> thank you, i will raise my hand :)
15:18:53 <flaper87> #topic OpenStack Summit Revisited (Tokyo)
15:19:08 <flaper87> Last week I mentioned that we should start thinking about Tokyo
15:19:27 <flaper87> I'd like to stress this topic a bit more and add to what I said last week that we won't have many fishbowl session
15:19:30 <flaper87> sessions*
15:19:39 <flaper87> well, no one will have as many as in previous summits
15:19:50 <flwang> due to big tent?
15:19:58 <flaper87> So, we gotta be prepared to have 2 fishbowl (or just one) and several workrooms
15:20:13 <flaper87> flwang: no, just sapce and time. So yeah, big tent
15:20:21 <flaper87> jokes apart, it's more related to space and time
15:20:36 <flaper87> I don't have the details but the hope is Austin won't have this problem
15:20:41 <flaper87> anyway, back on topic
15:21:02 <flaper87> pls, think of sessions in the form of workrooms where we can fit fewer brains but get more things done
15:21:20 <flaper87> no offense to the masses
15:21:22 <flaper87> :P
15:21:38 <flaper87> ok, that's all I have
15:21:48 <flaper87> #topic Pre-Open Discussion
15:21:58 <flaper87> does anyone have any other topic to discuss?
15:22:07 <flaper87> Otherwise, we can move to Open Discussion
15:22:09 <therve> Won't be in Tokyo, so please do'nt hesitate to have discussions outside of the summit :)
15:22:40 <flaper87> therve: very good point, I'll make sure all discussions are properly logged and that a good summary is sent out
15:22:47 <flaper87> therve: sad to not have you there :(
15:23:22 <ryansb> in general, remote-friendly summit activity is a great thing
15:23:27 <flwang> flaper87: re the submit session, i think we can propose a integration status update and a feature updates, like websocket and notification
15:23:32 <ryansb> so keep doing public etherpads and such
15:23:51 <flaper87> flwang: I'd love one of those sessions to be cross-project
15:23:54 <flaper87> but we'll see
15:23:58 <flaper87> I have 2 topics
15:24:00 <vkmc> IMO we can make it work for the work sessions
15:24:06 <flaper87> well, 1, I just forgot about one of the topic
15:24:16 <flaper87> #topic PTL elections
15:24:20 <vkmc> not so sure about the fishbowls... but since we don't have so many, its ok
15:24:22 <dclain_> Outlook for branching Liberty distribution, has this been discussed yet?
15:24:55 <flaper87> The PTL elections are 1 month away from now, please, don't hesitate to send your candidacy. Zaqar has lacked of multiple-candidates elections which are good and healthy
15:25:19 <flaper87> I understand our community is not big but pls, don't hesitate to put your name out there
15:25:40 <flaper87> #topic Cross-Project Liaison
15:25:58 <flaper87> It's probably a bit late to bring this since this effort started a while back
15:26:00 <flaper87> HOWEVER
15:26:23 <flaper87> we've not been very involved in cross-project activities in the past, which is probably why our impact hasn't been as good
15:26:47 <flaper87> Now that projects are starting to consume Zaqar, it's extremely important for us to be around and participate in CPL activities
15:27:03 <ryansb> are there specific CPL tasks that you thin are most needed?
15:27:06 <flaper87> Therefore, I'd like to ask if some of you would like to be the CP Liaison for Zaqar
15:27:20 <flaper87> ryansb: right now, I think presence is important
15:27:22 <jasondotstar> ryansb: about to ask the same thing
15:27:29 <flaper87> devstack maintnance is important
15:27:34 <flaper87> and make sure we don't break others
15:27:40 <flaper87> Bring feedback from requirements changes
15:27:50 <flaper87> from API-wg changes etc
15:27:56 <jasondotstar> should we 'sell' consuming zaqar to other projects ?
15:28:21 <flaper87> jasondotstar: we've been doing that. More than selling, we're trying to solve existing projects
15:28:25 <therve> Not sure it should be just one person. But I'm totally cool with maintaining the in-tree devstack plugin
15:28:34 <flaper87> we addressed use cases for Heat
15:28:41 * ryansb is already api-wg'ing
15:28:41 <flaper87> now we are moving forward with other projects
15:28:43 <therve> (Should we delete the one in devstack itself btw?)
15:28:47 <flaper87> but this is not about selling Zaqar
15:28:55 <jasondotstar> flaper87: ack.
15:28:55 <flaper87> but being part of the CP efforts and meeting
15:28:56 <ryansb> therve: I'd say yeah, since the plugin is "the way"
15:29:07 <flaper87> the meeting happens in a time that is very inconvenient for me
15:29:14 <flaper87> and it's hard for me to attend
15:29:18 <jasondotstar> whic is?
15:29:21 <flaper87> Tue 21 UTC
15:29:31 <therve> Uh yeah that sucks
15:29:37 <flaper87> therve: right? :(
15:29:39 <flwang> flaper87: seems it's works for me?
15:29:49 <flaper87> flwang: if you can attend, pls do.
15:29:52 <flwang> I think that's my 9:00am
15:30:05 <flaper87> I think the only thing we need from our CPL is to bring/give feedback
15:30:11 <flaper87> We'll totally split tasks
15:30:23 <flaper87> but please, we need you to attend the meetings
15:30:31 <flwang> ok, just put my name on
15:30:37 <flaper87> awesome
15:30:56 <flaper87> flwang: thanks :)
15:31:01 <flaper87> that's it from me
15:31:17 <flaper87> anything else? can we move on?
15:31:40 <ryansb> FYI I'm already the heat CPL for the APIWG
15:31:57 <flaper87> ryansb: and you're Zaqar's as well, you just don't know that
15:31:59 <flaper87> :P
15:32:04 <ryansb> since I already go to the meetings, I can also go for zaqar
15:32:08 <ryansb> ah, so I am
15:32:11 <ryansb> ;)
15:32:16 <flaper87> :D
15:32:50 <flaper87> ok
15:32:54 <flaper87> #topic Open Discussion
15:33:48 <flaper87> Everyone, pls, welcome ryansb to the Zaqar's core team
15:33:50 <flaper87> https://review.openstack.org/#/admin/groups/104,members
15:34:01 <flaper87> He's now gotten all the rights and priviledges
15:34:07 <flaper87> and he's ready to break Zaqar
15:34:09 <flaper87> :D
15:34:17 <ryansb> you mean improve, right?
15:34:28 * jasondotstar salutes
15:34:28 <flaper87> Jokes apart, ryansb thanks for joining and for taking this duty on
15:34:55 <flaper87> ok, that's it for realz
15:34:56 <flwang> ryansb:  http://i1.wp.com/openstackreactions.enovance.com/wp-content/uploads/2014/04/getting-ptl.gif?resize=480%2C360
15:35:07 <flaper87> unless there are other open discussions, I'll end the meeting
15:35:23 <ryansb> lol, thanks everyone
15:35:33 <ryansb> flaper87: sgtm
15:35:39 * flaper87 is glad flwang likes OSReactions
15:35:40 <flwang> flaper87: thanks
15:35:42 <therve> Congrats ryansb :)
15:35:52 <flaper87> ok, meeting ending in:
15:35:53 <vkmc> congrats ryansb!
15:35:54 <flaper87> 3
15:35:56 <flaper87> 2
15:35:58 <flaper87> 1
15:36:01 <flaper87> #endmeeting