15:01:04 <flaper87> #startmeeting Zaqar
15:01:05 <openstack> Meeting started Mon Dec 15 15:01:04 2014 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:08 <openstack> The meeting name has been set to 'zaqar'
15:01:26 <flaper87> #topic Roll Call
15:01:30 <flaper87> (o/
15:01:37 <vkmc> \o)
15:01:42 <dynarro> o/
15:02:03 <flaper87> I guess kgriffs will join eventually
15:02:11 <flaper87> #topic Agenda
15:02:17 <flaper87> #link https://wiki.openstack.org/wiki/Meetings/Zaqar#Agenda
15:02:33 <flaper87> #topic Review remaining specs
15:02:39 <flaper87> #link https://review.openstack.org/#/q/status:open+project:openstack/zaqar-specs,n,z
15:02:44 <flaper87> 2 specs for today
15:02:50 <flaper87> The first one is os-profile
15:03:14 <flaper87> #link https://review.openstack.org/#/c/135612/6/specs/kilo/osprofiler.rst,cm
15:03:36 <flaper87> zhiyan: ^
15:03:42 <flaper87> I think I'm good with this spec
15:03:53 <zhiyan> flaper87: sounds great!
15:03:55 <flaper87> based on the previous comments, it looks like kgriffs is good as well
15:04:02 <flaper87> vkmc: any concerns ?
15:04:09 <flaper87> zhiyan: thanks for working on this
15:04:32 <vkmc> flaper87, not at all
15:04:44 <vkmc> I'm good with it and I think its a great adition
15:05:03 <flaper87> kk
15:05:10 <vkmc> in fact, zhiyan already submitted some changes, its ready to review
15:05:11 <zhiyan> flaper87: vkmc thanks for review and input. and btw, the main change is ready to review, when/if you ok, any inputs are welcome .
15:05:19 <flaper87> #agreed Merge OsProfile spec
15:05:34 <flaper87> I think we should hold it back until k-2, though
15:05:39 <flaper87> we can start reviewing right away
15:05:46 <flaper87> but we could merge it in k-2
15:05:48 <zhiyan> i'm ok
15:05:50 <flaper87> k-1 is in 2 days
15:05:52 <flaper87> awesome
15:06:01 <zhiyan> indeed, a little limited.
15:06:01 <flaper87> #agreed merge osprofile changes in k-2
15:06:08 <vkmc> +1
15:06:26 <flaper87> +2A
15:06:28 <zhiyan> (sorry for delay)
15:06:37 <flaper87> zhiyan: no worries at all
15:06:40 <flaper87> next in line
15:06:46 <flaper87> #link https://review.openstack.org/#/c/134248/
15:06:53 <flaper87> yes yes, I know it's red and I've a -1
15:07:03 <vkmc> lol
15:07:14 <flaper87> However, now that exploreshaifali_'s patch has landed, I thikn it'll be very simple to remove sqlalchemy from the data plane
15:07:31 <zhiyan> thanks for all your support :D, glade to do some worth thing in zaqar.
15:07:36 <flaper87> thoughts? concerns? I'll update the patch and we can get that done in k-2 as well
15:08:01 <flaper87> zhiyan: and I'm glad we have you on board, we're good at giving people things to do so, don't hesitate to ask
15:08:03 <flaper87> :D
15:08:11 <vkmc> zhiyan, thanks to work on it!
15:08:33 <zhiyan> flaper87: vkmc i'm def will, sure!
15:08:48 <flaper87> vkmc: concerns on that sqla thing ?
15:08:48 <vkmc> s/to work/for working
15:09:08 <vkmc> flaper87, nope, I've raised my concerns last time we discussed about it
15:09:17 <vkmc> regarding sqlalchemy used for testing
15:09:20 <flaper87> ok, then I'll update this spec for realz this time
15:09:26 <flaper87> and get that done
15:09:40 <vkmc> k
15:09:52 <flaper87> #topic K1 status
15:09:55 <flaper87> #link https://launchpad.net/zaqar/+milestone/kilo-1
15:10:08 <vkmc> I remember sriram shared with us a neat tool to mock Mongo for tests... so +1 to sqlalchemy removal
15:10:09 <flaper87> so, I'll move the sqla one to k-2
15:10:23 <flaper87> vkmc: yeah, I've it in one of the 10k tabs I have
15:10:40 <vkmc> lol
15:10:49 <vkmc> cool
15:11:13 <flaper87> vkmc: updates on your bp ?
15:11:18 <flaper87> you have 2
15:11:22 <vkmc> flaper87, 3*
15:11:29 <flaper87> vkmc: not for k-1
15:11:31 <flaper87> :P
15:11:33 <flaper87> I just see 2
15:11:44 <vkmc> link?
15:12:01 <flaper87> #link https://launchpad.net/zaqar/+milestone/kilo-1
15:12:20 <vkmc> ok, the permanent transport one is missing
15:12:27 <flaper87> also, there are 2 bugs in progress, can we provide reviews there?
15:12:31 <flaper87> vkmc: yes, I removed it :P
15:12:59 <vkmc> so.. regarding those two bp I have for k-1
15:13:12 <flaper87> shoot
15:13:20 <flaper87> btw, this meeting will be really short
15:13:32 <flaper87> I could make it last the whole hour talking random things but well...
15:13:34 <flaper87> :P
15:13:42 <vkmc> #link https://blueprints.launchpad.net/zaqar/+spec/non-rest-wire-protocol
15:13:57 <vkmc> that one... the wiki has been updated but I think it requires some extra polishing and making sure its nothing missing
15:14:07 <vkmc> I'll update the whiteboard with the respective link
15:14:20 <vkmc> I think we can close it today
15:14:27 <flaper87> AWESOME!
15:14:36 * flaper87 gives vkmc 2 gummy bears
15:14:47 <vkmc> and
15:14:49 <vkmc> #link https://blueprints.launchpad.net/zaqar/+spec/cross-transport-api-spec
15:15:00 <flaper87> whatch it, I'll take them back if you say something bad
15:15:01 <vkmc> some patches related to that one is waiting for review
15:15:02 <flaper87> >.>
15:15:12 * vkmc takes the gummybears and run away
15:15:15 <flaper87> ok, I think we can move this one to k-2 as well
15:15:27 <flaper87> AFAICT, those patches don't cover it all
15:15:28 <flaper87> right?
15:15:29 <vkmc> sure... there is still some work to do
15:15:32 <flaper87> ok
15:15:39 <vkmc> nope, we are missing many endpoints
15:15:45 <vkmc> it shouldn't take much
15:15:49 <vkmc> but I also have to add the tests
15:16:12 <flaper87> ok, I'm not sure about moving the storage capabilities one
15:16:29 <flaper87> bah, who am I kidding? I'll move it
15:16:41 <flaper87> damn, just 1 bp done and a bunch of bugs
15:16:43 <vkmc> talking about moving blueprints
15:16:49 <vkmc> move https://blueprints.launchpad.net/zaqar/+spec/zaqar-rally-integration to k-1
15:16:50 <vkmc> that is done
15:17:16 <vkmc> I'll update the whiteboard with the last changes but we can say that we have been integrated with Rally
15:17:36 <flaper87> ok, done
15:18:23 <flaper87> vkmc: ok, please, mark the other one as implemented as soon as you update the wiki
15:18:34 <flaper87> also, please, provide reviews for the bugs in progress
15:18:47 <vkmc> flaper87, sure thing, I have been reviewing this morning
15:18:59 <flaper87> vkmc: awesome
15:19:02 <flaper87> thank you, a lot!
15:19:08 <flaper87> ok, I think that's all I have
15:19:22 <flaper87> if there's anything urgent that should bemerged before k-1, let me know
15:19:22 <vkmc> flaper87, notifications is for k-2?
15:19:28 <flaper87> vkmc: yeah
15:19:34 <flaper87> k-2 will be very busy
15:19:38 <vkmc> yeah
15:19:48 <vkmc> specs reviewing took us a lot of time
15:19:57 <flaper87> yup :/
15:20:03 * vkmc sighs
15:20:04 <vkmc> anyhow
15:20:08 <flaper87> anyway, we're not in a bad shape, we still have time to catch up
15:20:13 <vkmc> of course
15:20:16 <flaper87> and we have kgriffs to blame
15:20:35 <flaper87> ok, that's it
15:20:37 <vkmc> oh
15:20:38 <vkmc> wait
15:20:39 <flaper87> #topic Open Discussion
15:20:40 <vkmc> queues removal
15:20:51 <flaper87> #topic Queues Removal
15:20:54 <flaper87> shoot
15:21:06 <vkmc> we haven't received enough feedback from the community to do that change
15:21:29 <vkmc> and we have to define if that is happening or not
15:21:34 <flaper87> nope, I think it'll be on us to decide
15:21:40 <flaper87> yeah, here's what I've been thinking
15:21:42 <vkmc> I think its an important change
15:21:56 <vkmc> can we have a meeting with tc? I don't know if that is something we can do
15:22:03 <flaper87> Lets re-review the spec, we need to get flwang's thoughts on it w.r.t notifications
15:22:17 <flaper87> we don't need the TC to chime in here
15:22:31 <flaper87> we need a meeting with them - which I'm working on - but not for this
15:22:47 <vkmc> ok
15:23:17 <flaper87> vkmc: please, take another look to that spec
15:23:17 <vkmc> exploreshaifali_, comments on this? you bring that up in -zaqar
15:23:22 <vkmc> flaper87, will do so
15:23:23 <flaper87> I'll ask flwang too
15:24:00 <exploreshaifali_> vkmc: I don't know exactly why we need to remove queues
15:24:15 <exploreshaifali_> may be you people have resons for that
15:24:20 <vkmc> long story
15:24:32 <flaper87> exploreshaifali_: have you read the spec ?
15:24:43 <flaper87> (not that it explains everything, I'm just curious)
15:24:45 <exploreshaifali_> flaper87: no
15:24:51 <flaper87> oh, wait.
15:24:55 <exploreshaifali_> flaper87: which one?
15:25:03 <flaper87> exploreshaifali_: https://review.openstack.org/#/c/134015/
15:25:27 <exploreshaifali_> flaper87: kk I will explore it first :)
15:25:30 <flaper87> exploreshaifali_: and http://blog.flaper87.com/post/people-dont-like-to-queue-up/
15:25:53 <flaper87> exploreshaifali_: let me know if that helps and please, let me know if neither of them do
15:25:58 <flaper87> or if the idea sounds dumb
15:26:07 <exploreshaifali_> flaper87: sure :)
15:26:13 <flaper87> awesome
15:26:13 <exploreshaifali_> flaper87: thanks
15:26:29 <flaper87> vkmc: exploreshaifali_ anything else?
15:26:41 <vkmc> flaper87, nope :)
15:26:45 <exploreshaifali_> no
15:27:28 <flaper87> ok
15:27:41 <flaper87> tty next week then!
15:27:47 <flaper87> thank you all for your contributions
15:27:49 <flaper87> #endmeeting