#openstack-meeting-3: Zaqar

Meeting started by flaper87 at 21:00:03 UTC (full logs).

Meeting summary

  1. Roll Call (flaper87, 21:00:09)
  2. Actions from last meeting (flaper87, 21:02:05)
    1. http://eavesdrop.openstack.org/meetings/zaqar/2014/zaqar.2014-08-25-15.10.html (flaper87, 21:02:11)
    2. Base redis patch has been approved (flaper87, 21:02:49)
    3. Bench numbers were sent to the mailinig list. No feedback for now (flaper87, 21:04:02)
    4. ACTION: kgriffs to re-run benchmarks using the redis driver (flaper87, 21:06:35)

  3. What checks should go to the API/Storage layer? (flaper87, 21:07:09)
    1. https://review.openstack.org/#/c/117706/ (flaper87, 21:08:38)
    2. https://review.openstack.org/#/c/117706/3/zaqar/queues/storage/mongodb/pools.py,cm (flaper87, 21:09:05)
    3. AGREED: Checks should stay in the data plane they belong too. Storage drivers must enforce their data model stays consistent (flaper87, 21:21:44)
    4. ACTION: vkmc to add checks enforcement rule to our development docs (flaper87, 21:23:32)

  4. Summit Sessions Proposals (flaper87, 21:24:08)
    1. https://etherpad.openstack.org/p/kilo-zaqar-summit-topics (flaper87, 21:24:29)

  5. Should we start discussiong API v2? (flaper87, 21:28:33)
    1. AGREED: lets not start working on new APIs. Lets give the community at least 1 full cycle to digest v1.1 before we start talking about v2 (flaper87, 21:32:11)

  6. Graduation status (flaper87, 21:33:04)
    1. https://launchpad.net/zaqar/+milestone/juno-3 (flaper87, 21:33:07)
    2. Essential things missing in the redis patch are: 1. Garbage collection / expiration of claims, messages, 2. Remove stats counters and just calculate them dynamically (flaper87, 21:36:22)
    3. https://blueprints.launchpad.net/zaqar/+spec/api-v1.1-user-guide (flaper87, 21:37:13)

  7. Graduation Meeting (flaper87, 21:44:28)
  8. Open Discussions (flaper87, 21:47:41)
    1. http://www.imdb.com/title/tt2788780/ (flaper87, 21:56:55)


Meeting ended at 21:59:54 UTC (full logs).

Action items

  1. kgriffs to re-run benchmarks using the redis driver
  2. vkmc to add checks enforcement rule to our development docs


Action items, by person

  1. kgriffs
    1. kgriffs to re-run benchmarks using the redis driver
  2. vkmc
    1. vkmc to add checks enforcement rule to our development docs


People present (lines said)

  1. flaper87 (189)
  2. vkmc (61)
  3. kgriffs (38)
  4. flwang (11)
  5. openstack (4)


Generated by MeetBot 0.1.4.