17:00:12 <johnthetubaguy> #startmeeting XenAPI
17:00:13 <openstack> Meeting started Wed Mar 27 17:00:12 2013 UTC.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:16 <openstack> The meeting name has been set to 'xenapi'
17:00:32 <johnthetubaguy> hi, who is around for this weeks meeting?
17:00:40 <matelakat> me
17:00:44 * BobBall waves his hand
17:01:21 <johnthetubaguy> OK, cool
17:01:27 <johnthetubaguy> lets get cracking...
17:01:40 <BobBall> I was just saying to Mate, I might have to leave at 5 minutes past 5...
17:01:44 <johnthetubaguy> #topic Actions from previous meeting
17:01:51 <BobBall> But Mate thought that I should stay a little longer, so I will.
17:02:01 <johnthetubaguy> nothing to say
17:02:06 <BobBall> haha
17:02:07 <matelakat> No.
17:02:19 <johnthetubaguy> #topic blueprints
17:02:29 <johnthetubaguy> anything from anyone here?
17:02:38 <BobBall> well before we move on
17:02:41 <BobBall> there was an action on me
17:02:44 <johnthetubaguy> we all prep-ed for the summit?
17:02:46 <BobBall> that didn't get copied over from the week before
17:02:52 <BobBall> in terms of updating on the iSCSI timeout
17:02:55 * BobBall only just remembered
17:02:56 <johnthetubaguy> yes, true
17:03:04 <BobBall> what was the question again? Do you remember? or shall I go back through the logs?
17:03:14 <johnthetubaguy> you were working on a fix I think
17:03:18 <johnthetubaguy> to control the timeout
17:03:21 <matelakat> BobBall to update on iSCSI timeout when there is an update
17:03:35 <matelakat> #link http://eavesdrop.openstack.org/meetings/xenapi/2013/xenapi.2013-03-13-17.02.log.html
17:03:40 <BobBall> there were several iscsi timeout issues I've looked at over the last couple of weeks
17:03:57 <johnthetubaguy> it was the iscsi goes down, then it takes ages to timeout
17:03:58 <BobBall> oh yes
17:04:02 <johnthetubaguy> include the SR scan
17:04:03 <BobBall> the attach issue when the conn has gone away
17:04:06 <BobBall> we think so
17:04:18 <BobBall> oh hang on - that one was a different one (!)
17:04:59 <BobBall> Okay - the one where the attach was expecting a path to exist has been fixed - but that was a RS specific issue AFAIK
17:05:01 <johnthetubaguy> takes a while to detect the problem, there was a short term fix that uses the SR scan to detect failures
17:05:31 <BobBall> yes
17:05:37 <BobBall> that bug hasn't been progressed I'm afraid
17:05:44 <johnthetubaguy> we ideally need some way to specify a timeout
17:05:49 <johnthetubaguy> OK
17:05:50 <BobBall> (there is a separate OS bug raised talking about the 120s timeout)
17:06:01 <BobBall> although I'm struggilng to find that atm!
17:06:08 <johnthetubaguy> ah, you got that to hand?
17:06:46 <johnthetubaguy> #link https://bugs.launchpad.net/nova/+bug/1152401
17:06:49 <uvirtbot> Launchpad bug 1152401 in nova "xenapi: Detecting bad-volumes relies on 120 sec timeout" [High,Triaged]
17:07:01 <BobBall> ... I searched for xenapi 120 - how did that not come up?!
17:07:11 <johnthetubaguy> duno
17:07:18 <johnthetubaguy> shall I assign that to you?
17:07:23 <BobBall> odd.  Anyway, that's the one.
17:07:27 <BobBall> Please
17:07:46 <johnthetubaguy> OK, should be yours now
17:07:52 <johnthetubaguy> action sorted, tracked by a bug
17:07:56 <BobBall> Joy.
17:08:14 <johnthetubaguy> OK, so anything blueprinty?
17:08:26 <matelakat> no
17:08:28 <BobBall> I had a review of the etherpad and I'm happy
17:08:32 <johnthetubaguy> cool
17:08:39 <BobBall> although since we're talking about it, do we have a time for the session?
17:08:40 <johnthetubaguy> #topic docs
17:09:04 <BobBall> I'd like to book it in ASAP and see if James B / Guy B want to come along to sit in on the session
17:09:12 <johnthetubaguy> BobBall: its not even approved yet, I think that happens much nearer the time
17:09:17 <BobBall> bah
17:09:19 <BobBall> okay
17:09:24 <matelakat> Regarding to the docs, Release notes.
17:09:34 <johnthetubaguy> OK
17:09:45 <matelakat> On the meeting Wiki Page, I included the stuff, that I want to flush to the release notes.
17:09:56 <matelakat> Could you please add any missed stuff?
17:10:00 <johnthetubaguy> ah, got ya
17:10:22 <matelakat> So far we have ConfigDrive, and XenAPINFS
17:10:45 <matelakat> THe other question.
17:10:58 <johnthetubaguy> I would have to read through all the blueprints on launchpad to check
17:11:07 <johnthetubaguy> is anyone fancying that?
17:11:26 <johnthetubaguy> I probably should take a look anyways...
17:11:39 <johnthetubaguy> #action johnthetubaguy to review blueprints for release notes
17:11:53 <johnthetubaguy> any more for docs?
17:11:57 <matelakat> I wanted to put only the things implemented by us / being involved in.
17:12:00 <matelakat> yes.
17:12:02 <matelakat> We are missing a step in the documentation: /boot/guest creation
17:12:15 <johnthetubaguy> I meant review for xenapi related things
17:12:31 <johnthetubaguy> hmm, yes, good point
17:12:38 <johnthetubaguy> for three part images
17:12:41 <matelakat> I haven't pushed changes to the docs this week.
17:12:57 <matelakat> Y, so the q is: should it be a symlink to a subdir within the Local SR?
17:13:21 <BobBall> _yes_
17:13:23 <matelakat> devstack is just creating a directory: /boot/guest
17:13:38 <matelakat> Okay, so that's a devstack bug, and a documentation Todo.
17:13:41 <BobBall> I'm less fussed about devstack since the local directory could be used for lots
17:14:06 <BobBall> but any directory that could contain any non-trivial amount of data should be on the SR rather than in dom0
17:14:09 <matelakat> #action matelakat to fix /boot/guest in devstack, and document it.
17:14:13 <johnthetubaguy> yes, its not a very big deal, becuase the files there are quite small
17:14:22 <BobBall> /boot/guest coul contain a whole bunch of kernels, right?
17:14:23 <BobBall> +d
17:14:36 <matelakat> I remember, it caused pains for us for broken builds.
17:14:39 <johnthetubaguy> it could, yes
17:14:47 <johnthetubaguy> devstack should represent best practice
17:14:59 <johnthetubaguy> so I think it would be good to fix that, and make it match /images
17:15:10 <matelakat> Thanks.
17:15:11 <BobBall> OK - then yes, create a link.  Or better yet, move it to a configurable SR
17:15:30 <matelakat> small steps are welcome.
17:15:36 <BobBall> hard coded paths like /boot/guest and /images are bad :)
17:15:37 <johnthetubaguy> of course, if you don't do three part images, then there is no need, but hey
17:15:37 <matelakat> So first, it will be a symlink.
17:15:51 <BobBall> fair enough
17:15:52 <johnthetubaguy> so, it turns out the kernel *must* be in /boot/guest
17:16:09 <BobBall> oh really? Why's that?
17:16:09 <johnthetubaguy> but clearly we could sym link somewhere sensible
17:16:20 <johnthetubaguy> its a xapi restriction on the kernel boot param, I think
17:16:20 <matelakat> I will try the symlink approach
17:16:29 <BobBall> oh right.  Drat.
17:16:43 <johnthetubaguy> worth a double check though
17:17:09 <johnthetubaguy> I presume xen will follow the symlink correctly… hmm worth a test
17:17:41 <BobBall> okay - we'll look into that
17:17:43 <matelakat> You could leave that with me.
17:17:45 <BobBall> by we, I mean mate.
17:17:49 <johnthetubaguy> hehe, cool
17:17:50 <matelakat> ta
17:17:57 <BobBall> Welcome.
17:18:08 <johnthetubaguy> so I guess we our out of docs stuff
17:18:14 <matelakat> I believe.
17:18:16 <johnthetubaguy> #topic bugs
17:18:38 <BobBall> Can I talk about a bug?
17:18:45 <BobBall> #link https://bugs.launchpad.net/nova/+bug/1160323
17:18:46 <johnthetubaguy> OK, so I have been doing the odd bit of triage on the xenapi bugs
17:18:47 <uvirtbot> Launchpad bug 1160323 in nova "Cannot block migrate in xenapi with iSCSI cinder volumes attached" [Medium,In progress]
17:18:49 <johnthetubaguy> OK, sure
17:18:53 <BobBall> and particularly the review at:
17:19:01 <BobBall> #link https://review.openstack.org/25419
17:19:21 <matelakat> I was afraid, Bob will come up with the uuid one :-)
17:19:21 <johnthetubaguy> ah, yes, its on my todo list for this afternoon
17:19:30 <BobBall> *grin*
17:19:37 <BobBall> ahhhh good - if it's on the list, then that's fine, I'm happy
17:19:50 <BobBall> and the UUID one finally got in after a marathon number of comments
17:20:10 <johnthetubaguy> yes, its quite frequently like that
17:20:11 <BobBall> _AND_ the commit beat John's commit which probably conflicts in the test code, so I'm happy :)
17:20:26 <johnthetubaguy> hehe, probably
17:20:50 <johnthetubaguy> any other bugs?
17:20:58 <matelakat> I guess John does frequent rebasing, so he won't be hit by Bob's change...
17:21:07 <BobBall> oh yes, of course ;)
17:21:17 <johnthetubaguy> nah, don't both we that kind of thing
17:21:42 <matelakat> I have one.
17:21:47 <matelakat> It is not really a bug.
17:21:51 <johnthetubaguy> BobBall: it should prob have docimpact tag on there
17:21:58 <matelakat> I have it on the Other section.
17:22:02 <johnthetubaguy> OK, fire away
17:22:06 <johnthetubaguy> OK...
17:22:15 <johnthetubaguy> I see them
17:22:15 <BobBall> docimpact tag on the bug or the commit?
17:22:15 <matelakat> https://bugs.launchpad.net/nova/+bug/903445
17:22:17 <uvirtbot> Launchpad bug 903445 in nova "New xapi backend for Local Storage ISO SR" [Wishlist,Confirmed]
17:22:21 <matelakat> #link https://bugs.launchpad.net/nova/+bug/903445
17:22:31 <johnthetubaguy> #topic OpenDiscussion
17:22:40 <matelakat> I mean how we are doing with ISO files in general?
17:22:54 <johnthetubaguy> ah, very timely
17:23:01 <johnthetubaguy> I have just been fixing that up
17:23:17 <johnthetubaguy> https://review.openstack.org/#/c/24895/
17:23:38 <johnthetubaguy> https://wiki.openstack.org/wiki/XenServer/BootFromISO
17:23:51 <BobBall> odd - wonder why I wasn't notified of that review...
17:24:02 <BobBall> Typo in the commit message btw :)
17:24:22 <matelakat> John, is that something, that should go to the docs?
17:24:44 <johnthetubaguy> yes, if it works and we are happy with it
17:24:55 <johnthetubaguy> done some quick testing myself
17:25:03 <matelakat> #action matelakat to add https://wiki.openstack.org/wiki/XenServer/BootFromISO to the install docs
17:25:13 <johnthetubaguy> OK, thanks
17:25:31 <matelakat> Are there any XS version restrictions on this tweak?
17:25:38 <johnthetubaguy> turns out the unit tests for spawn were quite broken, so didn't test the ISO code path
17:25:49 <johnthetubaguy> matelakat: not that I know of
17:27:14 <matelakat> Okay
17:27:18 <johnthetubaguy> so next thing
17:27:23 <matelakat> Other question is around Console.
17:27:26 <johnthetubaguy> ok
17:27:34 <matelakat> #link https://bugs.launchpad.net/nova/+bug/1004175
17:27:35 <uvirtbot> Launchpad bug 1004175 in nova "XenAPI text console support" [Wishlist,In progress]
17:27:37 <johnthetubaguy> text console
17:27:40 <matelakat> Seems to be orphaned.
17:27:59 <matelakat> No activity since december.
17:28:13 <johnthetubaguy> yes, its worth someone adopting that one I think
17:28:16 <matelakat> So it won't hit G
17:28:35 <matelakat> John, do you think, that it could hit G?
17:28:56 <BobBall> Too late for G isn't it?
17:29:00 <johnthetubaguy> nothing will make G anymore
17:29:06 <johnthetubaguy> only critical fixes right?
17:29:09 <matelakat> Okaz, my bad.
17:29:14 <matelakat> Okay, my bad
17:29:19 <johnthetubaguy> no worries
17:29:25 <matelakat> I am just overusing my time-machine.
17:29:48 <johnthetubaguy> this one is really a feature, needs the blueprint bringing back to life
17:29:56 <BobBall> Looks like quite a simple change I guess
17:30:10 <BobBall> although testing it is more trick
17:30:11 <BobBall> +y
17:30:13 <matelakat> I would say, let's pick up that change.
17:30:17 <johnthetubaguy> its a shame, XenServer added a feature for the serial console for OpenStack, bit it doesn't really work with what OpenStack needs.
17:30:19 <matelakat> Tempest has tests for it.
17:30:24 <johnthetubaguy> its worth a whirl
17:30:34 <BobBall> ahhh I see
17:30:41 <matelakat> Who wants to pick it up?
17:31:03 <BobBall> Well we can't schedule when it'll be done, but we can add it to the backlog for things to pick up.  There are other higher priority things to pop off the top first
17:31:13 <johnthetubaguy> same here really
17:31:29 <johnthetubaguy> stuck in a pit of resize issues at the moment
17:31:31 <matelakat> Not good to hear these things... :-(
17:31:32 <BobBall> Particularly since it's missed G
17:31:55 <BobBall> Agreed...
17:32:02 <matelakat> I have another thing.
17:32:10 <johnthetubaguy> OK
17:32:15 <matelakat> I was looking at the plugin install in devstack
17:32:29 <matelakat> And I realised, that Quantum has changed...
17:32:34 <matelakat> https://github.com/openstack/quantum/blob/master/quantum/plugins/openvswitch/agent/xenserver_install.sh
17:32:39 <matelakat> #link https://github.com/openstack/quantum/blob/master/quantum/plugins/openvswitch/agent/xenserver_install.sh
17:32:59 <matelakat> So it seems, it no longer has the traditional xapi-plugin layout.
17:33:15 <johnthetubaguy> not sure what you mean
17:33:24 <matelakat> a sec
17:33:29 <johnthetubaguy> the quantum support hasn't hit trunk yet right?
17:33:44 <johnthetubaguy> there are no plugins in quantum yet, really
17:33:49 <johnthetubaguy> not for xenserver anyways
17:34:04 <johnthetubaguy> lol salvatore left quickly
17:34:13 <matelakat> So your saying, I cannot see that, cos it was never was there...
17:34:19 <johnthetubaguy> yep
17:34:26 <matelakat> How stupid I am.
17:34:40 <johnthetubaguy> https://review.openstack.org/#/c/15022/
17:34:44 <BobBall> He's in and out - guess he has a network issue
17:34:53 <matelakat> :-)
17:35:22 <BobBall> Mate laughed.  I appreciate the symapthy laugh.  Thanks,
17:35:53 <johnthetubaguy> hehe
17:35:59 <johnthetubaguy> so what else we got on the list for today?
17:36:02 <BobBall> I see - that change linked deletes the script Mate pointed at.
17:36:07 <matelakat> Anyhow, I think I overlooked that Quantum stuff
17:36:12 <matelakat> I have one thing to note.
17:36:19 <johnthetubaguy> kernel lock up?
17:36:22 <matelakat> The good old kernel locking issue.
17:36:24 <matelakat> yes.
17:36:48 <matelakat> So if you don't use the loopback device, the pain goes away.
17:36:56 <johnthetubaguy> so you add an extra disk intead?
17:37:04 <johnthetubaguy> instead?
17:37:06 <matelakat> That's what I do in the CI.
17:37:18 <johnthetubaguy> hmm, OK
17:37:22 <matelakat> And the Jenkins weather became better.
17:37:42 <johnthetubaguy> cool, not sure if you are just changing the race condition, but if it works, thats all good
17:37:48 <matelakat> I had tempest running in an infinite loop for a day, and no nasty kernel messages.
17:38:00 <johnthetubaguy> sounds good enough to me
17:38:08 <johnthetubaguy> cool
17:38:21 <matelakat> That's all from me.
17:38:29 <johnthetubaguy> cool, thanks, some good updates
17:38:46 <matelakat> blogpost
17:38:47 <BobBall> Saw the CentOS update from yesterday too - which is looking positive
17:38:54 <matelakat> #link http://blogs.citrix.com/2013/03/18/virtual-hypervisor/
17:38:56 <johnthetubaguy> virtual hypervisor post looks interesting too,
17:39:05 <johnthetubaguy> yes, took a quick look
17:39:20 <matelakat> Just some shell scripts, but might be handy.
17:39:31 <johnthetubaguy> its possibly a bit deep, but its good to advertise these things :-)
17:39:47 <johnthetubaguy> I install XCP using openstack to test my patch :-)
17:39:49 <matelakat> I am always too technical.
17:39:53 <johnthetubaguy> doing an iso boot
17:40:05 <matelakat> cool!
17:40:17 <johnthetubaguy> centos stuff is slowly moving forward
17:40:27 <johnthetubaguy> taking a break for the mo while stuff gets fixed
17:40:34 <johnthetubaguy> OK, I think we are all done?
17:40:43 <matelakat> y, John, thanks.
17:40:53 <BobBall> Think so
17:40:56 <johnthetubaguy> cool, thank you all
17:41:00 <johnthetubaguy> #endmeeting