17:02:26 <johnthetubaguy> #startmeeting XenAPI
17:02:27 <openstack> Meeting started Wed Mar 13 17:02:26 2013 UTC.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:31 <openstack> The meeting name has been set to 'xenapi'
17:02:42 <johnthetubaguy> Hey, sorry we are on the wrong channel today
17:03:14 <BobBall> it's a much smaller channel
17:03:15 <BobBall> :)
17:03:48 <johnthetubaguy> #topic Actions from last meeting
17:04:18 <johnthetubaguy> BobBall is mate around?
17:04:23 <matelakat> Hi
17:04:28 <johnthetubaguy> looking through actions from last week
17:04:29 <johnthetubaguy> hey
17:04:40 <matelakat> I see.
17:04:43 <BobBall> speak of the devil
17:04:45 <johnthetubaguy> matelakat you were going to check on the state of the docs wrt XenAPI
17:04:49 <BobBall> I'd quite like a short meeting this week if we can
17:04:53 <johnthetubaguy> how did it go?
17:04:59 <BobBall> or, more to the point, I'll have to leave early
17:04:59 <BobBall> :)
17:05:06 <johnthetubaguy> lol, no worries
17:05:27 <matelakat> So still in progress, I fixed a small bug, and what I see that we have some "structural" problems around.
17:05:38 <matelakat> At least that's my view.
17:05:50 <johnthetubaguy> do describe some?
17:05:58 <johnthetubaguy> as an example
17:06:08 <johnthetubaguy> BobBall: is there news on an iSCSI timeout
17:06:47 <matelakat> I just don't quite see the information flow properly by reading the doc.
17:07:01 <BobBall> johnthetubaguy, you mean the attach issue when the iSCSI conn has gone away
17:07:06 <BobBall> not yet I'm afraid
17:07:07 <matelakat> So it is more a generic OS doc issue, than a XenAPI one.
17:07:36 <johnthetubaguy> right, it is quite a reference guide at the moment, but I am sure Anne and team will take feedback
17:07:54 <matelakat> Yes, that's my plan to talk with anne about it.
17:08:00 <johnthetubaguy> what about XenAPI things, I reviewed the addition you made
17:08:05 <matelakat> I am a bit confused around install - config
17:08:14 <matelakat> Oh, yes, the cinder part.
17:08:43 <matelakat> I was thinking about a feature list as well.
17:08:48 <matelakat> we'll see.
17:08:49 <johnthetubaguy> matelakat: they have monthly meetings, an email list and irc, I found email best before
17:09:06 <johnthetubaguy> what you mean install vs config?
17:09:08 <matelakat> johnthetubaguy: y, Anne seems responsive.
17:09:19 <johnthetubaguy> you mean the install guide vs running guide?
17:09:19 <matelakat> yes, install vs. config.
17:09:31 <matelakat> let me show you an example.
17:10:01 <johnthetubaguy> OK
17:10:09 <matelakat> #link https://review.openstack.org/#/c/24081/
17:10:46 <matelakat> And now I linked to the config manual.
17:11:01 <matelakat> But, anyhow, I am reading the docs, and getting a bit more familiar.
17:11:19 <johnthetubaguy> OK
17:11:26 <matelakat> Oh, a q
17:11:36 <johnthetubaguy> that intro to xen bit goes in all the guides at the moment, but I guess you spotted that
17:11:42 <matelakat> Regarding to that picture in the doc.
17:11:48 <johnthetubaguy> OK
17:12:13 <matelakat> I think that internal comm. channel could be removed, right?
17:12:47 <johnthetubaguy> yep, it turned out not to be useful, use management network instead
17:12:57 <matelakat> Okay.
17:13:14 <johnthetubaguy> the visio file is in the source, but I guess you saw that
17:13:27 <matelakat> I was about to ask about that.
17:13:38 <johnthetubaguy> its in there somewhere, or should be
17:13:49 <matelakat> I just need a visio :-)
17:14:13 <matelakat> Any suggestion on the docs from anyone else?
17:14:22 <johnthetubaguy> I am sure bob can point you to a nice windows share for that
17:14:29 <matelakat> sure.
17:14:40 <BobBall> uhhhh lol
17:14:42 <BobBall> windows? :)
17:14:49 <BobBall> We'll see ;)
17:14:50 <johnthetubaguy> I was going to do some work on an install guide, making it work on CentOS, but I am blocked with getting XCP going right now
17:15:43 <BobBall> Are things progressing on that?
17:15:52 <BobBall> or proper blockage?
17:16:06 <johnthetubaguy> XCP on CentOS is a right PITA but slowly tip toeing forward
17:16:19 <johnthetubaguy> will be in the Citrix office on Friday to bug mike
17:16:26 <johnthetubaguy> OK, we are getting side tracked
17:16:29 <matelakat> Good, pastry day.
17:16:51 <matelakat> I guess we'll outsorce some QA work on the pastries.
17:16:56 <BobBall> sure - just thought a very quick update would be good :) Maybe it should be on the agenda - it's very relevant to XenAPI after all :)
17:16:58 <johnthetubaguy> #action BobBall to update on iSCSI timeout when there is an update
17:17:11 <BobBall> I'd rather have a deadline...
17:17:12 <BobBall> :)
17:17:26 <matelakat> Are we loosing focus?
17:17:26 <johnthetubaguy> there is a separate IRC meeting for that, but feel free to ask me in Open Discussion
17:17:31 <johnthetubaguy> indeed
17:17:35 <johnthetubaguy> I am just moving it on now
17:17:52 <johnthetubaguy> we have covered all the actions from last time now
17:18:01 <johnthetubaguy> #topic blueprints
17:18:20 <johnthetubaguy> keep updating the etherpad I guess
17:18:51 <johnthetubaguy> my summit talk has been rejected (the one on Xen) but obviously not hurd about design summit session yet
17:19:03 <BobBall> shame!
17:19:05 <matelakat> #link https://blueprints.launchpad.net/nova/+spec/extended-diagnostics
17:19:12 <matelakat> I added a link from Rachel.
17:19:29 <matelakat> (sorry to hear the session rejection)
17:19:51 <matelakat> Do you guys think, that the link could be useful?
17:19:52 <johnthetubaguy> you can come and hear it at CloudEast if you want to
17:20:14 <BobBall> When/where is cloud east? Got a link?
17:20:20 <johnthetubaguy> cloudeast.net
17:20:25 <BobBall> *grin*
17:20:26 <BobBall> okay
17:20:30 <BobBall> I could have googled.  Sorry.
17:20:37 <johnthetubaguy> erm, I think we spoke about that previously
17:20:43 <matelakat> That's near.
17:20:44 <johnthetubaguy> extended diagnostics
17:21:09 <johnthetubaguy> good to look at anyways
17:21:14 <johnthetubaguy> oh I see your link now
17:21:30 <johnthetubaguy> erm, partly useful
17:21:42 <johnthetubaguy> the thinking is how can we help opps guys find issues
17:22:00 <johnthetubaguy> metrics are obviously one way, and checking approprite heath
17:22:50 <matelakat> ok
17:22:52 <johnthetubaguy> OK, so we covered that stuff
17:23:04 <matelakat> sure, just wanted you to know about it.
17:23:05 <johnthetubaguy> make time to don thinking caps
17:23:10 <johnthetubaguy> cool, thanks
17:23:17 <matelakat> next?
17:23:46 <johnthetubaguy> #topic Docs
17:23:51 <johnthetubaguy> we have done this already
17:23:59 <johnthetubaguy> #topic Bugs and QA
17:24:19 <johnthetubaguy> I am looking at things around resize, we seem to fall over on two many error cases
17:24:32 <BobBall> I think I mentioned it last time - but it's frustrating that there aren't any gating tests for multi-host devstack setups
17:24:37 <BobBall> they hit us again today
17:24:41 <johnthetubaguy> looking at raising a few bugs and making a few fixes around disk sizes not matching flavours
17:24:45 <BobBall> how would we go about trying to add some?
17:24:56 <johnthetubaguy> let me find you a link
17:25:23 <matelakat> resize.
17:25:31 <johnthetubaguy> http://ci.openstack.org/third_party.html
17:25:34 <matelakat> Could we just talk about resize?
17:25:40 <johnthetubaguy> yep
17:25:50 <matelakat> So what's the issue?
17:26:15 <johnthetubaguy> resize is failing in a nasty way when the instance disk has grown two big for the size it is moving to
17:26:19 <BobBall> oh - it has to be external?  Isn't there a repo somewhere with the normal gating builds?  Thinking about what jenkins etc runs before it accepts the change
17:26:28 <johnthetubaguy> and it looks like the checks it are making are too long and too late
17:26:34 <johnthetubaguy> BobBall: it is all external
17:26:52 <matelakat> two bug = too big?
17:26:53 <johnthetubaguy> BobBall: multi-server has not happened yet, but see summit sessions
17:27:11 <johnthetubaguy> matelakat: oops, yes
17:27:14 <BobBall> oh okay
17:27:47 <matelakat> So if I resize to a size, that is too big, that fails?
17:28:10 <johnthetubaguy> sorry, resize to a flavor that is too small to fit the instance disk
17:28:27 <johnthetubaguy> its impossible sure, but it fails in a very aweful way
17:28:46 <matelakat> And there is another bug.
17:28:49 <matelakat> Around resize.
17:29:03 <johnthetubaguy> ?
17:29:18 <matelakat> So if your flavor has 0 disk size - meaning, that it should get the image's size, you will get negative numbers.
17:29:34 <johnthetubaguy> oh, yes, I have hit that one too earlier today
17:29:44 <johnthetubaguy> when you turn on auto disk size
17:29:45 <matelakat> I might have a report on that... wait
17:30:25 <johnthetubaguy> basically you need to check for instance_type == 0 in the resize code, its missing from there
17:30:38 <johnthetubaguy> although that does seem a bit bad, hey ho.
17:30:48 <matelakat> #link https://bugs.launchpad.net/nova/+bug/1152268
17:31:18 <matelakat> I think spending some time around resize/migration is a good idea.
17:31:29 <matelakat> It seemed to be a bit unstable for me as well.
17:31:43 <matelakat> #link https://bugs.launchpad.net/nova/+bug/1152714
17:32:20 <matelakat> #link https://github.com/citrix-openstack/qa/blob/master/jenkins/jobs/xslib/configure_for_resize.sh
17:32:31 <matelakat> If anyone wants to start playing with resize.
17:32:51 <BobBall> Should we be doing that, or devstack?
17:32:53 <matelakat> johnthetubaguy: Could you include me in your bug reports?
17:32:56 <johnthetubaguy> yes, the docs should be a bit clearer on that stuff
17:33:09 <johnthetubaguy> matelakat: sure, I need to pin down the issue and raise them
17:33:13 <matelakat> johnthetubaguy: I committed a change on that.
17:33:21 <johnthetubaguy> I saw one of those
17:33:25 <matelakat> BobBall: I guess it needs to be done in devstack.
17:33:27 <johnthetubaguy> the wiki is probably out of date
17:33:36 <johnthetubaguy> and yet, it should be in devstack
17:33:39 <johnthetubaguy> yes^
17:33:55 <johnthetubaguy> it keeps dropping off the radar
17:34:00 <BobBall> okay
17:34:01 <johnthetubaguy> anyway, its an area to look at
17:34:09 <matelakat> Y, good spot.
17:34:14 <johnthetubaguy> sometime we need to remove the need for the ssh transfer
17:34:20 <matelakat> I had tempest-smoke running.
17:34:33 <johnthetubaguy> cool, it did used to run
17:34:35 <matelakat> And that's how I hit this resize area.
17:34:40 <BobBall> yes - can be done by XSM now!
17:34:49 <matelakat> And I have a really good stuff.
17:34:57 <matelakat> john might be interested in this.
17:35:12 <matelakat> #link https://review.openstack.org/#/c/24297/
17:35:21 <matelakat> Please, +1 if you like.
17:35:42 <johnthetubaguy> BobBall, maybe, its a bit tricky as we change the disk size, and things
17:35:45 <matelakat> We have seen some nasty dmesg errors while playing with cinder (the dd bug)
17:36:03 <matelakat> And it seems, that if we use kernel-virtual, we don't get those timeouts.
17:36:16 <johnthetubaguy> hmm, interesting
17:36:22 <BobBall> johnthetubaguy, Can all be accomplished with XAPI changes and touching the VHD though can't it?
17:36:32 <BobBall> i.e. XSM over to target host, then do the actual "resize"
17:36:54 <johnthetubaguy> matelakat: have you tried 12.10?
17:36:56 <BobBall> possibly still need pause/restart to re-attach disk since we can't do live resize, but that's much less time than pause+transfer+resume
17:37:26 <matelakat> johnthetubaguy: not, but the main thing, is that -virtual is using the deadline I/O scheduler, whereas the -generic is using cqs
17:37:33 <matelakat> And that's bad.
17:37:37 <johnthetubaguy> BobBall: we already do better than the long way, we do snapshot, transfer, shudown, transfer, resize
17:37:59 <BobBall> johnthetubaguy, I know - the the final transfer step should be even shorter when you use XSM
17:38:07 <BobBall> (because it's not transfer, just resize)
17:38:28 <BobBall> I have to run, sorry guys
17:38:31 <johnthetubaguy> BobBall: sure, this is true
17:38:38 <johnthetubaguy> BobBall: OK
17:38:39 <BobBall> See you tomorrow!
17:38:42 <matelakat> see you Bob.
17:38:59 <johnthetubaguy> matelakat: all sounds odd, its a document Ubuntu bug though
17:39:13 <johnthetubaguy> matelakat: have you tried 12.10 to see if it is fixed?
17:39:19 <matelakat> Let me dig out the original bug report.
17:39:48 <matelakat> #link https://bugs.launchpad.net/cinder/+bug/1023755
17:40:15 <matelakat> Look at comment 62: https://bugs.launchpad.net/cinder/+bug/1023755/comments/62
17:40:58 <matelakat> So the message is, that linux-virtual seems to be fine.
17:41:28 <matelakat> if you wanted to test it.
17:41:32 <johnthetubaguy> OK
17:41:48 <johnthetubaguy> could update devstack to do that I guess
17:41:54 <matelakat> I did.
17:41:59 <johnthetubaguy> oh, cool
17:42:02 <johnthetubaguy> thanks
17:42:06 <matelakat> I just linked in the change, so +1 it if you like.
17:42:13 <matelakat> devstack reviews seem to be slow.
17:42:27 <matelakat> Do you know any reviewers, who might worth adding?
17:42:31 <johnthetubaguy> its a busy time
17:42:36 <matelakat> :-)
17:42:44 <johnthetubaguy> not sure for devstack these days, take a look at core
17:42:55 <johnthetubaguy> #topic Open Discussion
17:43:03 <johnthetubaguy> we are sort of doing this already
17:43:09 <johnthetubaguy> is there anything else from people?
17:43:36 <matelakat> not from me.
17:43:41 <johnthetubaguy> I would echo the email form Anne about it being a great time for docs
17:43:49 <matelakat> I have it.
17:43:56 <johnthetubaguy> and I think Russel said friday should be a bug day
17:44:01 <matelakat> y
17:44:21 <johnthetubaguy> to concentrate the mind of folk who are not 100% bug fixing right now
17:44:53 <matelakat> Oh
17:44:53 <johnthetubaguy> anyways, lets wrap up
17:45:00 <johnthetubaguy> #endmeeting