17:07:32 <johngarbutt> #startmeeting XenAPI
17:07:33 <openstack> Meeting started Wed Dec 12 17:07:32 2012 UTC.  The chair is johngarbutt. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:37 <openstack> The meeting name has been set to 'xenapi'
17:07:54 <johngarbutt> Hi all, lets start the XenAPI meeting
17:08:00 <johngarbutt> #link http://wiki.openstack.org/Meetings/XenAPI
17:08:10 <johngarbutt> Usual page has the agenda
17:08:24 <johngarbutt> let's start with blueprints
17:08:30 <johngarbutt> #topic blueprints
17:08:53 <johngarbutt> anyone got any progress to report on blueprints/features?
17:10:05 <johngarbutt> over in citrix we are working on refactoring the volume drivers in nova
17:10:06 <johngarbutt> https://blueprints.launchpad.net/nova/+spec/xenapi-volume-drivers
17:10:11 <johngarbutt> #link https://blueprints.launchpad.net/nova/+spec/xenapi-volume-drivers
17:10:26 <johngarbutt> seems to be getting there
17:10:52 <johngarbutt> anyone else?
17:10:55 <pvo> o/
17:11:08 <pvo> just a hello, that is.
17:11:15 <comstud> ehlo
17:11:15 <BobBall> And a hello from me also.
17:11:24 <johngarbutt> cool, hi people
17:11:35 <johngarbutt> we have pending reviews for this blueprint:
17:11:49 <johngarbutt> (in quantum)
17:11:52 <johngarbutt> #link https://blueprints.launchpad.net/quantum/+spec/xenapi-ovs
17:12:03 <johngarbutt> #link https://review.openstack.org/#/c/15022/
17:12:32 <johngarbutt> this is good work done by internap, so if people can take a look, but maybe more for a quantum specific meeting
17:12:44 <pvo> johngarbutt: I'll see if we can find some folks to take a look at that.
17:12:53 <johngarbutt> awesome, thanks.
17:13:14 <johngarbutt> there is this follow on one two #link https://review.openstack.org/#/c/15023/
17:13:41 <johngarbutt> cool, shall we move on to Docs stuff?
17:13:49 <johngarbutt> #topic docs
17:14:05 <johngarbutt> so we have this doc: http://wiki.openstack.org/HypervisorSupportMatrix
17:14:16 <johngarbutt> I have been updating it now and then
17:14:31 <johngarbutt> are there any major things that are missing
17:15:01 <BobBall> We're very keen to know if there are major items missing from the matrix
17:15:11 <johngarbutt> I spotted networking and storage features, i.e. support for particular vendors seems to be missing
17:15:25 <zykes-> i have a question in terms of things
17:15:36 <zykes-> does stuff now run in vpx machines with xenserver or on ubuntu nodes?
17:16:14 <johngarbutt> ubuntu VM on top of XenServer, or any other linux PV guest for that matter
17:16:32 <zykes-> is it hard to setup contra kvm ?
17:17:09 <johngarbutt> it is a bit harder, because of the extra VM, but devstack does deal with both
17:17:32 <johngarbutt> maybe you raise a good point, we need some docs on how to get started with Ubuntu packages an XenServer
17:17:52 <zykes-> johngarbutt: so you create a vm inside the xenserver?
17:17:54 <zykes-> automated or ?
17:18:01 <johngarbutt> #action raise doc bug for XenAPI in Ubuntu docs
17:18:23 <johngarbutt> depends what you are doing, devstack will create an Ubuntu VM for you, if you run it on your XenServer
17:19:03 <johngarbutt> we should probably take this offline onto #openstack later or the ML?
17:19:08 <comstud> http://wiki.openstack.org/XenServer/Development
17:19:22 <comstud> that contains part of getting a domU set up for nova-compute
17:19:25 <pvo> johngarbutt: are we trying to push more xenserver or xcp? Or that should be the exact same?
17:19:41 <pvo> does the feature lag time between the two matter?
17:19:47 <johngarbutt> And here: https://github.com/openstack-dev/devstack/blob/master/tools/xen/README.md
17:20:04 <annegentle_> #link http://docs.openstack.org/folsom/openstack-compute/install/apt/content/introduction-to-xen.html
17:20:21 <johngarbutt> XenServer vs XCP shouldn't matter in that list
17:20:35 <johngarbutt> which feature lag time were you thinking about?
17:20:40 <zykes-> only sad thing is that xenserver doesn�'t have ceilometer support :)
17:21:07 <johngarbutt> I thought it did have something, armandomi at Internap is a guy who knows
17:21:15 <johngarbutt> not sure it is documented yet...
17:22:21 <zykes-> johngarbutt: got time afterwards to chat a bit ?
17:22:37 <pvo> zykes-: what do you mean there?
17:22:55 <johngarbutt> afraid not today, but certainly should arrange some time soon
17:23:08 <pvo> johngarbutt: I thought the flow was opensource xen -> xcp -> xenserver in terms of feature dev and flow.
17:23:27 <pvo> but maybe I have some of that reversed
17:24:03 <zykes-> just chat about xenserver vs kvm
17:24:40 <johngarbutt> I see you mean, at the moment it is more Xen -> XenServer -> XCP
17:24:50 <johngarbutt> but I think there is a hope to change that
17:25:25 <johngarbutt> and get more people involved at the XCP level, patches are already welcome, just not great process around there yet
17:25:34 <pvo> zykes-: shoudln't ceilometer just take nova message formats?
17:25:47 <pvo> what isn't supported from the xen side?
17:26:22 <johngarbutt> not sure it works like that yet, I herd discussion on people moving that way, but not been tracking it closely enough
17:26:25 <BobBall> pvo, The confusion may have come from a recent XCP which was produced post-XS6.0 but pre-XS6.1 with some XS6.1 features included in it.
17:26:28 <pvo> I think there is interest on our side to get more involved at the XCP level as well.
17:27:05 <pvo> BobBall: maybe so. I know I need to get more visibility into it. Been kinda distracted by this whole "launch a product thing" :)
17:27:18 <zykes-> pvo: cpu pulling i think
17:27:32 <BobBall> Quite understandable! :)
17:27:57 <pvo> zykes-: this is cpu polling of the VMs?
17:28:15 <pvo> I'm actually interested in that as well. Are you using xen/xcp/xenserver and need that?
17:28:34 <zykes-> pvo: atm i'm on kvm, but concidering xen
17:28:51 <pvo> zykes-: is there a bug opened for it  yet?
17:29:41 <zykes-> don't think so
17:29:50 <zykes-> the stuff they poll off of libvirt is what you need
17:30:32 <pvo> zykes-: gotcha.
17:30:45 <johngarbutt> Armando told me there was a XenAPI RRD stuff, but I can't see it in the code now I am looking myself
17:30:51 <pvo> can probably model it the way we do bw.
17:31:03 <pvo> johngarbutt: we had a lot of issues with the rrd code for polling bw
17:31:09 <pvo> BobBall can attest
17:31:31 <johngarbutt> thanks for the heads up! I think bobball mentioned that
17:31:36 <zykes-> how well does SAN disks fare with OpenStack and Xen ?
17:31:59 <BobBall> I'm aware of a polling issue for net devices in XS6.0 but I believe they are resolved in XS6.1
17:32:00 <johngarbutt> if you do iscsi you are fine, roughly
17:32:14 <zykes-> johngarbutt: more like fc :)
17:32:23 <johngarbutt> We are in the process of adding NFS
17:32:54 <johngarbutt> no idea about fc I am afraid, XenServer supports that stuff, but not the OpenStack+XenServer combo at the moment
17:33:04 <johngarbutt> depends exactly what you want to do with your SAN
17:33:24 <zykes-> what is it that decides that johngarbutt ?
17:33:27 <zykes-> a xenapi layer ?
17:34:12 <johngarbutt> well I was more meaning if you want to store all VM disks on the SAN, or if you want to let OpenStack manage your SAN like Volumes that get attached
17:34:30 <zykes-> johngarbutt: both :)
17:34:38 <johngarbutt> OK...
17:34:59 <johngarbutt> do you want to do the first one using boot from volume, that is the best way I guess
17:35:15 <johngarbutt> the issue is getting your SAN vendor supported inside Cinder, does it work with KVM today?
17:35:58 <johngarbutt> the second issue is making that support work with how XenAPI models storage
17:35:59 <zykes-> johngarbutt: HP is working with it :)
17:36:14 <zykes-> and some others (brocade + emc i believe as well)
17:36:30 <johngarbutt> interesting, I would have to look at that, last time I looked they were all iSCSI based
17:36:31 <zykes-> it should be a pretty HOT topic i think since alot of enterprises already have fiberchannel
17:36:34 <zykes-> :p
17:37:12 <johngarbutt> its also a point where they can look at cheaper soutions, but lets get back on topic and make sure we talk more later, sounds interesting
17:37:20 <johngarbutt> any more on docs stuff?
17:37:29 <johngarbutt> did we spot anything missing on that matrix
17:37:42 <pvo> johngarbutt: I don't think so, atm
17:37:47 <johngarbutt> #action look at fiberchannel support in cinder, see if it needs to go on matrix
17:37:51 <johngarbutt> cool
17:38:02 <johngarbutt> lets move on QA
17:38:07 <johngarbutt> #topic QA
17:38:23 <johngarbutt> tomorrow is bug squash day, any big ones people are worries about
17:38:43 <johngarbutt> seems like a good chance to triage the Xen bugs, kick out some old ones, and see if there are some easy things we can fix
17:38:59 <BobBall> Fraid I have to jump now - will catch up on the minutes tomorrow.
17:39:10 <johngarbutt> OK
17:39:32 <pvo> johngarbutt: will review that list and see if we can throw some folks into that tomorrow.
17:39:42 <pvo> can't commit yet though
17:39:42 <zykes-> ofc you can buy cheaper stuff, but if you have existing gear already in place then you get the idea..... you can simply use what you have!
17:40:01 <pvo> johngarbutt: https://bugs.launchpad.net/nova/+bug/1061045 is pretty bad for us.
17:40:03 <uvirtbot> Launchpad bug 1061045 in nova "Failure to set root password leaves instance in ERROR" [High,Confirmed]
17:40:05 <johngarbutt> just for giggles, I am sat in the Cambridge office wearing black tie and dinner suit ready for the christmas party later!
17:40:35 <johngarbutt> ouch
17:41:06 <johngarbutt> there was some talk about this, we need to be able to report some errors but not put the instance into the Errored state
17:41:28 <pvo> yea, I think that was the gist of what Johannes mentioned in the bug
17:41:59 <johngarbutt> ah yes, I see his point, we could avoid the need for the error state
17:42:18 <comstud> i don't understand the API 500 side of that
17:42:22 <comstud> because the API doesn't wait
17:43:11 <johngarbutt> oh, I guess nova-compute  takes so long to return the manager recons the compute is dead
17:43:20 <johngarbutt> maybe it should be doing a cast not a call in the compute api
17:43:25 <johngarbutt> would have to check that
17:43:56 <comstud> set_admin_password is a call
17:43:59 <comstud> building is a cast
17:44:03 <johngarbutt> that would do it
17:44:15 <comstud> the bug report is not clear
17:44:22 <comstud> it must be referring to set_admin_password
17:44:25 <comstud> not building a new instance
17:44:40 <johngarbutt> I think so, we should add a node about that
17:45:11 <johngarbutt> OK, so in other QA news...
17:45:29 <johngarbutt> we are rebuilding our internal QA stuff, just running devstack and tempest
17:45:43 <johngarbutt> and using it to test everything we have added recently
17:45:54 <johngarbutt> NFS, boot from volume, live migration, etc
17:46:09 <johngarbutt> it would be ace to have more public tests
17:46:16 <johngarbutt> in the same vain as smokestack
17:46:34 <johngarbutt> i.e. hooking into gerrit but external
17:47:02 <johngarbutt> or maybe we could try get the CI team to get the existing system to work with XS too?
17:47:12 <johngarbutt> anyone got time to work on that at the moment?
17:47:23 <johngarbutt> does it seem important to you too?
17:47:40 <pvo> johngarbutt: we're look at some of those.
17:47:57 <pvo> our CI team is interfacing with OS CI team to get some of our tests integrated, like SmokeStack
17:48:06 <pvo> I should put you in touch with those guys on our side.
17:48:11 <johngarbutt> awesome, that would be good
17:48:36 <johngarbutt> we are already running devstack with XenServer quite frequently, and had a few ideas to improve things
17:48:48 <pvo> #action pvo to get john in touch with rax CI team
17:48:52 <johngarbutt> with XS 6.1 we should be able to run XenServer in a VM, which could help
17:49:02 <pvo> johngarbutt: ya, looking forward to that.
17:49:21 <johngarbutt> OK moving on to next part
17:49:29 <johngarbutt> (we covered bugs... oops)
17:49:33 <johngarbutt> #topic AOB
17:50:01 <johngarbutt> are people good with this meeting time?
17:50:10 <johngarbutt> is weekly good for people?
17:50:29 <pvo> ya, works for me
17:50:36 <pvo> wiki says its every 2nd Wed of the month
17:50:41 <johngarbutt> will try keep it shorter
17:50:48 <johngarbutt> yes, I was thinking move to weekly
17:50:51 <pvo> so we want to move?
17:50:51 <pvo> ok
17:50:56 <pvo> works for me
17:51:28 <johngarbutt> that we I am less likely to forget, and we can keep them short at meaningful, hopefully
17:51:45 <johngarbutt> awesome, afraid I should run off now
17:51:54 <pvo> sounds good.
17:51:54 <johngarbutt> thanks for coming along
17:51:58 <pvo> thanks john
17:52:01 <johngarbutt> np
17:52:04 <johngarbutt> #endmeeting