19:00:31 <amitgandhinz> #startmeeting Weekly Poppy Meeting
19:00:32 <openstack> Meeting started Thu Dec  4 19:00:31 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:36 <openstack> The meeting name has been set to 'weekly_poppy_meeting'
19:00:41 <amitgandhinz> #topic RollCall
19:00:47 <amitgandhinz> who do we have today
19:00:50 <catherineR> o/
19:01:38 <obulpathi> o/
19:01:59 <miqui__> ..hello poopers...
19:02:03 <miqui__> uuoops
19:02:06 <miqui__> poppers...
19:02:11 <megan_w_> hello poppers :)
19:02:12 <megan_w_> lol
19:02:20 <miqui__> sorry ...
19:02:34 <ycombinator_> o/
19:02:34 <guimarin> lol
19:02:37 <cpowell> o/ ?
19:02:38 <megan_w_> miqui__: is now officially my favorite teammate
19:02:43 <obulpathi> hahha
19:02:45 <miqui__> LOL
19:02:46 <miqui__> LOL
19:03:02 <miqui__> sorry ...too much caffeine...
19:03:07 <cpowell> o/
19:03:15 <amitgandhinz> haha ok
19:03:20 <amitgandhinz> lets get the show on the road
19:03:29 <amitgandhinz> #link https://wiki.openstack.org/wiki/Meetings/Poppy
19:03:46 <amitgandhinz> #topic Review Last Week
19:03:49 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-11-20-19.00.html
19:03:59 <amitgandhinz> only one action item
19:04:06 <amitgandhinz> malini to update guidelines regarding running api tests
19:04:11 <amitgandhinz> malini is out this week
19:04:33 <amitgandhinz> i know the readme files have been updated for running api tests
19:04:42 <amitgandhinz> and some work has been going on around using mimic
19:04:55 <amitgandhinz> there is also a patch out there by cpowell on running mimic docker containers
19:05:33 <amitgandhinz> for those who dont know, mimic lets us intercept requests to third parties so that we can run api tests locally without slowing them down hitting external services
19:05:41 <amitgandhinz> such as fastly, akamai, dns, etc
19:06:10 <miqui__> so it mocks/fakes the call to 3rd party CDNs?
19:06:16 <amitgandhinz> ya
19:06:21 <miqui__> cool..neat..
19:06:22 <miqui__> thahnks.
19:06:33 <tonytan4ever> Hi everyone
19:06:42 <tonytan4ever> sorry I am late
19:06:46 <amitgandhinz> np
19:07:14 <amitgandhinz> #topic Update on Kilo-1
19:07:19 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/kilo-1
19:07:37 <amitgandhinz> ok so kilo-1 cycle officially ended yesterday
19:07:47 <amitgandhinz> so i will be cutting a release today for it
19:08:09 <amitgandhinz> theres a few outstanding items that need their final +1's so if i can merge them after this meeting that would be cool
19:08:16 <amitgandhinz> so...lets go through the list
19:08:27 <amitgandhinz> tonytan4ever: Create caching rules for whole site or specific content
19:08:34 <amitgandhinz> specifically akamai caching rules
19:08:40 <amitgandhinz> (fastly was already merged)
19:08:43 <tonytan4ever> Yeah
19:08:57 <amitgandhinz> https://review.openstack.org/#/c/138449/
19:09:00 <tonytan4ever> I finished up Akamai and now just need another +1
19:09:11 <amitgandhinz> please review this everyone!
19:09:21 <obulpathi> I have reviewd it
19:09:25 <obulpathi> I think ready to be merged
19:09:37 <tonytan4ever> cool.
19:09:45 <amitgandhinz> approved!
19:10:05 <amitgandhinz> obulpathi: 	Rackspace Cloud DNS Driver
19:10:11 <obulpathi> Its done
19:10:15 <obulpathi> It need sa +1
19:10:20 <tonytan4ever> I just +1ed on this one.
19:10:21 <amitgandhinz> tonytan4ever: just +1'd it
19:10:22 <obulpathi> needs a +1
19:10:22 <amitgandhinz> haha
19:10:28 <obulpathi> cool
19:10:33 <obulpathi> it is ready to ber merged
19:10:36 <amitgandhinz> approved!
19:10:58 <obulpathi> thanks!
19:11:02 <amitgandhinz> the following two bp )DNS driver and Defautl DNS driver are related
19:11:16 <obulpathi> yep
19:11:25 <obulpathi> they are part of the same pr
19:11:28 <amitgandhinz> malini: 	Specify provider url in the conf file
19:11:36 <amitgandhinz> i know she fixed it for the fastly provider
19:11:42 <amitgandhinz> i think the other ones remain still
19:11:47 <amitgandhinz> i will move this bp to kilo-2
19:12:26 <amitgandhinz> okay
19:12:38 <amitgandhinz> i also moved other bp that i knew werent done yet to kio-2
19:12:57 <amitgandhinz> lets go through the bugs, and then we can take a look at whats planned for k-2
19:13:08 <amitgandhinz> #topic bugs
19:13:36 <amitgandhinz> https://bugs.launchpad.net/bugs/1392578
19:13:37 <uvirtbot> Launchpad bug 1392578 in poppy "Next link in GET /services is incorrect" [High,Triaged]
19:14:03 <amitgandhinz> ycombinator_: can you take a look at this again?
19:14:25 <ycombinator_> yes, as soon as I get fastly credentials and get rid of that error
19:14:28 <amitgandhinz> i think this bug is resolved by the enforcement of project_id
19:14:43 <amitgandhinz> ok, i will assign this to you
19:14:46 <ycombinator_> thanks
19:15:19 <amitgandhinz> done, also moved it to k2
19:15:29 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1392568
19:15:31 <uvirtbot> Launchpad bug 1392568 in poppy "Cannot GET service with name containing dot" [Medium,Triaged]
19:15:50 <amitgandhinz> this also seemed related to the missing projectid issue
19:16:15 <amitgandhinz> mind if i reassign to you ycombinator_ to confirm its fixed?
19:16:22 <ycombinator_> no problem
19:17:02 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1393558
19:17:03 <uvirtbot> Launchpad bug 1393558 in poppy "api-tests fail when flavor doesn't exist" [Medium,In progress]
19:18:09 <amitgandhinz> i think this was merged already
19:18:12 <amitgandhinz> looking for patch...
19:19:07 <amitgandhinz> yes it was fixed as part of this: https://review.openstack.org/#/c/136505/
19:20:02 <amitgandhinz> ok so that brings the K1 cycle to an end
19:20:34 <amitgandhinz> everyone deserves a round of applause as that also completes the core functionality we were targeting
19:20:42 <amitgandhinz> good job everyone =)
19:20:58 <obulpathi> :)
19:21:00 <tonytan4ever> \o/
19:21:01 <amitgandhinz> i will cut the release soon
19:21:03 * edward-fastly golf clap
19:21:21 <miqui__> good job folks...
19:21:39 <amitgandhinz> ok, now moving attention to Kilo-2 cycle...
19:21:41 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/kilo-2
19:22:01 <amitgandhinz> the focus on this milestone is to solidify a lot of what was done in K-1
19:22:20 <amitgandhinz> so you will see many bugs that need squishing have been bought over to here
19:22:34 <amitgandhinz> also there is some tech debt that we need to take care of
19:23:14 <miqui__> amitgandhinz:  what is the tech debt [recisely?
19:23:26 <amitgandhinz> eg the message queue driver
19:23:47 <tonytan4ever> Oh, we gotta pay that one.
19:23:49 <amitgandhinz> basically the async workers we have now are ok, but it would scale better using a queue (rabbit, zaqar) etc
19:24:04 <amitgandhinz> we also need to refactor the spotlight stuff
19:24:07 <miqui__> you mean learn about the specific backend?
19:24:10 <amitgandhinz> get to py34
19:24:16 <miqui__> like rabbit...zero, zaqer et.c..
19:24:35 <tonytan4ever> That's the 'backend' for queue driver
19:24:54 <miqui__> ...right....
19:24:57 <amitgandhinz> so rather than spawn threads to call out to the cdn providers and dns, we post a message on to a queue, and then have scalable workers that perform the task (eg call out to the cdn provider)
19:25:13 <cpowell> celery?
19:25:21 <amitgandhinz> celery could also be an option
19:25:23 <tonytan4ever> celery is a good candidate I think.
19:25:24 <miqui__> celery + rabbit?
19:25:34 <amitgandhinz> but celery is shy'ed upon
19:25:38 <cpowell> boo
19:25:40 <miqui__> hmm....
19:25:45 <amitgandhinz> i know the barbican team (i think) had incubation comments around it
19:26:23 <obulpathi> with celery we can improve the throughput of poppy by a factor atleast 10X
19:26:27 <amitgandhinz> #link http://lists.openstack.org/pipermail/openstack-tc/2013-December/000432.html
19:26:50 <obulpathi> its not anything specific with celery, but the processor backend for celery supports gevent
19:27:03 <amitgandhinz> but we should support it as a potential driver
19:27:11 <obulpathi> which means we can have potentially hundreds of requests simultaneously going on
19:27:27 <tonytan4ever> And I think Zaqar is not as suitable as celery in this instance.
19:27:31 <obulpathi> with process based queue mechanism, scalability will still be an issue
19:27:35 <tonytan4ever> We can talk about it later.
19:27:39 <amitgandhinz> i agree
19:27:53 <amitgandhinz> when we get to that blueprint lets have a design disussion on it
19:27:58 <obulpathi> +1
19:28:07 <miqui__> +1
19:28:14 <tonytan4ever> sure.
19:28:31 <amitgandhinz> #action amitgandhinz to set up a design discussion on the Message Queue Driver
19:29:08 <amitgandhinz> i will also do some work to pull some more bp's into the k2 cycle
19:29:18 <amitgandhinz> fyi, k-2 goes until Jan 22
19:29:26 <miqui__> i use draw.io for diagrams....
19:29:29 <amitgandhinz> so not that far out with the holidays
19:29:49 <obulpathi> oh its really short
19:30:13 <amitgandhinz> yeh the cycles are really only 1.5 months
19:30:17 <obulpathi> oh ok
19:30:21 <amitgandhinz> we just werent following them until now =P
19:30:24 <obulpathi> I though they are 2 months
19:30:29 <miqui__> me too..
19:30:49 <amitgandhinz> no, they allow time at the end between the end of k3 and the release for bug fiing
19:30:51 <amitgandhinz> fixing
19:31:00 <amitgandhinz> basically a feature freeze
19:31:17 <amitgandhinz> openstack cycles are 6 months total
19:31:24 <obulpathi> oh ok, got it
19:31:39 <tonytan4ever> So work harder or less bps ?
19:31:45 <tonytan4ever> in k-2 ?
19:31:58 <amitgandhinz> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
19:32:27 <amitgandhinz> in k2 we should focus on bugs, testing, etc and things that improve the work done in k1
19:32:40 <amitgandhinz> basically lets make what we have done so far nice and solid
19:32:50 <miqui__> a hip sprint...
19:32:50 <tonytan4ever> Understood.
19:33:11 <obulpathi> ok
19:33:31 <amitgandhinz> i will do more grooming of the k2 plan in the coming days
19:34:04 <amitgandhinz> ok moving on
19:34:08 <amitgandhinz> #topic new items
19:34:15 <amitgandhinz> nothing was set on the agenda here
19:34:30 <amitgandhinz> kind of alreayd covered the k1/k2 discussion i was going to have =p
19:34:36 <amitgandhinz> #topic open discussion
19:34:44 <amitgandhinz> anyone have anything else they want to discuss?
19:34:54 <miqui__> i do have an item, related to 'home doc' bp.. thanks amitgandhinz for the access
19:34:56 <miqui__> i can now edit...
19:35:14 <miqui__> ..now learning pecan routing so i can figure out the routes to document
19:35:45 <miqui__> it would help me a lot if you guys can email me the routes you have in place so that i can put them in apiary.io
19:36:17 <amitgandhinz> the apiary docs should already list the endpoints that exist
19:36:18 <miqui__> at the end of the day all of you can review the home doc and see if anything is missing or not...
19:36:45 <miqui__> right amitgandhinz... but am not sure yet...am going through the code
19:36:47 <amitgandhinz> you can also see the routes we have in pecan under the /poppy/transport/pecan/v1/... folder
19:36:55 <miqui__> yup....
19:37:26 <amitgandhinz> this might help: https://github.com/stackforge/poppy/blob/master/poppy/transport/pecan/driver.py#L55
19:37:41 <miqui__> ..jsut not used to pecan object routing.... in some other frameworks can you easily see the routes...
19:37:46 <miqui__> ...but thats my problem....
19:38:07 <amitgandhinz> as long as you cover the top level endpoints like /services then the user can follow the endpoints to get to the rest
19:38:18 <miqui__> hmm k...
19:38:20 <amitgandhinz> you dont need to list each service the user has in the home doc
19:39:11 <miqui__> amitgandhinz:  so basically once the user can see the json payload of the services... then he/.she can see the rest...
19:39:17 <amitgandhinz> yes
19:39:29 <amitgandhinz> a good example is the zaqar home doc: https://wiki.openstack.org/wiki/Zaqar/specs/api/v1
19:39:31 <miqui__> k.. sounds good.. thanks for the heads up...
19:40:01 <amitgandhinz> basically you output the link to /services, /health, /ping, /flavors
19:40:03 <miqui__> k. thanks..
19:40:13 <amitgandhinz> and the hints (GET, POST, DELETE) etc that are available on each endpoint
19:40:14 <miqui__> yeah seen similar doc pattern.. thanks
19:40:31 <miqui__> k, am set for now.. thanks amitgandhinz
19:40:33 <amitgandhinz> once the user follows /services, they will be exposed the links to each one of their services
19:40:34 <amitgandhinz> cool
19:40:50 <amitgandhinz> ok, any other questions?
19:41:03 <tonytan4ever> Not really questions, https://review.openstack.org/#/c/138449/
19:41:09 <tonytan4ever> needs another round of +1
19:41:18 <tonytan4ever> because of merge conflict.
19:41:23 <amitgandhinz> ok
19:41:29 <obulpathi> will do it
19:42:05 <tonytan4ever> thanks guys.
19:42:27 <amitgandhinz> ok, anything else?
19:42:42 <miqui__> not fromme...
19:43:20 <amitgandhinz> only other comment is lets make sure we are reviewing code on a regular basis
19:43:32 <amitgandhinz> everyone reviews
19:44:34 <amitgandhinz> ok, if there is nothing else....
19:44:39 <amitgandhinz> thanks everyone!
19:44:55 <miqui__> cya...
19:45:01 <tonytan4ever> see you guys later in poppy channel.
19:45:08 <amitgandhinz> later
19:45:14 <amitgandhinz> #endmeeting