18:59:55 <amitgandhinz> #startmeeting Weekly Poppy Meeting
18:59:56 <openstack> Meeting started Thu Oct 30 18:59:55 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:00 <openstack> The meeting name has been set to 'weekly_poppy_meeting'
19:00:06 <amitgandhinz> #topic RollCall
19:00:16 <tonytan4ever> \o
19:00:20 <amitgandhinz> o/
19:00:31 <catherin_> o/
19:00:40 <tonytan4ever> What does this sign o/ mean ?
19:00:55 <amitgandhinz> its a face and one hand up waving
19:00:56 <megan_w_> its a little guy waving his hand
19:00:57 <malini> o/
19:01:04 <megan_w_> o/
19:01:12 <amitgandhinz> tonytan4ever: must be left handed =P
19:01:15 <tonytan4ever> OK so I wasn't wrong, I am just waing my left hand
19:01:19 <malini> \o/
19:01:22 <obulpathi> o/
19:02:00 <amitgandhinz> ok looks like most of us are here
19:02:01 <obulpathi> malini is super happy
19:02:20 <malini> I was just letting folks know that I have two hands
19:02:23 <amitgandhinz> #topic last week tonight with amitgandhinz
19:02:41 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-10-23-19.00.html
19:02:47 <amitgandhinz> no action items
19:02:48 <malini> tht toic sounds very scary
19:02:50 <amitgandhinz> that was easy
19:03:29 <amitgandhinz> malini: its a play on the hbo show last week tonight with john oliver
19:03:42 <amitgandhinz> #topic blueprints
19:03:51 <amitgandhinz> #link https://blueprints.launchpad.net/poppy
19:03:57 <amitgandhinz> obulpathi: dns driver
19:04:21 <obulpathi> i started it
19:04:30 <obulpathi> have basic code
19:04:33 <amitgandhinz> slow or good progress?
19:04:42 <obulpathi> good progress :)
19:04:54 <obulpathi> but it is coming slowly
19:04:54 <amitgandhinz> cool
19:05:03 <amitgandhinz> thats a contradiction lol
19:05:11 <malini> slow and steady
19:05:12 <amitgandhinz> obulpathi: caching-rules
19:05:19 <obulpathi> have not started it yet
19:05:42 <obulpathi> once I get the patch merged, I will pick it up
19:05:47 <amitgandhinz> ok
19:05:56 <amitgandhinz> migui does not seem to be around today
19:06:15 <amitgandhinz> tonytan4ever: purge-content
19:06:22 <tonytan4ever> It's under review
19:06:29 <tonytan4ever> More reviews are welcome
19:06:30 <amitgandhinz> are ppl reviewing it?
19:06:51 <amitgandhinz> hmm it looks like its ready to merge
19:07:00 <amitgandhinz> oh wait wrong patch ehhe
19:07:31 <amitgandhinz> https://review.openstack.org/#/c/129674/
19:07:39 <amitgandhinz> you have a -1 from malini to work on
19:07:48 <tonytan4ever> got one comment to address
19:07:55 <tonytan4ever> Should be able to address quickly.
19:07:57 <malini> tht was moreof q uestion for everybody
19:08:13 <malini> But we can dicsuss it in #openstack-poppy
19:08:18 <amitgandhinz> ok
19:08:26 <tonytan4ever> or in open discussion
19:08:30 <amitgandhinz> amitgandhinz: queue-driver
19:08:42 <amitgandhinz> we need to ban tonytan4ever's space bar
19:08:55 <tonytan4ever> I banned it.
19:08:58 <amitgandhinz> queue-driver is being dev'd by the team this hackday hehe
19:08:58 <obulpathi> hhaha
19:09:01 <malini> thtwillbebad
19:09:22 <amitgandhinz> obulpathi: patch-service
19:09:37 <obulpathi> there are few final details to be ironed out
19:09:48 <obulpathi> so its still in the same state
19:09:58 <amitgandhinz> ok
19:10:21 <amitgandhinz> tonytan4ever: set-restrictions
19:10:31 <tonytan4ever> that one is under review as well.
19:10:43 <tonytan4ever> Could use more reviews on that one.
19:11:04 <amitgandhinz> yup.  i had some minor nits, but please others review it also
19:11:17 * amitgandhinz the patch, not my nits =P
19:11:18 <obulpathi> ok
19:11:39 <amitgandhinz> ok on to bugs
19:11:42 <amitgandhinz> #topic bugs
19:11:53 <amitgandhinz> #link https://bugs.launchpad.net/poppy
19:12:23 <amitgandhinz> i see 2 new ones
19:12:25 <tonytan4ever> one sec
19:12:39 <amitgandhinz> ?
19:12:51 <tonytan4ever> amitgandhinz: I need you to assign the akamai-driver bp to me before we jumping into bugs.
19:12:58 <malini> I updated apiary for this one https://bugs.launchpad.net/poppy/+bug/1386315
19:12:59 <uvirtbot> Launchpad bug 1386315 in poppy "Undocumented "name" property in POST /services error response JSON" [Undecided,New]
19:13:27 <amitgandhinz> done
19:13:32 <tonytan4ever> kk
19:13:38 <amitgandhinz> ok bugs...
19:14:10 <amitgandhinz> can that be closed now malini?
19:14:22 <malini> yes
19:14:41 <amitgandhinz> done
19:14:42 <amitgandhinz> https://bugs.launchpad.net/poppy/+bug/1386141
19:14:45 <uvirtbot> Launchpad bug 1386141 in poppy "Create Flavor - limit value not stored in Cassandra" [Undecided,New]
19:14:57 <amitgandhinz> this looks like a duplicate of https://bugs.launchpad.net/poppy/+bug/1381114
19:14:59 <uvirtbot> Launchpad bug 1381114 in poppy "Create Flavor - Flavor Limits not validated or saved" [Medium,Confirmed]
19:15:18 <malini> no..
19:15:23 <malini> phew..tht was close
19:15:50 <malini> well it is :/
19:15:57 <malini> :'(
19:16:08 <malini> I lost a new bug..
19:16:10 * amitgandhinz phew!
19:16:13 <malini> lets close the new one
19:16:16 <amitgandhinz> which one can we close
19:16:17 <amitgandhinz> ok
19:16:53 <malini> next time I will get a really NEW one
19:17:19 <amitgandhinz> not on my watch !
19:17:26 <amitgandhinz> =P
19:17:41 <amitgandhinz> any thing else on bugs?
19:17:44 <malini> tht is why I test at night BWAHAAHAAA
19:18:09 <malini> nope
19:18:21 <amitgandhinz> #topic Paris
19:18:31 <obulpathi> one more bug: https://bugs.launchpad.net/poppy/+bug/1384271
19:18:32 <uvirtbot> Launchpad bug 1384271 in poppy "List Services - NON ASCII limit causes poppy to return 500" [Medium,Confirmed]
19:18:34 <obulpathi> this one is fixed
19:18:40 <amitgandhinz> #link https://etherpad.openstack.org/p/poppy-design-session-paris
19:19:04 <amitgandhinz> obulpathi:  is that merged?
19:19:22 <obulpathi> yes sir
19:19:23 <amitgandhinz> also in the patch commit message you can put Closes Bug: 12345 and it updates the bug
19:19:42 <obulpathi> ok, will do
19:19:54 <amitgandhinz> updated.
19:19:57 <amitgandhinz> ok paris...
19:20:11 <amitgandhinz> so i think we finalized the agenda for the design session
19:20:33 <malini> wooot!
19:20:36 <amitgandhinz> basically do a 10m intro on poppy (basically the slides i will do in the brown bag)
19:21:10 <amitgandhinz> so that will be about 15 min all up from intro to slides
19:21:27 <amitgandhinz> then i want to spend the majority of the time talking about how poppy can integrate with swift
19:21:32 <amitgandhinz> learn about the challenges
19:21:45 <amitgandhinz> what features we need to support etc
19:21:59 <amitgandhinz> and hopefully come up with a list of things for the poppy team to do and maybe the swift team to do
19:22:38 <amitgandhinz> any comments on this?
19:23:28 <amitgandhinz> i think between all the logging work, getting production ready, and swift integration, that will take us to May for the L summit
19:23:29 <obulpathi> looks like a good plan
19:23:55 <amitgandhinz> megan_w_: comments?
19:24:01 <tonytan4ever> I am fine with this plan too.
19:24:16 <megan_w_> i thikn this looks good
19:24:29 <megan_w_> i think people will be ready for custom ssl, though
19:24:35 <amitgandhinz> probably
19:24:39 <megan_w_> we're already hearing it from our sales reps
19:24:45 <megan_w_> many people consider CDN useless without it
19:24:50 <amitgandhinz> but i think thats a discussion to be had directly with cdn providers
19:25:00 <amitgandhinz> rather than other openstack teams
19:25:05 <megan_w_> agreed
19:25:19 <megan_w_> just made the comment since you said those items would take us through may
19:25:32 <megan_w_> we may need to find room for ssl in the roadmap before then
19:25:35 <amitgandhinz> im sure there will be more but im just looking at priority list
19:25:44 <megan_w_> ya
19:25:45 <amitgandhinz> unless you think ssl is more important than swift
19:25:56 <megan_w_> i don't
19:26:00 <amitgandhinz> ok
19:26:41 <amitgandhinz> alright.....anything else to discuss about paris?
19:26:50 <malini> cheese?
19:27:06 <amitgandhinz> im going to try to stand at the expo booth on monday, and then design and brownbag on tuesday
19:27:11 <amitgandhinz> and then cheese and wine on wednesday
19:27:18 <megan_w_> sounds like a good week
19:27:23 <megan_w_> represent us well
19:27:30 <megan_w_> and take business cards!
19:27:45 <amitgandhinz> ah yes, must use them up
19:27:59 * amitgandhinz takes them out of drawer and dusts of the webs
19:28:11 <megan_w_> yeah, i figured that might be the case :)
19:28:21 <obulpathi> he literally did it
19:28:25 <malini> :D
19:28:26 <megan_w_> lol
19:28:28 <obulpathi> amitgandhinz, I mean
19:28:59 <amitgandhinz> ok, moving on
19:29:03 <amitgandhinz> #topic open discussion
19:29:12 <amitgandhinz> 31 min remaining to chat about whatever
19:29:26 <amitgandhinz> or we could get back to working =P
19:29:30 <obulpathi> so talking about ssl
19:29:34 <malini> tonytan4ever had something with spaces
19:29:39 <obulpathi> are there are plans to look into keyless ssl
19:29:48 <obulpathi> ?
19:29:49 <amitgandhinz> thats the SNI stuff?
19:29:50 <tonytan4ever> Let's chat about one comment to my patchset
19:29:59 <tonytan4ever> https://review.openstack.org/#/c/129674/7/poppy/manager/default/service_async_workers/purge_service_worker.py
19:29:59 <amitgandhinz> ok SSL first
19:29:59 <obulpathi> SNI?
19:30:28 <amitgandhinz> http://en.wikipedia.org/wiki/Server_Name_Indication
19:31:00 <megan_w_> yes, SNI is becoming a standard poor-mans ssl
19:31:05 <megan_w_> and it's plenty for a lot of cusotmres
19:31:09 <amitgandhinz> http://aws.amazon.com/cloudfront/custom-ssl-domains/
19:31:16 <megan_w_> i'd like for us to investigate it
19:31:20 <obulpathi> not sure if the SNI and key less ssl means the same
19:31:21 <obulpathi> https://www.cloudflare.com/keyless-ssl
19:31:34 <megan_w_> if we can get SNI done quickly, it buys us more time for custom SSL certificates
19:32:37 <amitgandhinz> with keyless SSL it sounds like something the CDN providers have to support
19:32:49 <amitgandhinz> since the traffic is NOT going through the operators
19:32:55 <megan_w_> amitgandhinz: is that the same as SNI?
19:33:13 <amitgandhinz> it looks similar
19:33:14 <megan_w_> maybe someone should spike this
19:33:23 <amitgandhinz> i think SNI is slightly different
19:33:42 <amitgandhinz> keyless is where cloudfront encrypts, decrypts, and reenvrypts the traffic
19:34:04 <obulpathi> yes, keyless required CDN providers to support it
19:34:08 <amitgandhinz> SNI is a shared IP with a cert on it
19:34:25 <megan_w_> SNI is basically a shared cert, right?
19:34:31 <amitgandhinz> ya
19:34:36 <megan_w_> as you just said..
19:34:48 <amitgandhinz> its more of a shared ip
19:34:52 <megan_w_> ..sounds like both require provider support
19:34:52 <amitgandhinz> with multiple certs on it
19:34:56 <amitgandhinz> yup
19:35:16 <amitgandhinz> at the end of the day, poppy should be just enabling exisitng features
19:35:25 <amitgandhinz> and making that provisioning easier
19:35:54 <amitgandhinz> so poppy could be responsible for sharing the cert keys etc (via barbican?) and then the rest is on the providers
19:36:07 <megan_w_> i am unclear about what "the rest" is
19:36:08 <amitgandhinz> i think this requrires more spiking though
19:36:12 <megan_w_> agreed
19:36:18 <obulpathi> agreed
19:36:25 <megan_w_> i can start conversations with some of the providers if you'd like
19:36:30 <megan_w_> you can give me the action
19:36:31 <amitgandhinz> "the rest" is using the cert, encrypting the traffic, etc
19:36:57 <amitgandhinz> #action megan_w_ to start investigation SNI and Keyless SSL
19:37:17 <amitgandhinz> ok, lets move on to tony's patch
19:37:44 <tonytan4ever> This is the link:https://review.openstack.org/#/c/129674/7/poppy/manager/default/service_async_workers/purge_service_worker.py
19:37:58 <tonytan4ever> see malini's comment inbetween
19:38:06 <amitgandhinz> i think i agree with malini
19:38:13 <amitgandhinz> purge all should be intentional
19:38:47 <amitgandhinz> what if we say the purge url has to be provided and purge all happens if they pass in '/'
19:38:50 <malini> make it ?url=all ??
19:39:02 <amitgandhinz> nah
19:39:10 <amitgandhinz> what if they have a folder called all lol
19:39:14 <malini> :D
19:39:19 <tonytan4ever> url=/ ?
19:39:25 <amitgandhinz> thats what im thinking
19:39:28 <obulpathi> * ?
19:39:29 <malini> I didnt like the url part either
19:40:04 <amitgandhinz> what if they leave the url param out and provide something else instead
19:40:29 <amitgandhinz> ?url=.... will purge a url.   ?all=true will purge all
19:40:51 <obulpathi> good idea
19:40:54 <tonytan4ever> I like this one.
19:40:55 <obulpathi> since anything can be in url
19:40:58 <tonytan4ever> all=True
19:40:59 <malini> me too
19:41:35 <megan_w_> seems like the right format
19:41:48 <amitgandhinz> what is the full url?
19:41:58 <malini> DELETE /services/{service_name}/assets{?url}
19:42:20 <amitgandhinz> ok
19:42:26 <amitgandhinz> so we all agreed?
19:42:33 <obulpathi> +1
19:42:43 <catherin_> I'm witing this down! :)
19:42:50 <tonytan4ever> I agree.
19:42:56 <malini> we agree too easily :d
19:43:20 <amitgandhinz> #agreed purge all requires a ?all=True parameter instead of ?url=blank
19:43:28 <amitgandhinz> now is it true or True
19:43:34 <tonytan4ever> yeah
19:43:42 <malini> tht is test case for me :D
19:43:54 <amitgandhinz> i like lowercase
19:44:10 <catherin_> can it be either?
19:44:13 <obulpathi> lowercase if good in urls
19:44:23 <malini> why cant it be either?
19:44:28 <obulpathi> lowarecase is good in urls
19:44:31 <amitgandhinz> it can, but lets document it in lowercase
19:45:10 <amitgandhinz> cool
19:45:11 <obulpathi> +1
19:45:17 <amitgandhinz> any other topics to discuss/
19:45:18 <catherin_> got it!
19:46:09 <malini> none from me..
19:46:15 <malini> do well in Paris amitgandhinz!
19:46:42 <amitgandhinz> thanks!
19:46:47 <megan_w_> just don't hold the mic all ghetto like kurt did
19:46:53 <amitgandhinz> hahahaha
19:46:55 <megan_w_> you'll do great
19:47:05 <catherin_> wear your chapeau!
19:47:09 <megan_w_> lol
19:47:11 <amitgandhinz> i feel i need to buy some beats by dre now
19:47:21 <megan_w_> aaaaand we're off
19:47:28 <amitgandhinz> #endmeeting