14:02:51 <csatari> #startmeeting Weekly Edge Computing Group Call
14:02:52 <openstack> Meeting started Tue Jun 26 14:02:51 2018 UTC and is due to finish in 60 minutes.  The chair is csatari. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:55 <openstack> The meeting name has been set to 'weekly_edge_computing_group_call'
14:03:02 <csatari> #topic Roll Call
14:03:40 <esarault_> #info Eric Sarault eric.sarault@kontron.com
14:04:02 <csatari> #topic Action items
14:04:15 <ildikov> #Ildiko Vancsa (IRC only)
14:04:38 <csatari> #topic Alternating meeting slots
14:04:56 <mbeierl> #info Mark Beierl mark.beierl@dell.com
14:05:14 <csatari> #info APAC slot is: every first Thursday of the month at 0700 UTC
14:05:22 <csatari> #info First APAC slot is Thursday, 5th of July
14:05:48 <csatari> #topic Use Case sub-group
14:06:15 <csatari> #info The template was updated.
14:06:25 <csatari> #link https://etherpad.openstack.org/p/feedback_on_template
14:08:03 <csatari> #info Anyone is fee to add use cases following the template to here: https://wiki.openstack.org/wiki/Edge_Computing_Group/Use_Cases
14:09:14 <csatari> #info We should have a status field for the use cases what indicated if ti is under disucssion or verified.
14:10:06 <mbeierl> #link https://gerrit.opnfv.org/gerrit/#/c/58959/
14:10:15 <csatari> #info OPNFV Edge team also started to write use cases: https://gerrit.opnfv.org/gerrit/#/c/58959/
14:11:06 <csatari> #info Expectation is to finalize the use cases by end of july
14:11:27 <csatari> #info Please add your comments to https://etherpad.openstack.org/p/feedback_on_template
14:11:55 <csatari> #topic Dublin PTG follow-up discussion
14:12:09 <csatari> #info Regular review meeting: Every Thursday 16-17h CET
14:12:32 <csatari> #info Starting from this week.
14:14:13 <csatari> #topic Glance
14:14:46 <csatari> #action Gerg0 to initiate a mail discussion about the pros and cons of the Glance architecture options
14:14:59 <csatari> #topic Keystone
14:15:51 <csatari> #link https://etherpad.openstack.org/p/ECG_Keystone_Testing
14:17:28 <csatari> #info OPNFV Edge Meeting tomorow from 1300 UTC: https://zoom.us/j/5014627785
14:17:34 <rcherrueau> Note that, in the FEMDC we did few weeks ago an evaluation of Keystone at the Edge based on database replication. Results are available online, but it is still a WIP: https://beyondtheclouds.github.io/blog/openstack/cockroachdb/2018/06/04/evaluation-of-openstack-multi-region-keystone-deployments.html
14:18:29 <rcherrueau> I encourage you to read the blog post if you are interested, even if results should still be analyzed
14:18:49 <csatari> #action Gerg0 to send the OPNFV Edge meeting details to the edge couputing maiing list
14:19:04 <ildikov> rcherrueau: thanks for sharing
14:19:27 <ildikov> rcherrueau: I will add the list no to the Edge Group wiki
14:19:40 <rcherrueau> ildikov: OK thanks
14:21:31 <csatari> #info There is an onging disucssion about the behaviour of K2K federation when there is a network connectivity issue between the Keystones
14:22:22 <csatari> #info No network issues inside the edge cloud instance, but the edge cloud instance is isolated from the rest of the edge cloud infrastructure
14:23:28 <csatari> #info In this case a manually added SAML info can be provided to Keystone
14:24:55 <csatari> #info There is also support for application credentials which also provides a solution for the problem.
14:26:31 <csatari> #info Basic diagram describing federated authentication workflows: https://bit.ly/2yJ0eGp
14:28:57 <csatari> #info Even more details: https://bit.ly/2HmXySC
14:32:48 <csatari> #info Users are replicated to the edge cloud instance using the shadow users
14:33:27 <csatari> #info To replicate the projects there is a feature called federated autoprovisioning.
14:33:49 <csatari> #link https://docs.openstack.org/keystone/queens/user/application_credentials.html
14:33:58 <csatari> #link https://docs.openstack.org/keystone/latest/advanced-topics/federation/federated_identity.html#auto-provisioning
14:36:27 <csatari> #info StartlingX does not use K2K federation at the moment. It uses https://wiki.openstack.org/wiki/Keystone_edge_architectures#Keystone_API_Synchronization_.26_Fernet_Key_Synchronization
14:39:33 <csatari> #topic AoB
14:39:50 <csatari> #info N/A
14:40:09 <csatari> #endmeeting