13:00:28 <alexchadin> #startmeeting watcher
13:00:30 <openstack> Meeting started Wed Nov 22 13:00:28 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:33 <openstack> The meeting name has been set to 'watcher'
13:00:39 <alexchadin> hi!
13:00:41 <Yumeng__> hi
13:00:45 <alexchadin> Agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F22.2F2017
13:02:20 <alexchadin> Yumeng__: let's discuss some things
13:02:28 <alexchadin> #topic Open Discussions
13:02:33 <alexchadin> Shouldn't we deprecate Ceilometer support in future release?
13:02:55 <alexchadin> Yumeng__: what do you think about it?
13:03:14 <alexchadin> first of all, I talk about datasource
13:05:01 <Yumeng__> alexchadin: in Sydney we discussed that
13:05:20 <Yumeng__> NEC use ceilometer for POC
13:05:43 <Yumeng__> and goncci for production
13:06:17 <alexchadin> Yumeng__: ceilometer-api is deprecated since Ocata
13:07:00 <Yumeng__> And ZTE use ceilometer for production, but we are considering replace ceilometer with gnocchi cause ceilometer is slow
13:07:38 <Yumeng__> I think we can keep that for a while since ceilometer is still used in production
13:08:11 <Yumeng__> Stop maintain ceilometer
13:08:29 <alexchadin> Yumeng__: I've seen this patch today: https://review.openstack.org/#/c/522183/
13:08:47 <Yumeng__> Support and maintain gnocchi
13:10:19 <alexchadin> Yumeng__: many things we are planning to do with Watcher works with Gnocchi mostly (and Monasca sometimes)
13:10:45 <alexchadin> Yumeng__: I'd propose to set gnocchi as default datasource at least
13:11:12 <suzhengwei> agree
13:12:33 <Yumeng__> ok.
13:12:43 <alexchadin> and to mark ceilometer as deprecated in future releases (by using appropriate logging)
13:12:43 <Yumeng__> It’s ok for me
13:12:57 <alexchadin> ok
13:13:06 <alexchadin> #action alexchadin mark ceilometer as deprecated
13:13:18 <alexchadin> It would be good to test HA in Watcher (Pike, master) using haproxy + keepalived (other proposals?)
13:13:33 <alexchadin> suzhengwei: I've seen your thread with hidekazu about HA
13:14:09 <alexchadin> suzhengwei: you've done it with Ocata, right?
13:14:17 <suzhengwei> yes
13:14:37 <alexchadin> suzhengwei: did you use haproxy + keepalived?
13:14:55 <suzhengwei> yes, but watcher doesn;t support haproxy.
13:15:21 <alexchadin> suzhengwei: yeap, I've seen your bug
13:15:47 <alexchadin> suzhengwei: I'll try to investigate it and to run Pike Watcher in HA mode
13:15:59 <suzhengwei> ok
13:16:24 <alexchadin> let's move on to Review Action Items
13:16:25 <suzhengwei> do you have some clue?
13:16:38 <alexchadin> suzhengwei: not yet
13:16:43 <alexchadin> #topic Review Action Items
13:16:49 <alexchadin> Watcher specs
13:16:57 <alexchadin> exclude locked instances needs to be updated #link https://review.openstack.org/#/c/506078/
13:18:40 <alexchadin> cluster-maintenance-strategy needs reviews #link https://review.openstack.org/#/c/464602/
13:19:01 <Yumeng__> I can review again
13:19:46 <alexchadin> me too, although it's mostly LGTM
13:19:59 <alexchadin> #action Yumeng__ alexchadin review https://review.openstack.org/#/c/464602/
13:20:13 <alexchadin> Add storage capacity balance Strategy needs to be updated #link https://review.openstack.org/#/c/501659/
13:20:33 <Yumeng__> Ops... I will update
13:20:36 <alexchadin> Yumeng__: +1
13:20:52 <alexchadin> #action Yumeng__ submit new PS https://review.openstack.org/#/c/501659/
13:21:10 <Yumeng__> From today I can spare more time in review and commit
13:21:19 <Yumeng__> :)
13:21:24 <alexchadin> Yumeng__: it's nice! :)
13:22:34 <alexchadin> Add audit scoper for storage data model spec needs reviews #link https://review.openstack.org/#/c/517169/
13:22:55 <alexchadin> Yumeng__: suzhengwei: aditi works on it
13:23:15 <alexchadin> it would be great if you take a look at it
13:23:37 <suzhengwei> ok
13:24:52 <alexchadin> #action suzhengwei review https://review.openstack.org/#/c/517169/
13:26:17 <alexchadin> do we need to continue listing Watcher patches?
13:26:31 <alexchadin> https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F22.2F2017 there are some of them
13:26:53 <alexchadin> most of them need reviews
13:27:08 <alexchadin> suzhengwei: option to rollback action_plan when it fails https://review.openstack.org/#/c/517179/ would be good to have unit tests
13:27:48 <alexchadin> suzhengwei: marker patches should be based on https://review.openstack.org/#/c/519945/
13:28:02 <suzhengwei> I will update it
13:28:15 <alexchadin> suzhengwei: you may rebase them to pass py-jobs
13:29:09 <alexchadin> do you have any questions?
13:29:17 <suzhengwei> they are all ok if common marker filter is merged.
13:29:21 <alexchadin> or topics to discuss :)
13:29:32 <alexchadin> suzhengwei: yeap, just try to rebase them
13:29:34 <suzhengwei> a serial of commits.
13:30:35 <alexchadin> then I'd propose to end up this meeting
13:30:44 <suzhengwei> this commit should be merged firstly.https://review.openstack.org/#/c/521847/
13:30:52 <alexchadin> hidekazu and aditi should join us next time
13:31:20 <alexchadin> suzhengwei: licanwei did the same commit
13:32:03 <alexchadin> suzhengwei: take a look: https://review.openstack.org/#/c/519945/
13:33:28 <suzhengwei> yes, I see. But the common filer for marker should be merged. So licanwei's commit or this commit is merged, other commits would be ok autoly.
13:34:17 <suzhengwei> commom filter for marker need to be merged firstly.
13:34:41 <alexchadin> suzhengwei: I've rebased one of your commit on licanwei's
13:34:49 <alexchadin> suzhengwei: let's see what we get
13:35:47 <alexchadin> suzhengwei: is it ok?
13:36:09 <suzhengwei> i think it will not work
13:36:55 <alexchadin> suzhengwei: why?
13:37:23 <alexchadin> now your audit template commit based on licanwei's commit
13:37:31 <suzhengwei> not add common filter of marker
13:37:33 <alexchadin> you both have the same utils.py file
13:39:50 <suzhengwei> I separate the common marker filter as one commit, https://review.openstack.org/#/c/521847/
13:40:19 <suzhengwei> we can discuss in waycher chanel.
13:40:20 <alexchadin> suzhengwei: yeap, and other commits which should use this commit
13:40:24 <alexchadin> yeap
13:40:29 <alexchadin> thank you for coming and have a good day
13:40:37 <alexchadin> #endmeeting