14:00:19 <alexchadin> #startmeeting watcher
14:00:19 <openstack> Meeting started Wed Nov 15 14:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:22 <openstack> The meeting name has been set to 'watcher'
14:00:40 <alexchadin> Greetings!
14:00:44 <Yumeng__> Hi
14:00:47 <hidekazu> started?
14:00:57 <suzhengwei> hi
14:01:02 <alexchadin> hidekazu: just now
14:01:09 <hidekazu> hi
14:01:38 <alexchadin> Today we have the following agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F15.2F2017
14:01:49 <alexchadin> #topic Announcements
14:02:03 <alexchadin> Yumeng Bao has presented Project Update of Watcher #link https://www.youtube.com/watch?v=1FGb-uocfTw
14:02:25 <alexchadin> Yumeng__: thanks a lot for your presentation, you've done it great!
14:03:08 <hidekazu> Yumeng__: thanks for moderating forum physically.
14:03:47 <Yumeng__> :) I’m very happy to do that
14:04:39 <alexchadin> Moreover, thanks for your feedback about using of Watcher #link https://etherpad.openstack.org/p/watcher-sydney-forum
14:05:57 <alexchadin> suzhengwei: you've listed interesting things to discuss
14:06:24 <alexchadin> I will talk with you about them tomorrow, I think
14:06:33 <suzhengwei> ok
14:06:46 <alexchadin> suzhengwei: if you are able to, of course
14:07:07 <suzhengwei> i will make time tomorrow
14:07:50 <alexchadin> any other announcements?
14:07:57 <hidekazu> alexchadin: thanks for adding answers. i listed questions.
14:08:53 <alexchadin> Yumeng__: what was the reaction of people on your presentation?
14:09:33 <alexchadin> hidekazu: yeap, it would be useful to plan our roadmap for future releases
14:10:36 <Yumeng__> alexchadin: some new people interested in our projects
14:10:49 <Yumeng__> Not bad :)
14:11:12 <alexchadin> Yumeng__: have you told them about our contacts or weekly meetings?
14:11:24 <Yumeng__> Several people come to ask questions and considering join us
14:11:59 <Yumeng__> Yes, I showed our IRC channel and meeting time
14:12:15 <Yumeng__> on prensentation
14:12:55 <alexchadin> Yumeng__: oh, I haven't seen last slides
14:13:20 <alexchadin> well, let's move on
14:13:31 <alexchadin> #topic Review Action Items
14:13:34 <alexchadin> Watcher specs
14:13:47 <alexchadin> exclude locked instances needs to be updated #link https://review.openstack.org/#/c/506078/
14:14:25 <alexchadin> suzhengwei: we have discussed with you about locked property of VM that looks interesting
14:14:41 <alexchadin> suzhengwei: please, update your spec with more details
14:14:59 <suzhengwei> sorry, I forgot to update the spec this. I will tomorrow
14:15:16 <alexchadin> suzhengwei: thanks
14:15:27 <alexchadin> #action suzhengwei update https://review.openstack.org/#/c/506078/
14:15:40 <alexchadin> Add Datasource Abstraction and Multi Datasource needs final core review #link https://review.openstack.org/#/c/508384/
14:16:01 <alexchadin> hidekazu: it would be good if you review it
14:16:16 <hidekazu> alexchadin: yes, i will/
14:17:00 <alexchadin> hidekazu: thanks
14:17:16 <alexchadin> #action hidekazu give final core review https://review.openstack.org/#/c/508384/
14:17:32 <alexchadin> cluster-maintenance-strategy needs to be updated #link https://review.openstack.org/#/c/464602/
14:18:06 <suzhengwei> ok
14:18:12 <alexchadin> suzhengwei: please, update your spec with your answers
14:18:49 <alexchadin> suzhengwei: the more details you provide, the faster it is merged
14:18:50 <suzhengwei> yes, i will
14:18:54 <alexchadin> suzhengwei: thanks
14:19:06 <alexchadin> #action suzhengwei update https://review.openstack.org/#/c/464602/
14:19:19 <alexchadin> Add storage capacity balance Strategy needs new PS (Zuul issue) #link https://review.openstack.org/#/c/501659/
14:21:03 <alexchadin> Yumeng__: have you seen Zuul error?
14:22:42 <alexchadin> Add audit scoper for storage data model spec needs new PS
14:22:49 <alexchadin> #link https://review.openstack.org/#/c/517169/
14:23:19 <hidekazu> alexchadin: adisky_ will update and implement this spec. we discussed today.
14:24:05 <hidekazu> alexchadin: because i joined customers project  for about 40% from this month.
14:24:17 <alexchadin> hidekazu: ok, next patch set will be from her?
14:24:38 <hidekazu> alexchadin: yes.
14:24:53 <alexchadin> hidekazu: fine
14:25:00 <hidekazu> alexchadin: we discussed face to face in japan today
14:25:11 <alexchadin> #action adisky_ update https://review.openstack.org/#/c/517169/
14:25:16 <Yumeng__> alexchadin: yep, I have seen zuul error. Will check tomorrow
14:25:27 <alexchadin> Yumeng__: thanks
14:25:47 <alexchadin> #action Yumeng__ update https://review.openstack.org/#/c/501659/
14:27:01 <alexchadin> listen to all necessary notifications needs new PS #link https://review.openstack.org/#/c/508105/
14:27:21 <suzhengwei> It adds two event notifications, is there any event we miss?
14:29:21 <alexchadin> suzhengwei: I haven't all notifications in nova, that ones you have provided make sense to me
14:29:32 <alexchadin> haven't seen*
14:30:09 <alexchadin> suzhengwei: I've left some comments, everything else looks good to me
14:31:50 <suzhengwei> ok.
14:33:15 <alexchadin> Watcher
14:33:24 <alexchadin> improve 'Restrict existing strategies to their default scope' needs reviews #link https://review.openstack.org/#/c/504857/
14:34:11 <alexchadin> suzhengwei: it is the second commit regarding extend-node-status ?
14:34:27 <alexchadin> suzhengwei: https://review.openstack.org/#/c/464557/ is it still actual?
14:35:33 <suzhengwei> yes
14:36:25 <alexchadin> who will review https://review.openstack.org/#/c/504857/ ?
14:37:11 <hidekazu> do they have dependency?
14:38:06 <suzhengwei> host maintaining depend it.
14:38:07 <alexchadin> suzhengwei: ^
14:39:08 <hidekazu> ok, they are independent.
14:40:46 <suzhengwei> hidekazu: would you review it?
14:41:00 <alexchadin> suzhengwei: do we really need https://review.openstack.org/#/c/464557/ ? I mean, isn't disabled_reason implemented by https://review.openstack.org/#/c/504857/ ?
14:41:02 <hidekazu> suzhengwei: ok.
14:41:04 <Yumeng__> +1
14:42:43 <alexchadin> #action hidekazu Yumeng__ review https://review.openstack.org/#/c/504857/
14:42:49 <hidekazu> maybe commit message is wrong or something. i will review including comment from alexchadin :)
14:43:18 <alexchadin> option to rollback migrations when action_plan fails needs new PS #link https://review.openstack.org/#/c/517179/
14:43:54 <suzhengwei> It need more comment, althought I prefer licanwei's.
14:44:50 <alexchadin> #action suzhengwei update https://review.openstack.org/#/c/517179/
14:45:00 <alexchadin> Notifications Changes Multiple Global Efficacy needs reviews #link https://review.openstack.org/#/c/519299/
14:45:23 <alexchadin> I will review it, who else? :)
14:46:04 <suzhengwei> I will
14:46:46 <alexchadin> #action suzhengwei alexchadin review https://review.openstack.org/#/c/519299/
14:46:58 <alexchadin> Add and identify excluded instances in compute CDM needs reviews #link https://review.openstack.org/#/c/504303/
14:47:52 <alexchadin> suzhengwei: is it still actual https://review.openstack.org/#/c/508108/ ?
14:48:07 <suzhengwei> yes
14:49:27 <alexchadin> I think, you need to add unit tests at least
14:50:48 <suzhengwei> The commit is not finished ,https://review.openstack.org/#/c/508108/
14:51:12 <alexchadin> suzhengwei: then mark it as [WiP], please
14:51:28 <alexchadin> Add storage capacity balance Strategy needs reviews #link https://review.openstack.org/#/c/516500/
14:52:52 <hidekazu> enough for reviewing? he updated four times.
14:53:09 <hidekazu> three times.
14:53:43 <alexchadin> hidekazu: since there is no [WiP] tag and unit tests are presented, I suppose we can review it
14:53:56 <hidekazu> alexchadin: ok, i try
14:54:22 <hidekazu> code includes volume migration :)
14:54:39 <alexchadin> #action hidekazu review https://review.openstack.org/#/c/516500/
14:54:50 <alexchadin> hidekazu: then it should be familiar to you :)
14:55:03 <hidekazu> alexchadin: yeap
14:55:05 <alexchadin> Can't cancell CONTINUOUS audit needs reviews #link https://review.openstack.org/#/c/514540/
14:55:29 <alexchadin> who would like to review it?
14:56:12 <suzhengwei> add me
14:56:55 <alexchadin> #action suzhengwei review https://review.openstack.org/#/c/514540/
14:57:09 <alexchadin> Add baremetal data model needs reviews #link https://review.openstack.org/#/c/482093/
14:57:44 <alexchadin> hidekazu: what about it?
14:58:21 <hidekazu> alexchadin: yeah, i have to.. i will in two weeks.
14:58:29 <alexchadin> hidekazu: thanks
14:58:43 <alexchadin> #action hidekazu review https://review.openstack.org/#/c/482093/
14:58:55 <alexchadin> unfortunately, we run out of time
14:59:05 <alexchadin> thank you for coming!
14:59:13 <hidekazu> thanks.
14:59:20 <alexchadin> see you next week!
14:59:21 <alexchadin> bye
14:59:25 <suzhengwei> bye
14:59:45 <alexchadin> #endmeeting