14:00:19 <alexchadin> #startmeeting watcher
14:00:20 <openstack> Meeting started Wed Nov  1 14:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:23 <openstack> The meeting name has been set to 'watcher'
14:00:28 <alexchadin> o/
14:00:29 <Yumeng__> hi
14:01:29 <suzhengwei> hi
14:01:48 <alexchadin> let's begin our meeting, team :)
14:01:56 <alexchadin> #announcements
14:02:05 <alexchadin> #topic announcements
14:02:16 <alexchadin> Watcher Queens-1 has been released #link https://review.openstack.org/#/c/513451/
14:02:40 <alexchadin> We have completed 2 blueprints of 7 actually
14:03:13 <alexchadin> part of them caused long discussions
14:04:04 <alexchadin> and we had complications with migration from jenkins to zuulv3
14:04:44 <alexchadin> unfortunately, CI is still unstable for now
14:06:01 <alexchadin> any other announcements?
14:06:31 <suzhengwei> The haproxy problem reapear in my another env.
14:07:46 <alexchadin> suzhengwei: what's wrong with it?
14:08:19 <alexchadin> suzhengwei: have you tried to use watcher along with haproxy?
14:08:31 <suzhengwei> yes
14:08:47 <suzhengwei> It doesn't work.
14:09:33 <alexchadin> suzhengwei: this isn't surprising, we haven't tested it with haproxy yet ;)
14:09:43 <Yumeng__> any error message?
14:10:02 <alexchadin> suzhengwei: could you please report a bug with description of problem?
14:10:27 <suzhengwei> I have reported the bug.
14:12:31 <suzhengwei> https://bugs.launchpad.net/watcher/+bug/1726725
14:12:32 <openstack> Launchpad bug 1726725 in watcher "watcher-api haproxy problem" [Undecided,New]
14:13:01 <alexchadin> suzhengwei: thanks, will take a look
14:14:28 <alexchadin> well, let's move on
14:14:37 <alexchadin> #topic Review Action Items
14:14:41 <alexchadin> Watcher specs
14:14:53 <alexchadin> listen to all necessary notifications needs new PS #link https://review.openstack.org/#/c/508105/
14:15:57 <alexchadin> suzhengwei: my bad, I see you've just updated it
14:16:05 <alexchadin> suzhengwei: I'll review it
14:16:40 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/508105/
14:17:23 <alexchadin> compute CDM include all instances needs to be discussed #link https://review.openstack.org/#/c/499119/
14:18:18 <alexchadin> suzhengwei: have you discussed it with hidekazu?
14:19:53 <suzhengwei> No
14:19:59 <Yumeng__> I once discussed with licanwei, but I need some time to recall. More than a week ago
14:20:55 <Yumeng__> suzhengwei : if you have time, we can discuss tomorrow
14:21:26 <alexchadin> suzhengwei: Yumeng__ it would be great if you discuss it
14:21:37 <alexchadin> Yumeng__: ping me if I will be available
14:21:43 <Yumeng__> Ok
14:22:38 <alexchadin> #action Yumeng__ suzhengwei discuss https://review.openstack.org/#/c/499119/
14:22:49 <alexchadin> cluster-maintenance-strategy needs reviews #link https://review.openstack.org/#/c/464602/
14:24:23 <alexchadin> Yumeng__: I think we could review it again
14:25:09 <Yumeng__> alexchadin: no problem 👌
14:25:54 <alexchadin> #action alexchadin Yumeng__ review https://review.openstack.org/#/c/464602/
14:26:07 <alexchadin> exclude locked instances needs to be discussed with suzhengwei #link https://review.openstack.org/#/c/506078/
14:27:19 <alexchadin> suzhengwei: why don't you want to use optimize bool in metadata of nova instance like it's described here: https://github.com/openstack/watcher-specs/blob/master/specs/pike/implemented/audit-tag-vm-metadata.rst ?
14:27:31 <suzhengwei> I have study the bp:audit-tag-vm-metadata, this is another same solution, but not work well.
14:27:45 <suzhengwei> I have test it.
14:28:01 <suzhengwei> we can discuss more if we are free.
14:29:10 <alexchadin> suzhengwei: agree
14:30:34 <alexchadin> Add storage capacity balance Strategy needs to be updated #link https://review.openstack.org/#/c/501659/
14:32:40 <alexchadin> Yumeng__: you've got some comments
14:32:45 <Yumeng__> Yes yes
14:33:03 <Yumeng__> I will make some time to do it before I go to Sydney
14:34:11 <alexchadin> Yumeng__: I hope you will have some fun there ;)
14:34:38 <alexchadin> #action Yumeng__ update https://review.openstack.org/#/c/501659/
14:34:45 <alexchadin> Add Datasource Abstraction and Multi Datasource needs reviews #link https://review.openstack.org/#/c/508384/
14:34:47 <Yumeng__> It’s summer :)
14:34:56 <Yumeng__> there
14:36:28 <alexchadin> suzhengwei: could you please review it?
14:36:47 <suzhengwei> ok
14:37:39 <alexchadin> #action suzhengwei review https://review.openstack.org/#/c/508384/
14:38:01 <alexchadin> Watcher
14:38:11 <alexchadin> Add hardware maintenance goal and efficacy needs reviews #link https://review.openstack.org/#/c/509043/
14:39:49 <alexchadin> we shouldn't merge it yet
14:40:04 <alexchadin> Migrate to Zuul v3 needs reviews #link https://review.openstack.org/#/c/509777/
14:40:37 <alexchadin> I have some issues with it, it is to be updated
14:40:59 <alexchadin> add name for audit, update audit notifications needs reviews #link https://review.openstack.org/#/c/476752/
14:41:38 <alexchadin> I will review it
14:41:49 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/476752/
14:41:50 <suzhengwei> thx
14:42:07 <Yumeng__> alexchadin: I can review again —add name for audit
14:42:28 <Yumeng__> But maybe later if not have enough time
14:42:44 <suzhengwei> Yumeng__: thanks
14:42:48 <alexchadin> Yumeng__: review this part of naming, please: https://review.openstack.org/#/c/475324/
14:43:07 <alexchadin> Yumeng__: it's part of watcherclient
14:43:08 <Yumeng__> Ok
14:43:37 <alexchadin> Yumeng__: what status of your project update presentation? do you need my help?
14:44:21 <Yumeng__> I finished a draft
14:44:35 <Yumeng__> I Will send you email
14:44:42 <Yumeng__> If possible take a look
14:46:03 <alexchadin> Yumeng__: sure, waiting for mail
14:46:41 <alexchadin> there are some bugs and fixes left: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F01.2F2017
14:47:04 <alexchadin> they should be updated with new PS or unit tests
14:47:39 <alexchadin> so, i'd prefer to end up our meeting if there aren't more questions
14:48:34 <alexchadin> thank you for attending :)
14:49:12 <suzhengwei> bye
14:49:19 <alexchadin> bye
14:49:50 <alexchadin> Yumeng__: have a nice Summit ;)
14:50:01 <alexchadin> #endmeeting