14:00:21 <alexchadin> #startmeeting watcher
14:00:22 <openstack> Meeting started Wed Aug  9 14:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <openstack> The meeting name has been set to 'watcher'
14:00:36 <alexchadin> Greetings!
14:00:45 <Yumeng__> Hi
14:00:47 <adisky__> Hi
14:01:10 <alexchadin> Here's our agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#08.2F09.2F2017
14:01:33 <hidekazu> hi
14:01:43 <suzhengwei> hi
14:01:53 <alexchadin> #topic announcements
14:02:10 <alexchadin> Aditi Sharma is in core team now.
14:02:24 <alexchadin> adisky__: my congratulations
14:02:29 <hidekazu> adisky__: congrats!
14:02:41 <adisky__> alexchadin: thanks
14:02:54 <suzhengwei> congratulations!
14:02:54 <adisky__> hidekazu: Yumeng__ : thanks for voting
14:02:56 <Yumeng__> adisky__: congratulations!!
14:03:12 <adisky__> suzhengwei: thanks
14:03:50 <alexchadin> Release Candidate will be tagged tomorrow.
14:04:23 <alexchadin> warning-is-error tag is set to watcher, python-watcherclient, watcher-specs repos. watcher-dashboard should be verified.
14:05:09 <alexchadin> We've got rid of warnings of docs
14:05:27 <hidekazu> alexchadin: nice
14:05:41 <alexchadin> And put documentation in order
14:06:00 <alexchadin> thank you for your help, team
14:07:34 <alexchadin> Fill up Denver etherpad with your proposals and questions: https://etherpad.openstack.org/p/queens-watcher-ptg
14:07:55 <hidekazu> who will attend ptg?
14:08:55 <alexchadin> I won't
14:09:41 <adisky__> depends on support from company
14:10:16 <Yumeng__> I will ask my boss tomorrow
14:10:51 <hidekazu> i am happy attendees will fill in until 21st(during my summer vacation :) )
14:11:31 <alexchadin> Unfortunately, I cannot visit PTG because of personal things :(
14:11:58 <hidekazu> alexchadin: yes, please do your best ;)
14:11:59 <Yumeng__> alexchadin :What if we schedule another time? Or place?
14:12:10 <alexchadin> But I'll try to do my best
14:12:38 <alexchadin> Yumeng__: I'd vote for something like Prague :)
14:13:02 <hidekazu> Prague??
14:13:37 <Yumeng__> Need shengen visa?
14:13:38 <alexchadin> We've already reserved place for our team on PTG so I hope some people can go there
14:14:13 <alexchadin> Yumeng__: yes
14:14:27 <alexchadin> hidekazu: why not?:)
14:14:42 <hidekazu> central europe..
14:15:26 <hidekazu> i am not familiar with central europe.
14:15:48 <hidekazu> sorry, please go on.
14:16:34 <alexchadin> anyway, leave your propositions on the etherpad about possible place to meet
14:16:38 <alexchadin> let's move on
14:16:49 <alexchadin> #topic Review Action Items
14:16:55 <alexchadin> Watcher specs
14:17:06 <alexchadin> cluster-maintenance-strategy needs to be addressed to Queens #link https://review.openstack.org/#/c/464602/
14:17:17 <suzhengwei> yes
14:17:26 <suzhengwei> I will update later
14:17:38 <alexchadin> suzhengwei: just change folder to queens, that's all
14:17:46 <suzhengwei> ok
14:17:53 <alexchadin> suzhengwei: thank you
14:18:04 <alexchadin> extend-node-status needs to be updated #link https://review.openstack.org/#/c/464549/
14:18:24 <suzhengwei> I will
14:18:25 <alexchadin> suzhengwei: there are some unaddressed questions
14:19:22 <suzhengwei> ok, I will check it later
14:19:35 <hidekazu> suzhengwei: Please add dependency between blueprints.
14:20:07 <alexchadin> hidekazu: +1
14:20:09 <hidekazu> suzhengwei: example: https://blueprints.launchpad.net/watcher/+spec/zone-migration-strategy
14:20:39 <hidekazu> suzhengwei: you can show Dependency tree in work items.
14:21:28 <suzhengwei> ok
14:22:29 <alexchadin> Spec for multi-datasource support needs to be addressed to Queens #link https://review.openstack.org/#/c/467102
14:23:06 <alexchadin> unfortunately, lakerzhou isn't here
14:23:24 <alexchadin> Watcher Bugs & Fixes
14:23:35 <alexchadin> Fix failure to load storage plugin needs reviews #link https://review.openstack.org/#/c/491386/
14:24:16 <adisky__> will review
14:24:41 <alexchadin> it's very critical patch since watcher won't launch properly if you don't have installed cinder
14:25:07 <alexchadin> #action adisky__ review https://review.openstack.org/#/c/491386/
14:25:29 <alexchadin> Fix gnocchi repository URL in local.conf.controller needs reviews #link https://review.openstack.org/#/c/490684/
14:25:59 <Yumeng__> +1
14:26:04 <hidekazu> this is easy.
14:26:58 <alexchadin> Restrict existing strategies to their default scope needs reviews #link https://review.openstack.org/#/c/478760/
14:27:47 <Yumeng__> +1
14:27:57 <alexchadin> #action Yumeng__ review https://review.openstack.org/#/c/478760/
14:28:00 <alexchadin> Yumeng__: thanks
14:28:05 <hidekazu> this patch implements blueprint extend-node-status.
14:28:55 <alexchadin> hidekazu: oh, I see
14:29:14 <alexchadin> Yumeng__: review without merging ;)
14:29:29 <hidekazu> i wonder why this is not bug fix.
14:29:30 <Yumeng__> alexchadin: ok
14:30:13 <suzhengwei> because now we test every strategy seperately.
14:30:34 <hidekazu> we can discuss in spec review.
14:32:07 <alexchadin> Adjust the action state judgment logic needs new PS #link https://review.openstack.org/#/c/491393/
14:32:56 <alexchadin> workload balance base on cpu or ram util needs reviews #link https://review.openstack.org/#/c/479257/
14:34:02 <alexchadin> hidekazu, adisky__ please review it again
14:34:34 <hidekazu> i already +2 though.
14:34:42 <adisky__> +1
14:35:13 <alexchadin> well, that's all for now
14:35:18 <hidekazu> this patch is not fixing bug , should not be merged before releasing RC.
14:35:49 <hidekazu> i am worry about the bug i reported: https://bugs.launchpad.net/watcher/+bug/1709544
14:35:50 <openstack> Launchpad bug 1709544 in watcher "Compute CDM failed to be created under multiple cells environment" [Undecided,New]
14:36:45 <hidekazu> i hope someone tests using multi node latest devstack.
14:37:12 <alexchadin> hidekazu: it makes sense
14:37:20 <adisky__> hidekazu: i will try it next week
14:37:30 <hidekazu> adisky?__: very thanks.
14:37:35 <hidekazu> adisky__
14:37:39 <alexchadin> hidekazu: ComputeNode is a child of osloversionedobjects
14:38:07 <alexchadin> hidekazu: I'll give a link, wait a sec
14:38:20 <hidekazu> alexchadin: nova doc says that we can not migrate instance across cells now.
14:39:06 <alexchadin> hidekazu: https://github.com/openstack/watcher/blob/master/watcher/decision_engine/model/element/node.py#L36
14:39:10 <hidekazu> alexchadin: we should not focus on multicell env??
14:39:25 <hidekazu> but default devstack is now multicell..
14:39:55 <alexchadin> hidekazu: could you give me a link to the doc?
14:40:56 <hidekazu> alexchadin: https://docs.openstack.org/nova/latest/user/cellsv2_layout.html#cross-cell-instance-migrations
14:41:17 <alexchadin> hidekazu: if I understand right, after you changed api_version to 2.53, ComputeNode class should contain id with StringField type
14:41:54 <hidekazu> alexchadin: yes
14:44:01 <alexchadin> hidekazu: you have exception even if you use nova api v2.0?
14:44:32 <hidekazu> alexchadin: first bug report is nova api 2. watcher default.
14:45:54 <alexchadin> that's strange
14:46:42 <hidekazu> alexchadin: i expect adisky__'s report :)
14:46:53 <alexchadin> hidekazu: I'll investigate it
14:46:55 <alexchadin> too
14:47:26 <hidekazu> alexchadin: i think key point is that my env is not simple cell setup, real multi cell.
14:47:56 <alexchadin> well, let's end up meeting
14:48:10 <hidekazu> thanks, bye.
14:48:12 <alexchadin> thank you for coming
14:48:13 <alexchadin> bye
14:48:17 <suzhengwei> bye
14:48:19 <adisky__> bye
14:48:33 <alexchadin> #endmeeting