14:00:16 <alexchadin> #startmeeting watcher
14:00:17 <openstack> Meeting started Wed Jun 14 14:00:16 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:20 <openstack> The meeting name has been set to 'watcher'
14:00:46 <alexchadin> hi watcher team
14:01:01 <Ibra> hello)
14:01:17 <alexchadin> vincentfrancoise and sballe_ will be a slightly late
14:01:22 <alexchadin> hi Ibra
14:01:25 <hidekazu_> hi
14:01:29 <alexchadin> hi hidekazu_
14:01:48 <alexchadin> Today our agenda is https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#06.2F14.2F2017
14:02:15 <alexchadin> #topic Announcements
14:03:06 <alexchadin> I've sent reminder to ML to let you give your opinion about Storyboard migration #link https://etherpad.openstack.org/p/watcher-storyboard
14:05:06 <alexchadin> so feel free to fill it up
14:05:06 <hidekazu_> alexchadin: i wrote storyboard sandbox url.
14:05:18 <alexchadin> hidekazu_: yeah, i've seen, thank you
14:05:43 <alexchadin> Cancel Action Plan has been merged. Thanks aditi sharma for your work! #link https://review.openstack.org/#/c/458492/
14:05:57 <alexchadin> adisky__: ping
14:06:46 <alexchadin> adisky__: well, BTW thank you for this blueprint :)
14:06:58 <alexchadin> Noisy Neighbor Strategy spec has been merged. #link https://review.openstack.org/#/c/398162/
14:07:32 <alexchadin> big thanks to Susanne and Pru
14:08:22 <alexchadin> Add new actions "power on" and "power off" in Watcher spec has been merged #link https://review.openstack.org/#/c/435436/
14:08:54 <alexchadin> Unfortunately, Yumeng Bao isn't here yet
14:09:25 <alexchadin> Santhosh Fernandes and Pradeep Kumar Singh have moved their focus to another project. We should address watcher-multi-datasource to someone. #link https://blueprints.launchpad.net/watcher/+spec/watcher-multi-datasource
14:09:58 <alexchadin> We have unassigned BP that has low priority
14:10:40 <alexchadin> it's some kind of refactor, but it would be useful for us in the future
14:11:00 <sballe_> hi
14:11:04 <alexchadin> hi sballe_
14:11:44 <hidekazu_> alexchadin: that is framework related.
14:11:45 <alexchadin> sballe_: I've addressed my congratulations to you and Pru about NNS spec :)
14:11:53 <sballe_> thx :-)
14:12:06 <sballe_> Pru is working hard on getting the code appred nw ;-)
14:12:09 <sballe_> approved
14:12:25 <sballe_> thx to everybody who reviewd the sed
14:12:27 <alexchadin> sballe_: what framework do you speak about?
14:12:57 <sballe_> you mean this question for hidekazu right
14:13:03 <hidekazu_> alexchadin: i said
14:13:10 <hidekazu_> alexchadin: :)
14:13:15 <alexchadin> sorry :)
14:13:23 <alexchadin> hidekazu_: sure
14:15:46 <alexchadin> well, any other announcements?
14:17:05 <alexchadin> let's move on
14:17:12 <alexchadin> #topic Review Action Items
14:17:16 <alexchadin> Watcher specs
14:17:25 <alexchadin> Support workload fingerprinting needs new PS #link https://review.openstack.org/#/c/448396/
14:18:00 <alexchadin> unfortunately, Ananth Narayan S is not here yet
14:18:06 <alexchadin> hi Yumeng__
14:18:16 <Yumeng__> hi sorry for late
14:19:09 <alexchadin> Build baremetal data model in watcher needs final core review #link https://review.openstack.org/#/c/448016/
14:19:55 <alexchadin> I don't have time to review specifications yet, so I appreciate any your reviews
14:20:35 <alexchadin> Ibra: could you please review it?
14:22:00 <alexchadin> hidekazu_: could you please review it?
14:22:07 <hidekazu_> yes.
14:22:33 <alexchadin> #action hidekazu_ review https://review.openstack.org/#/c/448016/
14:22:40 <Yumeng__> hidekazu_: thanks!
14:22:55 <alexchadin> update action description needs reviews #link https://review.openstack.org/#/c/459529/
14:23:54 <Yumeng__> alexchadin : I think this needs core review
14:24:07 <alexchadin> Yumeng__: I agree
14:24:40 <hidekazu_> alexchadin: i am discussing code with licanwei : https://review.openstack.org/#/c/454638/
14:25:16 <hidekazu_> alexchadin: we need other developers review.
14:26:12 <alexchadin> I will try to review it in the beginning of the next week
14:26:33 <hidekazu_> alexchadin: thanks.
14:26:45 <Yumeng__> Looks like lots of code. I would also try to review
14:26:57 <alexchadin> Yumeng__: thanks!
14:27:12 <Yumeng__> :)
14:27:59 <alexchadin> #action alexchadin Yumeng__ review https://review.openstack.org/#/c/459529/
14:28:04 <alexchadin> #action alexchadin Yumeng__ review https://review.openstack.org/#/c/454638/
14:29:34 <alexchadin> Add Volume migrate action spec needs final core review #link https://review.openstack.org/#/c/468817/
14:30:58 <alexchadin> Yumeng__: could you please review it?
14:31:09 <hidekazu_> alexchadin: i want this to be implemented in pike :)
14:31:28 <Yumeng__> alexchadin: yes no problem
14:31:31 <Yumeng__> Add me on it
14:31:36 <alexchadin> hidekazu_: it is fair enough :)
14:31:44 <alexchadin> me too
14:31:44 <hidekazu_> Yumeng__: thanks!
14:31:46 <Yumeng__> I will try
14:32:02 <hidekazu_> alexchadin: thanks, too.
14:33:14 <alexchadin> #action Yumeng__ review https://review.openstack.org/#/c/468817/
14:33:19 <alexchadin> hidekazu_: no worries
14:34:15 <alexchadin> Watcher
14:35:04 <alexchadin> Noisy Neighbor Strategy needs reviews #link https://review.openstack.org/#/c/454359/
14:35:29 <vincentfrancoise> Hi
14:35:31 <alexchadin> it is reviewing all the time so I don't have a requests about it:)
14:35:34 <alexchadin> hi vincentfrancoise
14:35:47 <Yumeng__> Hi vincentfrancoise
14:36:21 <hidekazu_> こんにちは vincentfrancoise
14:36:50 <alexchadin> привет vincentfrancoise :D
14:37:11 <hidekazu_> pru will update
14:37:12 <alexchadin> let's move on
14:37:22 <vincentfrancoise> hidekazu_: こんばんは
14:37:37 <alexchadin> hidekazu_: I know, sballe_ already said it
14:37:49 <alexchadin> Cinder model integration needs reviews #link https://review.openstack.org/#/c/450642/
14:38:03 <sballe_> yes he has updated the pathc several time
14:38:11 <sballe_> sorry going back to noisy neightbor
14:38:30 <sballe_> licamwei had a comment we didn;t understand. is he here
14:38:34 <hidekazu_> i updated for comment from licanwei.
14:38:52 <alexchadin> hidekazu_: I want to try your patch before merging, is it enough to install Cinder with LVM driver?
14:38:59 <sballe_> hidekazu_: thx I will read that. Thanks you for working on this 24 h/da
14:39:52 <hidekazu_> alexchadin: yes, i tested today with latest devstack, LVM driver.
14:40:34 <alexchadin> hidekazu_: Do you have some special devstack settings to test it?
14:40:58 <alexchadin> hidekazu_: I mean, additional pre-requisites to launch Cinder
14:41:55 <hidekazu_> alexchadin: you have to add topic name in cinder.conf as in nova.conf
14:42:42 <hidekazu_> alexchadin: https://docs.openstack.org/developer/watcher/deploy/configuration.html#configure-nova-notifications
14:43:01 <alexchadin> hidekazu_: oh, I see, thank you!
14:43:27 <alexchadin> Add action for compute node power on/off needs reviews #link https://review.openstack.org/#/c/470185/
14:44:30 <alexchadin> since spec is merged, we can review it as much as possible
14:45:45 <alexchadin> Yumeng__: could you please review it?
14:45:46 <vincentfrancoise> alexchadin: I just +2'd ir
14:45:56 <vincentfrancoise> it*
14:47:14 <Yumeng__> Sorry network error.
14:47:26 <Yumeng__> Did I miss something?
14:47:42 <alexchadin> vincentfrancoise: nice!
14:47:53 <Yumeng__> I can review https://review.openstack.org/#/c/470185/
14:47:55 <alexchadin> Yumeng__: could you please review https://review.openstack.org/#/c/470185/ ?
14:47:58 <alexchadin> yeah
14:48:02 <alexchadin> thank you!
14:48:13 <alexchadin> #action Yumeng__ review https://review.openstack.org/#/c/470185/
14:48:22 <alexchadin> jsonschema-validation bunch of PSs should be reviewed #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/jsonschema-validation
14:48:49 <alexchadin> most of them need final review
14:49:17 <hidekazu_> Yumeng__: could you answer https://review.openstack.org/#/c/472218/ ?
14:49:53 <Yumeng__> Yes will do tomorrow
14:50:14 <Yumeng__> hidekazu_: I didn't check it today. Thank you!
14:50:44 <Yumeng__> You have helped me a lot!
14:50:57 <hidekazu_> Yumeng__: if i will get answer, i will review other ps.
14:51:19 <Yumeng__> hidekazu_: ok. Got it.
14:51:24 <alexchadin> Add action description notification needs reviews #link https://review.openstack.org/#/c/454638/
14:52:04 <alexchadin> oh, we have already discussed it
14:52:09 <hidekazu_> vincentfrancoise: i want you to review.
14:52:39 <vincentfrancoise> hidekazu_: alexchadin: Put me on it ;)
14:52:53 <alexchadin> sure
14:53:01 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/454638/
14:53:11 <hidekazu_> this code does not completely work on my env and his env :(
14:53:44 <alexchadin> well, that's all for today
14:53:58 <alexchadin> please, don't forget to give your opinion on https://etherpad.openstack.org/p/watcher-storyboard
14:54:06 <vincentfrancoise> alexchadin: did I miss anything important?
14:54:17 <alexchadin> vincentfrancoise: ^^
14:54:17 <Yumeng__> Ops.. one more question.
14:54:32 <hidekazu_> alexchadin: how about https://review.openstack.org/#/c/469025/ ?
14:54:39 <Yumeng__> Does anyone has deployed multiple nodes using devstack?
14:55:15 <alexchadin> hidekazu_: I will review it :)
14:55:20 <vincentfrancoise> alexchadin: ok thx
14:55:36 <alexchadin> Yumeng__: we have docs for it
14:55:47 <hidekazu_> Yumeng__: alexchadin: thanks. that ps needs for cancel action plan.
14:56:13 <alexchadin> Yumeng__: have you faced with something unusual during your deployment?
14:56:29 <hidekazu_> Yumeng__: my env is one controller , two compute(storage) using devstack.
14:57:51 <alexchadin> Yumeng__: meeting time is running out, let's continue it on openstack-watcher channel
14:58:16 <Yumeng__> alexchadin: ok
14:58:25 <Yumeng__> I will ping you later
14:58:29 <hidekazu_> Yumeng__: nowadays devstack is under systemd
14:58:47 <Yumeng__> hidekazu_: yes I just updated
14:59:03 <Yumeng__> But Some troubles
14:59:25 <Yumeng__> Ok let's discuss later in watcher
14:59:28 <alexchadin> let's end up this meeting
14:59:33 <alexchadin> thank you for coming!
14:59:37 <hidekazu_> thans all
14:59:37 <Yumeng__> See you.
14:59:46 <hidekazu_> thanks :)
14:59:59 <alexchadin> bye
15:00:04 <alexchadin> #endmeeting