13:00:06 <alexchadin> #startmeeting watcher
13:00:07 <openstack> Meeting started Wed May 24 13:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:11 <openstack> The meeting name has been set to 'watcher'
13:00:18 <alexchadin> hi watcher team
13:00:24 <ananth_n> hello everyone
13:00:30 <licanwei> hi
13:00:40 <alexchadin> you are welcome, ananth_n
13:00:49 <hidekazu> hello
13:00:57 <alexchadin> hi hidekazu licanwei
13:01:22 <licanwei> hi alex, thank you for your gift :)
13:01:31 <hidekazu> i am still awake
13:01:40 <alexchadin> Today's agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#05.2F24.2F2017
13:01:51 <alexchadin> #topic Announcements
13:01:53 <sballe_> morning
13:01:56 <alexchadin> Two weeks left until Pike-2 milestone
13:02:07 <sballe_> alexchadin: I agree thx for the gift
13:02:07 <alexchadin> sballe_: morning, Susanne
13:02:21 <sballe_> hidekazu: thx for the gift
13:02:48 <alexchadin> licanwei, sballe_ I'm happy that you like my gifts ;)
13:02:54 <sballe_> ananth_n: Good to see you :)
13:03:04 <adisky_> hii
13:03:09 <ananth_n> hi sballe
13:03:11 <alexchadin> hi adisky_
13:03:20 <alexchadin> #info Two weeks left until Pike-2 milestone
13:03:35 <alexchadin> we have a lot of things to do
13:04:10 <alexchadin> and there are some long term specs that I really would like to merge by second milestone
13:04:20 <alexchadin> we will discuss them today
13:05:09 <alexchadin> and ananth_n has come to give us a little bit more infos about his specs
13:05:32 <alexchadin> let's move on
13:05:37 <alexchadin> #info Watcher Install guide dropped its WiP tag and is ready to be reviewed now
13:05:44 <alexchadin> #link https://review.openstack.org/#/c/463281/
13:06:10 <hidekazu> the spec is actively reviewed now.
13:07:07 <alexchadin> this commit will be changed a lot of time, of course, so please review it asap
13:07:37 <alexchadin> if you have personal issues with watcher installing, don't hesitate to share them with us
13:08:43 <alexchadin> this commit will affect on project's maturity level
13:09:09 <alexchadin> any other announcements?
13:09:38 <alexchadin> #topic Review Action Items
13:09:39 <sballe_> alexchadin: I will review since I will reinstall watcher from scratch in a new cluster I have
13:10:44 <alexchadin> sballe_: great! if it is possible, please follow the steps adisky_ proposed
13:11:39 <alexchadin> Watcher
13:11:51 <alexchadin> Add action description needs reviews #link https://review.openstack.org/#/c/450720/
13:12:02 <sballe_> yes that was what I was going ot do
13:12:24 <alexchadin> hidekazu: could you please review it?
13:12:41 <hidekazu> alexchadin: ok,
13:13:11 <alexchadin> #action hidekazu review https://review.openstack.org/#/c/450720/
13:13:31 <alexchadin> Add action description notification needs new PS (because of merge conflict) #link https://review.openstack.org/#/c/454638/
13:14:00 <alexchadin> licanwei: have you seen this PS now has merge conflict?
13:14:06 <hidekazu> alexchadin: revised spec is accepted first though.
13:14:36 <licanwei> yes
13:14:42 <alexchadin> hidekazu: I agree
13:15:05 <licanwei> I'll submit a new PS
13:15:06 <alexchadin> licanwei: could you please fix it by the time your spec is merged?
13:15:28 <licanwei> ok
13:15:30 <alexchadin> great
13:15:42 <alexchadin> #action licanwei submit new PS https://review.openstack.org/#/c/454638/
13:15:51 <alexchadin> Reduced the code complexity can it be merged? #link https://review.openstack.org/#/c/441873/
13:16:18 <alexchadin> hidekazu: I've seen you have some unanswered comments
13:16:46 <hidekazu> i added -1 due to trivial reason.
13:17:09 <hidekazu> alexchadin: i will fix for my comment and +2 :)
13:17:12 <alexchadin> hidekazu: but it may be hard to submit new PS since Béla Vancsics don't answer on it last 7 days
13:18:36 <alexchadin> Versioned Notifications for service object needs core reviews #link https://review.openstack.org/#/c/437333/
13:18:58 <alexchadin> Vincent is not here, but I want to merge it ASAP
13:19:32 <alexchadin> Vladimir answered on Vincent's comments and it should be ready to go
13:20:16 <alexchadin> who can review it?
13:20:43 <licanwei> I will
13:21:18 <alexchadin> #action licanwei review https://review.openstack.org/#/c/437333/
13:21:20 <alexchadin> licanwei: thanks
13:21:32 <hidekazu> of course i will, but this also spec is not merged
13:22:02 <hidekazu> alexchadin: https://review.openstack.org/#/c/445817/
13:22:45 <alexchadin> sballe_: could you please review https://review.openstack.org/#/c/445817/
13:22:51 <sballe_> yes
13:23:48 <alexchadin> hidekazu: we have already merged v.notifications without specs before :)
13:24:05 <alexchadin> #action sballe_ review https://review.openstack.org/#/c/445817/
13:24:31 <alexchadin> Noisy Neighbor Strategy needs reviews #link https://review.openstack.org/#/c/454359/
13:25:16 <alexchadin> sballe_: I've reviewed your spec, LGTM, but haven't seen code yet
13:25:32 <sballe_> the code is there too
13:25:37 <alexchadin> sballe_: Once I get more time to review, I'll do it firstly
13:25:55 <sballe_> the code is here: https://review.openstack.org/#/c/454359/2
13:26:05 <alexchadin> sballe_: I know, above is link to the code
13:26:35 <sballe_> oh I see what you mean. Sorry I misunderstood and thought you couldn;t find the code ;-)
13:26:45 <alexchadin> who would like to review Noisy Neighbor Strategy?
13:26:59 <sballe_> We need more people to review the spec so we can merge it and the code of course
13:28:36 <alexchadin> sballe_: We need more people at all :)
13:28:54 <hidekazu> i will do, but code does not have test at all, i treat this as wip.
13:28:56 <sballe_> agreed. hidekazu can you review please?
13:29:15 <alexchadin> #action alexchadin hidekazu review https://review.openstack.org/#/c/454359/
13:29:23 <alexchadin> hidekazu: thank you
13:29:32 <sballe_> thx ... We have been working on the tests I thougth he would have pushed those too. maybe he forgot
13:29:52 <alexchadin> Watcher specs
13:30:01 <alexchadin> update action description needs reviews #link https://review.openstack.org/#/c/459529/
13:30:59 <alexchadin> licanwei: could you please provide more detailed commit message?
13:31:14 <licanwei> yes
13:32:17 <licanwei> i' ll update the commit message
13:32:25 <alexchadin> licanwei: nice!
13:32:42 <alexchadin> Build baremetal data model in watcher needs new PS #link https://review.openstack.org/#/c/448016/
13:33:12 <alexchadin> seems Yumeng isn't here
13:33:59 <licanwei> I will tell her tommorrow
13:34:32 <alexchadin> Add new actions "power on" and "power off" in Watcher needs reviews #link https://review.openstack.org/#/c/435436/
13:36:25 <alexchadin> sballe_: can you review it?
13:36:32 <licanwei> +1
13:36:41 <sballe_> yes
13:36:59 <lakerzhou> alexchadin, I will review the power on/off too
13:37:20 <alexchadin> lakerzhou, sballe_, licanwei: thanks!
13:37:40 <alexchadin> #action sballe_ licanwei lakerzhou review https://review.openstack.org/#/c/435436/
13:38:01 <alexchadin> Noisy Neighbor Strategy spec needs reviews #link https://review.openstack.org/#/c/398162/
13:39:32 <alexchadin> There are some problems with watcher-specs-core group
13:40:04 <alexchadin> actully, only two core reviewer left there: me and Susanne
13:40:17 <sballe_> I really need people to review the spec so we can get it upstreamed
13:40:32 <sballe_> can other peopel at least review it and gice it a +1
13:40:49 * sballe_ apologizes for the typos
13:41:01 <hidekazu> sballe_: your comments are all clear now?
13:41:02 <alexchadin> hvprash, Joe Cropper and acabot aren't reviewing watcher specs for now
13:41:20 <alexchadin> sballe_: yeah, sure
13:41:50 <sballe_> hidekazu: yes. everything is good
13:41:50 <lakerzhou> alexchadin, I will review the noisy neighbor too
13:42:18 <alexchadin> #action lakerzhou review https://review.openstack.org/#/c/398162/
13:42:32 <hidekazu> sballe_: ok,i will review
13:43:07 <alexchadin> #topic Open Discussions
13:43:08 <sballe_> hidekazu: thx
13:44:13 <alexchadin> ananth_n: when do you plan to drop WiP tag from https://review.openstack.org/#/c/448402/ ?
13:44:39 <alexchadin> ananth_n: and this one: https://review.openstack.org/#/c/448571/
13:45:18 <ananth_n> thanks alexchadin. it's unlikely to make the Pike 2 timeframe you mentioned.
13:46:04 <ananth_n> i.e. within the next 2 weeks due to some other priority items to handle at work
13:47:37 <hidekazu> alexchadin: i added bp: https://blueprints.launchpad.net/watcher/+spec/volume-migrate-action
13:47:52 <alexchadin> ananth_n: ok, and your spec are ready to be reviewed, right?
13:48:11 <ananth_n> yes, the spec is ready for review. so please provide your comments.
13:48:49 <hidekazu> alexchadin: this bp is separate from zone-migration-strategy.
13:49:01 <alexchadin> hidekazu: isn't it a part of https://review.openstack.org/#/c/450642/ ?
13:49:22 <ananth_n> as I address the spec comments, I will also know the scope of the code changes required.
13:49:22 <alexchadin> ananth_n: thank you
13:49:56 <hidekazu> alexchadin: no, volume-migration-action is not part of cinder model.
13:50:53 <sballe_> alexchadin: I will review fingerpriting.. both spec and code
13:51:32 <hidekazu> alexchadin: please see dependency tree in https://blueprints.launchpad.net/watcher/+spec/zone-migration-strategy
13:51:34 <alexchadin> sballe_: thanks!
13:52:02 <alexchadin> hidekazu: yeah, already seeing, now it make more sense
13:52:53 <ananth_n> thanks sballe_
13:53:09 <hidekazu> alexchadin: i will propose volume-migrate-action spec by the next meeting
13:53:30 <alexchadin> hidekazu: great!
13:54:03 <alexchadin> we need more spec reviewers so I propose discuss it on next meeting
13:54:14 <alexchadin> core spec reviewers*
13:55:47 <alexchadin> well, is there something else to discuss?
13:56:35 <alexchadin> then let's end this meeting :)
13:56:43 <alexchadin> thank you for attending!
13:57:01 <hidekazu> thanks, bye!
13:57:03 <ananth_n> thanks everyone. bye
13:57:04 <licanwei> bye
13:57:21 <alexchadin> #endmeeting