14:00:11 <alexchadin> #startmeeting watcher
14:00:12 <openstack> Meeting started Wed May  3 14:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'watcher'
14:00:16 <hidekazu> hi
14:00:21 <alexchadin> o/
14:00:57 <Yumeng__> Hi
14:01:02 <alexchadin> Today's agenda is https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#05.2F03.2F2017
14:01:12 <licanwei> hi
14:01:37 <alexchadin> #info OpenStack Summit starts next Monday! Time to complete presentations and prepare installation stand for Watcher onboarding.
14:02:41 <alexchadin> We will need stand where we can show up how Watcher works
14:03:13 <alexchadin> Do someone of you have Devstack with last version of Watcher?
14:04:14 <alexchadin> well I will do it
14:04:15 <hidekazu> alexchadin: i can prepare if single node with no dashboard
14:04:43 <alexchadin> hidekazu: we will need at least two compute nodes (in virtual machines of course)
14:05:16 <hidekazu> alexchadin: sorry i am not sure.
14:05:19 <acabot___> hi, sorry for being late
14:05:23 <alexchadin> hi acabot___
14:05:52 <alexchadin> hidekazu: I will ask my colleagues to present some machines to us
14:06:20 <hidekazu> alexchadin: thanks.
14:06:29 <alexchadin> Yumeng__: as I've said before, I will discuss your presentation tomorrow with you
14:06:55 <alexchadin> Yumeng__: I may just leave some comments on slides if it is suitable for you
14:07:00 <Yumeng__> We have a three nodes, but doesn't work now. We are trying to recover them. Sorry can't help
14:07:27 <alexchadin> Yumeng__: no problem
14:07:30 <alexchadin> move on
14:07:36 <alexchadin> #info Spec Define grammar for workload characterization has been merged! Congratulations to Prashanth Hari, Chris Spencer and Susanne Balle!
14:07:47 <alexchadin> it was really long-term spec
14:08:20 <alexchadin> I'm glad we have approved it
14:08:27 <acabot___> me too :-)
14:08:42 <sballe_> +2
14:09:13 <alexchadin> Spec Add spec for Cinder model integration has been merged! Congratulations to Hidekazu Nakamura!
14:09:19 <alexchadin> #info Spec Add spec for Cinder model integration has been merged! Congratulations to Hidekazu Nakamura!
14:09:27 <alexchadin> hidekazu: congratulations!
14:09:34 <alexchadin> Thanks to all reviewers!
14:09:51 <acabot___> sorry for my late reviews on all these specs
14:09:51 <hidekazu> thanks reviewers.
14:10:31 <alexchadin> looks like previous week was week of spec merging ;)
14:10:33 <alexchadin> #info Spec Audit tag in VM Metadata has been merged! Congratulations to Prashanth Hari!
14:11:01 <alexchadin> hvprash: congratulations!
14:11:08 <alexchadin> and the last one
14:11:10 <alexchadin> Spec Add spec for cron based continuous audits has been merged!
14:11:16 <Yumeng__> Congrats to all the contributors!
14:11:17 <alexchadin> Thanks to all reviewers from me :)
14:11:31 <hidekazu> alexchadin: congrats!
14:11:32 <acabot___> now its time to code :-)
14:12:22 <alexchadin> acabot___: as practice shows, it is easier than writing specs :)
14:12:40 <acabot___> +1
14:12:45 <sballe_> +1
14:12:45 <alexchadin> I'd say, than approving specs
14:13:11 <acabot___> we still have a lot of specs open
14:13:12 <alexchadin> great work, folks
14:13:24 <alexchadin> so move on to them
14:13:29 <acabot___> I hope the summit will be the place to improve them
14:13:35 <alexchadin> #topic Review Action Items
14:13:40 <alexchadin> Watcher specs
14:13:50 <alexchadin> Build baremetal data model in watcher needs new PS #link https://review.openstack.org/#/c/448016/
14:14:35 <alexchadin> Yumeng__: have you seen comments hidekazu left for you?
14:14:47 <vincentfrancoise> hi
14:14:53 <vincentfrancoise> sorry for being late
14:15:04 <alexchadin> hi vincentfrancoise
14:15:14 <Yumeng__> Yes , canwei's comments was what I wants to reply
14:15:35 <Yumeng__> I will discuss it with hidekazu tomorrow
14:15:35 <acabot___> Yumeng__ you should probably look at https://review.openstack.org/#/c/450173/ for your spec
14:15:47 <acabot___> it would be kind of the same kind of spec
14:16:10 <hidekazu> alexchadin: i missed comment from canwei, sorry.
14:16:22 <Yumeng__> Thx acabot, I will have a look
14:16:59 <alexchadin> #action Yumeng__ and hidekazu discuss https://review.openstack.org/#/c/448016/ taking into account https://review.openstack.org/#/c/450173/
14:17:23 <alexchadin> update action description needs reviews #link https://review.openstack.org/#/c/459529/
14:17:58 <acabot___> <alexchadin
14:18:09 <acabot___> alexchadin do you have a BP for this ?
14:18:42 <acabot___> https://blueprints.launchpad.net/watcher/+spec/dynamic-action-description
14:18:54 <alexchadin> acabot___: https://blueprints.launchpad.net/watcher/+spec/dynamic-action-description
14:19:05 <alexchadin> acabot___: I've missed filling it
14:19:06 <acabot___> I suppose (you should update the topic to bp/dynamic-action-description)
14:19:12 <alexchadin> acabot___: yeah +1
14:19:50 <alexchadin> who would like to review it?
14:20:04 <hidekazu> i will again.
14:20:05 <acabot___> we already had a spec for it https://review.openstack.org/#/c/401111/
14:20:16 <Yumeng__> +1
14:20:32 <hidekazu> acabot___: yes, this will update approved spec.
14:21:04 <acabot___> ok its an update sorry
14:21:07 <acabot___> I can review
14:21:29 <alexchadin> #action acabot___ hidekazu review https://review.openstack.org/#/c/459529/
14:22:02 <alexchadin> Add spec for services-versioned-notifications-api bp needs core reviews #link https://review.openstack.org/#/c/445817/
14:23:01 <alexchadin> vincentfrancoise: Vladimir gave you an answer to your latest comment
14:24:33 <alexchadin> #action alexchadin vincentfrancoise review https://review.openstack.org/#/c/445817/
14:24:50 <alexchadin> Add spec for Supporting HA for background jobs in Watcher needs core reviews #link https://review.openstack.org/#/c/447996/
14:24:57 <vincentfrancoise> alexchadin: ok I'll review it once more
14:25:11 <alexchadin> hidekazu and licanwei already reviewed it
14:25:17 <alexchadin> hidekazu, licanwei thanks a lot
14:25:21 <alexchadin> vincentfrancoise: thx
14:25:30 <alexchadin> who would like to review it?
14:27:11 <vincentfrancoise> alexchadin: I won't have much time before going to Boston to review things
14:27:13 <alexchadin> vincentfrancoise: could you please review it again?
14:27:32 <vincentfrancoise> alexchadin: so we can discuss all this over there
14:27:41 <alexchadin> vincentfrancoise: ok let's discuss it together then
14:28:09 <vincentfrancoise> alexchadin: I don't know if you said it since I wasn't here on time
14:28:24 <vincentfrancoise> alexchadin: but do we cancel next week's meeting?
14:28:26 <sballe_> alexchadin: I can review and will do so today
14:28:50 <alexchadin> vincentfrancoise: I've planned to say it in the end of meeting
14:28:59 <vincentfrancoise> alexchadin: oh ok
14:29:09 <alexchadin> vincentfrancoise: BTW, I will do ML to openstack-dev channel
14:29:22 <alexchadin> sballe_: thank you!
14:29:38 <alexchadin> #action sballe_ vincentfrancoise review https://review.openstack.org/#/c/447996/
14:30:09 <alexchadin> Noisy Neighbor Strategy needs reviews #link https://review.openstack.org/#/c/398162/
14:31:11 <alexchadin> acabot___: can you review it?
14:31:27 <sballe_> yes please and Pr and I are putting the last things togetehr for the summit
14:31:33 <sballe_> s/Pru
14:31:56 * sballe_ Pru == pshedimb
14:32:18 <alexchadin> sballe_: should we mark it as WiP for now?
14:32:45 <sballe_> no please review
14:33:04 <acabot___> +1
14:33:09 <sballe_> the changes we are doing are to the code not the spec
14:33:35 <alexchadin> sballe_: ah ok
14:33:59 <alexchadin> #action acabot___ alexchadin review https://review.openstack.org/#/c/398162/
14:35:04 <alexchadin> I have three students which will take some commits to finish them
14:35:26 <alexchadin> like Spec for noisy-neighbor-dashboard from Chris Spencer and functional tests for strategies
14:35:34 <acabot___> great !
14:35:55 <vincentfrancoise> nice :)
14:36:10 <alexchadin> They will go for it since 15 May due to their exams :)
14:36:37 <sballe_> +2
14:36:40 <sballe_> great!
14:36:47 <alexchadin> I will have hangouts with them to introduce them into contributing process
14:37:15 <alexchadin> but there are some things with this commits where I may not to know all things
14:37:47 <alexchadin> so if you don't mind I'd like to send them to you if they have any questions
14:38:02 <alexchadin> vincentfrancoise: I'm about functional tests
14:38:42 <vincentfrancoise> alexchadin: ah yeah, if I have time I'll help :)
14:38:53 <alexchadin> vincentfrancoise: great!
14:39:01 <alexchadin> move on
14:39:04 <alexchadin> Watcher
14:39:19 <alexchadin> Add Watcher JobStore for background jobs needs core reviews #link https://review.openstack.org/#/c/449659/
14:39:40 <alexchadin> vincentfrancoise: since you have already +2'd it, could you please do it again?
14:40:03 <vincentfrancoise> alexchadin: ok
14:40:03 <alexchadin> vincentfrancoise: or bring it to workflow
14:40:28 <vincentfrancoise> alexchadin: done
14:40:52 <alexchadin> vincentfrancoise: nice!
14:41:15 <alexchadin> Add action description notification needs new PS #link https://review.openstack.org/#/c/454638/
14:41:51 <alexchadin> licanwei: have you seen vincentfrancoise's comments?
14:43:52 <licanwei> yes
14:44:28 <licanwei> but I have no time recently
14:44:48 <alexchadin> licanwei: will you attend Summit?
14:44:58 <licanwei> yes
14:46:09 <alexchadin> licanwei: then we will discuss it there :)
14:46:23 <alexchadin> Versioned Notifications for service object needs reviews #link https://review.openstack.org/#/c/437333/
14:46:26 <licanwei> :)
14:46:52 <alexchadin> vincentfrancoise: let's discuss it on the Summit too
14:47:33 <alexchadin> well, I hope he will be agreed :)
14:47:49 <alexchadin> Add action description needs reviews #link https://review.openstack.org/#/c/450720/
14:47:51 <vincentfrancois1> alexchadin: yep
14:48:22 <alexchadin> hidekazu: could you please review it?
14:48:45 <hidekazu> alexchadin: yes, i can
14:49:51 <alexchadin> #action hidekazu review https://review.openstack.org/#/c/450720/
14:50:19 <alexchadin> well, we won't have next meeting due to Summit
14:50:47 <alexchadin> I'd be glad to see you there!
14:51:36 <alexchadin> Do you have any other announcements?
14:51:54 <hidekazu> when will we have meeting in summit?
14:52:25 <acabot___> I would suggest to meet on Monday evening
14:52:45 <acabot___> as the summit party is on Tuesday
14:53:15 <alexchadin> acabot___: you speak about dinner?
14:53:21 <hidekazu> acabot___: you mean discussing or have dinner?
14:53:32 <alexchadin> hidekazu: what did you mean? :)
14:54:01 <sballe_> I haven't found a place yet and I am thinking our best best is just to meet and go somwhere
14:54:39 <acabot___> sorry I was speaking about dinner but we also need to schedule watcher meetings
14:54:41 <sballe_> I spend some time in Boston last weekend and there are a lot of places we can go and given the schedule I suggest we just meet and go some plce
14:54:45 <hidekazu> alexchadin: when will we discuss about spec or something in hacking room?
14:55:24 <alexchadin> hidekazu: let me see
14:55:29 <sballe_> oh just saw the party invite
14:56:14 <hidekazu> alexchadin: i assumed we will have meeting other than onboarding.
14:56:41 <alexchadin> hidekazu: yeah, I'm looking for rooms
14:57:38 <alexchadin> Hynes, MR 107
14:57:48 <alexchadin> This room will be free for all teams
14:58:08 <vincentfrancois1> alexchadin: good :)
14:58:10 <alexchadin> we can gather there
14:58:15 <alexchadin> https://ethercalc.openstack.org/Boston_Forum_Hacking_Rooms
14:58:26 <alexchadin> information here may be changed
14:58:43 <vincentfrancois1> alexchadin: then the only thing left to decide are the time slots to meet
14:59:06 <alexchadin> vincentfrancois1: let's discuss it on openstack-watcher channel now
14:59:29 <vincentfrancois1> alexchadin: ok
14:59:41 <alexchadin> thank you for attending
14:59:45 <alexchadin> bye!
14:59:49 <hidekazu> alexchadin: vincentfrancois1: ok, bye
14:59:52 <acabot___> ok bye
14:59:56 <vincentfrancois1> see you next week ;)
14:59:56 <adisky_> bye
15:00:10 <alexchadin> #endmeeting