14:00:48 <alexchadin> #startmeeting watcher
14:00:49 <openstack> Meeting started Wed Apr  5 14:00:48 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <openstack> The meeting name has been set to 'watcher'
14:01:04 <alexchadin> welcome here!
14:01:06 <chrisspencer> o/
14:01:07 <vincentfrancois1> o/
14:01:10 <dtardivel> hi
14:01:14 <licanwei> hi
14:01:15 <sballe_> o/
14:01:18 <ostroverkhov> o/
14:01:20 <pshedimb_> o/
14:01:41 <alexchadin> #info Today's agenda is placed here https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#04.2F05.2F2017
14:01:51 <alexchadin> #topic Announcements
14:01:57 <alexchadin> Our current milestone target is Pike-1 due April 10th
14:02:00 <acabot> o/
14:02:34 <alexchadin> so we have 5 BPs and 3 bugs for P-1
14:03:13 <alexchadin> I'm not sure that Noisy Neighbor Strategy and gnocchi support will be merged by release time
14:03:45 <alexchadin> So I propose to move them to the Pike-2
14:04:11 <vincentfrancois1> alexchadin: Support gnocchi in watcher i not well updated in laucnhpad
14:04:26 <vincentfrancois1> alexchadin: it's actually well under way
14:04:29 <alexchadin> pshedimb_ sballe_ what do you think about it?
14:04:35 <acabot> https://review.openstack.org/#/q/topic:bp/gnocchi-watcher
14:04:42 <alexchadin> vincentfrancois1: ok, I've seen your comments
14:04:42 <acabot> looks ok for pike-1 no ?
14:04:56 <vincentfrancois1> alexchadin: I reckon it can be merged on time
14:05:02 <vincentfrancois1> acabot: +1
14:05:10 <alexchadin> yeap, vincentfrancois1 started to review couple of hours ago
14:05:19 <sballe_> I will let pshedimb_ answer. We are very close. We could merge what we have and then if we see issues fix them as  bugs
14:05:40 <sballe_> but pshedimb_ has the last word
14:05:43 <alexchadin> ostroverkhov: what about Versioned Notifications for service object?
14:06:05 <alexchadin> sballe_: great!
14:06:19 <pshedimb_> alexchadin, Yeah I can merge whatever I have. But my priority now is to prepare a demo for Boston summit on this.
14:06:33 <sballe_> pshedimb_: +1
14:07:02 <sballe_> We want to make sure it works the way we want it do work and that is why we spend extra time testing the behavior and corner cases
14:07:26 <vincentfrancois1> pshedimb_: push for review what you have so you can get feedbacks
14:07:36 <alexchadin> sballe_: pshedimb_ let's make decision this Friday then
14:07:38 <pshedimb_> So once I receive reviews on the spec and once the spec is approved, I will push in the code change.
14:07:39 <sballe_> vincentfrancois1: make sense
14:07:51 <sballe_> pshedimb_: +1
14:08:05 <pshedimb_> vincentfrancois1, You want me to push the code before spec review?
14:08:19 <alexchadin> pshedimb_: code change will be appointed to P-2
14:08:35 <alexchadin> pshedimb_: push what you already have
14:08:56 <alexchadin> pshedimb_: just mark it with [WiP] tag
14:08:57 <pshedimb_> alexchadin, Okay, I'll do it in the next 1-2 days.
14:09:08 <pshedimb_> Once I integrate with recent changes.
14:09:28 <vincentfrancois1> alexchadin: +1
14:10:13 <alexchadin> move on
14:10:14 <alexchadin> Open Discussions topic will be follow after Announcements every even weeks.
14:10:33 <ostroverkhov> alexchadin: I read the messages, but there are a few questions
14:11:05 <alexchadin> ostroverkhov: ok, I will be in sync with you till the Friday
14:11:20 <ostroverkhov> alexchadin: ok
14:11:40 <alexchadin> I hope, nobody will mind about open discussions
14:12:06 <alexchadin> There are two hacking rooms for gathering on Summit. #link https://ethercalc.openstack.org/Boston_Forum_Hacking_Rooms
14:12:30 <alexchadin> They will be filled with roundtables for ad-hoc discussions that projects want to have.
14:12:44 <alexchadin> Hynes MR 108 and 109
14:13:44 <sballe_> nice! alexchadin can you add this to our Boston summit etherpad? I am loosing track of all the details
14:13:53 <alexchadin> I will set time for us when we can gather
14:13:58 <alexchadin> sballe_: sure
14:14:19 <alexchadin> #topic Open Discussions
14:14:25 <alexchadin> We should be prepared for onboarding rooms, where new contributors can come and we may teach them about the project, code, and give them an opportunity to meet established community members.
14:15:52 <alexchadin> we will have 90 minutes to show newcomers demo of Watcher and teach them our features/show live demo for everyone
14:15:52 <vincentfrancois1> alexchadin: what do you think we should prepare? slides?
14:16:14 <sballe_> alexchadin: one more thing. Did you update the generic Watcher slides from last summit? I am working on my slide set and just used the Watcher main arch slides from last summit. We have new contributors from NEC, and other companies that I would like ot add to the contributor slide.
14:16:30 <alexchadin> vincentfrancois1: I think we need OpenStack controller and 2 computes at least
14:16:41 <vincentfrancois1> alexchadin: oh ok, then maybe we need to show multiple Watcher strategies in action
14:16:54 <sballe_> vincentfrancois1: alexchadin good ideas
14:16:55 <alexchadin> vincentfrancois1: totally agreed
14:17:09 <vincentfrancois1> alexchadin: there's also a video on youtube we can use to explain how it works
14:17:33 <vincentfrancois1> #link https://www.youtube.com/watch?v=FJttohkf0sM
14:17:41 <alexchadin> sballe_: I haven't worked with slides yet, I will adapt them for Pike and hope to do it with you
14:17:56 <sballe_> alexchadin: ok
14:18:56 <alexchadin> vincentfrancois1: we can share video, but it isn't main reason to come for contributors, live demo would be great
14:19:19 <vincentfrancois1> alexchadin: yes but the animation is good to explain the concept
14:19:33 <alexchadin> vincentfrancois1: I agree
14:19:45 <vincentfrancois1> alexchadin: whereas live demos are to show the different use cases
14:20:11 <sballe_> agreed but video is great if live demo doesn't work
14:20:18 <alexchadin> vincentfrancois1: we need to place demo on wiki page
14:20:19 <vincentfrancois1> alexchadin: and also to show it's no bullsh*t
14:20:32 <sballe_> vincentfrancois1: +1
14:21:26 <alexchadin> I will add appropriate topic on etherpad
14:21:29 <alexchadin> move on
14:21:30 <alexchadin> adisky_ said that rdo-package for python-watcherclient will be prepared by number80 (Haïkel Guémar). We still need to find the ways to prepare watcher package.
14:22:32 <alexchadin> #link https://bugzilla.redhat.com/show_bug.cgi?id=1350974
14:22:32 <openstack> bugzilla.redhat.com bug 1350974 in Package Review "Openstack python-watcherclient" [Unspecified,Assigned] - Assigned to karlthered
14:23:40 <alexchadin> we still isn't in sync with packages for systems (except of python packages)
14:23:54 <alexchadin> I will discuss it with adisky_
14:24:05 <alexchadin> #action discuss packages issue with adisky_
14:24:15 <alexchadin> #topic Review Action Items
14:24:23 <alexchadin> Watcher specs
14:24:31 <alexchadin> Noisy Neighbor Strategy has got algorithm description and now is ready to be reviewed #link https://review.openstack.org/#/c/398162/
14:25:22 <alexchadin> who would like to take full review here?
14:26:01 <alexchadin> I may take it since I worked with strategies before
14:26:22 <sballe_> alexchadin: +1  thx
14:26:23 <chrisspencer> +1
14:26:30 <licanwei> +1
14:26:57 <alexchadin> #action alexchadin chrisspencer licanwei review https://review.openstack.org/#/c/398162/
14:27:14 <alexchadin> Define grammar for workload characterization Chris is waiting for Antoine's answer #link https://review.openstack.org/#/c/377100/
14:27:25 <alexchadin> seems chrisspencer has got it ;)
14:28:00 <acabot> done
14:28:09 <alexchadin> thank you, acabot
14:28:29 <chrisspencer> thank acabot
14:28:53 <alexchadin> BTW, help is appreciated here
14:29:29 <alexchadin> sballe_: will you take a look?
14:29:36 <sballe_> sure
14:30:13 <alexchadin> #action sballe_ review https://review.openstack.org/#/c/377100/
14:30:53 <alexchadin> Spec for noisy-neighbor-dashboard needs new answers and probable PS #link https://review.openstack.org/#/c/427308/
14:31:00 <alexchadin> probably*
14:31:20 <pshedimb_> +1
14:31:49 <alexchadin> #action pshedimb_ review https://review.openstack.org/#/c/427308/
14:32:01 <alexchadin> Support workload fingerprinting needs new PS #link https://review.openstack.org/#/c/448396/
14:32:34 <alexchadin> Audit tag in VM Metadata needs final core review #link https://review.openstack.org/#/c/391374/
14:33:10 <alexchadin> hvprash: I like integrating with audit scope
14:33:22 <alexchadin> I will review it, who else?
14:33:29 <alexchadin> dtardivel: thx for review
14:33:35 <acabot> +1
14:33:39 <vincentfrancois1> alexchadin: put me in too
14:34:25 <alexchadin> #action alexchadin acabot vincentfrancois1 review https://review.openstack.org/#/c/391374/
14:34:36 <alexchadin> Add spec for services-versioned-notifications-api bp needs new PS #link https://review.openstack.org/#/c/445817/
14:35:32 <alexchadin> vincentfrancois1: I had conversation with ostroverkhov and we decided that we might need to put status checking into new background job
14:36:01 <alexchadin> vincentfrancois1: it is useless to send notifications only when we request service status
14:36:38 <vincentfrancois1> alexchadin: Ah I though it was already the case actually, that's why I was talking about polling in my comment
14:37:02 <vincentfrancois1> alexchadin: so if there is no such job, then it doesn't make much sense indeed
14:37:43 <alexchadin> vincentfrancois1: ok, seems there will be some changes
14:38:01 <alexchadin> #action alexchadin ostroverkhov work on https://review.openstack.org/#/c/445817/
14:38:08 <alexchadin> move on
14:38:14 <alexchadin> Support visualizing workload fingerprints needs reviews #link https://review.openstack.org/#/c/448394/
14:39:09 <dtardivel> +1
14:39:34 <alexchadin> #action dtardivel review https://review.openstack.org/#/c/448394/
14:39:53 <alexchadin> Add spec for Cinder model integration needs reviews #link https://review.openstack.org/#/c/450173/
14:40:40 <alexchadin> vincentfrancois1 already put some comments, who else would like to take a look?
14:41:19 <acabot> alexchadin : I already looked at it and I have the same comments as vincentfancois1
14:42:00 <alexchadin> I think we will discuss some details from this spec on Summit
14:42:21 <alexchadin> acabot: thx
14:42:43 <vincentfrancois1> alexchadin: sure
14:43:07 <alexchadin> Watcher
14:43:10 <alexchadin> Added Actuator Strategy still needs to be taken by someone. Can Vladimir take it?
14:43:16 <alexchadin> #link https://review.openstack.org/#/c/425110/
14:43:46 <vincentfrancois1> ostroverkhov: alexchadin: go ahead, it's up for grab
14:44:13 <alexchadin> ostroverkhov: I think you can pick it up, what will you say?
14:44:48 <ostroverkhov> alexchadin: ok, i will pick it up
14:45:09 <vincentfrancois1> alexchadin: just one general remark: the multinode gate is always failing for a month now, we need to fix it
14:45:28 <alexchadin> #action ostroverkhov take https://review.openstack.org/#/c/425110/ to end it up
14:45:41 <alexchadin> vincentfrancois1: let's discuss it on main channel
14:45:59 <vincentfrancois1> alexchadin: np
14:46:00 <alexchadin> vincentfrancois1: just remind me sometime
14:46:13 <alexchadin> Added suspended audit state needs reviews. Have some tested it yet? #link https://review.openstack.org/#/c/438800/
14:46:45 <alexchadin> licanwei: have you tested it in Devstack for example?
14:46:55 <licanwei> yes
14:47:40 <alexchadin> licanwei: great! I will review it
14:47:57 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/438800/
14:48:09 <licanwei> it works well
14:48:14 <alexchadin> Prevent the migration of VM with 'optimize' False in VM metadata needs final core reviews #link https://review.openstack.org/#/c/443070/
14:48:31 <alexchadin> vincentfrancois1: thx for review!
14:49:19 <vincentfrancois1> alexchadin: you're welcome ;)
14:49:26 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/438800/
14:49:36 <alexchadin> gnocchi support topic should be reviewed #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/gnocchi-watcher
14:50:12 <alexchadin> chrisspencer, licanwei, dtardivel, pshedimb_ will you take it?
14:50:22 <licanwei> +1
14:50:25 <pshedimb_> +1
14:50:28 <chrisspencer> +1
14:51:04 <alexchadin> #action licanwei pshedimb_ chrisspencer review patchsets of https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/gnocchi-watcher
14:51:22 <alexchadin> Added tempest test for workload_stabilization needs to be tested by someone else #link https://review.openstack.org/#/c/393355/
14:52:23 <alexchadin> looks like it is up to me
14:52:32 <alexchadin> vincentfrancois1: I will contact you about it
14:52:53 <alexchadin> Add action description needs reviews #link https://review.openstack.org/#/c/450720/
14:53:00 <vincentfrancois1> alexchadin: ok
14:53:39 <alexchadin> vincentfrancois1 will you take this commit?
14:53:56 <alexchadin> to review
14:54:06 <vincentfrancois1> alexchadin: I can review  https://review.openstack.org/#/c/393355/
14:54:43 <alexchadin> vincentfrancois1: you've sent link to your patch ;)
14:54:45 <vincentfrancois1> alexchadin: as for https://review.openstack.org/#/c/450720/ I'll do it if I have time
14:54:58 <vincentfrancois1> alexchadin: but no promises :p
14:55:20 <alexchadin> #action vincentfrancois1 review https://review.openstack.org/#/c/450720/
14:55:29 <alexchadin> Add Watcher JobStore for background jobs needs reviews #link https://review.openstack.org/#/c/449659/
14:56:05 <alexchadin> this PS will be updated soon
14:56:21 <alexchadin> Run Watcher-API behind mod-wsgi needs new PS #link https://review.openstack.org/#/c/450740/
14:56:36 <vincentfrancois1> alexchadin: made a quick review of that one
14:56:59 <alexchadin> who else will take it?
14:57:47 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/450740/
14:58:26 <alexchadin> hidekazu proposed new BP today: https://blueprints.launchpad.net/watcher/+spec/zone-migration-strategy
14:59:13 <alexchadin> It isn't clear to me yet, we agreed to wait spec for it from hidekazu side
15:00:26 <alexchadin> well, let's continue to prepare for Summit
15:00:34 <alexchadin> have a nice day!
15:00:48 <sballe_> bye
15:00:49 <pshedimb_> bye :)
15:00:50 <alexchadin> thank you for your attention
15:00:52 <alexchadin> bye
15:00:53 <chrisspencer> bye
15:00:57 <ostroverkhov_> Bye
15:01:01 <licanwei> bye
15:01:03 <vincentfrancois1> bye
15:01:08 <alexchadin> #endmeeting