13:00:37 <alexchadin> #startmeeting watcher
13:00:38 <openstack> Meeting started Wed Mar 29 13:00:37 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:41 <openstack> The meeting name has been set to 'watcher'
13:00:55 <alexchadin> good morning/day/evening!
13:00:57 <vincentfrancois1> o/
13:00:59 <acabot> o/
13:01:12 <ostroverkhov> o/
13:01:29 <alexchadin> #info Today we have the following agenda https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F29.2F2017
13:01:47 <alexchadin> #topic Announcements
13:02:00 <alexchadin> Project Navigator will have new version soon. We need to know if Watcher may meet some Maturity criteria. #link http://devbranch.openstack.org/software/releases/ocata/components/watcher
13:02:43 <hidekazu> fancy mascot
13:02:53 <acabot> its been a long time the community is complaining about the project navigator…good to see some changes her
13:03:28 <vincentfrancois1> yeah that's good news :)
13:03:32 <alexchadin> There are items like supporting deprecations, having install guide, corporate diversity
13:03:34 <dtardivel> hi
13:03:51 <Yumeng_> hi
13:03:56 <acabot> I would remove the monkey on your shoulders Alex ;-)
13:03:58 <vincentfrancois1> alexchadin: how will they decide the maturity level?
13:04:22 <acabot> alexchadin : I dont know what kind of animal it is...
13:04:24 <alexchadin> vincentfrancois1: there are seven items we need to meet to get maturity
13:04:34 <alexchadin> vincentfrancois1: look at nova page: http://devbranch.openstack.org/software/releases/ocata/components/nova
13:05:24 <acabot> we simply needs to add TC tags to the project
13:05:36 <alexchadin> acabot: it is Malaysian Bear ;)
13:06:11 <acabot> alexchadin : ok go for the bear ;-)
13:06:37 <dtardivel> alexchadin: why api version for watcher is N/A in the project dashboard ?
13:07:40 <alexchadin> dtardivel: I haven't contacted management team to give them remarks
13:07:45 <alexchadin> yet
13:08:11 <chrisspencer> o/ sorry, I'm late
13:08:17 <alexchadin> This page is still in development so if you have any questions and proposals, feel free to share them
13:08:54 <dtardivel> vincentfrancois1: is api version coded in our source code ?
13:11:12 <alexchadin> dtardivel: we have v1 folder
13:11:17 <vincentfrancois1> dtardivel: yes it's v1
13:11:38 <vincentfrancois1> and we have a version number in each controller
13:12:11 <alexchadin> Etherpad for Boston discussions will be created by EOW. Everyone is invited to suggest topics to discuss.
13:12:29 <vincentfrancois1> dtardivel: https://github.com/openstack/watcher/blob/master/watcher/api/controllers/root.py#L73
13:12:35 <alexchadin> We will have about 90 minutes on Forum
13:13:09 <acabot> alexchadin : does it mean we will have only 90 minutes for watcher meetings ?
13:13:10 <vincentfrancois1> alexchadin: can you give the etherpad link please?
13:13:18 <alexchadin> it is best place to chat with people interested in getting started on Watcher
13:14:07 <alexchadin> acabot: I propose to define meeting times in etherpad
13:14:21 <acabot> alexchadin : vincentfrancois1 & I will be in Boston
13:14:44 <acabot> alexchadin : ok cool
13:14:54 <alexchadin> vincentfrancois1: https://etherpad.openstack.org/p/watcher-Boston-meetings
13:15:06 <alexchadin> it just has been created
13:15:31 <alexchadin> I will update it soon with structure
13:15:45 <hidekazu> alexchadin: how about https://etherpad.openstack.org/p/BOS-Watcher-brainstorming?
13:16:00 <acabot> added to #link https://etherpad.openstack.org/p/watcher-etherpads
13:16:39 <alexchadin> hidekazu: I've looked through proposed brainstorming from other projects and think that it would be redundant for us yet
13:16:40 <vincentfrancois1> hidekazu: +1
13:17:01 <acabot> hidekazu : BOS for Boston ? strange naming… :-)
13:17:45 <alexchadin> brainstorming means our project has achieved some point when we can get feedback from users
13:18:06 <hidekazu> alexchadin: ok, i understand purpose of BOS-Watcher-brainstorming.
13:18:27 <hidekazu> so we will have another meeting, right?
13:19:00 <alexchadin> it is the place where everyone can come and say "hi, your product works great in our production but there are some things to do"
13:19:10 <alexchadin> hidekazu: yes, of course
13:19:36 <alexchadin> any other announcements?
13:19:41 <hidekazu> alexchadin: nice.
13:20:05 <alexchadin> well move on
13:20:16 <alexchadin> #topic Review Action Items
13:20:22 <alexchadin> Watcher specs
13:20:31 <alexchadin> service-versioned-notifications-api needs core reviews #link https://review.openstack.org/#/c/445817/
13:20:48 <alexchadin> Vladimir is still waiting for your reviews ;)
13:21:12 <ostroverkhov> yep )
13:21:19 <vincentfrancois1> alexchadin: ostroverkhov: my bad
13:21:44 <acabot> I have added watcher-specs-core group as reviewers
13:21:46 <vincentfrancois1> alexchadin: took too much time on other BPs and questions
13:22:11 <alexchadin> vincentfrancois1: no problem with it
13:22:30 <alexchadin> #action vincentfrancois1 review https://review.openstack.org/#/c/445817/
13:22:40 <alexchadin> workload-fingerprinting-fingerprint-visuzalization should be updated #link https://review.openstack.org/#/c/448394/
13:23:20 <alexchadin> who knows IRC username of Ananth Narayan S?
13:23:37 <acabot> ananth
13:24:08 <acabot> but you should probably ask sballe to get feedback on this
13:24:43 <chrisspencer> acabot: I have a meeting with ananth in a couple hours
13:24:48 <alexchadin> acabot: since sballe_ won't be here during the meeting, will add it as action
13:25:10 <acabot> and I’m not sure the bp workload-fingerprinting-fingerprint-visuzalization must be part of Pike...
13:26:04 <alexchadin> acabot: it is PoC so we can just discuss it yet
13:26:22 <acabot> alexchadin : ok
13:26:30 <alexchadin> #action sballe_ chrisspencer get feedback from ananth about https://review.openstack.org/#/c/448394/
13:26:51 <alexchadin> workload-characterization-grammar needs to be answered by acabot #link https://review.openstack.org/#/c/377100/
13:27:12 <alexchadin> acabot: chrisspencer left comment for you
13:27:22 <acabot> alexchadin : I will thx
13:27:28 <vincentfrancois1> alexchadin: both the fingerprint BP and the ironic BP talk about adding extra API endpoints, so we should be careful about it because APIs will have to be quite stable
13:28:06 <alexchadin> vincentfrancois1: I suggest to add it as topic to discuss during the following Summit
13:28:23 <vincentfrancois1> alexchadin: why not yes
13:29:14 <alexchadin> #action alexchadin add discussions of fingerprint BP to the Boston-etherpad
13:29:32 <alexchadin> audit-tag-vm-metadata should be reviewed again #link https://review.openstack.org/#/c/391374/
13:29:51 <dtardivel> I can review it
13:29:58 <alexchadin> hvprash provided new PS
13:30:03 <alexchadin> dtardivel: great!
13:30:46 <alexchadin> #action dtardivel review https://review.openstack.org/#/c/391374/
13:31:01 <alexchadin> noisy-neighbor-dashboard needs to be answered by vincentfrancoise #link https://review.openstack.org/#/c/427308/
13:31:21 <alexchadin> vincentfrancois1: here is some questions addressed to you
13:31:57 <vincentfrancois1> alexchadin: I'll answer right away
13:32:27 <chrisspencer> thanks vincentfrancois1
13:32:39 <alexchadin> #action vincentfrancois1 give answers on https://review.openstack.org/#/c/427308/
13:32:52 <alexchadin> cinder-model-integration needs reviews #link https://review.openstack.org/#/c/450173/
13:33:42 <alexchadin> it is very interesting new BP so it would be great if almost everyone review it
13:34:30 <alexchadin> who would like to review it?
13:34:48 <vincentfrancois1> alexchadin: I'll try
13:34:55 <acabot> +1
13:35:14 <alexchadin> #action vincentfrancois1 acabot alexchadin review https://review.openstack.org/#/c/450173/
13:35:23 <alexchadin> background-jobs-ha needs new PS #link https://review.openstack.org/#/c/447996/
13:35:41 <alexchadin> thanks to vincentfrancois1, I will provide new PS soon
13:36:01 <alexchadin> #action alexchadin provide new PS of https://review.openstack.org/#/c/447996/
13:36:25 <alexchadin> Support workload fingerprinting needs new PS and answer questions #link https://review.openstack.org/#/c/448396/
13:36:47 <alexchadin> chrisspencer: please remind about it too
13:36:59 <chrisspencer> alexchadin: +1
13:37:18 <alexchadin> add-power-on-off needs new PS #link https://review.openstack.org/#/c/435436/
13:37:43 <alexchadin> Yumeng_: have you seen addressed comments?
13:38:38 <alexchadin> seems that Yumeng_ is not here yet
13:39:33 <alexchadin> #action Yumeng_ https://review.openstack.org/#/c/435436/ needs new PS
13:39:47 <alexchadin> build-baremetal-data-model-in-watcher needs to be redefined with dtardivel #link https://review.openstack.org/#/c/448016/
13:40:59 <alexchadin> dtardivel: I've seen that there are some fundamental issues with the current PS
13:41:00 <dtardivel> +1
13:41:47 <alexchadin> #action Yumeng_ contact dtardivel to redefine https://review.openstack.org/#/c/448016/
13:41:53 <alexchadin> Watcher
13:42:04 <alexchadin> gnocchi support for strategies should be reviewed #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/gnocchi-watcher
13:42:34 <alexchadin> there is bunch of gnocchi-related commits that should be reviewed
13:43:28 <alexchadin> who would like to take a look at it?
13:43:48 <vincentfrancois1> alexchadin: I reviewed 1
13:43:52 <alexchadin> I may take workload-stabilization
13:44:15 <hidekazu> i will.
13:44:17 <vincentfrancois1> alexchadin: but the comment needs to be copied over in all others
13:44:42 <alexchadin> vincentfrancois1: the same issue with all others?
13:45:20 <pksingh> Hello
13:45:21 <vincentfrancois1> alexchadin: not written exactly the same, but fairly similar
13:45:21 <alexchadin> #action hidekazu vincentfrancois1 alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/gnocchi-watcher
13:45:30 <alexchadin> vincentfrancois1: ok
13:45:47 <alexchadin> suspended-audit-state needs core reviews #link https://review.openstack.org/#/c/438800/
13:46:23 <alexchadin> I will take it
13:46:43 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/438800/
13:46:44 <hidekazu> milestone of suspended-audit-state is pike-1.
13:47:17 <alexchadin> I see, we will merge it before
13:47:26 <alexchadin> dynamic-action-description needs to add notifications #link https://review.openstack.org/#/c/413893/
13:48:06 <alexchadin> seems that this commit was abandoned
13:48:36 <alexchadin> I will take a look at it and will se if someone else can take it
13:48:49 <vincentfrancois1> alexchadin: I guess so
13:49:01 <alexchadin> audit-tag-vm-metadata needs core reviews #link https://review.openstack.org/#/c/443070/
13:50:02 <alexchadin> vincentfrancois1: have you resolved last issue with pksingh?
13:50:38 <pksingh> alexchadin: i submitted new patch after comment incorporation
13:50:48 <pksingh> guys please have a look, when you get time
13:51:12 <vincentfrancois1> alexchadin: pksingh: I'll try
13:51:22 <alexchadin> #action vincentfrancois1 alexchadin review https://review.openstack.org/#/c/443070/
13:51:28 <pksingh> thanks vincentfrancois1
13:51:32 <alexchadin> Added tempest test for workload_stabilization needs new PS #link https://review.openstack.org/#/c/393355/
13:52:19 <alexchadin> vincentfrancois1: chrisspencer reported that there is a failure on 178 line of https://review.openstack.org/#/c/393355/8/watcher_tempest_plugin/tests/scenario/test_execute_workload_balancing.py
13:53:18 <vincentfrancois1> alexchadin: if someone can take over it I would be glad
13:53:34 <alexchadin> vincentfrancois1: got it, will mark
13:53:40 <alexchadin> dynamic-action-description needs reviews #link https://review.openstack.org/#/c/450720/
13:54:01 <vincentfrancois1> alexchadin: I don't have a working devstack at hand right now...
13:54:05 <alexchadin> licanwei: is it ready to review?
13:54:16 <licanwei> alexchadin: yes
13:54:40 <alexchadin> #action alexchadin add watcher team to review https://review.openstack.org/#/c/450720/
13:54:43 <licanwei> and i'll still working for notification
13:55:02 <alexchadin> noisy-neighbor-strategy needs reviews #link https://review.openstack.org/#/c/451215/
13:55:11 <alexchadin> licanwei: will it come as another commit?
13:55:24 <licanwei> yes
13:56:08 <Yumeng_> alexchadin: i want to review it
13:56:24 <alexchadin> #action Yumeng_ review https://review.openstack.org/#/c/451215/
13:56:35 <alexchadin> Yumeng_: read log of meeting if missed something
13:56:49 <alexchadin> Watcher CLI & Dashboard
13:56:53 <Yumeng_> alexchadin:ok
13:57:14 <alexchadin> Here is https://review.openstack.org/#/c/450181/ from Yumeng_
13:57:38 <alexchadin> already got +2 from licanwei, it need more core reviews
13:58:21 <alexchadin> Unfortunately, we are out of time to start Open Discussions
13:58:45 <alexchadin> I will announce it in our channel
13:58:52 <alexchadin> and ML
13:59:03 <vincentfrancois1> alexchadin: just W+1 https://review.openstack.org/#/c/450181/
13:59:16 <alexchadin> vincentfrancois1: nice!
13:59:27 <alexchadin> it is time to end meeting
13:59:35 <vincentfrancois1> thanks
13:59:37 <alexchadin> have a nice day!
13:59:38 <hidekazu> thanks
13:59:42 <vincentfrancois1> bye
13:59:43 <Yumeng_> bye
13:59:44 <alexchadin> thank you
13:59:45 <chrisspencer> bye
13:59:46 <licanwei> bye
14:00:02 <alexchadin> #endmeeting